The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Помогите подружить 2611XM и radiusd/ Проблема с паролем"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Помогите подружить 2611XM и radiusd/ Проблема с паролем" 
Сообщение от Sergey emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 01-Сен-04, 18:06  (MSK)
имеем cisco 2611xm IOS c2600-is-mz.121-18.bin
на ней
.......
aaa new-model
aaa authentication login login-rad group radius local
aaa authentication ppp radius-ppp group radius
aaa authorization network radius-net if-authenticated
aaa accounting network radius-acc start-stop group radius
aaa processes 4
......
!
interface Group-Async1
ip unnumbered Loopback1
ip accounting output-packets
ip nat inside
encapsulation ppp
no ip route-cache
ip tcp header-compression passive
no ip mroute-cache
keepalive 10
async dynamic address
async mode dedicated
no cdp enable
ppp authentication pap radius-ppp
ppp authorization radius-net
ppp accounting radius-acc
group-range 33 36
!
..
radius-server host 192.168.3.2 auth-port 1812 acct-port 1813
radius-server retransmit 3
radius-server key Cisco
...
line 33 36
login authentication login-rad
modem Dialin
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware

с другой стороны
FreeBSD 5.2.1-RELEASE на ней стоит radiusd-cistron-1.6.7

проблемa не воспринимает пароль правильно

# /usr/local/sbin/radiusd -y -x -i 192.168.3.2 -D
Starting - reading configuration files ...
Ready to process requests.
radrecv: Packet from host 192.168.3.1 code=1, id=10, length=73
    NAS-IP-Address = 192.168.3.1
    NAS-Port = 33
    NAS-Port-Type = Async
    User-Name = "plu"
    User-Password = "\324\331S\274M\345\0268\335\010\306\275l\270N\345"
    Service-Type = Framed-User
    Framed-Protocol = PPP
Sending Reject of id 10 to 192.168.3.1
Login incorrect: [plu/130877] (from nas Cisco1/S33)

вот настройки радиуса
ns1# more /usr/local/etc/raddb/clients
192.168.3.1             Cisco

ns1# more /usr/local/etc/raddb/users
...
plu Auth-Type = Local, Password = "130877"
        Service-Type = Framed-User,
        Framed-Protocol = PPP,
        Framed-IP-Address = 192.168.4.11,
        Framed-IP-Netmask = 255.255.255.255,
        Framed-Routing = Broadcast-Listen,
        Framed-MTU = 1500,
        Framed-Compression = Van-Jacobson-TCP-IP

ns1# more /usr/local/etc/raddb/naslist
192.168.3.1             Cisco1          Cisco

ПОМОГИТЕ победить Login incorrect.....
если проблема с радиусом этим, готов поставить любой простейший с текстовыми списками доступа
Заранее, спасибо..

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Помогите подружить 2611XM и radiusd/ Проблема с паролем" 
Сообщение от ru Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 02-Сен-04, 03:54  (MSK)
Меня спасло
radius-server attribute 69 clear
попробуй может поможет
правда у меня 2610
  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Помогите подружить 2611XM и radiusd/ Проблема с паролем" 
Сообщение от Skiv emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 02-Сен-04, 10:43  (MSK)
>Меня спасло
>radius-server attribute 69 clear
>попробуй может поможет
>правда у меня 2610


а ты уверен, что для задания пароля используется именно этот файл (naslist)? Возможно в данной версии радиус изменен списко конфиг файлов

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Помогите подружить 2611XM и radiusd/ Проблема с паролем" 
Сообщение от Sergey emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 02-Сен-04, 16:21  (MSK)
Спасибо. Это победилось...
вычислил, когда в дебуге с -xx запустил, с -x не показывала..
считала, что пользователь раньше попался..DEFAULT
теперь другая проблема...

Пользователю выдает:
Checking network protoсol connections...
TCP/IP reported error 738: The server did not assign an adress

>имеем cisco 2611xm IOS c2600-is-mz.121-18.bin
>на ней
>.......
!
interface Loopback1
description DialUp
ip address 192.168.4.1 255.255.255.0
!
....
!
interface Group-Async1
ip unnumbered Loopback1
ip accounting output-packets
ip nat inside
encapsulation ppp
no ip route-cache
ip tcp header-compression passive
no ip mroute-cache
keepalive 10
async dynamic address
async mode dedicated
no cdp enable
ppp authentication pap radius-ppp
ppp authorization radius-net
ppp accounting radius-acc
group-range 33 36
!
....
line 33 36
login authentication login-rad
modem Dialin
autoselect arap
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
.....

/usr/local/etc/raddb/users

plu  Auth-Type = Local, Password = "130877"
       Service-Type = Framed-User,
       Framed-Protocol = PPP,
       Framed-IP-Address = 192.168.4.11,
       Framed-IP-Netmask = 255.255.255.255,
       Framed-Compression = Van-Jacobson-TCP-IP

Подскажите, уже не соображу совсем куда копнуть..

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру