The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"устновка php-5 из библиотек"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [Проследить за развитием треда]

"устновка php-5 из библиотек"  
Сообщение от mirage52 email(ok) on 25-Июн-07, 15:24 
пытаюсь настроить веб сервер на фряхи 6.1
поставил Apache 2.2.4 из библиотеки httpd-2.2.4.tar.gz
потом установил mysql 5.0.41 то же скачал архив и изнего установил
еще opennssl -0.9
после этого установил еще не которые библиотеки
     t1lib-5.0.0.tar.gz — PostScript 1.
     libpng-1.2.5.tar.gz — Библиотека для работы с png.
     jpegsrc.v6b.tar.gz — Библиотека для работы с jpeg.
     zlib-1.1.4.tar.gz — Компрессия gzip.
     xpm-3.4k.tar.gz — Xpm.
     libiconv-1.8.tar.gz — Преобразователь кодировок.
     libxml2-2.5.8.tar.gz — XML функции.
     gd-2.0.15.tar.gz
все поставилось нормально без ошибок apache и mysql работают

теперь пытаюсь поставить php-5.2.3
анологично скачал библиотеку с сайта php.net - php-5.2.3.tar.gz

роспаковываю  #tar -zxvf 5.2.3.tar.gz
после этого   #./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --enable-ftp --with-gd=/usr/local
--with-zlib=/usr/local --with-iconv=/usr/local --with-jpeg-dir=/usr/local
--with-png-dir=/usr/local --with-ttf=/usr/local --with-freetype-dir=/usr/local
--with-t1lib=/usr/local --enable-gd-native-ttf --with-gettext=/usr/local

но ничего не выполнил ((
после этого пробую скомпилировать #make
но он мне пишет что отсутсвует makefile
кто знает что нужно сделать ???
заранее спасибо !!!

P.S. Из портов прошу не советовать устанавливать сколько не ставлю все время одни ошибки вылетают (((( и все както криво стаиться

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "устновка php-5 из библиотек"  
Сообщение от newser (ok) on 25-Июн-07, 15:43 
>пытаюсь настроить веб сервер на фряхи 6.1
>поставил Apache 2.2.4 из библиотеки httpd-2.2.4.tar.gz
>потом установил mysql 5.0.41 то же скачал архив и изнего установил
>еще opennssl -0.9
>после этого установил еще не которые библиотеки
>     t1lib-5.0.0.tar.gz — PostScript 1.
>     libpng-1.2.5.tar.gz — Библиотека для работы с png.
>
>     jpegsrc.v6b.tar.gz — Библиотека для работы с jpeg.
>
>     zlib-1.1.4.tar.gz — Компрессия gzip.
>     xpm-3.4k.tar.gz — Xpm.
>     libiconv-1.8.tar.gz — Преобразователь кодировок.
>     libxml2-2.5.8.tar.gz — XML функции.
>     gd-2.0.15.tar.gz
>все поставилось нормально без ошибок apache и mysql работают
>
>теперь пытаюсь поставить php-5.2.3
>анологично скачал библиотеку с сайта php.net - php-5.2.3.tar.gz
>
>роспаковываю  #tar -zxvf 5.2.3.tar.gz
>после этого   #./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --enable-ftp --with-gd=/usr/local
>--with-zlib=/usr/local --with-iconv=/usr/local --with-jpeg-dir=/usr/local
>--with-png-dir=/usr/local --with-ttf=/usr/local --with-freetype-dir=/usr/local
>--with-t1lib=/usr/local --enable-gd-native-ttf --with-gettext=/usr/local
>
>но ничего не выполнил ((
>после этого пробую скомпилировать #make
>но он мне пишет что отсутсвует makefile
>кто знает что нужно сделать ???
>заранее спасибо !!!
>
>P.S. Из портов прошу не советовать устанавливать сколько не ставлю все время
>одни ошибки вылетают (((( и все както криво стаиться

Поставьте из портов, предварительно выпрямив руки! Если у Вас особо клинический случай, то попросите более грамотного человека все сделать за Вас.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "устновка php-5 из библиотек"  
Сообщение от mirage52 email(ok) on 25-Июн-07, 15:49 
>
>Поставьте из портов, предварительно выпрямив руки! Если у Вас особо клинический случай,
>то попросите более грамотного человека все сделать за Вас.

Ок! можно ли поставить из порта таким образом, чтобы установился только php ?, тоесть чтобы он не устанавливал зависимые программы одновременно.  


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "устновка php-5 из библиотек"  
Сообщение от sw1tch (??) on 25-Июн-07, 16:20 

>Ок! можно ли поставить из порта таким образом, чтобы установился только php
>?, тоесть чтобы он не устанавливал зависимые программы одновременно.

это как? ставь из портов
никогда проблем небыло

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "устновка php-5 из библиотек"  
Сообщение от mirage52 email(ok) on 25-Июн-07, 16:30 
>
>>Ок! можно ли поставить из порта таким образом, чтобы установился только php
>>?, тоесть чтобы он не устанавливал зависимые программы одновременно.
>
>это как? ставь из портов
>никогда проблем небыло


но вот я поставил библиотеки выше указанные
после этого ставлю php из порта /usr/ports/lang/php5
так он мне начинает apahce грузить потом libiconv и т.д тоесть проверяеться зависимость порта от любых других программ
а зачем они мне нужны я же их все поставил и все работает мне осталось только php установить (((  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "устновка php-5 из библиотек"  
Сообщение от newser (ok) on 25-Июн-07, 17:09 
>>
>>>Ок! можно ли поставить из порта таким образом, чтобы установился только php
>>>?, тоесть чтобы он не устанавливал зависимые программы одновременно.
>>
>>это как? ставь из портов
>>никогда проблем небыло
>
>
>но вот я поставил библиотеки выше указанные
>после этого ставлю php из порта /usr/ports/lang/php5
>так он мне начинает apahce грузить потом libiconv и т.д тоесть проверяеться
>зависимость порта от любых других программ
>а зачем они мне нужны я же их все поставил и все
>работает мне осталось только php установить (((

А Вы сами себе злобный буратино. Удалите все, что Вы понаставили, и соберите все из портов. И почитайте, наконец, хэндбук!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "устновка php-5 из библиотек"  
Сообщение от mirage52 email(ok) on 25-Июн-07, 18:18 
>А Вы сами себе злобный буратино. Удалите все, что Вы понаставили, и
Премного благодарен за комплимент
>соберите все из портов. И почитайте, наконец, хэндбук!
Знаете какой толк от того, что я буду все это удалять и переустанавливать, все и так нормально работает, нет ни какого желания все удалять и за - php
хэндбук и еще много статей я прочитал и читаю......
давайте забудем про эти порты, вопрос звучал в том, что почему у меня не формируется ./configure ???? даже просто чтобы узнать атрибуты # ./configure --help он мне нечего не выдает ???
  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "устновка php-5 из библиотек"  
Сообщение от sw1tch (??) on 25-Июн-07, 19:25 
>#./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs -->enable-ftp --with-gd=/usr/local
>--with-zlib=/usr/local --with-iconv=/usr/local --with-jpeg-dir=/usr/local
>--with-png-dir=/usr/local --with-ttf=/usr/local --with-freetype-dir=/usr/local
>--with-t1lib=/usr/local --enable-gd-native-ttf --with-gettext=/usr/local

что было здесь? ошибки какие?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "устновка php-5 из библиотек"  
Сообщение от eax0r (ok) on 02-Июл-07, 05:08 
>пытаюсь настроить веб сервер на фряхи 6.1
>поставил Apache 2.2.4 из библиотеки httpd-2.2.4.tar.gz
>потом установил mysql 5.0.41 то же скачал архив и изнего установил
>еще opennssl -0.9
>после этого установил еще не которые библиотеки
>     t1lib-5.0.0.tar.gz — PostScript 1.
>     libpng-1.2.5.tar.gz — Библиотека для работы с png.
>
>     jpegsrc.v6b.tar.gz — Библиотека для работы с jpeg.
>
>     zlib-1.1.4.tar.gz — Компрессия gzip.
>     xpm-3.4k.tar.gz — Xpm.
>     libiconv-1.8.tar.gz — Преобразователь кодировок.
>     libxml2-2.5.8.tar.gz — XML функции.
>     gd-2.0.15.tar.gz
>все поставилось нормально без ошибок apache и mysql работают
>
>теперь пытаюсь поставить php-5.2.3
>анологично скачал библиотеку с сайта php.net - php-5.2.3.tar.gz
>
>роспаковываю  #tar -zxvf 5.2.3.tar.gz
>после этого   #./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --enable-ftp --with-gd=/usr/local
>--with-zlib=/usr/local --with-iconv=/usr/local --with-jpeg-dir=/usr/local
>--with-png-dir=/usr/local --with-ttf=/usr/local --with-freetype-dir=/usr/local
>--with-t1lib=/usr/local --enable-gd-native-ttf --with-gettext=/usr/local
>
>но ничего не выполнил ((
>после этого пробую скомпилировать #make
>но он мне пишет что отсутсвует makefile
>кто знает что нужно сделать ???
>заранее спасибо !!!
>
>P.S. Из портов прошу не советовать устанавливать сколько не ставлю все время
>одни ошибки вылетают (((( и все както криво стаиться

Нужно немного думать, а не тупо переписывать конфиг из доков =).
Во-первых, у Вас апач 2.х, поэтому --with-apxs2=/реальный/путь/до/apxs_апача2
Когда пишешь --with-ЧТО_ТО и указываешь ПОЛНЫЙ путь, где ЧТО_ТО находится. Если Вы, конечно, все библиотеки в /usr/local не поставили =).
Если не получится, то список ошибок сюда.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "устновка php-5 из библиотек"  
Сообщение от mirage email(??) on 04-Июл-07, 11:37 
Всем спасибо разобрался в чем была проблема
Оказывается я скачал версию системы автоматического построения PHP
Установил утилиты autoconf  и libtool и выполнил программу
./ext_skel my_module
./buildconf
после этого
./configure с нужными параметрами
./make && make install

все установилось и работает ))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру