The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Ограничение трафика по PPP"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Ограничение трафика по PPP" 
Сообщение от Ограничение трафика по PPP emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Фев-04, 10:59  (MSK)
Всем привет. Вторую неделю бьюсь с проблемой:
Нужно ограничить скорость доступа пользователя, работающего по PPP и авторизующегося через Radius.
Есть радиосетка, через радиомодем пользователь попадает на NAS,
тот в свою очередь по VPDN попадает на циску. Пользователь авторизуется на Radius-е. После авторизации пользователя на основе интерфейса Virtual-Template1 создается интерфейс Virtual-Access x (х номер свободного интерфейса по возрастанию).
Проблема в том, что скорость каждого модема порядка 2-х мегабит, а нужно иметь возможность разным юзерам давать разные скорости (126, 256К и т.д.). Возможности сделать traffic-shape или rate-limit на интерфейс Virtual-Access x нет, конфигурится только Virtual-Template.

Кусок конфига:

ip address-pool local
vpdn enable
!
vpdn-group TEST
! Default L2TP VPDN group
accept-dialin
  protocol l2tp
  virtual-template 1
local name test2
no l2tp tunnel authentication
source-ip 172.17.1.126
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
description Link to NiaB (inside)
ip address 172.17.1.126 255.255.255.128
speed 100
full-duplex
timeout absolute 600 0
no cdp enable
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0
ip nat inside
ip tcp adjust-mss 1458
peer default ip address pool ip_pool2
ppp authentication chap
!


Может кто делал что подобное, подскажите плз.
А то уже в голове мыслей не осталось ;)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Ограничение трафика по PPP" 
Сообщение от evo Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Фев-04, 13:03  (MSK)
>Всем привет. Вторую неделю бьюсь с проблемой:
>Нужно ограничить скорость доступа пользователя, работающего по PPP и авторизующегося через Radius.
>
>Есть радиосетка, через радиомодем пользователь попадает на NAS,
>тот в свою очередь по VPDN попадает на циску. Пользователь авторизуется на
>Radius-е. После авторизации пользователя на основе интерфейса Virtual-Template1 создается интерфейс Virtual-Access
>x (х номер свободного интерфейса по возрастанию).
>Проблема в том, что скорость каждого модема порядка 2-х мегабит, а нужно
>иметь возможность разным юзерам давать разные скорости (126, 256К и т.д.).
>Возможности сделать traffic-shape или rate-limit на интерфейс Virtual-Access x нет, конфигурится
>только Virtual-Template.
>
>Кусок конфига:
>
>ip address-pool local
>vpdn enable
>!
>vpdn-group TEST
>! Default L2TP VPDN group
> accept-dialin
>  protocol l2tp
>  virtual-template 1
> local name test2
> no l2tp tunnel authentication
> source-ip 172.17.1.126
>!
>!
>!
>!
>!
>!
>!
>!
>fax interface-type fax-mail
>mta receive maximum-recipients 0
>!
>!
>!
>!
>interface FastEthernet0/0
> description Link to NiaB (inside)
> ip address 172.17.1.126 255.255.255.128
> speed 100
> full-duplex
> timeout absolute 600 0
> no cdp enable
>!
>interface Virtual-Template1
> ip unnumbered FastEthernet0/0
> ip nat inside
> ip tcp adjust-mss 1458
> peer default ip address pool ip_pool2
> ppp authentication chap
>!
>
>
>Может кто делал что подобное, подскажите плз.
>А то уже в голове мыслей не осталось ;)


Приветствую!
Покопайся в настройках Радиуса для пользователя, там что-то есть на эту тему.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Ограничение трафика по PPP" 
Сообщение от Ограничение трафика по PPP emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Фев-04, 14:33  (MSK)
Покопался, пересмотрел все стандартные Radius атрибуты, ничего подходящего не нашел :( Может где нить в другом месте есть.
Вообще, это возможно делать? А то может я зря всю эту тему задумал.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Попоробуй еще поставить squid...(+)" 
Сообщение от David emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 23-Фев-04, 07:15  (MSK)
Если это делается для доступа в инет, то после всех этапов авторизации и доступа, поставь еще squid. Там точно есть ограничение по скорости по юзерам по IP и т.д.!
  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Попоробуй еще поставить squid...(+)" 
Сообщение от pure Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 25-Фев-04, 12:17  (MSK)
>Если это делается для доступа в инет, то после всех этапов авторизации
>и доступа, поставь еще squid. Там точно есть ограничение по скорости
>по юзерам по IP и т.д.!

Это не решение проблемы. Человеку надо, что бы пользователи Radius`а ограничивались. И потом это криво.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Ограничение трафика по PPP" 
Сообщение от Alex emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 11-Мрт-04, 13:35  (MSK)
Вот вычитал на cisco.com следующее:

On the Cisco 7200 series with the Broadband feature set, Cisco IOS Software Release 12.2(4)B1 introduces support for rate limiting on the RADIUS user profile applied to the virtual access interface in a PPPoE environment. A sample configuration is provided:

shashi@pepsi.com Password = "cisco"
Service-Type = Framed,
Framed-Protocol = PPP,
Framed-MTU = 1400,
Framed-Routing = 1
Cisco-Avpair = "lcp:interface-config=rate-limit output
access-group 101 64000 1 6000 32000 conform-action transmit exceed-action
drop",
interface Virtual-Access2
  mtu 1492
  ip unnumbered Loopback1
  rate-limit output access-group 101 64000
16000 32000 conform-action transmit exceed-action drop

ссылка: http://www.cisco.com/warp/public/105/pppoe_qos_dsl.html


Вроде то что нужно. Получается нужно 7200 покупать?

PS. Шеф балдеет, говорит если не заработает, заберешь её домой, прибьешь гвоздями к стенке и будешь отрабатывать её стоимость. А мне как-то совсем смешно ;)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "Ограничение трафика по PPP" 
Сообщение от SWorld emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 01-Апр-04, 15:08  (MSK)
>PS. Шеф балдеет, говорит если не заработает, заберешь её домой, прибьешь гвоздями
>к стенке и будешь отрабатывать её стоимость. А мне как-то совсем
>смешно ;)
Cisco AS5350
FreeRadius(http://www.Freeradius.org)

в кофиге сиски
ip access-list extended 103
     permit ip any any
в радиусе
Cisco-AVPair=lcp:interface-config#1=traffic-shape group 103 128000

только есть одно работает только если тунель с компрессией (MPPC например Framed-Compression = 3 причем именно 3 :) )

  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Ограничение трафика по PPP" 
Сообщение от vasili Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 03-Апр-04, 22:20  (MSK)
>Всем привет. Вторую неделю бьюсь с проблемой:
>
>
>Может кто делал что подобное, подскажите плз.
>А то уже в голове мыслей не осталось ;)

Делал и все работало.

en
conf t
virtual-profile aaa
virtual-profile virtual-template 1

В радиусе:
Cisco-Avpair = "lcp:interface-config#1=rate-limit input
access-group 101 64000 1 6000 32000 conform-action transmit exceed-action drop"

Cisco-Avpair + "lcp:interface-config#2=rate-limit output
access-group 101 64000 1 6000 32000 conform-action transmit exceed-action drop"

Вроде так. За синтаксис команд не ручаюсь. Если не получится стучи в мыло ;)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "Ограничение трафика по PPP" 
Сообщение от Alex emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 14-Июл-04, 19:25  (MSK)
Так ничего и не получилось. Может IOS какой-то особенный нужен. Пробовал и на 12.2(16)В2 и на 12.3(8)Т, никакого толку :((

Может подскажете что-нибудь. Cisco 7206VXR.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "Ограничение трафика по PPP" 
Сообщение от vasili emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 19-Июл-04, 16:46  (MSK)
>Так ничего и не получилось. Может IOS какой-то особенный нужен. Пробовал и
>на 12.2(16)В2 и на 12.3(8)Т, никакого толку :((
>
>Может подскажете что-нибудь. Cisco 7206VXR.

debug radius
debug aaa ?

и смотри что происходит.

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру