The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Apache + php4 +php5"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [Проследить за развитием треда]

"Apache + php4 +php5"  
Сообщение от tuxper email on 03-Ноя-06, 22:07 
Необходима на сервере поддержка php4 и php5
Как подружить php4 и php5 на одном сервере???
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Apache + php4 +php5"  
Сообщение от Keeper (??) on 05-Ноя-06, 12:04 
Здесь на форуме была ссылка на решение, когда один из PHP устанавливается как mod_php, а второй - как CGI. Находится поиском.

Пробовал вариант с двумя mod_php -- у меня не получилось. -_-
Проблемы с линковкой разных библиотек к одному апачу, одни и те же имена функций и т.п.
Если кому-нибудь удалось -- буду рад узнать, как.

Как вариант - запуск двух Апачей с разными конфигами - один с mod_php4, другой - с mod_php5.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Apache + php4 +php5"  
Сообщение от Tuxper email(??) on 06-Ноя-06, 06:42 
>Здесь на форуме была ссылка на решение, когда один из PHP устанавливается
>как mod_php, а второй - как CGI. Находится поиском.
>
>Пробовал вариант с двумя mod_php -- у меня не получилось. -_-
>Проблемы с линковкой разных библиотек к одному апачу, одни и те же
>имена функций и т.п.
>Если кому-нибудь удалось -- буду рад узнать, как.
>
>Как вариант - запуск двух Апачей с разными конфигами - один с
>mod_php4, другой - с mod_php5.


А вариант php4 как статический модуль, а php5 как динамический модуль не пройдет???

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Apache + php4 +php5"  
Сообщение от Kreept email(ok) on 07-Ноя-06, 10:42 
>Необходима на сервере поддержка php4 и php5
>Как подружить php4 и php5 на одном сервере???
У себя установил пхп5 как cgi, а пхп4 как модуль все прекрасно работает!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Apache + php4 +php5"  
Сообщение от Keeper email(??) on 07-Ноя-06, 13:28 
Не сомневаюсь. Но в этом случае возможности, специфичные для mod_php, для PHP5 будут недоступны.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Apache + php4 +php5"  
Сообщение от Ares (??) on 08-Ноя-06, 12:27 
>Необходима на сервере поддержка php4 и php5
>Как подружить php4 и php5 на одном сервере???

Я делал так: устанавливал Apache 2.2 + php 5, на эту же машину Apache 1.3 + php 4. И на эту же машину nginx. С помощью последнего запросы которые нужно обрабатывать с помощью php5 отправлял на порт который слушает Apache 2.2, а запросы которые нужно обрабатывать с помощью php4 соответственно на порт который слушает Apache 1.3. Все работает замечательно!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру