The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Catalyst 2960 dhcp relay"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Catalyst 2960 dhcp relay"  +/
Сообщение от lioncub (ok) on 13-Авг-12, 12:38 
Catalyst 2960 c2960-lanbasek9-mz.122-58.SE2
Не получается настроить на cisco dhcp relay (t82). Релей на dlink'e работает, а на cisco не хочет... (статикой все работает)
Клиент vlan11 подключен к cisco, dhcp сервер на linux vlan200 (192.168.0.2).

#sh run:
interface FastEthernet0/1
switch port access vlan11
switchport mode access  
!
interface GigabitEthernet0/2
switchport trunk allowed vlan 11,200
switchport mode trunk
!
interface Vlan11
ip dhcp relay information trusted
no ip address
ip helper-address 192.168.0.2
!
interface Vlan200
description hw
ip address 192.168.0.50 255.255.255.0
!

Что не так?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Catalyst 2960 dhcp relay"  +/
Сообщение от RSG (??) on 14-Авг-12, 13:21 
> interface Vlan11
>  no ip address

Релей юникастом перенаправляет пакеты на сервер.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Catalyst 2960 dhcp relay"  +/
Сообщение от GolDi (??) on 14-Авг-12, 14:50 
>> interface Vlan11
>>  no ip address
> Релей юникастом перенаправляет пакеты на сервер.

http://hypercomp.ru/articles/configuring-dhcp-relay-on-cisco.../

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Catalyst 2960 dhcp relay"  +/
Сообщение от lioncub (ok) on 14-Авг-12, 15:30 
> http://hypercomp.ru/articles/configuring-dhcp-relay-on-cisco.../

Ошибка 404! Страница не найдена! Ошибка 404!

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Catalyst 2960 dhcp relay"  +/
Сообщение от GolDi (??) on 15-Авг-12, 10:16 
>> http://hypercomp.ru/articles/configuring-dhcp-relay-on-cisco.../
> Ошибка 404! Страница не найдена! Ошибка 404!

Надо в конце добавить  /
http://hypercomp.ru/articles/configuring-dhcp-relay-on-cisco.../

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "Catalyst 2960 dhcp relay"  +/
Сообщение от GolDi (??) on 15-Авг-12, 10:16 
>>> http://hypercomp.ru/articles/configuring-dhcp-relay-on-cisco.../
>> Ошибка 404! Страница не найдена! Ошибка 404!
> Надо в конце добавить  /
> http://hypercomp.ru/articles/configuring-dhcp-relay-on-cisco.../

Настройка DHCP Relay на коммутаторе Cisco [27.05.2008]
Переадресация DHCP-запросов на маршрутизатор Cisco

Настройка DHCP Relay позволяет коммутатору Cisco переадресовывать запросы от DHCP-клиента (рабочей станции, IP-телефона) к другому DHCP-серверу (например, старшему в иерархии сети маршрутизатору Cisco). Это дает большее удобство конфигурации (все настройки DHCP хранятся только на маршрутизаторе), а также позволяет с помощью использования опции DHCP 82 избежать широковещательных запросов. Эта опция, включенная на коммутаторе, запоминает, с какого из его портов пришел запрос на получение параметров DHCP, и отправляет ответ только на этот порт. Рассмотрим пример конфигурации DHCP Relay.

1. Выполнить стандартную настройку DHCP-сервера на коммутаторе.
2. Включить DHCP-Relay: (из configure terminal):
  service dhcp
    ip dhcp relay information option
3. Настроить DHCP-Relay (forwarding):
  configure terminal
    interface vlan 2 # VLAN, в котором находятся порты для подключения к маршрутизатору
      ip address 192.168.0.2 255.255.255.0 # Адрес и маска этого интерфейса
      ip helper-address 192.168.0.100 # Адрес, куда переправляются DHCP-запросы (адрес маршрутизатора)
      exit
    interface range FastEthernet0/1 - 5 # Задаем диапазон портов, к которым будут подключены DHCP-клиенты
      switchport mode access
      switchport access-vlan 2


Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Catalyst 2960 dhcp relay"  +/
Сообщение от lioncub (ok) on 15-Авг-12, 14:22 
#ip dhcp relay information option
                                             ^
% Invalid input detected at '^' marker.

+ у меня в другом vlan'е dhcp-сервер

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

4. "Catalyst 2960 dhcp relay"  +/
Сообщение от lioncub (ok) on 14-Авг-12, 19:02 
> http://hypercomp.ru/articles/configuring-dhcp-relay-on-cisco.../

"ip dhcp relay information option"
такой нет команды

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Catalyst 2960 dhcp relay"  +/
Сообщение от lioncub (ok) on 15-Авг-12, 06:19 
>> interface Vlan11
>>  no ip address
> Релей юникастом перенаправляет пакеты на сервер.

interface Vlan200
ip address 192.168.0.50 255.255.255.0

все верно, перенаправляет, но через другой vlan

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

9. "Catalyst 2960 dhcp relay"  +/
Сообщение от RSG (??) on 17-Авг-12, 09:08 
>>> interface Vlan11
>>>  no ip address
>> Релей юникастом перенаправляет пакеты на сервер.
> interface Vlan200
> ip address 192.168.0.50 255.255.255.0
> все верно, перенаправляет, но через другой vlan

У тебя каталист L2. Он не умеет роутить. У него может быть только один SVI. Релей будет только в одном вилане.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

10. "Catalyst 2960 dhcp relay"  +/
Сообщение от karen durinyan (ok) on 17-Авг-12, 09:21 
>>>> interface Vlan11
>>>>  no ip address
>>> Релей юникастом перенаправляет пакеты на сервер.
>> interface Vlan200
>> ip address 192.168.0.50 255.255.255.0
>> все верно, перенаправляет, но через другой vlan
> У тебя каталист L2. Он не умеет роутить. У него может быть
> только один SVI. Релей будет только в одном вилане.

попробуйте поменять sdm если уже не сделали:

conf term
sdm prefer lanbase-routing
end
copy run start

обязательно надо перезагрузить коммутатор, потом

conf term
ip route 0.0.0.0 0.0.0.0 x.x.x.x
ip routing
end
copy run start

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру