The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от opennews (??) on 11-Фев-08, 14:01 
Выпущены обновления Linux ядра - 2.6.24.2 (http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.24.2), 2.6.22.18 (http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.22.18) и 2.6.23.16 (http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.23.16), с исправлением уязвимости, используя которую локальный злоумышленник может получить права суперпользователя в системе.

Проблема вызвана отсутствием проверки указателя в системном вызове vmsplice (http://lwn.net/Articles/181169/), используемом для прямого копирования данных из файлового дескриптора в память. Начиная с ядра 2.6.17, для устранения лишних пересылок между буферами ядра, в sendfile() задействован механизм ввода/вывода - splice.


Уязвимости подвержены все Linux ядра начиная с 2.6.17 и заканчивая 2.6.24.1. Проблему усугубляет наличие эксплоита (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464953) в открытом доступе.

URL: http://permalink.gmane.org/gmane.linux.kernel.announce/509
Новость: https://www.opennet.ru/opennews/art.shtml?num=14141

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 14:01 
Жесть !!!
Как это они так промахнулись в свое время...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Yuriy_S email(??) on 11-Фев-08, 14:05 
>Жесть !!!
>Как это они так промахнулись в свое время...

В любой программе всегда есть уязвимости

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

47. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от ЩекнИтрч on 11-Фев-08, 18:27 
>>Жесть !!!
>>Как это они так промахнулись в свое время...
>
>В любой программе всегда есть уязвимости

В любой программе или в любом ядре? :)
НЕТУ уязвимостей в программах, писанных with security in mind :) НЕ ТУ :)

Уже лет 50 всё пишут й пишут о ПРОВЕРКЕ валидности ввода, а все есть простор для йексплойтов :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

61. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Michael Shigorin email(ok) on 11-Фев-08, 20:21 
>НЕТУ уязвимостей в программах, писанных with security in mind :) НЕ ТУ
>:)

Не надо ля-ля.  Уж слишком хорошо помнится искреннее удивление Solar Designer при выходе из чрута двойным chroot(2).

>Уже лет 50 всё пишут й пишут о ПРОВЕРКЕ валидности ввода, а
>все есть простор для йексплойтов :)

Есть предел представимости кода и данных в человеческой голове.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

78. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от R007 (??) on 12-Фев-08, 20:32 
>В любой программе или в любом ядре? :)

Даже в ОЧЕНЬ МАЛЕНЬКИХ ядрах бывают очень обидные баги.Как пример - дырка в гипервизоре xbox360 была.Уж куда, блин, мельче.

>НЕТУ уязвимостей в программах, писанных with security in mind :) НЕ ТУ
>:)

Ох уж эти сказочники, ох уж эти сказки.В теории оно, конечно, именно так.Но на практике все выглядит иначе: авторы понтуются секурити программы ... пока ее однажды не сломают.Потом стыдливо затыкаются :)

>Уже лет 50 всё пишут й пишут о ПРОВЕРКЕ валидности ввода, а
>все есть простор для йексплойтов :)

Баги были, есть и будут есть.В теории бывают безошибочные программы.На практике - нет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 14:05 
Интересно в каких дистрах уже выпущены обнавления безопастности по этой проблеме?
Поделитесь!
У меня Debian 4 пока еще молчат...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от aZ on 11-Фев-08, 14:08 
>Интересно в каких дистрах уже выпущены обнавления безопастности по этой проблеме?
>Поделитесь!
>У меня Debian 4 пока еще молчат...

Через год проснётся, не волнуйся.. :D

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

67. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от devcoder email(??) on 11-Фев-08, 22:09 
>У меня Debian 4 пока еще молчат...

2aZ
> Через год проснётся, не волнуйся.. :D

Однако бессонница у старичка :)
http://lists.debian.org/debian-security-announce/debian-secu...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от w01f email(ok) on 11-Фев-08, 14:26 
>Интересно в каких дистрах уже выпущены обнавления безопастности по этой проблеме?
>Поделитесь!
>У меня Debian 4 пока еще молчат...

а у меня еще 6-я федора, дык не работает эксплойт :-)  вызывает ошибку сегментирования и все. думаю, что во всех дистрах от редхата данный эксплойт не работает.

Ps:
uname -r
2.6.22.9-61.fc6

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

73. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от prapor (??) on 12-Фев-08, 01:22 
На платном пятом RHES и оракловом (на нем же основанном) работает. Либо в панику вываливает.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 15:14 
>Интересно в каких дистрах уже выпущены обнавления безопастности по этой проблеме?
>Поделитесь!
>У меня Debian 4 пока еще молчат...

В Gentoo утром появилось.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "попробовал - работает"  
Сообщение от mikevmk email(??) on 11-Фев-08, 14:41 
На моей рабочей debian lenny - работает

uname -a
Linux admin 2.6.22-3-686 #1 SMP Mon Nov 12 08:32:57 UTC 2007 i686 GNU/Linux

Но сервера на freebsd :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 14:44 
Gentoo c hardened ядром кладет болт на этот эксплоит

hl@aquinas /tmp $ uname -a
Linux aquinas 2.6.23-hardened-r1 #3 SMP Mon Dec 10 23:14:52 MSK 2007 x86_64 Intel(R) Core(TM)2 Quad CPU @ 2.40GHz GenuineIntel GNU/Linux

hl@aquinas /tmp $ id
uid=1000(hl) gid=100(users) группы=16(cron),100(users)

hl@aquinas /tmp $ ./explo2
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] mmap: 0x100000000000 .. 0x100000001000
[+] page: 0x100000000000
[+] page: 0x100000000038
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4038
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0x351511d06000 .. 0x351511d38000
Убито
hl@aquinas /tmp $ cat /etc/shadow
cat: /etc/shadow: Отказано в доступе

hl@aquinas /tmp $ id
uid=1000(hl) gid=100(users) группы=16(cron),100(users)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

82. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от dem (??) on 12-Фев-08, 23:54 
>Gentoo c hardened ядром кладет болт на этот эксплоит

а ты запусти несколько раз иногда срабатывает

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Денис Подгородниченко email on 11-Фев-08, 14:49 
debian lenny 2.6.22-3-k7

работает ((((

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 15:06 
Как проверить работает эта фича или нет?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от anonymous (??) on 11-Фев-08, 15:13 
>Как проверить работает эта фича или нет?

Лол! Оказывается уязвимости - это фичи такие, я валяюсь...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Lindemidux email(??) on 11-Фев-08, 15:14 
>Как проверить работает эта фича или нет?

собирается командой gcc <имя файла>

Мандрива 2008 - в нокаут, щас буду генту проверять

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 15:18 
неприятно
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 15:26 
Короче полная Ж!

Тестил и просто эксплоит и изменение системного вызова, даже если эксплоит падает с сег. фоултом, машина все равно на какойто раз уходит в кернел паник.

Подвержены виртуальные машины Xen, а на OpenVZ падает нафинг всех node.

Слава linux-у, у меня все сервера в полном... хочу ругацца матом

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 15:51 
>Короче полная Ж!
>
>Тестил и просто эксплоит и изменение системного вызова, даже если эксплоит падает
>с сег. фоултом, машина все равно на какойто раз уходит в
>кернел паник.
>
>Подвержены виртуальные машины Xen, а на OpenVZ падает нафинг всех node.
>
>Слава linux-у, у меня все сервера в полном... хочу ругацца матом

На virtuozzo тоже полный абзац

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

43. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 18:02 
>[оверквотинг удален]
>>
>>Тестил и просто эксплоит и изменение системного вызова, даже если эксплоит падает
>>с сег. фоултом, машина все равно на какойто раз уходит в
>>кернел паник.
>>
>>Подвержены виртуальные машины Xen, а на OpenVZ падает нафинг всех node.
>>
>>Слава linux-у, у меня все сервера в полном... хочу ругацца матом
>
>На virtuozzo тоже полный абзац

А типа virtuozzo не openvz... вот разница а :)
Наложил патчик уже, на остальных жду офф. обновления - ибо там шелов нет почти и все доверенные.

А у кого сегфолтится, вы много раз подряд запускайте его :D потом ловите машину в кернел панике.

И фанатикам привет, как-будто фрю не люди, а роботы пишут, ай тоже ошибаться могут.

Летим дальше.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

62. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Michael Shigorin email(ok) on 11-Фев-08, 20:24 
>а на OpenVZ падает нафинг всех node.

Это с N-го раза?

PS: http://home.powertech.no/oystein/ptpatch2008/

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Slayer605 on 11-Фев-08, 15:29 
юзайте PAX в ядре и не будет такое г.. вас беспокоить
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Konwin email(ok) on 11-Фев-08, 15:54 
Почему это всех так удивляет - как будто в никсах раньше дырок не было.... Что ж вы хотите при таком кол-ве постоянных изменений - до 1500 строк в сутки?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от spamtrap (ok) on 11-Фев-08, 16:23 
>Почему это всех так удивляет - как будто в никсах раньше дырок
>не было.... Что ж вы хотите при таком кол-ве постоянных изменений
>- до 1500 строк в сутки?

маладёжь...не видели детки ещё значить...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 15:53 
Я в шоке..
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 16:02 
Чёй-то не компиляетса... Пишет:
expl.c:335:207: warning: no newline at end of file

В чём бага?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Роман (??) on 11-Фев-08, 16:07 
>Чёй-то не компиляетса... Пишет:
>expl.c:335:207: warning: no newline at end of file
>
>В чём бага?

добавь пустую строчку в конце файла.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

27. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 16:29 
непомогает... иначеб не спрашивал.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

31. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 16:49 
warning не error, компили и запускай =))
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

36. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 17:07 
>warning не error, компили и запускай =))

Ворнинг то не ерор, но ксплоит непашет:

kender@navi:~/bin> ./expl
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] mmap: 0x0 .. 0x1000
[+] page: 0x0
[+] page: 0x20
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4020
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0xb7dce000 .. 0xb7e00000
[-] vmsplice
kender@navi:~/bin>

В чём бага? Система: openSuSe10.3
kender@navi:~/bin> uname -r
2.6.22.5-23-default

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

87. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 20-Фев-08, 14:20 
баги-то как раз и нету. радуйся.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от ak (??) on 11-Фев-08, 16:11 
ядро 2.6.20-gentoo-r8-inst, выдал только это:
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[-] !@#$
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Lindemidux email(??) on 11-Фев-08, 16:19 
На Gentoo 2.6.24-gentoo тоже работает Ж((

Мда нафиг нужен su если есть эксплойт.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 16:20 
а у тебя su любой пользователь может заюзать?)))
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

30. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Lindemidux email(??) on 11-Фев-08, 16:42 
>а у тебя su любой пользователь может заюзать?)))

Да любой. А что при отсутствии пользователя в группе wheel эксплойт не пашет?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

29. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от mma on 11-Фев-08, 16:39 
еще вчера в gentoo-sources-2.6.24-r1 и практически сразу r2 сказано что пофиксено относительно всех извествных эксплойтов на эту уязвимость.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

44. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Славко on 11-Фев-08, 18:03 
Из под обычного пользователя запустите и все заработает
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

28. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Basmach on 11-Фев-08, 16:34 
user@admin:~/Desktop:$ ./exploit
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] mmap: 0x0 .. 0x1000
[+] page: 0x0
[+] page: 0x20
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4020
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0xb7dff000 .. 0xb7e31000
[+] root
root@admin:~/Desktop:# uname -a
Linux admin 2.6.21.5-smp #2 SMP Tue Jun 19 14:58:11 CDT 2007 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux

Slackware 12.0... Работает зараза.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

32. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 16:52 
Ubuntu со всеми апдейтами на ноуте - работает.

Фряшка 6.3 с линукс эмуляцией - vmsplice not implemented. Плохой во фре линуксятор ;-)))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

35. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от FSA (??) on 11-Фев-08, 17:05 
>Фряшка 6.3 с линукс эмуляцией - vmsplice not implemented. Плохой во фре
>линуксятор ;-)))

Дык и если бы была эмуляция, то не работала бы. Это же не ядро линукса сюда впихивают, а собственный код пишут

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

85. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Осторожный on 13-Фев-08, 20:24 
>>Фряшка 6.3 с линукс эмуляцией - vmsplice not implemented. Плохой во фре
>>линуксятор ;-)))
>
>Дык и если бы была эмуляция, то не работала бы. Это же
>не ядро линукса сюда впихивают, а собственный код пишут

В FreeBSD эмулируется Linux 2.6.16, поэтому и нету vmsplice ;)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

33. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Анонима on 11-Фев-08, 16:56 
Все подняли такой шум не из-за очередной ошибки никсов, а из-за общедоступного _рабочего_ эксплоита, благодаря которому любой ушастик сможет положить большинство серверов (имея там шелл).
Вот что страшно...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

34. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 17:05 
>Все подняли такой шум не из-за очередной ошибки никсов, а из-за общедоступного
>_рабочего_ эксплоита, благодаря которому любой ушастик сможет положить большинство серверов (имея
>там шелл).
>Вот что страшно...

даже не шелл, а, например, cgi.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

49. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от ЩекнИтрч on 11-Фев-08, 18:45 
>Все подняли такой шум не из-за очередной ошибки никсов, а из-за общедоступного
>_рабочего_ эксплоита, благодаря которому любой ушастик сможет положить большинство серверов (имея
>там шелл).
>Вот что страшно...

Типа, именно ушастик и именно положить :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

83. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от R007 (??) on 13-Фев-08, 03:21 
>>Все подняли такой шум не из-за очередной ошибки никсов, а из-за общедоступного
>>_рабочего_ эксплоита, благодаря которому любой ушастик сможет положить большинство серверов (имея там шелл).

Если охота поиметь хостера так имея шел можно повесить на нем проксик и ехидно шепнуть о нем на проксичекательном ресурсе.После этого ехидно наблюдать как трафф полезет в гору :) и никакие руты в общем то для такой подставы не нужны а траффа будет дай боже :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

37. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Legiar email(??) on 11-Фев-08, 17:13 
Не работает.

uname -a
2.6.18-xen #1 SMP Fri May 18 16:01:42 BST 2007 x86_64 GNU/Linux

Kernel из комплекта xen-3.1 (бинарная сборка).

Не работет как в dom0, так и в domU.


-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] mmap: 0x100000000000 .. 0x100000001000
[+] page: 0x100000000000
[+] page: 0x100000000038
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4038
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0x2b0662960000 .. 0x2b0662992000
Segmentation fault
kernel: general protection fault: 0000 [1] SMP

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

39. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 17:48 
Да, теперь хана тому, что не обновиться. :( Слава богу, серваки у меня на фре.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

40. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от DarkHost (??) on 11-Фев-08, 17:49 
Это ж сколько корпоративных серверов поимели в первые несколько часов после выхода сплойта?!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

42. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Samm (??) on 11-Фев-08, 17:55 
У вас есть локальные права на корпоративных серверах? :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

51. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от DarkHost (??) on 11-Фев-08, 18:51 
Как правильно сказали, достаточно cgi. Либо удаленный шелл через php.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

69. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Samm (??) on 11-Фев-08, 22:14 
>Как правильно сказали, достаточно cgi. Либо удаленный шелл через php.

Сказал я :)
Повторюсь, у вас есть шелл на корпоративных серверах? :) Или CGI?

Да и с php грамотные админы врубают safe mode и отрубают функции выполнения кода. Так что как раз для corporate этот эксплоит не страшен. В отличии от хостинг провайдеров и community services. Кстати, первое что я сделал - проверил шелл сервера на берлиос и соурсфорж. И там и там старые ядра, так что отдыхаем :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

48. "OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от nevaj on 11-Фев-08, 18:40 
а чё вы переживаете, ну очередной эксплойт и что?
это *преимущество* открытого кода.
т.к. в открытом коде, если даже кто-то заметит баг и втихаря начнёт его юзать,то рано или поздно другой умный и внимательный хлопец заметит *ТОЖЕ* заметит это и напишет разработчикам.
а в случае с закрытыми исходниками....ммм... тот первый хитрец будет его использовать несколько лет(!!!!!!!!!) и никто этого не узнает.
так что это абсолютно штатная ситуация.
всё равно open source рулит. у кого правда тот и сильнее)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

53. "OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от DarkHost (??) on 11-Фев-08, 18:55 
"И что?" - у вас будет ровно до тех пор, пока 10 или больше серверов вашей компании, которые должны работать в режиме nonstop, не накроются медным тазом. Проблема ведь не в том, что "ой, неужели Linux уязвим?", а в последствиях, которые может иметь опубликованный сплойт в руках "юных хакеров".
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

68. "OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от Samm (??) on 11-Фев-08, 22:09 
кто заставляет вас открывать на них локальный доступ?

Реально проблема затрагивает, в основном, хостинг провайдеров и community сервера, с shell access. И то и другое можно смело положить на время апгрейда, а если так уж критично - есть куча вариантов с дублированием серверов (например, с единой нфс файловой базой) и последовательным ребутом. Не первый и не последний експлоит, "и не надо так кричать".

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

84. "OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от R007 (??) on 13-Фев-08, 03:29 
>"И что?" - у вас будет ровно до тех пор, пока 10
>или больше серверов вашей компании, которые должны работать в режиме nonstop,
>не накроются медным тазом. Проблема ведь не в том, что "ой,
>неужели Linux уязвим?", а в последствиях, которые может иметь опубликованный сплойт
>в руках "юных хакеров".

А в случае виндов все тупо приходит к тому что МИЛЛИОНЫ машин по всей планете каждый день шлют спам.А упыри из микрософта еще имеют наглость демонстративно бороться со злом которое на 99.9% сами же и создали.Вы представляете себе ддосы, спам и прочие "приятности" без дырявых виндов?Нет?Ну надо же.Один мощный сервак под линуксом не вопрос отстрелить где-нить на фиреволле.А вот много тысяч виндовых зомбиков фиг отстрелишь когда они вперемешку с легитимными клиентами.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

50. "OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от raver email(??) on 11-Фев-08, 18:46 
Уже пропатчил ядро.. У меня 2.6.21.5 ,так что патч по ссылке для него не подошел, номер строки другой в моем файле. Весь смысл в том, чтобы найти в файле /usr/src/linux/fs/splice.c строку: if (unlikely(!base)) и заменить ее на
if (!access_ok(VERIFY_READ, base, len))

Далее можно собирать новое ядро и потом exploit уже не пашет - проверил.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

52. "OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от Lindemidux email(??) on 11-Фев-08, 18:53 
>Уже пропатчил ядро.. У меня 2.6.21.5 ,так что патч по ссылке для
>него не подошел, номер строки другой в моем файле. Весь смысл
>в том, чтобы найти в файле /usr/src/linux/fs/splice.c строку: if (unlikely(!base)) и
>заменить ее на
>if (!access_ok(VERIFY_READ, base, len))
>
>Далее можно собирать новое ядро и потом exploit уже не пашет -
>проверил.

Большое спасибо, а то бы пришлось самому копать, совсем неохота снимать патчи с ядра.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

54. "OpenNews: Критическая локальная уязвимость в Linux ядрах с 2..."  
Сообщение от DarkHost (??) on 11-Фев-08, 18:56 
Респект и уважуха :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

57. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 19:12 
gentoo-никам обновить ядро и все!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

66. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Ским on 11-Фев-08, 21:48 
>gentoo-никам обновить ядро и все!

Вот кому-кому, а гентушникам необязательно обновляться мне кажется...


scroll@skim ~ $ gcc ./b.c
./b.c:12:22: error: asm/page.h: Нет такого файла или каталога
./b.c: В функции ‘main’
./b.c:193: ошибка: ‘PAGE_SIZE’ undeclared (first use in this function)
./b.c:193: ошибка: (Each undeclared identifier is reported only once
./b.c:193: ошибка: for each function it appears in.)

Возможно я криворукий?

п.с. uname -a
Linux skim 2.6.21-gentoo-r3 #1 SMP Sun Jul 22 14:10:04 MSD 2007 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ AuthenticAMD GNU/Linux

П.П.С. у меня возникает ощущение, что не работает просто на амдшных процах... Хотя судя по коду проц мало отношения имеет к делу, но статистика...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

79. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от лка on 12-Фев-08, 20:41 
>[оверквотинг удален]
>
>п.с. uname -a
>Linux skim 2.6.21-gentoo-r3 #1 SMP Sun Jul 22 14:10:04 MSD 2007 i686
>AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ AuthenticAMD GNU/Linux
>
>
>
>П.П.С. у меня возникает ощущение, что не работает просто на амдшных процах...
>Хотя судя по коду проц мало отношения имеет к делу, но
>статистика...

у мня тоже нет такого на серверах с vserver ядром
в 2.6.17 есть... проапгр

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

63. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 20:44 
$ uname -a
Linux zkc 2.6.24.2-zkcr0 #1 PREEMPT Mon Feb 11 18:44:23 EET 2008 i686 GNU/Linux

обновилсо. На 2.6.24.1 работало :(
зы, дебиан ленни

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

64. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от 221 on 11-Фев-08, 20:45 
однозначно радует оперативность выхода патча
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

65. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от kukulkan (ok) on 11-Фев-08, 21:28 
ubuntu 8.04

test@srv-2:~/exploits$ uname -a
Linux srv-2 2.6.24-5-server #1 SMP Thu Jan 24 20:26:45 UTC 2008 i686 GNU/Linux
test@srv-2:~/exploits$ ./proof-of-concept
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] mmap: 0x0 .. 0x1000
[+] page: 0x0
[+] page: 0x20
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4020
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0xb7e36000 .. 0xb7e68000
[-] vmsplice
test@srv-2:~/exploits$ id
uid=1001(test) gid=1001(test) groups=1001(test)
test@srv-2:~/exploits$

не работает!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

70. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 11-Фев-08, 22:45 
2.6.22.12-desktop-1mdv
[xxx@nixhouse tmp]$ ./exploit
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] addr: 0xc011e150
[-] wtf
[xxx@nixhouse tmp]$  

Эээ. Не пашет видать. Mandriva 2008

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

72. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от exn (??) on 12-Фев-08, 01:14 
хорошо хоть 2.4 не берет, проверенно.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

76. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от IMDagger on 12-Фев-08, 16:11 
>хорошо хоть 2.4 не берет, проверенно.

полностью согласен :))))
$uname -a
Linux Undead 2.4.31 #6 Sun Jun 5 19:04:47 PDT 2005 i686 unknown unknown GNU/Linux


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

75. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 12-Фев-08, 15:01 
Как и сказал: gentoo-никам обновить ядро и все!
до обновлении ядро exploit работал а после неа:

-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] mmap: 0x0 .. 0x1000
[+] page: 0x0
[+] page: 0x20
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4020
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0xb7e78000 .. 0xb7eaa000
[-] vmsplice: Bad address

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

77. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Lindemidux email(??) on 12-Фев-08, 16:20 
Я дро можно обновить на любом дистрибе и все, просто на дистрибах с извращенными ядрами типа suse придется накопать нужных патчей (просто помню поставил на сусе ванильное ядра DNS и Apparmor отвалились :). Или ждать официального ядра для дистров.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

80. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Basmach on 12-Фев-08, 20:47 
В Slackware уже новое ядро лежит. Переставил и все, не работает.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

81. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Michael Shigorin email(ok) on 12-Фев-08, 23:21 
>В Slackware уже новое ядро лежит. Переставил и все, не работает.

У меня другой вопрос -- кто ещё _не_ выпустил исправление?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

86. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Аноним (??) on 14-Фев-08, 13:42 
>Я дро можно обновить на любом дистрибе и все, просто на дистрибах
>с извращенными ядрами типа suse придется накопать нужных патчей (просто помню
>поставил на сусе ванильное ядра DNS и Apparmor отвалились :). Или
>ждать официального ядра для дистров.

"kender@navi:~/bin> ./expl
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
[+] mmap: 0x0 .. 0x1000
[+] page: 0x0
[+] page: 0x20
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4020
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0xb7dce000 .. 0xb7e00000
[-] vmsplice
kender@navi:~/bin>

В чём бага? Система: openSuSe10.3
kender@navi:~/bin> uname -r
2.6.22.5-23-default" (см. выше)

На дистрах с "изврашенными" ядрами типа сусе, оно просто не работат )))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

88. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от jill email on 25-Фев-08, 04:53 
hoster1@mera:/tmp$ ./rootit
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
Run as root to minimize risk of crashing system
Press Enter to proceed as normal user.  Press Ctrl-C to abort.

[+] mmap: 0x0 .. 0x1000
[+] page: 0x0
[+] page: 0x20
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4020
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0xb7de9000 .. 0xb7e1b000
[-] vmsplice
hoster1@mera:/tmp$    
mysql@mera:/tmp$ uname -a
Linux mera 2.6.21.5-smp #2 SMP Tue Jun 19 14:58:11 CDT 2007 i686 Intel(R) Celeron(R) CPU 2.60GHz GenuineIntel GNU/Linux
на слакваре не сработал, хотя до этого видел посто что на этом ядре получилось

hoster1@mera:/tmp$ ./rootit
-----------------------------------
Linux vmsplice Local Root Exploit
By qaaz
-----------------------------------
Run as root to minimize risk of crashing system
Press Enter to proceed as normal user.  Press Ctrl-C to abort.

[+] mmap: 0x0 .. 0x1000
[+] page: 0x0
[+] page: 0x20
[+] mmap: 0x4000 .. 0x5000
[+] page: 0x4000
[+] page: 0x4020
[+] mmap: 0x1000 .. 0x2000
[+] page: 0x1000
[+] mmap: 0xb7de9000 .. 0xb7e1b000
[-] vmsplice
hoster1@mera:/tmp$    
hoster1@mera:/tmp$ uname -a
Linux mera 2.6.21.5-smp #2 SMP Tue Jun 19 14:58:11 CDT 2007 i686 Intel(R) Celeron(R) CPU 2.60GHz GenuineIntel GNU/Linux
на слакваре не сработал, хотя до этого видел посто что на этом ядре получилось

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

89. "Критическая локальная уязвимость в Linux ядрах с 2.6.17 по 2..."  
Сообщение от Mike (??) on 26-Фев-08, 21:40 
Centos 5 ядро 2.6.18-53.1.4.el5
эксп работает
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру