The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Тематический каталог: Cisco Безопасность в Cisco IOS (Secure IOS Template) (eng) (cisco security howto acl aaa flood ios)"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Тематический каталог: Cisco Безопасность в Cisco IOS (Secure IOS Template) (eng) (cisco security howto acl aaa flood ios)"  +/
Сообщение от auto_topic (?), 30-Апр-04, 12:37 
Обсуждение статьи тематического каталога: Cisco Безопасность в Cisco IOS (Secure IOS Template) (eng) (cisco security howto acl aaa flood ios)

Ссылка на текст статьи: https://www.opennet.ru/base/cisco/secure_ios.txt.html

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Cisco Безопасность в Cisco IOS (Secure IOS Template) (eng) (cisco security howto acl aaa flood ios)"  +/
Сообщение от dmitry kiselev (?), 30-Апр-04, 12:37 
Сильно устаревший template. Новый нужно брать с cymru.. один null-routing 82/8, 83/8 чего стоит..
Ответить | Правка | Наверх | Cообщить модератору

2. "Cisco Безопасность в Cisco IOS (Secure IOS Template) (eng) (cisco security howto acl aaa flood ios)"  +/
Сообщение от Glushenkoemail (?), 02-Май-04, 15:02 
А не изволите-ль ссылочку туда кинуть?

С уважением, Владимир

Ответить | Правка | Наверх | Cообщить модератору

3. "Cisco Безопасность в Cisco IOS (Secure IOS Template) (eng) (cisco security howto acl aaa flood ios)"  +/
Сообщение от Glushenkoemail (?), 02-Май-04, 15:02 
Простите. Вот тут правильная почта!
Ответить | Правка | Наверх | Cообщить модератору

6. "fedulov solo"  +/
Сообщение от student666email (?), 22-Апр-22, 03:24 
hostnamectl set-hostname (имя) - дебиан

Адресация

-CLI
ip 3.3.3.(число от 2 до 10)
маска 24
гэтэвээй 3.3.3.1

-ISP
nano /etc/network/interfaces

auto ens256
iface ens256 inet static
address 3.3.3.1
netmask 255.255.255.0

auto ens224
iface ens224 inet static
address 5.5.5.1
netmask 255.255.255.0

auto ens192
iface ens192 inet static
address 4.4.4.1
netmask 255.255.255.0

ctrl + x потом Y и ентер

systemctl restart networking

ip a чекунть айпи и интерфейсы

-RTR L

en
conf t
int g1
ip address 4.4.4.100 255.255.255.0
no sh
int g2
ip address 192.168.100.254 255.255.255.0
no sh

-RTR R

en
conf t
int g1
ip address 5.5.5.100 255.255.255.0
no sh
int g2
ip address 172.16.100.254 255.255.255.0
no sh

-WEB L

nano /etc/network/interfaces

auto ens192
iface ens192 inet static
address 192.168.100.100
netmask 255.255.255.0
gateway 192.168.100.254

systemctl restart networking

-WEB R

nano /etc/network/interfaces

auto ens192
iface ens192 inet static
address 172.16.100.100
netmask 255.255.255.0
gateway 172.16.100.254

systemctl restart networking

-SRV

ip 192.168.100.200/24
gateway 192.168.100.254


1. Сети, подключенные к ISP, считаются внешними:
ISP forward
nano /etc/sysctl.conf
   net.ipv4.ip_forward=1
   sysctl -p
image

RTR-L Gitw
ip route 0.0.0.0 0.0.0.0 4.4.4.1

RTR-R gitw
ip route 0.0.0.0 0.0.0.0 5.5.5.1

2. Платформы контроля трафика, установленные на границах регионов, должны выполнять трансляцию трафика, идущего из соответствующих внутренних сетей во внешние сети стенда и в сеть Интернет.
RTR-L NAT
на внутр. интерфейсе - ip nat inside

на внешн. интерфейсе - ip nat outside

int gi 1
ip nat outside
!
int gi 2
ip nat inside
!
access-list 1 permit 192.168.100.0 0.0.0.255
ip nat inside source list 1 interface Gi1 overload

RTR-R NAT
int gi 1
ip nat outside
!
int gi 2
ip nat inside
!
access-list 1 permit 172.16.100.0 0.0.0.255
ip nat inside source list 1 interface Gi1 overload

3. Между платформами должен быть установлен защищенный туннель, позволяющий осуществлять связь между регионами с применением внутренних адресов.
RTR-L GRE
interface Tunne 1
ip address 172.16.1.1 255.255.255.0
tunnel mode gre ip
tunnel source 4.4.4.100
tunnel destination 5.5.5.100
exi
router eigrp 6500
network 192.168.100.0 0.0.0.255
network 172.16.1.0 0.0.0.255

RTR-R
interface Tunne 1
ip address 172.16.1.2 255.255.255.0
tunnel mode gre ip
tunnel source 5.5.5.100
tunnel destination 4.4.4.100
exi
router eigrp 6500
network 172.16.100.0 0.0.0.255
network 172.16.1.0 0.0.0.255

RTR-L
crypto isakmp policy 1
encr aes
authentication pre-share
hash sha256
group 14
!
crypto isakmp key TheSecretMustBeAtLeast13bytes address 5.5.5.100
crypto isakmp nat keepalive 5
!
crypto ipsec transform-set TSET  esp-aes 256 esp-sha256-hmac
mode tunnel
!
crypto ipsec profile VTI
set transform-set TSET
interface Tunnel1
tunnel mode ipsec ipv4
tunnel protection ipsec profile VTI

RTR-R
conf t

crypto isakmp policy 1
encr aes
authentication pre-share
hash sha256
group 14
!
crypto isakmp key TheSecretMustBeAtLeast13bytes address 4.4.4.100
crypto isakmp nat keepalive 5
!
crypto ipsec transform-set TSET  esp-aes 256 esp-sha256-hmac
mode tunnel
!
crypto ipsec profile VTI
set transform-set TSET
interface Tunnel1
tunnel mode ipsec ipv4
tunnel protection ipsec profile VTI

4. Платформа управления трафиком RTR-L выполняет контроль входящего трафика согласно следующим правилам:
RTR-L ACL
ip access-list extended Lnew
permit tcp any any established
permit udp host 4.4.4.100 eq 53 any
permit udp host 5.5.5.1 eq 123 any
permit tcp any host 4.4.4.100 eq 80
permit tcp any host 4.4.4.100 eq 443
permit tcp any host 4.4.4.100 eq 2222
permit udp host 5.5.5.100 host 4.4.4.100 eq 500
permit esp any any
permit icmp any any
int gi 1
ip access-group Lnew in

5. Платформа управления трафиком RTR-R выполняет контроль входящего трафика согласно следующим правилам:
RTR-R ACL
ip access-list extended Rnew
permit tcp any any established
permit tcp any host 5.5.5.100 eq 80
permit tcp any host 5.5.5.100 eq 443
permit tcp any host 5.5.5.100 eq 2244
permit udp host 4.4.4.100 host 5.5.5.100 eq 500
permit esp any any
permit icmp any any
int gi 1
ip access-group Rnew in


6. Обеспечьте настройку служб SSH региона Left:
RTR-L SSH
ip nat inside source static tcp 192.168.100.100 22 4.4.4.100 2222
RTR-R SSH
ip nat inside source static tcp 172.16.100.100 22 5.5.5.100 2244
SSH WEB-L
apt-cdrom add
apt install -y openssh-server ssh
systemctl start sshd
systemctl enable ssh
SSH WEB-R
apt-cdrom add
apt install -y openssh-server ssh
systemctl start sshd
systemctl enable ssh

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру