The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"OpenNews: Почему PHP не рекомендуется использовать с Apache ..."
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [Проследить за развитием треда]

"OpenNews: Почему PHP не рекомендуется использовать с Apache ..."
Сообщение от opennews (??) on 05-Апр-04, 11:04 
Simon Willison пояснил в своем блоге, почему на сайте php.net (http://www.php.net/manual/en/install.apache2.php) до сих пор особо подчеркнуто противопоказанность использования PHP совместно с apache 2.0 для более-менее критичных задач.
Проблемы возникают из-за неподготовленности многих библиотек PHP для работы в мульти-тредовом режиме, поэтому крайне рекомендуется  при использовании mod_php активировать в apache 2.0 только мульти-процессный модуль MPM prefork (http://httpd.apache.org/docs-2.0/mod/prefork.html) (под unix подключается по умолчанию), а не популярный MPM worker (http://httpd.apache.org/docs-2.0/mod/worker.html). Т.е. проблем при использовании mod_php с apache 2.0 + prefork не больше, чем при использовании apache 1.3 (если не считать более часто появляющиеся проблемы с безопасностью).

URL: http://simon.incutio.com/archive/2004/03/31/phpAndApache2
Новость: https://www.opennet.ru/opennews/art.shtml?num=3598

Cообщить модератору | Наверх | ^

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Почему PHP не рекомендуется использовать с Apache 2.0"
Сообщение от Nickolay email(??) on 05-Апр-04, 11:04 
кто-то в курсе когда появится модуль для apache2 для заворачивания его через xinetd?
Cообщить модератору | Наверх | ^

2. "Запуск через *inetd"
Сообщение от Дмитрий Ю. Карпов email on 05-Апр-04, 14:27 
Запуск программ в режиме сервиса (через inetd или его продвинутые версии) приемлем для тех программ, которые быстро стартуют и долго работают. К таковым относятся telnetd, ftpd и smbd (nmbd запускается через inetd, но не заканчивает работу, а остаётся в режиме демона). В принципе, так можно запускать и sshd, хотя его старт может затянуться из-за необходимости генгерировать какие-то ключи (хотя я так и не понял, почему их нельзя сгенерировать один раз и сохранить на диск). Кроме того, через inetd нельзя запускать программы, которые работают по третьим протоколам (не TCP и не UDP), а также все программы, которые "слушают" bpf (Berkley Packet Filter). Протокол HTTP расчитан на закрытие TCP-сессии сразу после выдачи запрошенной страницы, поэтому ни Apache, ни Squid не имеет смысла запускать в режиме сервиса. IMHO.
Cообщить модератору | Наверх | ^

3. "Почему PHP не рекомендуется использовать с Apache 2.0"
Сообщение от sadmitry email(??) on 06-Апр-04, 09:51 
Apache 2.0 еще сыроват. Для production целей не годится. А насчет (x)inted... Такой способ не рекомендуется для запуска Apache. Оставлен по историческим причинам.
Cообщить модератору | Наверх | ^

4. "Почему PHP не рекомендуется использовать с Apache 2.0"
Сообщение от Аноним Jessy on 23-Фев-06, 19:01 
А нам неадминам всёравно :)
Cообщить модератору | Наверх | ^

Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру