The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Тематический каталог: Установка ядра linux-2.6.1 (вместо 2.4..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"Тематический каталог: Установка ядра linux-2.6.1 (вместо 2.4..."  
Сообщение от auto_topic on 20-Янв-04, 14:09 
Обсуждение статьи тематического каталога: Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install slackware linux)

Ссылка на текст статьи: https://www.opennet.ru/base/sys/26_kernel_install.txt.html

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от anonymous on 20-Янв-04, 14:09 
Собственно зачем такой изврат с каталогом? Всегда ядро компилили в /usr/src/, а тут вдруг /home/...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Hak email on 20-Янв-04, 14:28 
44 пункта и это что бы только ядро пересобрать !!!!

ДА FreeBSD тут рулит..... 6 команд и всё готово и ни какого гемороя ....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от xz on 20-Янв-04, 14:49 
Блин да че вы сосвоими бздями то никак не успакоитесь ? сидите и рулите/тормазите на своей любимой бзде!
Статья расчитана на начинающего пользователя а не на мега гуру вроди вас!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от sovchik on 20-Янв-04, 16:36 
М-да.. Задачка не для средних умов (особенно с контролем за файлами). Подожду пока любимый slackware с ядром 2.6.хх не выйдет
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от u on 20-Янв-04, 18:33 
хм, всё же очень просто, в той же слаке 9.0/9.1:

ядра с 2.5.какого-то используют не старый modutils, а новый module-init-tools:

module-init-tools which replaces modutils for modern kernels (http://www.kernel.org/pub/linux/kernel/people/rusty/)

поэтому, ставим сначала mod-init-tools:

// качаем
root@server:~# wget http://www.kernel.org/pub/linux/kernel/people/rusty/modules/...

// разархивируем в /usr/src
root@server:~# tar jxvf module-init-tools-0.9.14.tar.gz -C /usr/src

// переходим в сырочки
root@server:~# cd /usr/src/module-init-tools-0.9.14

// конфигурим
root@server:/usr/src/module-init-tools-0.9.14# ./configure --prefix=/ --enable-zlib

// компилируем
root@server:/usr/src/module-init-tools-0.9.14# make

// инсталлим
root@server:/usr/src/module-init-tools-0.9.14# make install

Всё, теперь старые modutils доступны с расширением name.old, например /sbin/modprobe.old, а новый, как /sbin/modprobe :)

Теперь качаем и ставим само ядро (с патчем):

// переходим в хомяк
root@server:/usr/src/module-init-tools-0.9.14# cd

// качаем
root@server:~# wget http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.1.tar.bz2

// разархивируем в /usr/src
root@server:~# tar jxvf linux-2.6.1.tar.bz2 -C /usr/src

// теперь качаем патчик прямиком в директорию сырочков ядрышка
root@server:~# wget -O /usr/src/linux-2.6.1 http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2...

// устанавливаем права для юзера, под ктр-ым будем компилить ядро
root@server:~# chown -R user.group /usr/src/linux-2.6.1

// устанавливаем красивое название хвоста
root@server:~# hostname server.domain.uz

// переходим на этого юзера
root@server:~# su - user

// переходим в директорию сырочков ядра
user@server:~$ cd /usr/src/linux-2.6.1

// разархивируем патч и сразу же патчим ядро
user@server:/usr/src/linux-2.6.1$ bzip2 -dc 2.6.1-mm5.bz2 | patch -p1

// очищаем всё и приводим в исходное состояние (в принципе необязательно)
user@server:/usr/src/linux-2.6.1$ make clean mrproper

// запускаем меню (если ругнётся на ncurses, то ставим эту библиотеку, под rpm-like: http://rpmfind.net/linux/rpm2html/search.php?query=ncurses-d..., под pkgtool: ftp://ftp.linuxpackages.net/pub/Slackware-7/ncurses-5.1/ncur... или сырочки: http://freshmeat.net/redir/ncurses/6995/url_tgz/ncurses-5.3....)
user@server:/usr/src/linux-2.6.1$ make menuconfig

// компилируем сжатое ядро и модули
user@server:/usr/src/linux-2.6.1$ make bzImage modules

// возвращаемся к рутам
user@server:/usr/src/linux-2.6.1$ exit

// заходим в директорию сырочков ядра
root@server:~# cd /usr/src/linux-2.6.1

// инсталлим модули в /lib/modules/2.6.1-mm5
root@server:/usr/src/linux-2.6.1# make modules_install

// копируем сжатое ядро в директорию загрузки /boot
root@server:/usr/src/linux-2.6.1# cp ./arch/i386/boot/bzImage /boot/bzImage-ide-2.6.1

// копируем карту системы в директорию загрузки /boot
root@server:/usr/src/linux-2.6.1# cp System.map /boot/System.map-ide-2.6.1

// копируем конфиг ядра в директорию загрузки /boot
root@server:/usr/src/linux-2.6.1# cp .config /boot/config-ide-2.6.1

// переходим в директорию загрузки /boot
root@server:/usr/src/linux-2.6.1# cd /boot

// удаляем старые символические ссылки на старые ядра
root@server:/boot# rm -f config bzImage System.map

// создаём символическую ссылку на новое ядро
root@server:/boot# ln -s bzImage-ide-2.6.1 bzImage

// создаём символическую ссылку на новую карту системы
root@server:/boot# ln -s System.map-ide-2.6.1 System.map

// создаём символическую ссылку на новый конфиг ядра
root@server:/boot# ln -s config-ide-2.6.1 config

// редактируем конфиг lilo (если у Вас grub, то редактируйте /etc/grub.conf)
root@server:/boot# vi /etc/lilo.conf

// добавляем следующее:
# Linux bootable partition config begins
image = /boot/bzImage
  root = /dev/hda2
  label = Linux-2.6.1
  read-only
# Linux bootable partition config ends

соответственно, исправляя ссылки на старые ядра:
# Linux bootable partition config begins
image = /boot/bzImage-ide-2.4.24
  root = /dev/hda2
  label = Linux-2.4.24
  read-only
# Linux bootable partition config ends
// И сохраняемся -- [Esc] [Esc] [:] [x] [Enter]

// записываем загрузчик
root@server:/boot# lilo
Added Linux-2.6.1 *
Added Linux-2.4.24
Added Original-2.4.22

// и перезагружаемся
root@server:/boot# reboot

// после перезагрузки, гордо глядим:
root@server:~# cat /proc/version

зы. никакой ответственности за опечатки или некорректную инфу я не несу, я просто описал мой личный алгоритм пересборки ядер (который, кстати, далёк от совершенства, так что пинки типа "ламер" -- не принимаются!) под слаку (заметьте, под СЛАКУ!), хотя от других дистрибов отличается всё только названиями файлов в /boot директории и конфиге загрузчика ;)

зы2. В ядре 2.6 появились не только секьюрити и криптографии, в частности конфиги драйверов вынесены в отдельный раздел, что удобнее, однако почему то настройки сети, вынесены в конфиг драйверов сети ;). Появилась наконец встроенная поддержка ACPI, XFS, а так же есть и NPTL.

зы3. Из указанных выше обязательных пакетов для ядра можно спокойно исключить те, ктр-ые вам не понадобятся, например если вы не используете JFS от IBM, NFS и XFS, то jfsutils, nfs-utils и xfsprogs можно выбросить, и pcmcia-cs я не использую на серверах, т.к. это имхо для PCMCIA у ноутбуков. isdn4k-utils -- не нужен, если у Вас нет ISDN, а вот наличие компилятора си и его библиотек -- разумеется обязательно, хотя в список почему то не включён ncurses, без которого невозможно построение синеньгих менюшей make menuconfig. Ну и т.п. ;)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Soldier on 20-Янв-04, 19:51 
>зы2. В ядре 2.6 появились не только секьюрити и криптографии, в частности конфиги
>драйверов вынесены в отдельный раздел, что удобнее, однако почему то настройки сети,
>вынесены в конфиг драйверов сети ;). Появилась наконец встроенная поддержка ACPI,
>XFS, а так же есть и NPTL.

И убрана поддержка кое-какого железа, поддерживаемого ядрами 2.4.x :)))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от u on 20-Янв-04, 19:59 
ну и фиг с ним ;), если надо -- доставим патчами/драйверами :)

а у меня слава богу сервера с нормальным железом :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от mr_Y on 09-Апр-04, 14:41 
Про module-init-tols все очень великолепно описано, но у меня на практике чуток разашлось.
Система RH9, ядро- 2.4.20-8 (шло в с системой) (module-init-tools 3.0-закачал с kernel.org)
Захотел поставить 2.6.4.
Поставил. При загрузке стало появляться сообщение что QM_MODULE нормально не отрабатывает (точно сообщение не запомнил :)) )
Прочел статью, коментарии, выполнил - пофиг не работает.
В коментарии пропущена операция #2
1.  ./configure --prefix=/
2.  make moveold
3.  .....
За более подробными коментариями смотрим README в папке module-init-tools 3.0

А за статью и коментарии большое спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

28. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от L0rda on 06-Окт-04, 16:42 
про initrd ни слова;)
однако если вы используете scsi или sata(или еще что-то подобное), и при установке не сделаете preload драйвера скази-хост-адаптера в initrd, вам светит kernel panic
например MPT fusion и sata на федоре работать отказывались
а MPT fusion на 2.6 ядрах встает только модулем
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Anikina Galina email on 21-Янв-04, 02:39 
Данная статья написана для начинающих - так как когда я начинала копаться с ядром нигде не могла найти одну подробную статью на данную тему предельно просто написанную). Находились только информация фрагментами - немного там, немного там. Трата времени на поиски информацмм - непозволительная роскошь - потому что у меня нет под боком ГУРУ, который бы мне все расталмачивал. А насчет modutil-init... Вы наверное не заметили - уменя изначально стояло ядро 2.4.20, а не серии 2.5.х. Касательно 44 пунктов - как вы заметили наверное там много вопросов не относящихся напрямую к ядру: в частности вопросы как пользоваться программами ls, grep и др. То есть простому юзеру (желающему прикоснуться к данному вопросу) предоставляется как бы поддержка на первых порах, так как после перехода с графической оболочки любого типа на консоль , не знаю кому как , а мне было слегка дискомфортно от полного незнания что-как). А далее почуствовал себя более уверенно он и сам освоится. Должны же у нас еще появиться новые Кулибины... Не всеж телесериалами взахлеб увлекаться (или отгадыванием слов).
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от shurutov email on 21-Янв-04, 14:29 
Уважаемая Галина! Вы указали, что ядро ставится на Слаку 9.1.
module-init-tools-0.9.14 идут в ней по умолчанию. modutils-ов я в ней не наблюдал. Это первое, второе в этом дистрибутиве ядро 2.4.22. Откуда у Вас 2.4.20?
Зачем вводить новичков в заблуждение?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от krep on 21-Янв-04, 08:04 
Поразительно.Как можно из четырех строчек файла
README столько создать.Много ничего.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Searcher email on 21-Янв-04, 11:29 
Эх, вставлю и я своих 5 копеек и по статье и по коментам :-)

:-) Коменты для типа просветлённых, кто в танке - сам виноват :-) пора познавать мир за его пределами

Первый момент, посмотрел на дату постинга статьи (16 Jan 2004) - довольно свежая, правда не знаю когда сама статья писалась - ставить ядро с тест версии с патчованием - изврат дикий и неверный при наличии уже стабильной ветки (например уже доступна 2.6.1 как минимум к моменту выхода статьи здесь, я уже не говорю про патчи, в том числе и мм)
К чему это я - это к тому что количество телодвижений уменьшается :-) особенно с патчами
И это мой ответ на закидон фришников (:-))) я тоже юзаю фрю и не толко фрю, вплоть даже до винды :-) ). Более того не могу удержаться "ДА FreeBSD тут рулит..... 6 команд и всё готово и ни какого гемороя" :-) не нужно лукавить и нужно признать что эти 6 команд просто есть множество других команд, просто соглашусь - что оптимизировано, хотя и скрыта суть получается.
:-) Чел как минимум сам не "рулит" которой судит на уровне "рулит не рулит" и делает ГЛОБАЛЬНЫЕ выводы на основании количества команд по сборке ядра даже особо не вникая в то что тут описано и не зная что в линух как и в любой никс системе есть много путей решения одной и той же проблемы (тут типа в постингах частично описали типа как попроще проделать тоже самое, но попроще подразумевает что вы в курсе о каждом шаге который проделываете :-))

Что меня "убивает" в подобных статьях (типа для чайников):
"а если не - тоже не беда- так как у вас до этого
  было другое ядро и, надеюсь вы были благоразумны и не удалили его из
  /boot - грузимся с него.
"
Моменты резервной загрузки неописаны никогда чётко , тоесть грубо говоря, человеку не даётся, с моей точки зрения, нужной уверенности в том, что он не "увалит" всё основательно.
Для этого всего лиш нужно было кратко сказать (даже не сказать а сакцентировать внимание) о том, что нужно указываемую "строку" (блок) просто добавить паралельно со "строкой" для старого ядра.
А ещё лучше (раз уж так расписан механизм контроля файлов через поиск по таймстамповым меткам) расписать типа резервный механизм через 2 пункта меню для лило (1-новое ядро, 2-старое)

Про новое ядро - не нужно превозносить новое ядро, хотя оно действительно хорошо. На данный момент ещё чудесно можно использовать и 2.4.х ветку (я отдаю предпочтение 2.4.24) с нужным тюнингом (куча патчей разных, :-) расписывать влом)
С новым ядром также наблюдается небольшой "траблик" - много ещё чего из существующего софта не юзает его потенциал на полную катушку.
Тоесть я не хочу спорить что лучше и т д, я просто хочу сказать что всегда нужно что-то использовать в зависимости от задач, и при этом полностью понимать что происходит и зачем ты это делаеш.
:-) но тестировать новые ядра уважающий себя линуксоид просто обязан!


:-) подпись: Searcher, неизменный фанат Слаки, тоже юзающий мультибут и держащий кучу ОС-хлама на своём компе с "извращёнными конфигами"... :-)))))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Anikina Galina email on 22-Янв-04, 03:57 
Modutils-2.4.22-i386-1, а Slackware 9.0 - извините очепятка. Я ее первый раз поставила - потому что кое-что э.. не так сделала в RedHat 7.3 и мне надо было восстановить работоспособность - поэтому и попробовала поставить Slackware с одного компакта, который купила ради пробы. Теперь не жалею об этом - она гораздо проще в управлении и апгрейде чем RedHat, хотя та лучше для начинающих. А вообще вы по-моему не обратили внимания на самое интересное - что грузятся две системы (а может и не две а больше...). И как правильно заметили этот момент не расписан четко - надо написать будет - это интересно. Кстате если будет время, силы и т.д. - поставлю фри - лежит один компакт - для пробы.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Timur on 23-Янв-04, 09:44 
Здарова!
Я вот тут возился с Gentoo ...
Понятно, что мне туда и надо, но все-таки.
Короче вот чего. Ставлю в 2.6.1 поддержку devfs (в Gentoo это надо делать обязательно), а поддержки, то и нет. Стартовый скрипт Gentoo орет, что мол вы скомпилили ядро без таковой поддержки. Опция "mount at boot" тоже не помогает (тем более что это плохая идея). Кто-нибудь сталкивался с такими проблемами? Самое противное, что nVidia модуль не хочет собираться без devfs. В логах компиляции видел ругань именно на функции работы с devfs. Странно это вообще-то, но вполне возвожно, что это прикол самого Gentoo (USE и все такое).
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Timur on 23-Янв-04, 15:23 
Хм ... Заработало.
В общем все ок.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от kalessin on 28-Янв-04, 16:00 
[root@zevs module-init-tools-0.9.14]# make
source='lsmod.c' object='lsmod.o' libtool=no \
depfile='.deps/lsmod.Po' tmpdepfile='.deps/lsmod.TPo' \
depmode=gcc3 /bin/sh ./depcomp \
gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"module-init-tools\" -DVERSION=\"0.9.14\" -DCONFIG_USE_ZLIB=1  -I. -I.     -g -O2 -Wunused -Wall -Wcast-align -c `test -f 'lsmod.c' || echo './'`lsmod.c
gcc  -g -O2 -Wunused -Wall -Wcast-align   -o lsmod  lsmod.o -Wl,-Bstatic -lz -Wl,-Bdynamic
/usr/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
make: *** [lsmod] Ошибка 1
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от cr_lam0 email on 16-Фев-04, 15:22 
> /usr/bin/ld: cannot find -lz
Проверь, стоит ли у тебя zlib. Если у тебя RedHat-совместимый дистрибутив, то:
rpm -qa | grep zlib
rpm -qa | grep zlib-devel

Если package is not installed, то инсталлируй его :)

Ну или ls -l /usr/lib/libz.*, должно быть что-то вроде:
[root@wall /root]# ls -l /usr/lib/libz.*
-rwxr-xr-x    1 root     root        65956 Apr  8  2001 /usr/lib/libz.a
lrwxrwxrwx    1 root     root           13 Aug 25 02:46 /usr/lib/libz.so -> libz.so.1.1.3
lrwxrwxrwx    1 root     root           13 Aug 25 02:44 /usr/lib/libz.so.1 -> libz.so.1.1.3
-rwxr-xr-x    1 root     root        59686 Apr  8  2001 /usr/lib/libz.so.1.1.3

Если либ нет, то иди на http://www.info-zip.org/pub/infozip/zlib/, качай исходники, компилируй и инсталлируй.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от kalessin email on 29-Янв-04, 10:54 
вопрос решился установкой module-init-tools-3.0-pre7
на 0.9.14 ядро 2.6.1 неработает с модулями и не делает модпрорбе ...
а ошибка с лд решалось перепрописыванием лд.со.кониг
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Agan email on 31-Янв-04, 19:39 
Ничего не понял, собственно я для пробы поставил в первые в жизни Слаку. До ентого сидел исключительно на винде. Начитался доков аж из ушей полезло))). Пытался перекомпилить ядро 2.4.20 Под свой атлон. Ельза перестала вставать. Вот решил поставить 2.6.1 вроде в нём уже она есть. Да тут во такие засады(((. До гуру какого небудь, как до луны. Вооот
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Аникина Галина email on 17-Фев-04, 20:35 
Молодец что поставил слаку. Э..э.. можно уточнить, что такое Ельза (для тех, кто в танке :))).
А слака очень простая, быстрая и удобная.
Поясни - в чем проблема.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "ематический каталог: Установка ядра linux-2.6.1 (вместо 2.4...."  
Сообщение от starling on 04-Мрт-04, 13:32 
Эээээ....
А make modules делать не будем???
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от AMMA email on 22-Мрт-04, 16:20 
Проблемы с установкой ядра 2.6.1-2.6.2
Стояла Red Hat 7.2. со своим ядром. Установил ядро
2.4.24 без особых проблем.
При установке 2.6.1. с патчем отказывается становится(все рекомендации "Changes" также были выполнены).
   Установка 2.6.2 (тоже с патчем) идет дальше, но где-то в конце (make bzImage modules modules_install) make выдает "... i810..." и т.д.
  Поставил Слаку 9.1 (2.4.22)(к слову сказать - в полном восторге: все работает как швейцарские часы).Результат тот же, но теперь на обоих ядрах.
Может что-то в конфигурялках или в железе? Посоветуйте.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Serg email(??) on 30-Апр-04, 14:50 
Установил 2.6.4 на свой SUSE 9.0 (2.4.21), пропал звук (мамка нфорс2)алсаконф не помогает , и до загрузки Х-ов наблюдаю за черным экраном, ошибок при установке небыло.
Посоветуйте че-нить. Заранее благодарен.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

27. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от netracer email on 06-Июл-04, 17:01 
собери ядро с поддержкой ALSA и OSS-эмуляцией, но без самого OSS. Из поддерживаемых карт выбери Intel/NVIDIA. Далее грузи если это модуль и ставь громкость на максимум (aumix -w 100, ну и дальше поиграй с остальными громкостями)/ Все OK!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от kolobok email on 30-Июн-04, 17:44 
я ставил вместо 2.4.21 ядрышко 2.6.6 в- бЭзпроблем встало на asp 9.2  все просто летает !!! !
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

29. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Игорь email(??) on 22-Фев-05, 19:34 
Доброго здоровья!
Помогите, плиз...
после сборки нового ядра при загрузке, почти в самом начале после Creating root device, Mouting root filesystem
пишет:
mount : error 19 mouting ext3
mount : error 2 mouting node
Switching to new root
switchroot : mount failed: 22
umount /initrd/dev failed:2
Kernel panik - not syncling : Attempled to kill init!

Что делать - не знаю! Перепробовал разные ядра, все одна история!
Пробовал конфиг от старого ядра, все то же!
Что делать?
А перебрать ядро очень нужно для поддержки MPPE ppp!
Пожалуйста!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

33. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от George email(??) on 01-Авг-05, 21:41 
Неподскажешь как решили, таже фигня. Спасибо.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

30. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Игорь email(??) on 24-Фев-05, 00:30 
Cам уже разобрался:-)))
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

31. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от passshok email on 15-Май-05, 09:14 
> mount : error 19 mouting ext3
> mount : error 2 mouting node
> Switching to new root
> switchroot : mount failed: 22
> umount /initrd/dev failed:2
> Kernel panik - not syncling : Attempled to kill > init!
А не могли бы вы рассказать в чём всё-таки проблема, а то я вот тоже мучаюсь и не могу понять в чём дело.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

32. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от olaf (??) on 21-Июл-05, 20:53 
Доброе время суток!
Так чем же лечиться эта беда?
Вы ее решили?? если да, то поделитесь опытом.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

35. "Установка ядра linux-2.6.1 (вместо 2.4.x) (kernel install sl..."  
Сообщение от Раджа on 17-Июл-07, 17:31 
Скорее всего трабл в конфиге загрузчика, потомо чту ядро не находит родную ФС и впадает в панику. Попробуй загрузить старое ядро
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру