The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"NAT"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"NAT"  +/
Сообщение от mitsumoto (ok) on 18-Ноя-12, 15:43 
Всем привет народпомогите пожалуйста настроить НАТ на 1841 модели


интерфйс провайдера
FastEthernet0/0
ip адрес от провайдера получаю по dhcp 192.168.227.163


интерфйс для локальной сети
FastEthernet0/1
ip адреса раздаю по dhcp


ПК в локальной сети получает ip адрес от циски, жлюз пингуется но ресурсы провайдера нет.
например 192.168.227.20 не пингуется, хотя данный ИП с циски пингуется

вот ман по которому производил настройку
http://www.it-club.org/leadership/pyat_sposobov_nastroit_nat...


Building configuration...

Current configuration : 1585 bytes

!

! Last configuration change at 15:26:10 UTC Sun Nov 18 2012 by admin

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname kiska

!

boot-start-marker

boot-end-marker

!

no logging buffered

no logging console

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip routing

no ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.0.128 10.0.0.255

ip dhcp excluded-address 10.0.0.1 10.0.0.10

!

ip dhcp pool LAN

   network 10.0.0.0 255.255.255.0

   default-router 10.0.0.1

   dns-server 10.0.0.3 10.0.0.4

   domain-name pc.lan

!

ip dhcp pool local

   default-router 10.0.0.1

!

!

ip domain name test.lan

!

username admin privilege 15 secret 5 xxxxxxxxxxx

!

!

!

interface FastEthernet0/0

description WAN

ip address dhcp

ip nat outside

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0/1

description LAN

ip address 10.0.0.1 255.255.255.0

ip nat inside

rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop

rate-limit output 10240000 1920000 3840000 conform-action transmit exceed-action drop

no ip route-cache

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

!

ip http server

ip http authentication local

ip nat inside source list NAT interface FastEthernet0/0 overload

!

ip access-list extended NAT

permit ip 10.0.0.0 0.0.0.255 any

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

end


Ответить | Правка | Cообщить модератору

Оглавление

  • NAT, karen durinyan, 16:52 , 18-Ноя-12, (1)  
  • NAT, karen durinyan, 17:09 , 18-Ноя-12, (2)  
    • NAT, spiegel, 17:54 , 18-Ноя-12, (3)  
  • NAT, elk_killa, 17:58 , 18-Ноя-12, (4)  
    • NAT, mitsumoto, 08:42 , 19-Ноя-12, (5)  
      • NAT, fasv, 14:22 , 11-Янв-13, (6)  
        • NAT, Merridius, 14:40 , 11-Янв-13, (7)  
          • NAT, fasv, 16:16 , 11-Янв-13, (8)  
            • NAT, Merridius, 16:35 , 11-Янв-13, (9)  
              • NAT, fasv, 07:54 , 14-Янв-13, (10)  

Сообщения по теме [Сортировка по времени | RSS]


1. "NAT"  +/
Сообщение от karen durinyan (ok) on 18-Ноя-12, 16:52 
>[оверквотинг удален]
> control-plane
> !
> !
> line con 0
> line aux 0
> line vty 0 4
>  login
> !
> end
>

а что получается если убрать "ip route 0.0.0.0 0.0.0.0 FastEthernet0/0" строчку?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "NAT"  +/
Сообщение от karen durinyan (ok) on 18-Ноя-12, 17:09 
>[оверквотинг удален]
> control-plane
> !
> !
> line con 0
> line aux 0
> line vty 0 4
>  login
> !
> end
>

a можно увидеть вывод от "show ip route" и "show ip int FastEthernet0/0"?

и еще я бы сделал так:

conf term
!
no ip nat inside source list NAT interface FastEthernet0/0 overload
!
route-map NAT permit 10
match ip address NAT
match interface FastEthernet0/0
!
ip nat inside source route-map NAt interface FastEthernet0/0 overload
!
end

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "NAT"  +/
Сообщение от spiegel (ok) on 18-Ноя-12, 17:54 
no ip routing ни о чем не говорит?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "NAT"  +/
Сообщение от elk_killa (ok) on 18-Ноя-12, 17:58 
> no ip routing

для начала включить

ip routing


> ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

и желвтельно определиться с адресом шлюза

ip route 0.0.0.0 0.0.0.0 dhcp

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "NAT"  +/
Сообщение от mitsumoto (ok) on 19-Ноя-12, 08:42 
заработало, всем спасибо!

ip routing
ip cef
ip route 0.0.0.0 0.0.0.0 dhcp

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "NAT"  +/
Сообщение от fasv (ok) on 11-Янв-13, 14:22 
Приветствую Вас уважаемые форумчане!!! Подскажите пожалуйста, столкнулся с такой же проблемой - не могу никак настроить NAT. Конфиг почти такой же, единственно у меня идет жесткая привязка ip адресов. Пробовал вводить команды:

ip routing
ip route 0.0.0.0 0.0.0.0 dhcp

Но не помогло. Впринципе в Packet Tracer  у меня все работало и без них, а вот в жизни не получилось. Помогите пожалуйста советом.

Ниже выкладываю полный конфиг:

Current configuration : 1054 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
dot11 syslog
ip source-route
!
!
!
!
ip cef
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0/1
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "NAT"  +/
Сообщение от Merridius (ok) on 11-Янв-13, 14:40 
> ip nat inside source list 1 interface FastEthernet0/1

Ну для начала включите PAT, добавив команду overload в конец вашего правила NAT.
ip routing должен быть включен обязательно, иначе маршрутизация не заработает.
Так же не вижу записи о дефолтном маршруте.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "NAT"  +/
Сообщение от fasv (ok) on 11-Янв-13, 16:16 
Большое спасибо Все заработало!!!
Ввел две строчки
ip routing
ip route 0.0.0.0 0.0.0.0 192.168.2.2

Недавно настраивал NAT на cisco 1751 и там все благополучно работало без  ip route, поэтому
у меня возникает вопрос: зачем маршрутизатору указывать два раза куда слать пакеты, ведь по сути команда ip nat inside source list 1 interface FastEthernet0/1 overload

и команда ip route 0.0.0.0 0.0.0.0 192.168.2.2

показывают как обращаться с пакетами предназначенными для другой сети????

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "NAT"  +/
Сообщение от Merridius (ok) on 11-Янв-13, 16:35 
>[оверквотинг удален]
> Ввел две строчки
> ip routing
> ip route 0.0.0.0 0.0.0.0 192.168.2.2
> Недавно настраивал NAT на cisco 1751 и там все благополучно работало без
>  ip route, поэтому
>  у меня возникает вопрос: зачем маршрутизатору указывать два раза куда слать
> пакеты, ведь по сути команда ip nat inside source list 1
> interface FastEthernet0/1 overload
> и команда ip route 0.0.0.0 0.0.0.0 192.168.2.2
> показывают как обращаться с пакетами предназначенными для другой сети????

Трансляция и маршрутизация разные вещи не связанные друг с другом.
NAT - просто сервис работающий поверх маршрутизации, так же как например zbfw.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "NAT"  +/
Сообщение от fasv (ok) on 14-Янв-13, 07:54 
Теперь все ясно. Спасибо за разъяснение.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру