The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"cisco l2tp vpn ipsec client"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 15-Июн-12, 10:11 
Приветствую!

Ребята, нужна помощь!

Собственно по теме - как настроить L2TP client на cisco!

То есть счас мне приходиться на компе (винда) создавать впн подключение и конектиться к удаленному серверу. Хотелось бы что б это делала цыска.

Заранее благодарен!!


Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "cisco l2tp vpn ipsec client"  +/
Сообщение от fantom (ok), 15-Июн-12, 11:10 
> Приветствую!
> Ребята, нужна помощь!
> Собственно по теме - как настроить L2TP client на cisco!
> То есть счас мне приходиться на компе (винда) создавать впн подключение и
> конектиться к удаленному серверу. Хотелось бы что б это делала цыска.
> Заранее благодарен!!

Воспользоваться поиском на cisco.com

Ответить | Правка | Наверх | Cообщить модератору

2. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 15-Июн-12, 11:37 
>> Приветствую!
>> Ребята, нужна помощь!
>> Собственно по теме - как настроить L2TP client на cisco!
>> То есть счас мне приходиться на компе (винда) создавать впн подключение и
>> конектиться к удаленному серверу. Хотелось бы что б это делала цыска.
>> Заранее благодарен!!
> Воспользоваться поиском на cisco.com

ну да... можно и google. Можно много книг начитаться и вообще быть очень умным и сюда писать только ответы ( хотя я и так могу - буду писать везде "Смотри поиск на cisco.com " )

P.S. И гуглил и пітался разобраться на cisco.com , но к сожалению.... :(((

Ответить | Правка | Наверх | Cообщить модератору

3. "cisco l2tp vpn ipsec client"  +/
Сообщение от fantom (ok), 15-Июн-12, 14:33 
>[оверквотинг удален]
>>> То есть счас мне приходиться на компе (винда) создавать впн подключение и
>>> конектиться к удаленному серверу. Хотелось бы что б это делала цыска.
>>> Заранее благодарен!!
>> Воспользоваться поиском на cisco.com
> ну да... можно и google. Можно много книг начитаться и вообще быть
> очень умным и сюда писать только ответы ( хотя я и
> так могу - буду писать везде "Смотри поиск на cisco.com "
> )
> P.S. И гуглил и пітался разобраться на cisco.com , но к сожалению....
> :(((

Что делали? на чем заткнулось? какие ошибки вывалило?
http://www.cisco.com/en/US/docs/ios-xml/ios/vpdn/configurati...

Есть пример конфига и клиента и сервера.

Ответить | Правка | Наверх | Cообщить модератору

4. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 15-Июн-12, 15:54 
>[оверквотинг удален]
>>> Воспользоваться поиском на cisco.com
>> ну да... можно и google. Можно много книг начитаться и вообще быть
>> очень умным и сюда писать только ответы ( хотя я и
>> так могу - буду писать везде "Смотри поиск на cisco.com "
>> )
>> P.S. И гуглил и пітался разобраться на cisco.com , но к сожалению....
>> :(((
> Что делали? на чем заткнулось? какие ошибки вывалило?
> http://www.cisco.com/en/US/docs/ios-xml/ios/vpdn/configurati...
> Есть пример конфига и клиента и сервера.

Вот например нашел конфиг (opennet.ru) :

!
l2tp-class class1
!
pseudowire-class class2
encapsulation l2tpv2
protocol l2tpv2 class1
ip local interface FastEthernet0/0
!
interface Virtual-PPP1
ip unnumbered Loopback0
ip nat outside
ppp authentication chap callin
ppp chap hostname corbina
ppp chap password 0 corbina
pseudowire xx.xx.xx.xx(адрес впн сервера??) 10 pw-class class2
!


но не понятно как прикрутить ipsec (в винде  называется "предварительный ключ" для l2tp IPsec VPN)

не ясно мне что такое "ip local interface "


Вот крнфиг с cisco.com

l2tp-class l2tpclass1
!
pseudowire-class pwclass1
encapsulation l2tpv2
protocol l2tpv2 l2tpclass1
ip local interface ethernet0/0
!
interface virtual-ppp 1
ip unnumbered loopback1
ppp authentication chap
ppp chap hostname peer1
pseudowire 172.24.13.196 10 pw-class pwclass1
!
ip route 10.10.10.0 255.255.255.0 virtual-PPP 1

но вопросы те же :((

Спасибо за ответ

Ответить | Правка | Наверх | Cообщить модератору

5. "cisco l2tp vpn ipsec client"  +/
Сообщение от Николай_kv (ok), 15-Июн-12, 16:15 
l2tp-class l2tpclass1
hidden
authentication
password "l2tp key"
Ответить | Правка | Наверх | Cообщить модератору

6. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 18-Июн-12, 09:44 
> l2tp-class l2tpclass1
> hidden
> authentication
> password "l2tp key"

Спасибо, попробую!

А что такое "ip local interface FastEthernet0/0"

Что за интерфейс?? Внешний?? Или наоборот интрф. локалки(правда не пойму зачем тогда..)??


Ответить | Правка | Наверх | Cообщить модератору

7. "cisco l2tp vpn ipsec client"  +/
Сообщение от Николай_kv (ok), 18-Июн-12, 10:52 
>> l2tp-class l2tpclass1
>> hidden
>> authentication
>> password "l2tp key"
> Спасибо, попробую!
> А что такое "ip local interface FastEthernet0/0"
> Что за интерфейс?? Внешний?? Или наоборот интрф. локалки(правда не пойму зачем тогда..)??

Неужели слабо почитать или тут вариант почитал и все равно ничего не понял?

Ответить | Правка | Наверх | Cообщить модератору

8. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 18-Июн-12, 14:17 
>>> l2tp-class l2tpclass1
>>> hidden
>>> authentication
>>> password "l2tp key"
>> Спасибо, попробую!
>> А что такое "ip local interface FastEthernet0/0"
>> Что за интерфейс?? Внешний?? Или наоборот интрф. локалки(правда не пойму зачем тогда..)??
> Неужели слабо почитать или тут вариант почитал и все равно ничего не
> понял?

l2tp-class l2tpclass1
hidden
authentication
password "предварительный ключ"
!
pseudowire-class pwclass1
encapsulation l2tpv2
protocol l2tpv2 l2tpclass1
ip local interface  FastEthernet1
!
interface virtual-ppp 1
ip unnumbered loopback0
ppp authentication chap callin
ppp chap hostname "name"
ppp chap password  "password"
pseudowire 176.154.34.23 10 pw-class pwclass1
!

ip local interface  FastEthernet1 - Specifies the PE router interface whose IP address is to be used as the source IP address for sending tunneled packets (поставил внешнтий)

Но ничего не работает (ip route 10.ХХ.ХХ.0 255.255.255.0 virtual-PPP 1 - пока не прописывал)

Ответить | Правка | Наверх | Cообщить модератору

9. "cisco l2tp vpn ipsec client"  +/
Сообщение от Николай_kv (ok), 18-Июн-12, 15:12 

>[оверквотинг удален]
> protocol l2tpv2 l2tpclass1
> ip local interface  FastEthernet1
> !
> interface virtual-ppp 1
> ip unnumbered loopback0
> ppp authentication chap callin
> ppp chap hostname "name"
> ppp chap password  "password"
> pseudowire 176.154.34.23 10 pw-class pwclass1
> !

ничего не работает это что именно?


> ip local interface  FastEthernet1 - Specifies the PE router interface whose
> IP address is to be used as the source IP address
> for sending tunneled packets (поставил внешнтий)
> Но ничего не работает (ip route 10.ХХ.ХХ.0 255.255.255.0 virtual-PPP 1 - пока
> не прописывал)

Ответить | Правка | Наверх | Cообщить модератору

10. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 20-Июн-12, 10:13 
>[оверквотинг удален]
>> ppp chap hostname "name"
>> ppp chap password  "password"
>> pseudowire 176.154.34.23 10 pw-class pwclass1
>> !
> ничего не работает это что именно?
>> ip local interface  FastEthernet1 - Specifies the PE router interface whose
>> IP address is to be used as the source IP address
>> for sending tunneled packets (поставил внешнтий)
>> Но ничего не работает (ip route 10.ХХ.ХХ.0 255.255.255.0 virtual-PPP 1 - пока
>> не прописывал)

Еще раз, буду признателен, если кто то поможет (может еще надо какая то информация?)
Спасибо!

Ответить | Правка | Наверх | Cообщить модератору

15. "cisco l2tp vpn ipsec client"  +/
Сообщение от jied83 (ok), 12-Июл-12, 13:24 
>[оверквотинг удален]
>>> !
>> ничего не работает это что именно?
>>> ip local interface  FastEthernet1 - Specifies the PE router interface whose
>>> IP address is to be used as the source IP address
>>> for sending tunneled packets (поставил внешнтий)
>>> Но ничего не работает (ip route 10.ХХ.ХХ.0 255.255.255.0 virtual-PPP 1 - пока
>>> не прописывал)
> Еще раз, буду признателен, если кто то поможет (может еще надо какая
> то информация?)
> Спасибо!

Честно говоря, вообще не понял что вы делаете....
http://www.cisco.com/en/US/tech/tk801/tk703/technologies_con...

вот тут почитайте, тут пример с dialin и dialout

вкратце: настраиваете l2tp и диалером коннектитесь

Ответить | Правка | Наверх | Cообщить модератору

11. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 20-Июн-12, 12:16 
>[оверквотинг удален]
>> ip local interface  FastEthernet1
>> !
>> interface virtual-ppp 1
>> ip unnumbered loopback0
>> ppp authentication chap callin
>> ppp chap hostname "name"
>> ppp chap password  "password"
>> pseudowire 176.154.34.23 10 pw-class pwclass1
>> !
> ничего не работает это что именно?

Virtual-PPP1               unassigned      YES manual down                  down

порт в down

Пробовал еще так
interface Virtual-PPP1
ip address negotiated
(я должен получить адрес от удаленной сети! Вообщем я окончательно запутался)


Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

12. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 25-Июн-12, 11:47 
help
Ответить | Правка | Наверх | Cообщить модератору

13. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 11-Июл-12, 18:34 
Подскажите пожайлуста, возможно ли настроить клиент L2tp+Ipsec на cisco 1841? На руках есть логин, пароль и ключ IPsec. На данный момент подключение выполняется на компьютере
под управлением WinXP. Доступ к серверу L2tp отсутствует.

Еще раз спасибо!

Ответить | Правка | Наверх | Cообщить модератору

14. "cisco l2tp vpn ipsec client"  –1 +/
Сообщение от Николай_kv (ok), 12-Июл-12, 10:58 
>  Подскажите пожайлуста, возможно ли настроить клиент L2tp+Ipsec на cisco 1841? На
> руках есть логин, пароль и ключ IPsec. На данный момент подключение
> выполняется на компьютере
> под управлением WinXP. Доступ к серверу L2tp отсутствует.
> Еще раз спасибо!

Настроить возможно :)

Ответить | Правка | Наверх | Cообщить модератору

16. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 13-Июл-12, 15:49 
>>  Подскажите пожайлуста, возможно ли настроить клиент L2tp+Ipsec на cisco 1841? На
>> руках есть логин, пароль и ключ IPsec. На данный момент подключение
>> выполняется на компьютере
>> под управлением WinXP. Доступ к серверу L2tp отсутствует.
>> Еще раз спасибо!
> Настроить возможно :)

Я надеюсь Вы не опечатались пропустив "не" ))))

Если возможно то подскажите (а то в нете вроде и куча инфы, но почти везде по разному, у одних Virtual-PPP у других dialer, но в основном есть примеры когда идет подключение к провайдеру, но у меня немного не так!  )

Ответить | Правка | К родителю #14 | Наверх | Cообщить модератору

17. "cisco l2tp vpn ipsec client"  –1 +/
Сообщение от Николай_kv (ok), 13-Июл-12, 18:46 
> Если возможно то подскажите (а то в нете вроде и куча инфы,
> но почти везде по разному, у одних Virtual-PPP у других dialer,
> но в основном есть примеры когда идет подключение к провайдеру, но
> у меня немного не так!  )

А у вас как-то по-особенному :))))

Ответить | Правка | К родителю #16 | Наверх | Cообщить модератору

18. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 17-Июл-12, 09:52 
>> Если возможно то подскажите (а то в нете вроде и куча инфы,
>> но почти везде по разному, у одних Virtual-PPP у других dialer,
>> но в основном есть примеры когда идет подключение к провайдеру, но
>> у меня немного не так!  )
> А у вас как-то по-особенному :))))

Смотри выше.
И я не понимаю, если сам не знаешь зачем флудить? "Пройди" мимо

Ответить | Правка | К родителю #17 | Наверх | Cообщить модератору

19. "cisco l2tp vpn ipsec client"  +/
Сообщение от Николай_kv (ok), 17-Июл-12, 10:04 
>>> Если возможно то подскажите (а то в нете вроде и куча инфы,
>>> но почти везде по разному, у одних Virtual-PPP у других dialer,
>>> но в основном есть примеры когда идет подключение к провайдеру, но
>>> у меня немного не так!  )
>> А у вас как-то по-особенному :))))
> Смотри выше.
> И я не понимаю, если сам не знаешь зачем флудить? "Пройди" мимо

Чел ты уже всем мозг вынес, я тебе дал конфиги ты их даже собрать не можешь. Ты хочешь что бы из г...а пуля сама слепилась или люди написали тебе конфиг под твои задачи? Если для тебя нет разницы в  Virtual-PPP и Dialer, и разбираться ты не хочешь, нафиг ты вообще сюда пишешь?

Ответить | Правка | К родителю #18 | Наверх | Cообщить модератору

20. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 17-Июл-12, 12:31 
>[оверквотинг удален]
>>>> но в основном есть примеры когда идет подключение к провайдеру, но
>>>> у меня немного не так!  )
>>> А у вас как-то по-особенному :))))
>> Смотри выше.
>> И я не понимаю, если сам не знаешь зачем флудить? "Пройди" мимо
> Чел ты уже всем мозг вынес, я тебе дал конфиги ты их
> даже собрать не можешь. Ты хочешь что бы из г...а пуля
> сама слепилась или люди написали тебе конфиг под твои задачи? Если
> для тебя нет разницы в  Virtual-PPP и Dialer, и разбираться
> ты не хочешь, нафиг ты вообще сюда пишешь?

Говори за себя, "Чел".

> я тебе дал конфиги ты их  даже собрать не можешь

Где??? Это??
l2tp-class l2tpclass1
hidden
authentication
password "l2tp key"

Остальные твои посты ты просто флудишь! :

> Неужели слабо почитать
> ничего не работает это что именно?
> Настроить возможно :)
> Чел ты уже всем мозг вынес
> для тебя нет разницы в  Virtual-PPP и Dialer, и разбираться
> ты не хочешь, нафиг ты вообще сюда пишешь?

Как раз пишу сюда, потому что хочу разобраться, и услышать совет, а не "умные" слова, типа :"Настроить возможно", " Неужели слабо почитать".

Я тебя попросил, не можешь (не знаешь, не хочешь) помочь - не пиши!

Cisco Router как L2TP Client
  Настройка Cisco 2800 как L2TP Client-а

Рабочий крнфиг:

service internal ! Обязятельная скрытая команда
ip cef
ip multicast-routing
!
vpdn-group L2TP-STRONGVPN
request-dialin
  protocol l2tp
  pool-member 1
initiate-to ip 207.204.224.21
no l2tp tunnel authentication
!
!        
crypto isakmp policy 5
encr 3des
authentication pre-share
group 2  
lifetime 3600
crypto isakmp key _Password_ address 207.204.224.21
!        
!        
crypto ipsec transform-set ESP-AES256-SHA esp-aes 256 esp-sha-hmac
mode transport
!        
crypto map STRONGVPN 10 ipsec-isakmp
set peer 207.204.224.21
set transform-set ESP-AES256-SHA
match address L2TP_SA_DIALER1
!        
interface FastEthernet0/0
description -= Local network =-
ip address 172.16.44.44 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description -= Outside Interface =-
ip address 77.91.xxx.yyy 255.255.255.240
ip access-group INPUT_ACL in
ip flow ingress
ip flow egress
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
crypto map STRONGVPN
!
interface Dialer1
description -= VPN (StrongVPN) L2TP client =-
ip address negotiated
ip mtu 1492
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no cdp enable
ppp chap hostname _USERNAME_
ppp chap password  _Password_
!
ip route 0.0.0.0 0.0.0.0 Dialer1 ! Весь трафик заворачиваем в тунель
ip route 172.16.44.0 255.255.255.0 FastEthernet0/0
ip route 207.204.224.21 255.255.255.255 77.91.xxx.xxx  !на шлюз провайдерв
!

-------------------------------------------------------------------

Добрый день всем.
l2tp клиента на роутере cisco 1841.

aaa new-model
!
aaa authentication ppp default local
aaa authorization network default none
!
l2tp-class class1
!
pseudowire-class class2
encapsulation l2tpv2
protocol l2tpv2 class1
ip local interface FastEthernet0/0
!
interface Virtual-PPP1
ip unnumbered Loopback1
ip nat outside
ppp authentication chap
ppp chap hostname corbina
ppp chap password 0 corbina
pseudowire 85.21.121.50 10 pw-class class2
!
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route <маршрут на VPN сервер>
ip route <маршрут на DNS>

------------------------------------------------

И там и там l2tp, но настроены совершенно по разному!

Ответить | Правка | К родителю #19 | Наверх | Cообщить модератору

21. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 17-Июл-12, 12:32 
На данный момент настроено :

l2tp-class DEFAULT-L2TP-CLASS

pseudowire-class PW-L2TP-FA00
encapsulation l2tpv2
protocol l2tpv2 DEFAULT-L2TP-CLASS
ip local interface FastEthernet1

crypto isakmp policy 100
hash md5
authentication pre-share

crypto isakmp key asjdkll;a address 0.0.0.0 0.0.0.0

crypto ipsec transform-set L2TP esp-3des esp-md5-hmac
mode transport

crypto map L2TP 150 ipsec-isakmp
set peer 15.19.51.20
set transform-set L2TP
match address L2TP

interface FastEthernet1
crypto map L2TP

interface Virtual-PPP1
ip address negotiated
ppp authentication ms-chap-v2 callin
ppp chap hostname transgarant-kiev-6
ppp chap password *************
pseudowire  195.149.70.70 10 pw-class PW-L2TP-FA00

ip access-list extended L2TP
permit udp host 78.25.18.86 eq 1701 host 15.19.51.20 eq 1701

[сообщение отредактировано модератором]

Ответить | Правка | К родителю #20 | Наверх | Cообщить модератору

22. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 17-Июл-12, 12:33 
Не ясно какие надо маршруты прописать!
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

23. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 17-Июл-12, 16:15 
Всем спасибо. Получилось

Ответить | Правка | К родителю #22 | Наверх | Cообщить модератору

24. "cisco l2tp vpn ipsec client"  +/
Сообщение от McS555 (ok), 17-Июл-12, 17:51 
Отдельное спасибо юзеру  Николай_kv
Ответить | Правка | К родителю #23 | Наверх | Cообщить модератору

25. "cisco l2tp vpn ipsec client"  +/
Сообщение от Sivich (ok), 02-Апр-13, 12:17 
> Отдельное спасибо юзеру  Николай_kv

Добрый день! А конфиг выше рабочий (На данный момент настроено)? По поводу Cisco 1841 VPN Client.

Ответить | Правка | К родителю #24 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру