The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"PRI на cisco1760"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Сопряжение с АТС)
Изначальное сообщение [ Отслеживать ]
SWITCH+ROUTE+TSHOOT – курсы Cisco CCNP для администраторов больших сетей
"PRI на cisco1760"  +/
Сообщение от Konstantin_PL email(ok) on 18-Апр-12, 13:31 
Добрый день, коллеги.

Есть cisco1760, на борту VWIC 2MFT-E1, PVDM12. Есть необходимость подключиться по Е1 к телефонной станции. Но не могу запустить PRI.

На сколько я понял не поднимается 2 уровень. "Физика" в порядке. Причём если задавать несколько раз sh isdn ststus, то видно, что попытки поднять связь предпринимаются, так как состояние потока меняется с State = TEI_ASSIGNED на State = AWAITING_ESTABLISHMENT, но потом назад на State = TEI_ASSIGNED.

Router#sh isdn stat
Global ISDN Switchtype = primary-net5
ISDN Serial0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x0000001F
    Number of L2 Discards = 0, L2 Session ID = 21
ISDN Serial0/1:15 interface
        dsl 1, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x0000001F
    Number of L2 Discards = 0, L2 Session ID = 21
    Total Allocated ISDN CCBs = 0
Router#sh isdn stat
Global ISDN Switchtype = primary-net5
ISDN Serial0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMENT
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x0000001F
    Number of L2 Discards = 0, L2 Session ID = 21
ISDN Serial0/1:15 interface
        dsl 1, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMENT
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x0000001F
    Number of L2 Discards = 0, L2 Session ID = 21
    Total Allocated ISDN CCBs = 0
Router#

Поток пробовал подключать и на АТС (с заведомо рабочими настройками) и заворачивал внутри циски с одного порта на другой, результат одинаковый.

Подскажите, в чём может быть дело и куда копать. Может я что то в конфигурации не дописал, так как собирал её из разных источников.

Вот конфигурация:
Current configuration : 2196 bytes
!
! Last configuration change at 22:33:52 UTC Wed May 11 2011
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
tdm clock E1 0/0 both export line
tdm clock E1 0/1 both import E1 0/0 internal
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 0
!
voice-card 2
!
no aaa new-model
ip subnet-zero
ip cef
!
ip audit po max-events 100
isdn switch-type primary-net5
!
voice rtp send-recv
!
voice service voip
sip
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
!
controller E1 0/0
framing NO-CRC4
pri-group timeslots 1-5,16
!
controller E1 0/1
framing NO-CRC4
pri-group timeslots 1-5,16
!
interface FastEthernet0/0
ip address 192.168.100.201 255.255.255.0
speed auto
!
interface Serial0/0:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice modem
isdn send-alerting
isdn sending-complete
no cdp enable
!
interface Serial0/1:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice modem
isdn send-alerting
isdn sending-complete
no cdp enable
!
ip classless
!
no ip http server
no ip http secure-server
!
voice-port 0/0:15
no vad
no comfort-noise
cptone RU
bearer-cap Speech
!
voice-port 0/1:15
no vad
no comfort-noise
cptone RU
bearer-cap Speech
!
voice-port 2/0
disc_pi_off
cptone RU
!
voice-port 2/1
disc_pi_off
cptone RU
!
dial-peer voice 1000 voip
description from e1 to asterisk
destination-pattern 2..$
voice-class codec 1
session protocol sipv2
session target ipv4:192.168.100.200
dtmf-relay rtp-nte
no vad
!
dial-peer voice 9222 pots
destination-pattern 9222$
port 2/0
!
dial-peer voice 9333 pots
destination-pattern 9333
port 2/1
!
dial-peer voice 1 voip
huntstop
answer-address .T
!
sip-ua
no redirection
retry invite 3
retry response 3
retry bye 3
retry cancel 3
timers trying 1000
sip-server ipv4:192.168.100.200
!
line con 0
line aux 0
line vty 0 4
login
!
end

Заранее спасибо за полезные мысли...

Константин

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "PRI на cisco1760"  +/
Сообщение от BJ (ok) on 18-Апр-12, 13:52 
interface Serial0/0:15
isdn protocol-emulate network
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "PRI на cisco1760"  +/
Сообщение от ogiss on 18-Апр-12, 14:30 
"isdn incoming-voice modem" заменить на
isdn incoming-voice voice

и со стороны АТС тоже только 5 слотов в потоке ?


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "PRI на cisco1760"  +/
Сообщение от Konstantin_PL email(ok) on 19-Апр-12, 13:32 
Спасибо за помощь! Теперь всё ОК.
Я знал, что что то подобное должно быть в настройках. Просто ни в одном образце конфигурации не нашёл режим network. Видимо все использовали только user.

Со стороны станции полный поток прописан был.
Просто у меня напряг с PVDM, поэтому я решил прописать только 5 каналов.

Ещё такой вопросик, поставив пару PVDM12 (больше не получится) я получу примерно 24 канала.
Могу ли я настроить при этом 2хЕ1 потока и получу максимум одновременно 24 разговора или больше 24 каналов вообще настроить будет невозможно?

Константин.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "PRI на cisco1760"  +/
Сообщение от Николай_kv (ok) on 19-Апр-12, 14:46 
>[оверквотинг удален]
> в одном образце конфигурации не нашёл режим network. Видимо все использовали
> только user.
> Со стороны станции полный поток прописан был.
> Просто у меня напряг с PVDM, поэтому я решил прописать только 5
> каналов.
> Ещё такой вопросик, поставив пару PVDM12 (больше не получится) я получу примерно
> 24 канала.
> Могу ли я настроить при этом 2хЕ1 потока и получу максимум одновременно
> 24 разговора или больше 24 каналов вообще настроить будет невозможно?
> Константин.

PVDM12 - сюда не подходят. Они вставляються только в NM-HDV(2) модули. Для 1760 вам нужны PVDM-256k-12/16/20

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "PRI на cisco1760"  +/
Сообщение от Konstantin_PL email(ok) on 20-Апр-12, 06:47 
>[оверквотинг удален]
>> Со стороны станции полный поток прописан был.
>> Просто у меня напряг с PVDM, поэтому я решил прописать только 5
>> каналов.
>> Ещё такой вопросик, поставив пару PVDM12 (больше не получится) я получу примерно
>> 24 канала.
>> Могу ли я настроить при этом 2хЕ1 потока и получу максимум одновременно
>> 24 разговора или больше 24 каналов вообще настроить будет невозможно?
>> Константин.
> PVDM12 - сюда не подходят. Они вставляються только в NM-HDV(2) модули. Для
> 1760 вам нужны PVDM-256k-12/16/20

Встречал в инете информацию, что PVDM12 подходят в cisco1760 с некоторой вероятностью. Видимо у меня как раз такой случай. Модули работают, разговоры проходят нормально. Если под рукой окажутся PVDM-256k... обязательно попробую. И тем не менее, 2хPVDM12 даст максимально 24 одновременных разговора или возможность использовать 24 канала из имеющихся "на борту" потоков?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "PRI на cisco1760"  +/
Сообщение от ogiss on 20-Апр-12, 08:33 
Each PVDM-12 contains 3 TI 549 DSPs.

    Runs up to twelve voice calls using a medium complexity CODEC (G.711, G.729a/b, G.726, fax).

    Runs up to six voice calls using a high complexity CODEC (G.729, G.728, G.723.1).

Каждый PVDM-12 содержит 3 TI 549 DSPs.

    Поднимаются двенадцать речевых вызовов, использовавших среднюю сложность CODEC (G.711, G.729a/b, G.726, факс).

Или

    Поднимаются шесть речевых вызовов, использовавших высокую сложность CODEC (G.729, G.728, G.723.1).

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру