The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"IP-телефоны не получают IP-шник по DHCP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]

"IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от Huaweiboy (ok) on 16-Апр-12, 14:20 
Прямо и не знаю что делать - кто-нибудь сталкивался с такой проблемой? Новые закупленные телефоны не хотят получать IP-адрес по DHCP. Старые телефоны все получают и прекрасно работают. Стоит подключить новый к тому же порту - не получает.
На DHCP в логах по МАК-у телефона ничего нет.
На свитче прописал дополнительные МАК-и телефонов:
voice-vlan mac-address b4b0-1700-0000 mask ffff-ff00-0000 description avaya_ph1

Повторяю - телефония развернута, всё работает, не работают именно телефоны, которые только привезли.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от eek email on 16-Апр-12, 15:03 
А саппорт аваи что по этому поводу говорит?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от Huaweiboy (ok) on 16-Апр-12, 15:28 
> А саппорт аваи что по этому поводу говорит?

к ним не обращались. Проблема какая-то тривиальная..Что-то на свитче прописать, а что - хрен его знает.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от Aleks305 (ok) on 16-Апр-12, 17:12 
>> А саппорт аваи что по этому поводу говорит?
> к ним не обращались. Проблема какая-то тривиальная..Что-то на свитче прописать, а что
> - хрен его знает.

так сбросьте конфиг свитча - может у Вас там фильтрация какая по mac или еще что-нить

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от Huaweiboy (ok) on 17-Апр-12, 09:54 
>>> А саппорт аваи что по этому поводу говорит?
>> к ним не обращались. Проблема какая-то тривиальная..Что-то на свитче прописать, а что
>> - хрен его знает.
> так сбросьте конфиг свитча - может у Вас там фильтрация какая по
> mac или еще что-нить

Да нет там фильтрации никакой, там всё довольно просто. Relay на vlanif прописан, voice-vlan mac-address телефонов авайя прописан, не пойму что ещё нужно ему - хоть убейте не хочет получать IP по DHCP. Но старые телефоны (тоже авайя, тоже ip-телефоны) на этом свитче работают.


Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от fantom (ok) on 17-Апр-12, 10:09 
>>>> А саппорт аваи что по этому поводу говорит?
>>> к ним не обращались. Проблема какая-то тривиальная..Что-то на свитче прописать, а что
>>> - хрен его знает.
>> так сбросьте конфиг свитча - может у Вас там фильтрация какая по
>> mac или еще что-нить
> Да нет там фильтрации никакой, там всё довольно просто. Relay на vlanif
> прописан, voice-vlan mac-address телефонов авайя прописан, не пойму что ещё нужно
> ему - хоть убейте не хочет получать IP по DHCP. Но
> старые телефоны (тоже авайя, тоже ip-телефоны) на этом свитче работают.

Воспользоваться снифером религия не позволяет?
Тыкаете фон напрямую в комп и снифером слушаете - просит ли он вообще что-нибудь, и если прости - то что и с какого МАС-а....

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от WatchTh1s (ok) on 17-Апр-12, 11:41 
Модель телефона в студию.
Рабочий конфиг цискосвитча для работы телефонов 16**/96** (естественно вырезка)
При этом предполагается, что DHCP-server и телефоны находятся в разных VLAN.

!
lldp run
!
vlan 30
name voice ! strictly AVAYA recommended due to phones lldp compatibility
!
vlan 10
name users ! anyname
!
interface vlan 30
ip helper-address 192.168.1.1 !(dhcp-server ip)
!
interface FastEthernet3/48
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 30
spanning-tree portfast
!

Рекомендую на каждый телефон создать резервирование в ДХЦП. Сильно упрощает жизнь.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от Pve1 (ok) on 18-Апр-12, 09:56 
>[оверквотинг удален]
>  ip helper-address 192.168.1.1 !(dhcp-server ip)
> !
> interface FastEthernet3/48
>  switchport trunk encapsulation dot1q
>  switchport trunk native vlan 10
>  switchport mode trunk
>  switchport voice vlan 30
>  spanning-tree portfast
> !
> Рекомендую на каждый телефон создать резервирование в ДХЦП. Сильно упрощает жизнь.

Абсолютно безграмотный конфиг!

switchport voice vlan 30  - актуально только когда порт в режиме switchport mode access X!
Делать порты доступа switchport mode trunk - не правильно.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от WatchTh1s (ok) on 19-Апр-12, 18:42 
> switchport voice vlan 30  - актуально только когда порт в режиме
> switchport mode access X!

Пруфлинк пожалуйста. Ни в одном описании не нашел данной информации. В моем понимании voice vlan служит для определения VLAN Для голосового трафика в связке с LLDP, и отправляется в качестве идентификатора VLAN при обмене LLDP сообщениями. После чего дальнейший обмен трафиком с телефоном производится с указанным тегом.

> Делать порты доступа switchport mode trunk - не правильно.

Вы ошибаетесь. Подключение многих IP-телефонов осуществляется именно по транк-портам из-за особенностей их работы (как например способ получения адресов и посылка нескольких DHCP запросов с разными VLAN ID), и в тех случаях когда не поддерживается LLDP. Если разбирать конкретно данный случай, да, можно ограничиться

!
interface FastEthernet3/48
  switchport mode access
  switchport access vlan 10
  switchport voice vlan 30
  spanning-tree portfast
!

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

7. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от Huaweiboy (ok) on 17-Апр-12, 11:56 
>[оверквотинг удален]
>>> так сбросьте конфиг свитча - может у Вас там фильтрация какая по
>>> mac или еще что-нить
>> Да нет там фильтрации никакой, там всё довольно просто. Relay на vlanif
>> прописан, voice-vlan mac-address телефонов авайя прописан, не пойму что ещё нужно
>> ему - хоть убейте не хочет получать IP по DHCP. Но
>> старые телефоны (тоже авайя, тоже ip-телефоны) на этом свитче работают.
> Воспользоваться снифером религия не позволяет?
> Тыкаете фон напрямую в комп и снифером слушаете - просит ли он
> вообще что-нибудь, и если прости - то что и с какого
> МАС-а....

Насчет сниферов и т.д. - дело в том, что филиал удаленный - я в Москве, они в Омске. Слово Снифер там для них - кличка собаки.

Рабочий конфиг такой: (правда не циска), телефоны AVAYA 9620L\9630

Уровень доступа

sysname 4210
#
undo password-control aging enable
undo password-control length enable
undo password-control history enable
password-control login-attempt 3 exceed lock-time 120
#
local-server nas-ip 127.0.0.1 key 3com
#
priority trust
#
igmp-snooping enable
#
radius scheme system
#
domain system
#
local-user admin
service-type ssh telnet terminal
level 3
local-user manager
password simple manager
service-type ssh telnet terminal
level 2
local-user monitor
password simple monitor
service-type ssh telnet terminal
level 1
#
vlan 1
igmp-snooping enable
#
vlan 22
#
vlan 1000
#
interface Vlan-interface1
ip address 172.17.20.21 255.255.255.0
#
interface Aux1/0/0
#
interface Ethernet1/0/1
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
interface Ethernet1/0/2
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
interface Ethernet1/0/3
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
interface Ethernet1/0/4
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
interface Ethernet1/0/5
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
interface Ethernet1/0/6
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
interface Ethernet1/0/7
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
interface Ethernet1/0/8
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
voice vlan enable
voice vlan legacy
#
interface Ethernet1/0/9
poe enable
stp edged-port enable
port link-type hybrid
port hybrid vlan 1000 tagged
port hybrid vlan 1 22 untagged
#
------- и т.д. до interface Ethernet1/0/24
#
interface NULL0
#
voice vlan mac-address 0007-3b00-0000 mask ffff-ff00-0000
voice vlan mac-address 001b-4f00-0000 mask ffff-ff00-0000
voice vlan mac-address b4b0-1700-0000 mask ffff-ff00-0000 description avaya_ph1
#
ip route-static 172.17.17.215 255.255.255.255 172.17.20.254 preference 60
#
snmp-agent
snmp-agent local-engineid 8000002B001AC1F0E8656877
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info version all
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 4
authentication-mode scheme
#
return


Ядро

sysname Omsk_S5300_CORE1
#
info-center loghost source Vlanif201
info-center loghost 172.17.17.149
info-center loghost 172.17.17.249
info-center loghost 172.17.17.39
#
dns server 172.17.20.10
#
vlan batch 1 21 to 22 24 201 1000 to 1001
#
observing-port 1 interface GigabitEthernet0/0/22
#
stp instance 0 priority 0
stp enable
#
cluster enable
ndp enable
#
voice-vlan mac-address 0001-e300-0000 mask ffff-ff00-0000 description Siemens phone
voice-vlan mac-address 0003-6b00-0000 mask ffff-ff00-0000 description Cisco phone
voice-vlan mac-address 0004-0d00-0000 mask ffff-ff00-0000 description Avaya phone
voice-vlan mac-address 0060-b900-0000 mask ffff-ff00-0000 description Philips/NEC phone
voice-vlan mac-address 00d0-1e00-0000 mask ffff-ff00-0000 description Pingtel phone
voice-vlan mac-address 00e0-7500-0000 mask ffff-ff00-0000 description Polycom phone
voice-vlan mac-address 00e0-bb00-0000 mask ffff-ff00-0000 description 3com phone
voice-vlan mac-address b4b0-1700-0000 mask ffff-ff00-0000 description avaya_ph1
voice-vlan mac-address 0007-3b00-0000 mask ffff-ff00-0000 description AVAYA
#
undo http server enable
#
vlan 1
description Servers, Switches, Office
vlan 21
description Call Center, Switches
vlan 22
description Call Center, Swithes
vlan 24
description Personal, Nat
vlan 201
description CheckPoint<->CORE1
vlan 1000
description IP-Telephony, Avaya
vlan 1001
description Avaya
#
acl number 3004
rule 0 permit ip destination 172.17.0.0 0.0.15.255
rule 1 permit ip destination 172.17.16.0 0.0.3.255
#
interface Vlanif1 ------ОСНОВНОЙ ШЛЮЗ ДЛЯ VLAN 1----
ip address 172.17.20.254 255.255.255.0
ip forward-broadcast
ip relay address 172.17.20.10
dhcp select relay
#
interface Vlanif21
ip address 172.17.21.254 255.255.255.0
ip forward-broadcast
ip relay address 172.17.20.10
dhcp select relay
#
interface Vlanif22
ip address 172.17.22.254 255.255.255.0
ip forward-broadcast
ip relay address 172.17.20.10
dhcp select relay
#
interface Vlanif24
ip address 192.168.3.254 255.255.255.0
#
interface Vlanif201
ip address 172.17.201.254 255.255.255.0
#
interface Vlanif1000
ip address 172.17.39.254 255.255.252.0
ip relay address 172.17.20.10
dhcp select relay
#
interface Vlanif1001
ip address 172.17.34.254 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
broadcast-suppression packets 3000
port link-type access
port default vlan 1
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/2
description CP NODE 1
broadcast-suppression packets 3000
port link-type access
port default vlan 201
stp edged-port enable
trust dscp
undo negotiation auto
speed 100
bpdu enable
traffic-remark outbound acl 3004 rule 0 dscp ef
traffic-remark outbound acl 3004 rule 1 dscp ef
#
interface GigabitEthernet0/0/3
bpdu enable
#
interface GigabitEthernet0/0/4
broadcast-suppression packets 3000
port link-type access
port default vlan 1001
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/5
broadcast-suppression packets 3000
port link-type access
port default vlan 1
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/6
bpdu enable
#
interface GigabitEthernet0/0/7
broadcast-suppression packets 3000
port link-type access
port default vlan 1
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/8
description CAJUN 1
broadcast-suppression packets 3000
port default vlan 1001
port trunk allow-pass vlan 1000 to 1001
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/9
broadcast-suppression packets 3000
port default vlan 21
port trunk allow-pass vlan 1000
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/10
broadcast-suppression packets 3000
port default vlan 21
port trunk allow-pass vlan 1000
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable
ndp enable
#
interface GigabitEthernet0/0/11
broadcast-suppression packets 3000
port default vlan 1
port trunk allow-pass vlan 1000
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/12
broadcast-suppression packets 3000
port default vlan 1
port trunk allow-pass vlan 1000
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/13
broadcast-suppression packets 3000
port link-type access
port default vlan 1
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/14
broadcast-suppression packets 3000
port default vlan 21
port trunk allow-pass vlan 1000
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/15
broadcast-suppression packets 3000
port default vlan 21
port trunk allow-pass vlan 1000
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/16
broadcast-suppression packets 3000
port default vlan 1
port trunk allow-pass vlan 1000
stp edged-port enable
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/17
broadcast-suppression packets 3000
port default vlan 1000
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/18
broadcast-suppression packets 3000
port default vlan 1000
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/19
broadcast-suppression packets 3000
port link-type access
port default vlan 21
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/20
broadcast-suppression packets 3000
port link-type access
port default vlan 1001
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/21
broadcast-suppression packets 3000
port default vlan 22
port trunk allow-pass vlan 1000
trust 8021p
bpdu enable
#
interface GigabitEthernet0/0/22
broadcast-suppression packets 3000
port default vlan 1001
port trunk allow-pass vlan 1000
stp edged-port enable
bpdu enable
#
interface GigabitEthernet0/0/23 -----СЮДА ПОДКЛЮЧЕН СВИТЧ НАШ -----
broadcast-suppression packets 3000
port default vlan 1
port trunk allow-pass vlan 1000
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound
trust 8021p
bpdu enable

.......

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от Huaweiboy (ok) on 18-Апр-12, 09:47 
Проблема решена, всем спасибо)
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

11. "IP-телефоны не получают IP-шник по DHCP"  +/
Сообщение от WatchTh1s (ok) on 19-Апр-12, 18:44 
> Проблема решена, всем спасибо)

А причину и решение можно в студию пожалуйста?

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру