The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"MPLS/VPN Cisco with Huawei"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Разное)
Изначальное сообщение [ Отслеживать ]

"MPLS/VPN Cisco with Huawei"  +/
Сообщение от regnalos email(ok) on 14-Авг-11, 15:29 
На оборудовании Huawei 8500 настроили VPLS сеть - всё отлично работало.
Краткая настройка Huawei:
#
mpls
mpls l2vpn
#
mpls ldp
#
mpls ldp remote-peer 2
remote-ip 192.168.10.2
#
mpls ldp remote-peer 8
remote-ip 192.168.10.8
#
#
vsi england static
label-range 0
encapsulation vlan
cos 1
pwsignal ldp
  vsi-id 500
  peer 192.168.10.2
  peer 192.168.10.8
#
#
interface Vlan-interface3777
l2 binding vsi england access-mode vlan
#
[8500]disp mpls ldp peer
Displaying information about all peers:

   Local LDP ID: 192.168.10.6:0
   Peer LDP ID: 192.168.10.8:0
   Internetwork Address Type: IPv4
   Internetwork Address: 192.168.10.8
   Maximum Peer PDU length: 4096
   Peer KeepAlive hold time: 180
   Peer Distribution Method: Downstream Unsolicited
   Peer Type: Remote
   Peer RowStatus: Active

[8500]disp mpls ldp session
Displaying information about all sessions:

   Local LDP ID: 192.168.10.6:0;   Peer LDP ID: 192.168.10.2:0
   TCP Connection: 192.168.10.6 -> 192.168.10.2
   Session State: Operational
   Session Role: Active
   Session existed time: 1 days 22 hours 17 minutes 48 seconds
   Extended Hello Packets Sent/Received: 9052509/9051059
   KeepAlive Packets Sent/Received: 6945/6945
   Negotiated Keepalive hold time: 60   Peer PV Limit: 0
   LDP Basic Discovery Source((A) means active):
   LDP Extended Discovery Source((A) means active):
   192.168.10.6(A)

   Local LDP ID: 192.168.10.6:0;   Peer LDP ID: 192.168.10.8:0
   TCP Connection: 192.168.10.6 <- 192.168.10.8
   Session State: Operational
   Session Role: Passive
   Session existed time: 1 hours 51 minutes 51 seconds
   Basic Hello Packets Sent/Received: 74647/68039
   Extended Hello Packets Sent/Received: 23083/68364
   KeepAlive Packets Sent/Received: 280/384
   Negotiated Keepalive hold time: 60   Peer PV Limit: 0
   LDP Basic Discovery Source((A) means active):
   Vlan-interface44(A)
   LDP Extended Discovery Source((A) means active):
   192.168.10.6

К этой VPLS сети подключили Cisco 7600, вот краткие настройки:
mpls ldp discovery targeted-hello accept
mpls label range 16 44800
mpls label protocol ldp
!
l2 vfi england manual
vpn id 500
neighbor 192.168.10.2 encapsulation mpls
neighbor 192.168.10.6 encapsulation mpls
!
!
interface TenGigabitEthernet12/1
mtu 1520
ip address 192.168.20.42 255.255.255.252
ip flow ingress
mpls ip
no cdp enable
!
!
interface Vlan3777
no ip address
xconnect vfi england
!

cisco_7600#sh mpls ldp neighbor
    Peer LDP Ident: 192.168.10.6:0; Local LDP Ident 192.168.10.8:0
        TCP connection: 192.168.10.6.646 - 192.168.10.8.13945
        State: Oper; Msgs sent/rcvd: 3856/364; Downstream
        Up time: 01:57:13
        LDP discovery sources:
          TenGigabitEthernet12/1, Src IP addr: 192.168.10.6
          Targeted Hello 192.168.10.8 -> 192.168.10.6, active, passive
        Addresses bound to peer LDP Ident:
          192.168.10.6       192.168.20.18     192.168.20.41
cisco_7600#sh mpls l2transport vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
VFI england    VFI                        192.168.10.2       500        UP
VFI england    VFI                        192.168.10.6       500        UP

Вроде всё сошлось, работает, но есть одна проблема - а именно, переодический в среднем 1 раз в час, на Cisco_7600, приходят "Notification Message" и происходит разрыв всех MPLS стыков, а в логах записывается причина разрыва - The TLV Length is too large, that is, indicates that the TLV extends beyond the end of the containing
message. This is a fatal error signaled by the Bad TLV Length Status Code.
В "LDP спецификации" rfc3036 эта проблема встречается в главе 3.5.1.2.2. , но так и не нашёл как решить эту проблему. То ли как-то можно изменить размер "LDP сообщений", то ли их можно как-то игнорировать.

Специалисты, кто сталкивался с подобной проблемой или может предложения есть что в данном случае можно попробывать.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "MPLS/VPN Cisco with Huawei"  +/
Сообщение от ivb (??) on 15-Авг-11, 13:35 
С Хуавеем не работал никогда.
Но явно у  вас LDP падает на Хуэвее.
Включите там подробные логи, или debug ldp, посмотрите что пишет.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "MPLS/VPN Cisco with Huawei"  +/
Сообщение от Aneken email(ok) on 29-Июл-14, 10:29 
Настройка оборудование актуальна?

>[оверквотинг удален]
> и происходит разрыв всех MPLS стыков, а в логах записывается причина
> разрыва - The TLV Length is too large, that is, indicates
> that the TLV extends beyond the end of the containing
> message. This is a fatal error signaled by the Bad TLV Length
> Status Code.
> В "LDP спецификации" rfc3036 эта проблема встречается в главе 3.5.1.2.2. , но
> так и не нашёл как решить эту проблему. То ли как-то
> можно изменить размер "LDP сообщений", то ли их можно как-то игнорировать.
> Специалисты, кто сталкивался с подобной проблемой или может предложения есть что в
> данном случае можно попробывать.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "MPLS/VPN Cisco with Huawei"  +/
Сообщение от mschedrin email on 10-Июн-15, 11:21 
>[оверквотинг удален]
>> и происходит разрыв всех MPLS стыков, а в логах записывается причина
>> разрыва - The TLV Length is too large, that is, indicates
>> that the TLV extends beyond the end of the containing
>> message. This is a fatal error signaled by the Bad TLV Length
>> Status Code.
>> В "LDP спецификации" rfc3036 эта проблема встречается в главе 3.5.1.2.2. , но
>> так и не нашёл как решить эту проблему. То ли как-то
>> можно изменить размер "LDP сообщений", то ли их можно как-то игнорировать.
>> Специалисты, кто сталкивался с подобной проблемой или может предложения есть что в
>> данном случае можно попробывать.

Huawei использует проприетарные TLV для согласования MTU по LDP. Можно включить режим совместимости с RFC3988:
sys
mpls ldp
  mtu-signalling apply-tlv
return

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру