The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"interface vlan"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"interface vlan"  +/
Сообщение от traceroute email(ok) on 14-Июн-11, 08:33 
Всем привет! Естьтакая проблема: на комутаторе CISCO 2960 имеется ip address 10.30.30.30/24 находящийся на "interface vlan 30", этот vlan является "managemet" (т.е. на роутере где гинерируется этот влан access-listами разрешон доступ из другой сети 10.20.20.0/24) в которой и находится мая машина. В этом же комутаторе на трёх итерфейсах подключены три машины с адресами из той же сети что и моя машина (10.20.20.0/24), интерфейсы в которых находятся эти три машины находятся в trunkе, vlan 15.Получается следующая картина:зайдя на любую из трёх машин - я вижу остальные две (по 15 vlanу) но со своей машины мне не одна из них не доступна. Я пробывал создавать "interface vlan 15" с адресом  из сети 10.20.20.0/24 но это привело к тому что комутатор просто перестал быть доступен и по 10.20.20.0/24 и по 10.30.30.0/24 адресам(с моей машины)но был доступен с любой из трйх машин которые в 15 vlanе. Подскажите пож-ста как мне сделать так, чтобы я со своей машины мог бы заходить нате три не миняя ip address? И ещё не маловажный вопрос:НА КОЙ БОЛТ НУЖНЫ interface vlan? и КАК ОНИ РАБОТАЮТ?

interface FastEthernet0/13
!
interface FastEthernet0/14
description
switchport trunk allowed vlan 15
switchport mode trunk
!
interface FastEthernet0/15
description
switchport trunk allowed vlan 15
switchport mode trunk
no cdp enable
!
interface FastEthernet0/16
description
switchport trunk allowed vlan 15
switchport mode trunk
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
description
switchport access vlan 22
switchport mode access
!
interface FastEthernet0/24
description
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan30
ip address 10.30.30.30 255.255.255.0
no ip route-cache
!
ip default-gateway 10.30.30.1
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
password 7 010011084B3A1F5C011B46
login local
line vty 5 15
no login
!
end  

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "interface vlan"  +/
Сообщение от StSphinx (??) on 14-Июн-11, 10:16 
>[оверквотинг удален]
> !
> !
> line con 0
> line vty 0 4
>  password 7 010011084B3A1F5C011B46
>  login local
> line vty 5 15
>  no login
> !
> end

Так как у Вас 2960, то больше одного SVI(так в терминологии Cisco называется vlan interface) поднять нельзя. Вернее можно, но уже существующий SVI перейдет в состояние down. Все это обусловлено тем, что модель 2960 исключительно L2 коммутатор.
Самый простой выход из вашей ситуации - перевести те три ПК в VLAN 30.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "interface vlan"  +/
Сообщение от traceroute email(ok) on 14-Июн-11, 12:19 

> Так как у Вас 2960, то больше одного SVI(так в терминологии Cisco
> называется vlan interface) поднять нельзя. Вернее можно, но уже существующий SVI
> перейдет в состояние down. Все это обусловлено тем, что модель 2960
> исключительно L2 коммутатор.
> Самый простой выход из вашей ситуации - перевести те три ПК в
> VLAN 30.

Если я вас правельно понимаю, то такая фигня со всеми комутаторами L2 домена? Или только с этой моделью ? И ещё: если на CISCO L3 домена можно вешать более одного SVI получается что если на железке L3 к примеру весит 3 SVI с разными сетями то она (железка)будет доступна по тем адресам каторые весят на всех SVI? Или я не туда думаю ?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

5. "interface vlan"  +/
Сообщение от StSphinx (??) on 14-Июн-11, 13:06 

>[оверквотинг удален]
>> перейдет в состояние down. Все это обусловлено тем, что модель 2960
>> исключительно L2 коммутатор.
>> Самый простой выход из вашей ситуации - перевести те три ПК в
>> VLAN 30.
> Если я вас правельно понимаю, то такая фигня со всеми комутаторами L2
> домена? Или только с этой моделью ? И ещё: если на
> CISCO L3 домена можно вешать более одного SVI получается что если
> на железке L3 к примеру весит 3 SVI с разными сетями
> то она (железка)будет доступна по тем адресам каторые весят на всех
> SVI? Или я не туда думаю ?

Это характерно не только для данной модели, а для всех L2. Собсно на то он и L2.
Думаете верно, будет доступна на всех своих интерфейсах. Если необходимо фильтровать доступ к свичу, делается это через acl, который вешается на line vty.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "interface vlan"  +/
Сообщение от traceroute email(ok) on 14-Июн-11, 14:18 

> Это характерно не только для данной модели, а для всех L2. Собсно
> на то он и L2.
> Думаете верно, будет доступна на всех своих интерфейсах. Если необходимо фильтровать доступ
> к свичу, делается это через acl, который вешается на line vty.

Большое вам спасибо! Приятно беседовать с адекватными людьми! ДАННУЮ ТЕМУ СЧЕТАЮ ЗАКРЫТОЙ.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

2. "interface vlan"  +/
Сообщение от GolDi (??) on 14-Июн-11, 10:24 
>[оверквотинг удален]
> три машины находятся в trunkе, vlan 15.Получается следующая картина:зайдя на любую
> из трёх машин - я вижу остальные две (по 15 vlanу)
> но со своей машины мне не одна из них не доступна.
> Я пробывал создавать "interface vlan 15" с адресом  из сети
> 10.20.20.0/24 но это привело к тому что комутатор просто перестал быть
> доступен и по 10.20.20.0/24 и по 10.30.30.0/24 адресам(с моей машины)но был
> доступен с любой из трйх машин которые в 15 vlanе. Подскажите
> пож-ста как мне сделать так, чтобы я со своей машины мог
> бы заходить нате три не миняя ip address? И ещё не
> маловажный вопрос:НА КОЙ БОЛТ НУЖНЫ interface vlan? и КАК ОНИ РАБОТАЮТ?

А удалённо управлять как будешь?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "interface vlan"  +/
Сообщение от traceroute email(ok) on 14-Июн-11, 12:20 

>  А удалённо управлять как будешь?

дк, я чего и добиваюсь!

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру