The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"QinQ на Catalyst 3560"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"QinQ на Catalyst 3560"  +/
Сообщение от ax.kyiv email on 09-Мрт-11, 17:45 
Добрый день, господа.

Имеется 2 офиса.
В каждом по Catalyst 3560.
Сейчас связь между коммутаторами идет через 3ий вилан.
Catalyst1 (FastEthernet0/1) -> Провайдер -> Catalyst1 (FastEthernet0/1)
Работает. Оба коммутатора видят друг друга в рамках сети 10.0.0.0/24

Необходимо пробросить еще другие вланы 3 и 4.
Провайдер предоставляет только влан 10.

Собрал следующую схему:
! Catalyst 1
!
vlan 10
name Q-in-Q
!
!
!
interface FastEthernet0/1
switchport access vlan 3
switchport mode access
no cdp enable
spanning-tree bpdufilter enable
!
interface FastEthernet0/2                
description ToSwitch2ViaTransport                      
switchport trunk encapsulation dot1q                  
switchport trunk allowed vlan 10                      
switchport mode trunk                                  
!                                                      
interface FastEthernet0/3                              
description QinQLoopTrunk                              
switchport trunk encapsulation dot1q                  
switchport trunk allowed vlan 3,4                  
switchport mode trunk                                  
duplex full                                            
!                                                                                        
interface FastEthernet0/4                              
description Q-IN-Q                                    
switchport access vlan 10                            
switchport mode dot1q-tunnel                          
switchport nonegotiate                                
no cdp enable                                          
spanning-tree portfast                                
spanning-tree bpdufilter enable                        
spanning-tree bpduguard enable                        
!                                                      
!                                                      
interface Vlan3                                      
ip address 10.0.0.1 255.255.255.0                      
!                                                      
!                                                      
interface Vlan10
ip address 10.0.100.1 255.255.255.0
!
!


! Catalyst 2
!
interface FastEthernet0/1
switchport access vlan 3
switchport mode access
no cdp enable
spanning-tree bpdufilter enable
!
interface FastEthernet0/2                
description ToSwitch1ViaTransport        
switchport trunk encapsulation dot1q    
switchport trunk allowed vlan 10        
switchport mode trunk                    
!                                        
interface FastEthernet0/3                
description QinQLoopTrunk                
switchport trunk encapsulation dot1q    
switchport trunk allowed vlan 3,4    
switchport mode trunk                    
duplex full                              
!                                        
interface FastEthernet0/4                
description Q-IN-Q                      
switchport access vlan 10              
switchport mode dot1q-tunnel            
switchport nonegotiate                  
no cdp enable                            
spanning-tree bpdufilter enable          
spanning-tree bpduguard enable          
!                                        
interface Vlan3                        
ip address 10.0.0.4 255.255.255.0        
!                                        
interface Vlan10                        
ip address 10.0.100.4 255.255.255.0      
!          

На обоих коммутаторах FastEthernet0/2 воткнут патчкордом в FastEthernet0/3.

Провайдер переводит свой порт в  trunk-mode.
Перетыкаю патчкорды, чтоб получилась схема:
Catalyst1 (FastEthernet0/4) -> Провайдер -> Catalyst1 (FastEthernet0/4)
Везде mtu=1500.

Не работает.
В как в рамках сети 10.0.0.0/24, так и в рамках сети 10.0.100.0/24 коммутатора друг друга не видят.
Подскажите, пожалуйста, что я упустил?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "QinQ на Catalyst 3560"  +/
Сообщение от Aleks305 (ok) on 09-Мрт-11, 17:58 

interface FastEthernet0/4
description Q-IN-Q
switchport access vlan 10 - зачем???не нужно, мне кажется у Вас после этой команды уже никаког trunka не будет
switchport mode dot1q-tunnel - может в новой версии иос появилась такая команда.Я всегда пользовался switchport mode trunk, главное чтобы DTP со стороны провайдра согласовала trunk, то есть у них должно быть dynamic desirable
switchport nonegotiate - и как после этой команды транк согласуется сторонами???
no cdp enable
spanning-tree bpdufilter enable
spanning-tree bpduguard enable - придет bpdu - и весь ваш транк тут же упадет, потому что интерфейс отрубится.

Дайте вывод команды: show int fa0/4 sw

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "QinQ на Catalyst 3560"  +/
Сообщение от anonymous (??) on 09-Мрт-11, 18:33 
добрый день
пожалуйста прочтите следкующую статью
http://www.hilik.org.ua/я█п╨п╬п╫п╬п╪п╫п╟я▐-я│я┘п╣п╪п╟-п©п╬я│я┌я─п╬п╣п╫п╦я▐-qinq/
там все достаточно понятно описано.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "QinQ на Catalyst 3560"  +/
Сообщение от burban email(ok) on 09-Мрт-11, 18:51 
> добрый день
> пожалуйста прочтите следкующую статью
> http://www.hilik.org.ua/я█п╨п╬п╫п╬п╪п╫п╟я▐-я│я┘п╣п╪п╟-п©п╬я│я┌я─п╬п╣п╫п╦я▐-qinq/
> там все достаточно понятно описано.

Да собственно по данной инструкции и делалось.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "QinQ на Catalyst 3560"  +/
Сообщение от zaikini (??) on 10-Мрт-11, 17:17 
>> добрый день
>> пожалуйста прочтите следкующую статью
>> http://www.hilik.org.ua/я█п╨п╬п╫п╬п╪п╫п╟я▐-я│я┘п╣п╪п╟-п©п╬я│я┌я─п╬п╣п╫п╦я▐-qinq/
>> там все достаточно понятно описано.
> Да собственно по данной инструкции и делалось.

Туннелинг выполняется на стороне провайдера, а не у вас. С вашей стороны в сторону провайдера должны быть просто транковые порты.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "QinQ на Catalyst 3560"  +/
Сообщение от burban email(ok) on 10-Мрт-11, 17:22 
> Туннелинг выполняется на стороне провайдера, а не у вас. С вашей стороны
> в сторону провайдера должны быть просто транковые порты.

Провайдер дает только пару vlan-нов в транке.
И мои вланы не совпадают с вланами провайдера.
Плюс рассматривается возможность добавление у нас дополнительных вланов для проброски между нашими коммутаторами.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "QinQ на Catalyst 3560"  +/
Сообщение от zaikini email(??) on 10-Мрт-11, 23:12 
>> Туннелинг выполняется на стороне провайдера, а не у вас. С вашей стороны
>> в сторону провайдера должны быть просто транковые порты.
> Провайдер дает только пару vlan-нов в транке.
> И мои вланы не совпадают с вланами провайдера.
> Плюс рассматривается возможность добавление у нас дополнительных вланов для проброски
> между нашими коммутаторами.

В любом случае поддержка q-in-q должна быть со стороны провайдера, а не на вашем оборудовании.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "QinQ на Catalyst 3560"  +/
Сообщение от nwton on 19-Сен-11, 19:41 
> На обоих коммутаторах FastEthernet0/2 воткнут патчкордом в FastEthernet0/3.
> Провайдер переводит свой порт в  trunk-mode.
> Перетыкаю патчкорды, чтоб получилась схема:
> Catalyst1 (FastEthernet0/4) -> Провайдер -> Catalyst1 (FastEthernet0/4)
> Подскажите, пожалуйста, что я упустил?

Поздний ответ, но для потомков отвечаю.
Согласно настройкам петля не в тех портах стоит и провайдер не туда воткнут, должно быть так:

На обоих коммутаторах FastEthernet0/4 воткнут патчкордом в FastEthernet0/3.
Провайдер переводит свой порт в  trunk-mode.
Перетыкаю патчкорды, чтоб получилась схема:
Catalyst1 (FastEthernet0/2) -> Провайдер -> Catalyst1 (FastEthernet0/2)

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру