The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"iptv от двух провайдеров на cisco 3725"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"iptv от двух провайдеров на cisco 3725"  +/
Сообщение от Андрей Петрович email(ok) on 11-Окт-10, 20:07 
Имеется cisco 3725, Cisco IOS Software C3725-ADVENTERPRISEK9_SNA-M Version 12.4(23)
Настроен NAT на трех  провайдеров.
Попытался настроить iptv... Работает только от первого провадера.
Адреса каналов вещания у двух провайдеров:
второй 239.xxx.0.0
первый 239.0.x.0 и 239.0.xx.0
Подскажите как получить iptv от обоих провайдеров одновременно?

!
interface FastEthernet0/0
description home net
ip address 192.168.1.1 255.255.255.0
ip pim sparse-mode
ip nat inside
ip virtual-reassembly
ip igmp helper-address 10.1.1.1 - тут вообще пришлось вписать левый ip...
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface FastEthernet0/1
description firstWAN
mac-address 00xx.xxxx.xxxx
ip address dhcp client-id FastEthernet0/1
ip pim sparse-mode
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface FastEthernet1/0
description secondWAN
ip address 10.100.xxx.xxx 255.255.255.0
ip pim sparse-mode
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface FastEthernet1/1
description thirdWAN
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ip-gateway-firstWAN
!тут маршруты для локалок провайдеров 2 и 3
ip route 10.16.0.0 255.240.0.0 ip-gateway-thirdWAN
ip route 10.32.0.0 255.240.0.0 ip-gateway-thirdWAN
ip route 10.64.0.0 255.240.0.0 ip-gateway-thirdWAN
ip route 10.96.0.0 255.224.0.0 ip-gateway-secondWAN
ip route 10.115.202.0 255.255.255.0 ip-gateway-secondWAN
ip route 10.128.0.0 255.192.0.0 ip-gateway-secondWAN
ip route 10.255.0.0 255.255.0.0 ip-gateway-thirdWAN
!
!
ip pim rp-address xxx.xxx.xxx.xxx first-iptv override
ip pim rp-address yyy.yyy.yyy.yyy second-iptv override
ip nat inside source route-map second interface FastEthernet1/0 overload
ip nat inside source route-map first interface FastEthernet0/1 overload
ip nat inside source route-map third interface FastEthernet1/1 overload

!
ip access-list standard second-iptv
permit 239.xxx.0.0 0.0.0.255
ip access-list standard first-iptv
permit 239.0.x.0 0.0.0.255
permit 239.0.xx.0 0.0.0.255
!
access-list 10 permit 192.168.1.0 0.0.0.255
snmp-server community public RO
no cdp run
!
route-map second permit 20
match ip address 10
match interface FastEthernet1/0
!
route-map first permit 10
match ip address 10
match interface FastEthernet0/1
!
route-map third permit 30
match ip address 10
match interface FastEthernet1/1
!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "iptv от двух провайдеров на cisco 3725"  +/
Сообщение от Андрей Петрович email(ok) on 14-Окт-10, 16:54 
Уважаемые форумчане... Неужели никто не сталкивался???


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "iptv от двух провайдеров на cisco 3725"  +/
Сообщение от AP email(??) on 14-Окт-10, 21:23 
Почитайте про VRF-LITE


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "iptv от двух провайдеров на cisco 3725"  +/
Сообщение от Гость on 15-Окт-10, 06:40 
Или просто добавить роуты к источникам мультикастов второго провайдера?
PIM-SM делает spt switchover для этого он стоит дерево к источнику, возможно нету более специфического роута к источнику трафика с второго провайдера и он использует шлюз по умолчанию (первый провайдер).
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "iptv от двух провайдеров на cisco 3725"  +/
Сообщение от Гость2 on 15-Окт-10, 06:45 
> Или просто добавить роуты к источникам мультикастов второго провайдера?
> PIM-SM делает spt switchover для этого он стоит дерево к источнику, возможно
> нету более специфического роута к источнику трафика с второго провайдера и
> он использует шлюз по умолчанию (первый провайдер).

Также чтобы роут к RP второго провайдера был через нужный интерфейс

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру