The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"непонятный глюк pppoe и NAT"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"непонятный глюк pppoe и NAT"  +/
Сообщение от disia (ok) on 07-Авг-10, 14:55 
не понимаю, что происходит...есть 857 циска, соединяется с провайдером по pppoe, включен нат, с ней работают три локальных узла, один зацеплен по вайфай и два через её внутренний свитч, связь между узлами есть, её BVI интерфейс пингуется...работает даже днс....но вот с инетренетом творится что то не понятное..провайдер не виноват...потому что цепляясь с компа..все работает прекрасно, но как только цепляюсь циской творится что т оне понятное, аська цепляется, фтп работает...но тоже не всегда..а вот хттп и хттпс почти никогда...днс работает отлично...циска работает как форвард, адреса возвращает иправно...а вот соединения устанавливает криво...два сайта открываются..остальные нет...пытаясь соединится телнетом на 80ый порт того же маил.ру...могу получить коннект и ответ..через 5 минут уже ничего не получаю, соединение вроде как установлено..но ответа нет...и так со всеми сайтами...за исключением одного-двух..которые почему то всегда отвечают..хотя никак с локальной сетью и даже провайдером не связаны..такое ощущение что циска как то неправильно транслирует адреса...не может толи ответ сервера доставить..толи фаер в ней сума сошел..потому что с самой циски..сконсоли..телнет всегда получает ответ от 80го порта..а вот узла за натом...глючат...вот конфиг:

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname host
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone OMSK 6
clock save interval 8
!
!
dot11 syslog
!
dot11 ssid disia
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 blablabla
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.254
ip dhcp ping packets 5
!
ip dhcp pool local
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.254
   dns-server 192.168.0.254
   domain-name dom.ru
!
ip dhcp pool local.comp.fe.1
   host 192.168.0.1 255.255.255.0
   client-identifier 0100.1617.eb79.33
   client-name local.nbook.fe
   lease infinite
!
ip dhcp pool local.nbook.fe
   host 192.168.0.2 255.255.255.0
   client-identifier 0100.23ae.293b.72
   client-name local.nbook.fe
   lease infinite
!
ip dhcp pool local.nbook.wifi
   host 192.168.0.3 255.255.255.0
   client-identifier 0100.225f.8244.91
   client-name local.nbook.wifi
   lease infinite
!
ip dhcp pool local.xbox
   host 192.168.0.4 255.255.255.0
   client-identifier 0100.2248.d4be.fe
   client-name local.xbox
   lease infinite
!
!
ip cef
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
no ip address
ip virtual-reassembly
no ip mroute-cache
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no keepalive
no cdp enable
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers tkip
!
ssid disia
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2437
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname login
ppp chap password 0 pass
ppp ipcp dns request
!
interface BVI1
ip address 192.168.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip dns server
ip nat inside source list 10 interface Dialer1 overload
!
access-list 10 permit any
dialer-list 1 protocol ip permit
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "непонятный глюк pppoe и NAT"  +/
Сообщение от disia (ok) on 07-Авг-10, 14:59 
дебаги смотреть пробовал всякие...ниче не увидел вменяемого..подскажите что посмотреть
пинги ходят все замечательно и на инет узлы
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "непонятный глюк pppoe и NAT"  +/
Сообщение от DS email(??) on 07-Авг-10, 15:59 
>дебаги смотреть пробовал всякие...ниче не увидел вменяемого..подскажите что посмотреть
>пинги ходят все замечательно и на инет узлы

debug ip error непрерывно показывает такого типа записи:

IP: s=95.27.59.146 (Dialer1), d=217.25.221.10, len 58, dispose udp.noport

я так понимаю какие то потери идут

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "непонятный глюк pppoe и NAT"  +/
Сообщение от oO on 08-Авг-10, 10:44 
>>дебаги смотреть пробовал всякие...ниче не увидел вменяемого..подскажите что посмотреть
>>пинги ходят все замечательно и на инет узлы
>
>debug ip error непрерывно показывает такого типа записи:
>
> IP: s=95.27.59.146 (Dialer1), d=217.25.221.10, len 58, dispose udp.noport
>
>я так понимаю какие то потери идут

смотри в сторону MTU. некоторые сайты хотят 1500, а пппое пропускает только 1492 байта

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру