The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"проброс VLAN через cisco 1803"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 10-Июн-10, 18:18 
Народ большие ГУРУ, помогите разобраться с мелкой проблемкой.

Надо пробросить через cisco 1803 один vlan 111 без маршрутизации а другой vlan 222 cмаршрутизировать. Эти два vlan приходят с одного порта fa1. Но почему то не получается: vlan 222 работает отлично, а vlan 111 не пробрасывается с fa1 на fa2.
Вот конфигурация:


version 12.4
service nagle
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
!
hostname 1803
!
boot-start-marker
boot-end-marker
!
logging buffered 10000 debugging
enable secret 5 $1$41rB$zTYjHUzF/Llv8Mm23HyGs/
!
aaa new-model
!
!
aaa authentication attempts login 20
aaa authentication banner ^CFreeBSD/i386 (еее-gw.ааа.ru) (ttyp2)
^C        
aaa authentication fail-message ^C
Login incorrect
^C
aaa authentication username-prompt "Login: "
aaa authentication login default local
aaa authentication enable default enable
!
aaa session-id common
!
resource policy
!
clock timezone SAMT 4
clock summer-time SAMST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
ip cef
!
!
ip vrf forwarding
!
ip vrf inet
description ***VRF test***
rd 100:100
route-target export 100:100
route-target import 100:100
!

ip multicast-routing vrf inet
!
!
crypto pki trustpoint TP-self-signed-2759403664
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2759403664
revocation-check none
rsakeypair TP-self-signed-2759403664
!
!
crypto pki certificate chain TP-self-signed-2759403664
certificate self-signed 01
  
  quit
username чччч privilege 15 password 7 чч
username чч privilege 15 secret 5 ччч
!
!
controller DSL 0
mode atm
line-term cpe
line-mode auto
dsl-mode shdsl symmetric annex B
ignore-error-duration  15
description *** 2851 ееецц dsl 0/2/0 ***
!
!
bridge irb
!
!
!
interface Loopback100
description **Clients**
ip address 192.43.188.1 255.255.255.0 secondary
ip address 192.43.182.1 255.255.255.0
!
interface FastEthernet0
description **Vnrshka**
no ip redirects
no ip proxy-arp
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
description **Provaiper**
switchport mode trunk
no cdp enable
!
interface FastEthernet2
description old_VV
switchport access vlan 111
no cdp enable
!
interface FastEthernet3
shutdown
no cdp enable
!
interface FastEthernet4
switchport access vlan 222
no cdp enable
!
interface FastEthernet5
switchport access vlan 222
no cdp enable
!
interface FastEthernet6
shutdown
no cdp enable
!
interface FastEthernet7
shutdown
no cdp enable
!
interface FastEthernet8
shutdown
no cdp enable
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface Vlan1
no ip address
!
!
interface Vlan111
description old_VV
no ip address
!
interface Vlan222
ip address y.y.y.y 255.255.255.z
!

!
ip route 0.0.0.0 0.0.0.0 A.B.C.D

!
ip flow-export version 5
ip flow-export destination x.x.x.x 9996
!
no ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
ip http max-connections 2
ip nat inside source list 13 interface FastEthernet0 vrf inet overload
ip nat inside source list 5 interface FastEthernet0 overload
!
ip access-list extended real_import
!
access-list 1 permit 10.214.0.222
access-list 1 permit 85.112.35.1
access-list 1 permit 85.112.35.10
access-list 1 permit 10.214.0.202
access-list 1 permit 10.214.136.125
access-list 1 permit 10.214.76.223
access-list 1 permit 10.214.136.48
access-list 1 permit 10.214.235.82
access-list 1 permit 10.214.136.33
access-list 1 permit 10.214.0.18
access-list 1 permit 10.214.240.0 0.0.7.255
access-list 1 permit 10.214.237.244 0.0.0.3
access-list 1 permit 192.168.230.0 0.0.0.3
access-list 1 permit 10.214.100.48 0.0.0.3
access-list 5 permit 192.43.188.0 0.0.0.255
access-list 13 permit 192.168.13.0 0.0.0.255
access-list 99 permit 0.0.0.2 255.255.255.252
snmp-server community tulup RO
!
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
line aux 0
access-class 1 in
access-class 1 out
line vty 5 15
access-class 1 in
!
ntp clock-period 17180217
ntp server 10.214.0.18
ntp server 10.251.4.18
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end


В vlan database эти vlan есть

  VLAN ISL Id: 222
    Name: new_VV
    Media Type: Ethernet
    VLAN 802.10 Id: 100039
    State: Operational
    MTU: 1500

  VLAN ISL Id: 111
    Name: old_VV
    Media Type: Ethernet
    VLAN 802.10 Id: 100879
    State: Operational
    MTU: 1500


Помогите плиззз....

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "проброс VLAN через cisco 1803"  +/
Сообщение от sh_ email(ok) on 10-Июн-10, 18:51 
А можно посмотреть что-нибудь типа sh int fa 1, sh int fa 2, sh int trunk, sh span, sh mac- | i 0/2|0/1
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 11-Июн-10, 08:49 
>А можно посмотреть что-нибудь типа sh int fa 1, sh int fa
>2, sh int trunk, sh span, sh mac- | i 0/2|0/1
>

1803#sh int fa 1
FastEthernet1 is up, line protocol is down
  Hardware is FastEthernet, address is 0014.a899.0ed6 (bia 0014.a899.0ed6)
  Description: **VolgaTelekom**
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
1803#sh int fa 2
FastEthernet2 is up, line protocol is down
  Hardware is FastEthernet, address is 0014.a899.0ed7 (bia 0014.a899.0ed7)
  Description: old_VV
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


1803#sh span

Bridge group 1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0014.a899.0ed4
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 15:21:34 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300


1803#sh mac- | include 1
0014.a899.0ed4          Self          1     Vlan1
0014.a899.0ed4          Self         39     Vlan39
0014.a899.0ed4          Self        879     Vlan879
1803#sh mac- | include 2
1803#

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "проброс VLAN через cisco 1803"  +/
Сообщение от kod (??) on 10-Июн-10, 23:40 
>interface FastEthernet1
> description **Provaiper**
> switchport mode trunk
> no cdp enable

Возможно проблема из-за ненастроенной инкапсуляции...
на fa1 :
  encapsulation dot1q

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 11-Июн-10, 08:50 
encapsulation dot1q

уже пробовал. не помогает.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "проброс VLAN через cisco 1803"  +/
Сообщение от sh_ email(ok) on 11-Июн-10, 11:40 
Дык, у вас интерфейсы в down. Как оно вообще может работать?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 11-Июн-10, 11:48 
>Дык, у вас интерфейсы в down. Как оно вообще может работать?

Сейчас да. cisco отключена. На время поставил другое оборудование, но потом всё равно необходимо cisco. Не ужели нет возможности так посмотреть?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "проброс VLAN через cisco 1803"  +/
Сообщение от dmn49 (ok) on 11-Июн-10, 11:45 
>vlan 111 не пробрасывается с fa1 на fa2.

А что вы под этим подразумеваете?
Как вы хотите, чтобы 111 влан работал?

С конфигом у вас вроде все в порядке.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 11-Июн-10, 12:03 
>>vlan 111 не пробрасывается с fa1 на fa2.
>
>А что вы под этим подразумеваете?
>Как вы хотите, чтобы 111 влан работал?
>
>С конфигом у вас вроде все в порядке.

vlan 111 надо просто пробросить с тегированного порта fa1 на нетегиронный fa2. Там он идёт на D-Link 2110 (настройки D-link проверил, там точно ошибок нет) т.д.

Больше скажу все vlan-ы на cisco 1803 нормально проходят (вчера ночью проверил, пока обе фирмы не работали). Проверял забиванием ip из одной и другой сети на vlan-ах в cisco 1803. Но дальше не идут ни в какую.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "проброс VLAN через cisco 1803"  +/
Сообщение от dmn49 (ok) on 11-Июн-10, 12:15 
покажите схему сети и адресации.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "проброс VLAN через cisco 1803"  +/
Сообщение от tanker (ok) on 11-Июн-10, 12:16 
Ну, по конфигурации 1803 у Вас в само деле все нормально, может Вы на D-link ждете с тегом трафик по ошибке?
на D-link на порту смотрящем, на 1803 точно нет никаких MAC-ов?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 11-Июн-10, 12:32 
>Ну, по конфигурации 1803 у Вас в само деле все нормально, может
>Вы на D-link ждете с тегом трафик по ошибке?
>на D-link на порту смотрящем, на 1803 точно нет никаких MAC-ов?

Я уверен в D-link потому что раньше от провайдера на прямую не тегированный трафик шёл.

| провайдер | -> | d-link 2110 |  (не тегированный трафик, рабочая схема)

Сейчас я хочу

| провайдер | -> | cisco 1803 | -> | vlan 111 (нетегированный) d-link 2110 |
                                  |
                                  |
                               vlan 222
                                  

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "проброс VLAN через cisco 1803"  +/
Сообщение от dmn49 (ok) on 11-Июн-10, 12:43 
>[оверквотинг удален]
>          
>|
>            
>          
>          
>|
>            
>          
>        vlan 222
>

А Вы не могли бы еще добавить адресацию к схеме. Где какие сети, кто кому шлюзом приходится.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 11-Июн-10, 12:50 
На счёт MAC-ов ничего не могу сказать. До оборудования после d-link нет доступа. На D-link точно ничего не прописано.

Значит по вашему мнению у мя всё правильно прописано?
Остаётся только единственная проблема связанная с MAC ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "проброс VLAN через cisco 1803"  +/
Сообщение от dmn49 (ok) on 11-Июн-10, 13:53 
Я про IP.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "проброс VLAN через cisco 1803"  +/
Сообщение от tanker (ok) on 11-Июн-10, 15:04 
>На счёт MAC-ов ничего не могу сказать. До оборудования после d-link нет
>доступа. На D-link точно ничего не прописано.
>
>Значит по вашему мнению у мя всё правильно прописано?
>Остаётся только единственная проблема связанная с MAC ?

на d-link видны MAC-и со стороны cisco, ну и на порту cisco со стороны d-link?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "проброс VLAN через cisco 1803"  +/
Сообщение от sh_ email(ok) on 11-Июн-10, 16:55 
А лампочки то загораются, когда вы d-link с цызкой соединяете?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "проброс VLAN через cisco 1803"  +/
Сообщение от Valery12 (ok) on 16-Июн-10, 15:10 
>[оверквотинг удален]
>          
>|
>            
>          
>          
>|
>            
>          
>        vlan 222
>

как я понимаю нужно между двумя интерфейсами сделать бридж
я вижу в конфиге
bridge irb
bridge 1 protocol ieee
но ни на одном из интерфейсов нет
bridge-group 1

пардон видимо речь идет о Ethernet switch interface card
если порт смотрящий на провайдера из этого модуля то на нем не мешает добавить
no vtp
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
потому что возможно он просто блокирует порт

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 18-Июн-10, 15:23 
Народ спасибо за все предложения. Проблемка пока не решилась, но по ходу я нашёл причину этого глюка.
Это не хорошие отношения между D-Link и CISCO. Я поставил вместо 1803 обычный коммутатор 2950 и он мне сразу показал линк есть а пакеты не ходят (и лампочка красным горит). Посмотрел прошивку D-Link - 1.0.2. Я думаю на следующей неделе перепрошью на новую прошивку и проблема решится и c 1803.

Жонглирование нстройками speed и duplex с обоих сторон(d-link и CISCO) ничего не дало.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 12-Июл-10, 08:56 
Народ ни когда не скрещивайте D-Link и cisco, убил кучу времени и получил больших пи... от начальства в итоге всё переделываю на cisco.

Не повторяйте мою ошибку не покупайте никогда D-link, если расчитываете хоть когда нибудь использовать cisco.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "проброс VLAN через cisco 1803"  +/
Сообщение от mario email(ok) on 12-Июл-10, 09:26 
>Народ ни когда не скрещивайте D-Link и cisco, убил кучу времени и
>получил больших пи... от начальства в итоге всё переделываю на cisco.
>
>
>Не повторяйте мою ошибку не покупайте никогда D-link, если насчитываете хоть когда
>нибудь использовать cisco.

у вас терминации не было ... это не зоопарк  виноват ....

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

21. "проброс VLAN через cisco 1803"  +/
Сообщение от swichmen29 (ok) on 12-Июл-10, 09:37 
>у вас терминации не было ... это не зоопарк  виноват ....
>

линк был, если вы об этом.
А если нет. То чеми эта самая терминация настраивается? и как их подружить?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру