The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"RSPAN"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"RSPAN"  +/
Сообщение от Bbi4 (ok) on 07-Апр-10, 15:45 
Добрый  день, всезнающий ALL
Имеется связка:
Сервер--f0/5 (*1*) g0/2 -trunk- g0/8 (*2*) g0/7 -trunk- g1/0/1 (*3*) g2/0/48 --сниффер,
где (*1*) - cisco WS-C2950T-24 (IOS Version 12.1(12c)EA1)
(*2*) - cisco WS-C3550-12T (IOS Version 12.1(20)EA1a)
(*3*) - cisco WS-C3750G-48TS (IOS (C3750-ADVIPSERVICESK9-M), 12.2(44)SE2)

На всех есть Remote Span Vlan 1001
По транкам он разрешен.

На (*1*):
interface FastEthernet0/5
switchport access vlan 205
switchport mode access
no ip address
no cdp enable
spanning-tree portfast
end

interface FastEthernet0/13
no ip address
no cdp enable
spanning-tree portfast
end

interface Port-channel1
switchport mode trunk
no ip address
end

interface GigabitEthernet0/2
switchport mode trunk
no ip address
channel-group 1 mode on
end

monitor session 1 source int f0/5
monitor session 1 dest rem vlan 1001 reflect-port f0/13

На (*3*):

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,20,30,202,1001
switchport mode trunk
load-interval 30
end

interface GigabitEthernet2/0/48
switchport access vlan 20
switchport mode access
end

monitor session 1 source rem vlan 1001
monitor session 1 dest int g2/0/48

Результат нулевой.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • RSPAN, Gbyte, 15:47 , 07-Апр-10, (1)  
    • RSPAN, Bbi4, 15:53 , 07-Апр-10, (2)  
      • RSPAN, Gbyte, 16:05 , 07-Апр-10, (3)  
        • RSPAN, Bbi4, 16:21 , 07-Апр-10, (4)  
          • RSPAN, GByte, 19:24 , 07-Апр-10, (5)  
            • RSPAN, Bbi4, 09:49 , 08-Апр-10, (6)  
              • RSPAN, Gbyte, 10:19 , 08-Апр-10, (7)  
                • RSPAN, Bbi4, 11:58 , 08-Апр-10, (8)  
                  • RSPAN, Gbyte, 12:35 , 08-Апр-10, (9)  
                    • RSPAN, Bbi4, 12:43 , 08-Апр-10, (10)  

Сообщения по теме [Сортировка по времени | RSS]


1. "RSPAN"  +/
Сообщение от Gbyte email(ok) on 07-Апр-10, 15:47 
interface Port-channel1
switchport mode trunk
no ip address
end

это что? ченел в L3? - поторопился, не может 2950 L3 :)

что показывает
#sho int trunk
?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "RSPAN"  +/
Сообщение от Bbi4 (ok) on 07-Апр-10, 15:53 
>[оверквотинг удален]
>switchport mode trunk
>no ip address
>end
>
>это что? ченел в L3? - поторопился, не может 2950 L3 :)
>
>
>что показывает
>#sho int trunk
>?

#sh int po1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Po1       on           802.1q         trunking      1

Port      Vlans allowed on trunk
Po1       1-4094

Port      Vlans allowed and active in management domain
Po1       1,3,10,13,17,20,30-31,202,204-205,209,254,1001

Port      Vlans in spanning tree forwarding state and not pruned
Po1       1,3,10,13,17,20,30-31,202,204-205,209,254,1001

В etherchanel1 входит только один порт g0/2

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "RSPAN"  +/
Сообщение от Gbyte email(ok) on 07-Апр-10, 16:05 
показал бы сразу по всем транковым портам всех коммутаторов, или сам проверь :)

таааак :)

а вилан 1001 как создан? :)

conf t
vlan 1001
name rspan
remote-span
exit

так? на всех трех коммутаторах? :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "RSPAN"  +/
Сообщение от Bbi4 (ok) on 07-Апр-10, 16:21 
>показал бы сразу по всем транковым портам всех коммутаторов, или сам проверь
>:)

Извините. Проверил и на всякий случай показываю.

>а вилан 1001 как создан? :)
>
>conf t
>vlan 1001
>name rspan
>remote-span
>exit
>
>так? на всех трех коммутаторах? :)

Да. На всех.

(*1*)
#sh vlan id 1001

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1001 RemoteSpan                       active    Po1

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1001 enet  101001     1500  -      -      -        -    -        0      0  

Remote SPAN VLAN
----------------
Enabled

(*2*)
#sh vlan id 1001

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1001 RemoteSpan                       active    Gi0/2, Gi0/7, Po1, Po2, Po3, Po4, Po5, Po6, Po7, Po8

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1001 enet  101001     1500  -      -      -        -    -        0      0  

Remote SPAN VLAN
----------------
Enabled

#sh run int g0/8
Building configuration...

Current configuration : 147 bytes
!
interface GigabitEthernet0/8
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 4 mode on
end

#sh int po4 tru

Port        Mode         Encapsulation  Status        Native vlan
Po4         on           802.1q         trunking      1

Port      Vlans allowed on trunk
Po4         1-4094

Port        Vlans allowed and active in management domain
Po4         1,3,10,13,17,20,30-31,202,204-205,209,254,1001

Port        Vlans in spanning tree forwarding state and not pruned
Po4         1,3,10,13,17,20,30-31,202,204-205,209,254,1001

#sh int g0/7 tru

Port        Mode         Encapsulation  Status        Native vlan
Gi0/7       on           802.1q         trunking      1

Port      Vlans allowed on trunk
Gi0/7       1,20,30,202,1001

Port        Vlans allowed and active in management domain
Gi0/7       1,20,30,202,1001

Port        Vlans in spanning tree forwarding state and not pruned
Gi0/7       1,20,30,202,1001

(*3*)

#sh vlan id 1001

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1001 RemoteSpan                       active    Gi1/0/1

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1001 enet  101001     1500  -      -      -        -    -        0      0  

Remote SPAN VLAN
----------------
Enabled

#sh int g1/0/1 tru

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/1     on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/1     1,20,30,202,1001

Port        Vlans allowed and active in management domain
Gi1/0/1     1,20,30,202,1001

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/1     1,20,30,202,1001


Может надо что-нибудь на транзитном (*2*) прописать?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "RSPAN"  +/
Сообщение от GByte email(??) on 07-Апр-10, 19:24 
Вот это читал?

>а вилан 1001 как создан? :)
>
>conf t
>vlan 1001
>name rspan
>remote-span
>exit
>
>так? на всех трех коммутаторах? :)

еще раз повторю вилан должен быть обозначен как remote-span на всех коммутаторах учавствующих в пересылке.

и еще Внимание! вилан remote-span не учавствует в STP!!! - можно запросто петлю сделать...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "RSPAN"  +/
Сообщение от Bbi4 (ok) on 08-Апр-10, 09:49 
>еще раз повторю вилан должен быть обозначен как remote-span на всех коммутаторах
>учавствующих в пересылке.

#sh vlan id 1001

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1001 RemoteSpan                       active    Gi1/0/1

Remote SPAN VLAN
----------------
Enabled

Я же показал, что на всех трех он такой и есть.

Для любого другого:
#sh vlan id 20

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
101  FR_DATA                          active    Gi1/0/2

Remote SPAN VLAN
----------------
Disabled

>и еще Внимание! вилан remote-span не учавствует в STP!!! - можно запросто
>петлю сделать...

А как запретить вилану участвовать в STP? Хотя в данной ситуации никакой петли быть не может. Пока сеть построена без резервирования линков.
На портах сервера и снифера был port-security, но его я убрал.

На форуме (https://www.opennet.ru/openforum/vsluhforumID6/6580.html) наткнулся на такую конструкцию:
На промежуточном коммутаторе (*2*) remote vlan зеркалируется сам в себя:

второй Catalyst (транзитный)
monitor session 1 source remote vlan 10
monitor session 1 destination remote vlan 10 reflector port <interface>

Надо ли это делать? Попробовать не могу, т.к. на промежуточном нет свободных портов.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "RSPAN"  +/
Сообщение от Gbyte email(ok) on 08-Апр-10, 10:19 
в руководстве написано, что remote-span вилан в STP автоматически не учавствует.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/so...

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/so...

эти страницы читал?

я ничего неправильного у тебя не нахожу, кроме reflect-port f0/13 на первом.
без него не работает?

каким образом определяешь заработал или нет спан?

проверь еще раз все внимательно, может где опечатка?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "RSPAN"  +/
Сообщение от Bbi4 (ok) on 08-Апр-10, 11:58 
>в руководстве написано, что remote-span вилан в STP автоматически не учавствует.
>
>http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/so...
>
>http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/so...
>
>эти страницы читал?

Читал.
>
>я ничего неправильного у тебя не нахожу, кроме reflect-port f0/13 на первом.
>без него не работает?

Без него не дает ввести команду, да и в мануалах написано, что придется пожертвовать портом для зеркалирования в remote vlan.
>
>каким образом определяешь заработал или нет спан?

варяшарка ничего не показывает
>
>проверь еще раз все внимательно, может где опечатка?

Вроде нет.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "RSPAN"  +/
Сообщение от Gbyte email(ok) on 08-Апр-10, 12:35 

>варяшарка ничего не показывает

может трафика нет? :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "RSPAN"  +/
Сообщение от Bbi4 (ok) on 08-Апр-10, 12:43 
>
>>варяшарка ничего не показывает
>
>может трафика нет? :)

Есть. Заколебался и обычным SPANом снял на ноут.
Но это не выход. Хочу все-таки RSPAN иметь под рукой.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру