The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Как вынести нат из PPPoE сервера (cisco 3725)"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от sergeyfromkomi email(ok) on 22-Окт-09, 17:38 
Ув. инженеры помогите пож.!!! Как вынести нат из PPPoE сервера (cisco 3725) в другую cisc-у? Так чтоб "другая" cisc-а была в роли нат-а для cisco 3725. Юзер PPPoE получает IP из сети 10.1.1.0/24(кроме 10.1.1.2 и 10.1.1.1 )

bba-group pppoe PPPoE
virtual-template 1
sessions per-vlan limit 1000
!
!
!
interface FastEthernet0/0
description WAN access
ip address 10.1.1.2 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache policy
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
description connect to catalyst
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
duplex auto
speed auto
pppoe enable
no cdp enable
!
interface FastEthernet0/1.1
description PPP clients
encapsulation dot1Q 60
no ip redirects
ip virtual-reassembly
no snmp trap link-status
pppoe enable group PPPoE
!
interface FastEthernet0/1.2
description Radius and Billing and Admin
encapsulation dot1Q 918
ip address 10.14.6.169 255.255.255.224
no snmp trap link-status
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Virtual-Template1
mtu 1400
ip unnumbered FastEthernet0/0
ip flow ingress
ip flow egress
no peer default ip address
ppp authentication ms-chap-v2 chap
ppp ipcp dns 62.182.26.182 62.182.30.147
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 172.16.250.252 255.255.255.255 10.14.6.183
ip route 192.168.168.0 255.255.255.0 10.14.6.183
!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от shutdown now on 22-Окт-09, 22:20 
>[оверквотинг удален]
> ip flow ingress
> ip flow egress
> no peer default ip address
> ppp authentication ms-chap-v2 chap
> ppp ipcp dns 62.182.26.182 62.182.30.147
>!
>ip route 0.0.0.0 0.0.0.0 10.1.1.1
>ip route 172.16.250.252 255.255.255.255 10.14.6.183
>ip route 192.168.168.0 255.255.255.0 10.14.6.183
>!

в этом конфиге ната нет. скорее всего, что нат уже на 10.1.1.1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от sergeyfromkomi email(ok) on 23-Окт-09, 09:11 
>в этом конфиге ната нет. скорее всего, что нат уже на 10.1.1.1

Да так оно и есть.. (Нат на 10.1.1.1) но от авторизов. клиентов (PPPoE) пинги дальше 10.1.1.2 не идут... а с самой cisc-и пинги уходят в мир отлично....  


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от fantom (??) on 23-Окт-09, 09:34 
>>в этом конфиге ната нет. скорее всего, что нат уже на 10.1.1.1
>
>Да так оно и есть.. (Нат на 10.1.1.1) но от авторизов. клиентов
>(PPPoE) пинги дальше 10.1.1.2 не идут... а с самой cisc-и пинги
>уходят в мир отлично....

Настроить маршрутизацию надо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от sergeyfromkomi email(ok) on 23-Окт-09, 09:42 
>Настроить маршрутизацию надо.

Маршрутизацию для PPPoE клиентов? Разве надо если с самой cisc-и уходит всё отлично..
IP клиентов из той же сети что и сisc-а... Если надо настроить то может напишете примерно как... буду оч. благодарен...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от sshutdownow email(ok) on 23-Окт-09, 12:08 
>>Настроить маршрутизацию надо.
>
>Маршрутизацию для PPPoE клиентов? Разве надо если с самой cisc-и уходит всё
>отлично..
>IP клиентов из той же сети что и сisc-а... Если надо настроить
>то может напишете примерно как... буду оч. благодарен...

Подожди, у тебя вообще лажа: 10.1.1.0/24 - эта сеть на интерфейсах между рутерами и из неё же ты выдаёшь IP клиентам. Рутер, где NAT ищет их не там, для него эта сеть connected, он пытается найти клиента по ARP.

Сделай между рутерами 10.1.1.0/30 сетку, а на 10.1.1.1 пропиши обратный маршрут:
ip route 10.1.1.0 255.255.255.0 10.1.1.2

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от sergeyfromkomi email(ok) on 23-Окт-09, 13:11 
>Сделай между рутерами 10.1.1.0/30 сетку, а на 10.1.1.1 пропиши обратный маршрут:
>ip route 10.1.1.0 255.255.255.0 10.1.1.2

Огромное вам спасибо sshutdownow. Я многое теперь понял в иначе(правильнее) благодаря Вашему совету...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от евгений (??) on 23-Окт-09, 13:10 
>[оверквотинг удален]
> ip flow ingress
> ip flow egress
> no peer default ip address
> ppp authentication ms-chap-v2 chap
> ppp ipcp dns 62.182.26.182 62.182.30.147
>!
>ip route 0.0.0.0 0.0.0.0 10.1.1.1
>ip route 172.16.250.252 255.255.255.255 10.14.6.183
>ip route 192.168.168.0 255.255.255.0 10.14.6.183
>!

Я так понял "другую циску "подключать будешь через vlan.
1. устанавливаешь связь между двумя цисками (с префиксом /30 к примеру).
2. там где будешь натить надо inside и outside интерфейсы для ната.
3. делаешь роутмап для пула адресов pppoe клиентов на адрес inside интерфейса 2-ой циски.
4. там где будешь натить пишешь нат (с инсайд соурс роутмапом).
5. там где будешь натить пишешь роут 0,0,0,0 и шлюз.
6. следишь за CEF (чтобы работал на 1-ой циске) и за CPU (чтобы не попасть на 100% на второй).

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от евгений (??) on 23-Окт-09, 13:12 
>[оверквотинг удален]
>Я так понял "другую циску "подключать будешь через vlan.
>1. устанавливаешь связь между двумя цисками (с префиксом /30 к примеру).
>2. там где будешь натить надо inside и outside интерфейсы для ната.
>
>3. делаешь роутмап для пула адресов pppoe клиентов на адрес inside интерфейса
>2-ой циски.
>4. там где будешь натить пишешь нат (с инсайд соурс роутмапом).
>5. там где будешь натить пишешь роут 0,0,0,0 и шлюз.
>6. следишь за CEF (чтобы работал на 1-ой циске) и за CPU
>(чтобы не попасть на 100% на второй).

вообще 3725 при нате >3000 сессий (торренты легко это делают) легко попадает на 100% cpu. Увы. Сам с этим столкнулся.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Как вынести нат из PPPoE сервера (cisco 3725)"  +/
Сообщение от sergeyfromkomi email(ok) on 23-Окт-09, 13:29 
sshutdownow был прав!!!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру