The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Периодические потери при роутинге сетей"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 07-Июн-16, 16:04 
Есть 3560 (cisco) на ней настроены две сети в каждой сети есть по компу.
Делаю тесты iperf раз в 5 секунд потери от 7 до 15 пакетов, затем 55 секунд все хорошо и далее по кругу.

[  3] 15.0-20.0 sec  41.0 KBytes  67.2 Kbits/sec   0.060 ms    0/  140 (0%)
[  3] 20.0-25.0 sec  38.1 KBytes  62.4 Kbits/sec   0.073 ms    9/  139 (6.5%)
[  3] 25.0-30.0 sec  41.0 KBytes  67.2 Kbits/sec   0.083 ms    0/  140 (0%)
[  3] 30.0-35.0 sec  41.0 KBytes  67.2 Kbits/sec   0.085 ms    0/  140 (0%)
[  3] 35.0-40.0 sec  40.7 KBytes  66.7 Kbits/sec   0.048 ms    0/  139 (0%)
[  3] 40.0-45.0 sec  41.0 KBytes  67.2 Kbits/sec   0.133 ms    0/  140 (0%)
[  3] 45.0-50.0 sec  40.7 KBytes  66.7 Kbits/sec   0.062 ms    0/  139 (0%)
[  3] 50.0-55.0 sec  41.0 KBytes  67.2 Kbits/sec   0.074 ms    0/  140 (0%)
[  3] 55.0-60.0 sec  41.0 KBytes  67.2 Kbits/sec   0.115 ms    0/  140 (0%)
[  3] 60.0-65.0 sec  40.7 KBytes  66.7 Kbits/sec   0.068 ms    0/  139 (0%)
[  3] 65.0-70.0 sec  41.0 KBytes  67.2 Kbits/sec   0.054 ms    0/  140 (0%)
[  3] 70.0-75.0 sec  40.7 KBytes  66.7 Kbits/sec   0.059 ms    0/  139 (0%)
[  3] 75.0-80.0 sec  41.0 KBytes  67.2 Kbits/sec   0.068 ms    0/  140 (0%)
[  3] 80.0-85.0 sec  38.4 KBytes  62.9 Kbits/sec   0.074 ms    8/  139 (5.8%)
[  3] 85.0-90.0 sec  41.0 KBytes  67.2 Kbits/sec   0.086 ms    0/  140 (0%)
[  3] 90.0-95.0 sec  41.0 KBytes  67.2 Kbits/sec   0.119 ms    0/  140 (0%)

interface Vlan202
ip address 192.168.0.62 255.255.255.192

interface Vlan203
ip address 192.168.0.126 255.255.255.192

Компы соответственно 192.168.0.1 и 192.168.0.65

Оба порта
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 202,203
switchport mode trunk
switchport nonegotiate

И персонально на первом порту
switchport trunk native vlan 202

на втором порту
switchport trunk native vlan 203

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 07-Июн-16, 21:05 
>[оверквотинг удален]
> Компы соответственно 192.168.0.1 и 192.168.0.65
> Оба порта
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 202,203
>  switchport mode trunk
>  switchport nonegotiate
> И персонально на первом порту
> switchport trunk native vlan 202
> на втором порту
> switchport trunk native vlan 203

Если на каждом порту только по одной машине, то сделайте switchport mode access.
Если после перехода на access повторится - выводите сюда sh ver, sh proc cpu hist, sh logging, sh int.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 07-Июн-16, 21:26 
> Если на каждом порту только по одной машине, то сделайте switchport mode
> access.

Не получится, там еще есть VLAN на портах (боевые). Но если те же порты и сеть одна и та же, то потерь нет.

Форматирование на форумы не действует :(

sh ver
Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(52)SE, RELEASE   SOFTWARE (fc3)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 25-Sep-09 08:13 by sasyamal
Image text-base: 0x01000000, data-base: 0x02E00000

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(44)SE5, RELEASE SOFTWARE (fc1)

msk-gw2.ru uptime is 3 years, 41 weeks, 2 days, 21 hours, 51 minutes
System returned to ROM by power-on
System restarted at 00:07:09 MSD Thu Aug 23 2012
System image file is "flash:c3560-ipservicesk9-mz.122-52.SE.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C3560G-24TS (PowerPC405) processor (revision D0) with 131072K bytes of memory.
Processor board ID FOC1238W0RE
Last reset from power-on
20 Virtual Ethernet interfaces
28 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:23:34:AB:52:80
Motherboard assembly number     : 73-10215-04
Power supply part number        : 341-0098-02
Motherboard serial number       : FOC1238169C
Power supply serial number      : DCA123191VU
Model revision number           : D0
Motherboard revision number     : B0
Model number                    : WS-C3560G-24TS-S
System serial number            : FOC1238W0RE
Top Assembly Part Number        : 800-26851-01
Top Assembly Revision Number    : B0
Version ID                      : V03
CLEI Code Number                : CNMW200ARC
Hardware Board Revision Number  : 0x09


Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 28    WS-C3560G-24TS     12.2(52)SE            C3560-IPSERVICESK9-M


Configuration register is 0xF

==================================================================================

sh proc cpu hist

    11111111111     11111              11111
    1000000000099999777777777777778888833333888888888888888999
100
90
80
70
60
50
40
30
20                 *****
10 **********************************************************
   0....5....1....1....2....2....3....3....4....4....5....5....
             0    5    0    5    0    5    0    5    0    5
               CPU% per second (last 60 seconds)

    1232222332212322222121122222222222222222262222232222322213
    7009004221191120127739990208300018312813268733212020311291
100
90
80
70                                          *
60                                          *
50                                          *
40                                          *
30   **   **    *    *    *   *     *   *   ***   *    *    *
20 *******#**********#********#*************#*****#****#*****
10 ##########################################################
   0....5....1....1....2....2....3....3....4....4....5....5....
             0    5    0    5    0    5    0    5    0    5
               CPU% per minute (last 60 minutes)
              * = maximum CPU%   # = average CPU%
         1
    6793603536455334544357337634545454334544468453344466364636664433336564
    6299609763223650505391775039838365859379809602563403672466437387597528
100   *  *
90   *  *                                    *
80   *  *                  *                 *
70 *** **               *  *                 *          *   *        *
60 *** ** * *      *   **  **  * * *        **       ** * * ***      ***
50 *** ** * * **   * * **  ** ** * **  *********  *  ** * * ****     ****
40 ******************* ****** ****************** ************************
30 **********************************************************************
20 **********#*****#***##*****##*#*#*******##**#***#*****##*#*#*******##*
10 ######################################################################
   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.
             0    5    0    5    0    5    0    5    0    5    0    5    0
                   CPU% per hour (last 72 hours)
                  * = maximum CPU%   # = average CPU%
==================================================================================

sh logging
Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.


    Console logging: disabled
    Monitor logging: disabled
    Buffer logging:  level debugging, 69792 messages logged, xml disabled,
                     filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    File logging: disabled
    Persistent logging: disabled

No active filter modules.

    Trap logging: level informational, 69070 message lines logged
        Logging to XX.XX.XX.XX  (udp port 514,  audit disabled,
              authentication disabled, encryption disabled, link up),
              69070 message lines logged,
              0 message lines rate-limited,
              0 message lines dropped-by-MD,
              xml disabled, sequence number disabled
              filtering disabled

Log Buffer (4096 bytes):
expected message type has arrived. Terminating the connection
Jun  7 00:08:27: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 00:27:04: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 02:56:37: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 05:49:49: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 05:55:35: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 05:59:53: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 05:59:53: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 05:59:53: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 05:59:53: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 06:21:25: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 06:30:18: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 10:01:06: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 10:32:18: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 10:35:17: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 11:49:37: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 12:09:55: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 12:31:06: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
Jun  7 12:39:04: %SSH-4-SSH2_UNEXPECTED_MSG: Unexpected message type has arrived. Terminating the connection
==================================================================================
GigabitEthernet0/22 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0023.34ab.5296 (bia 0023.34ab.5296)
  Description: ISL
  MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 3/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 25w1d, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3178959
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 12277000 bits/sec, 6680 packets/sec
  5 minute output rate 1487000 bits/sec, 835 packets/sec
     568832727262 packets input, 97181871710804 bytes, 0 no buffer
     Received 605590994 broadcasts (477443577 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 477443577 multicast, 0 pause input
     0 input packets with dribble condition detected
     135400198495 packets output, 38928682682515 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
GigabitEthernet0/23 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0023.34ab.52c8 (bia 0023.34ab.52c8)
  Description: di-net peer 2
  Internet address is XX.XX.XX.XX/XX
  MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 5/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:21, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 20826000 bits/sec, 4475 packets/sec
     83406739833 packets input, 17493463844262 bytes, 0 no buffer
     Received 1762328 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 1762315 multicast, 0 pause input
     0 input packets with dribble condition detected
     28291532356 packets output, 8665763732946 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 07-Июн-16, 21:58 
>> [оверквотинг удален]

Это как так? Сначала вы говорите, что у вас:

> Оба порта
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 202,203
> switchport mode trunk
> switchport nonegotiate
> И персонально на первом порту
> switchport trunk native vlan 202
> на втором порту
> switchport trunk native vlan 203

Теперь у вас какая-то петрушка пошла. На одном интерфейсе явно no switchport стоит (internet address только на L3 может быть):

> GigabitEthernet0/23 is up, line protocol is up (connected)
>   Hardware is Gigabit Ethernet, address is 0023.34ab.52c8 (bia 0023.34ab.52c8)
>   Description: di-net peer 2
>   Internet address is XX.XX.XX.XX/XX

При этом через один порт у вас трафик в обе стороны летает:

>   5 minute input rate 12277000 bits/sec, 6680 packets/sec
>   5 minute output rate 1487000 bits/sec, 835 packets/sec

А через другой только в одну:

>   5 minute input rate 0 bits/sec, 0 packets/sec
>   5 minute output rate 20826000 bits/sec, 4475 packets/sec

Где-то вы не досмотрели свою схему сети. Или отдаете неправильные данные.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 07-Июн-16, 22:02 
Сори  порт второй не тот.
Вот тот порт
GigabitEthernet0/21 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0023.34ab.5295 (bia 0023.34ab.5295)
  Description: ISL
  MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 5/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 25w1d, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 271923
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 20936000 bits/sec, 1923 packets/sec
  5 minute output rate 3091000 bits/sec, 2366 packets/sec
     50393685350 packets input, 15468589804101 bytes, 0 no buffer
     Received 1150068093 broadcasts (1100334383 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 1100334383 multicast, 0 pause input
     0 input packets with dribble condition detected
     622050095339 packets output, 111249289904629 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 07-Июн-16, 22:10 
>[оверквотинг удален]
>      0 watchdog, 1100334383 multicast, 0 pause input
>      0 input packets with dribble condition detected
>      622050095339 packets output, 111249289904629 bytes, 0 underruns
>      0 output errors, 0 collisions, 0 interface
> resets
>      0 babbles, 0 late collision, 0 deferred
>      0 lost carrier, 0 no carrier, 0
> PAUSE output
>      0 output buffer failures, 0 output buffers
> swapped out

С какими параметрами запускаете iperf?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 07-Июн-16, 22:14 
Сервер
iperf --server  --udp --len 300 --tos 184 -fk --interval 5 -p 5002

Клиент
iperf -c 192.168.0.1 --udp --len 300 --bandwidth 67000 --dualtest --tradeoff --tos 184 -fk --interval 5 --time 600 --listenport 5003 -p 5002

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 07-Июн-16, 22:47 
> Сервер
> iperf --server  --udp --len 300 --tos 184 -fk --interval 5 -p
> 5002
> Клиент
> iperf -c 192.168.0.1 --udp --len 300 --bandwidth 67000 --dualtest --tradeoff --tos 184
> -fk --interval 5 --time 600 --listenport 5003 -p 5002

"Total output drops" на интерфейсах растет?  

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 08-Июн-16, 00:05 
В течении месяца на 100-200 пакетов. Но не постоянно, а видимо что-то прилетает из неправильных фреймов. Взаимоотношения между потерей пакетов и "Total output drops" нет.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 08-Июн-16, 21:04 
> В течении месяца на 100-200 пакетов. Но не постоянно, а видимо что-то
> прилетает из неправильных фреймов. Взаимоотношения между потерей пакетов и "Total output
> drops" нет.

Выделить порты специально для "погонять трафик между портами" есть возможность?
Если принимать тегированные VLAN на компьютерах проблема останется?

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 08-Июн-16, 23:27 
На всех портах, тегировано и не тегировано проверил. Везде одинаково.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 09-Июн-16, 21:29 
> На всех портах, тегировано и не тегировано проверил. Везде одинаково.

Тогда либо сменить IOS либо заявку в Cisco TAC, если есть сервисный контракт. Но они первым делом скажут "обновите IOS".

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 09-Июн-16, 21:38 
Вот и у меня остается только обновить IOS.
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Периодические потери при роутинге сетей"  +/
Сообщение от Stanislav (??) on 09-Июн-16, 22:49 
> Вот и у меня остается только обновить IOS.

  Цифра в 55 секунд уж что-то сильно напоминает время сходимости старого доброго STP, еще не M/RSTP. У вас петель там не наблюдается?
  Включите STP и его логи, посмотрите на всякий случай.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 09-Июн-16, 22:55 
Выставлен
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id


debug spanning-tree event - включил.

Петель нет.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 10-Июн-16, 14:30 
Все что нашел об изменении топологии.

show spanning-tree vlan 1 detail
...
Number of topology changes 0 last change occurred 26w1d ago
...

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 10-Июн-16, 21:49 
> Все что нашел об изменении топологии.
> show spanning-tree vlan 1 detail
> ...
> Number of topology changes 0 last change occurred 26w1d ago
> ...

Да vlan 1 тут скорее не при делах. Да и 55 секунд (или 60) это не таймеры блокировки STP.
BPDU hello - 2 секунды. При получении некорректного BPDU - блокировка моментальная.
По срокам похоже на таймеры восстановления порта из состояния Blocking.
Blocking -> 20 сек -> Listening-> 15 сек -> Learning -> 15 сек -> Forwarding. Но это получается 50 сек и в это время порт не пропускает пакеты. Но тут ситуация полностью обратная.
Больше похоже на буферы IO интерфейсов или очередей. Но нет большого количества дропов на интерфейсах. Так что похоже на буферы очередей.
Кстати что будет, если пропустить "--tos" при вызове iperf?  
Можно еще ICMP flood запустить для проверки.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 10-Июн-16, 22:14 
Есть такой параметр
interface VlanXXX
arp timeout 10

Может ли он влиять на потери?

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "Периодические потери при роутинге сетей"  +/
Сообщение от Stanislav (??) on 12-Июн-16, 01:53 
Все правильно - таймер сходимости STP 50 секунд (суммарный, по умолчанию, от BLK->FWD 55 это же примерное значение), только это не значит что  пока этот порт сходится трафик не идет другим путем, а потом наоборот. И кстати между 7 и 15 секундами находится время сходимости RSTP.
Некорректный BPDU не нужен, этого можно добиться и корректным путем )
Проверить стоило.

и pvst я бы в современных реалиях не использовал, хоть это возможно к источнику проблем и не имеет отношения.

>[оверквотинг удален]
> (или 60) это не таймеры блокировки STP.
> BPDU hello - 2 секунды. При получении некорректного BPDU - блокировка моментальная.
> По срокам похоже на таймеры восстановления порта из состояния Blocking.
> Blocking -> 20 сек -> Listening-> 15 сек -> Learning -> 15
> сек -> Forwarding. Но это получается 50 сек и в это
> время порт не пропускает пакеты. Но тут ситуация полностью обратная.
> Больше похоже на буферы IO интерфейсов или очередей. Но нет большого количества
> дропов на интерфейсах. Так что похоже на буферы очередей.
> Кстати что будет, если пропустить "--tos" при вызове iperf?
> Можно еще ICMP flood запустить для проверки.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

19. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 12-Июн-16, 17:44 
Хотите всех удивлю? Есть влан в котором нет параметра "arp timeout 10" и там потерь нет.
Так вот убрали этот параметр из нужного мне и все потерь нет.

Осталось выяснить каким боком этот параметр влиял на потерю пакетов.

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "Периодические потери при роутинге сетей"  +/
Сообщение от Andrey (??) on 12-Июн-16, 21:59 
> Хотите всех удивлю? Есть влан в котором нет параметра "arp timeout 10"
> и там потерь нет.
> Так вот убрали этот параметр из нужного мне и все потерь нет.
> Осталось выяснить каким боком этот параметр влиял на потерю пакетов.

arp timeout XXX - на какое время сохраняется MAC/IP в ARP таблице маршрутизатора.
Ставить arp timeout менее 60 сек. нет смысла, все равно запоминается не менее чем на 60 сек. Хотя поставить менее 60 сек. дает.
По истечении времени хранения запись ARP удаляется и маршрутизатор начинает запрашивать, кто есть в сети с таким IP адресом (ARP запрос). На это уходит время. В результате несколько IP пакетов просто пропадают, т.к. маршрутизатор не знает кому их посылать.

Кстати при большом размере сети и маленьком arp timeout можно получить перегрузку CPU на маршрутизаторе. Осторожно с этим, особенно если в сети есть любители посканировать наличие хостов в сети.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "Периодические потери при роутинге сетей"  +/
Сообщение от StreSS.t (ok) on 12-Июн-16, 22:38 
Насколько мне известно ARP таблица очистится в случае не активности владельца MAC (в данном же случае трафик идет).
В cisco очистка произойдет автоматически ни смотря ни на что?
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

23. "Периодические потери при роутинге сетей"  +/
Сообщение от zanswer on 20-Июн-16, 06:00 
> Насколько мне известно ARP таблица очистится в случае не активности владельца MAC
> (в данном же случае трафик идет).
> В cisco очистка произойдет автоматически ни смотря ни на что?

Как и везде, только при отсутствие обращения к записи, иначе timeout будет сбрасываться.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Ideco
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру