The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Почему коммутатор не отправляет BPDU от Root коммутатора"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Mirzhan email(ok) on 20-Май-16, 09:55 
Добрый день !
На Packet Tracer собрал кольцевую схему обычный Spanning tree.
                
                     Root switch
                    /             \
                 SW1        SW5
                   |               |
                SW2          SW4
                    \             /
                        SW3
На SW3 порт заблокирован в сторону SW2
Вопрос: Падает SW5
SW3 не отправляет BPDU от Root коммутатора SW4 почему ?

  



Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Mirzhan email(ok) on 20-Май-16, 10:00 
SW3 не отправляет BPDU от Root коммутатора SW4 забыл дописать прошу прощения
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Andrey (??) on 20-Май-16, 13:32 
> SW3 не отправляет BPDU от Root коммутатора SW4 забыл дописать прошу прощения

Внимание! Начинаю считывание конфигурации телепатическим методом!
Ждите! Ждите!
....
У вас неправильные настройки на коммутаторах.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Mirzhan email(ok) on 20-Май-16, 17:37 
>> SW3 не отправляет BPDU от Root коммутатора SW4 забыл дописать прошу прощения
> Внимание! Начинаю считывание конфигурации телепатическим методом!
> Ждите! Ждите!
> ....
> У вас неправильные настройки на коммутаторах.

Настройки минимальные
Switch(config)#spanning-tree vlan 1
Такой конфиг на всех коммутаторах

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Andrey (??) on 23-Май-16, 07:04 
>>> SW3 не отправляет BPDU от Root коммутатора SW4 забыл дописать прошу прощения
>> Внимание! Начинаю считывание конфигурации телепатическим методом!
>> Ждите! Ждите!
>> ....
>> У вас неправильные настройки на коммутаторах.
> Настройки минимальные
> Switch(config)#spanning-tree vlan 1
> Такой конфиг на всех коммутаторах

А sh spanning-tree с каждого коммутатора?
А настройки портов sh run int?
А sh logging с коммутаторов после сбоя SW5?
А debug spanning-tree event?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Mirzhan email(ok) on 23-Май-16, 08:00 
>[оверквотинг удален]
>>> Ждите! Ждите!
>>> ....
>>> У вас неправильные настройки на коммутаторах.
>> Настройки минимальные
>> Switch(config)#spanning-tree vlan 1
>> Такой конфиг на всех коммутаторах
> А sh spanning-tree с каждого коммутатора?
> А настройки портов sh run int?
> А sh logging с коммутаторов после сбоя SW5?
> А debug spanning-tree event?

Лог с Root коммутатора
Switch#sh spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0005.5EE4.7E64
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0005.5EE4.7E64
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/2            Desg FWD 19        128.2    P2p

Такой конфиг на всех коммутаторах
interface FastEthernet0/1
switchport trunk allowed vlan 1
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk allowed vlan 1
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk allowed vlan 1
switchport mode trunk


Результат комманды  sh logging со всех коммутаторов одинаковый
Switch#sh logging
Syslog logging: enabled (0 messages dropped, 0 messages rate-limited,
          0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.


No Inactive Message Discriminator.


    Console logging: level debugging, 12 messages logged, xml disabled,
          filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
          filtering disabled
    Buffer logging:  disabled, xml disabled,
          filtering disabled

    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled

No active filter modules.

ESM: 0 messages dropped
    Trap logging: level informational, 12 message lines logged

Debug не поддерживает
Switch(config)#do sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE SOFTWARE(fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 18-May-05 22:31 by jharirba
Image text-base: 0x80010000, data-base: 0x80562000

ROM: Bootstrap program is is C2950 boot loader
Switch uptime is 24 minutes, 13 seconds
System returned to ROM by power-on

Cisco WS-C2950-24 (RC32300) processor (revision C0) with 21039K bytes of memory.
Processor board ID FHK0610Z0WC
Last reset from system-reset
Running Standard Image
24 FastEthernet/IEEE 802.3 interface(s)

63488K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 0005.5EE4.7E64
Motherboard assembly number: 73-5781-09
Power supply part number: 34-0965-01
Motherboard serial number: FOC061004SZ
Power supply serial number: DAB0609127D
Model revision number: C0
Motherboard revision number: A0
Model number: WS-C2950-24

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Andrey (??) on 23-Май-16, 13:48 
>>[оверквотинг удален]
>> А sh spanning-tree с каждого коммутатора?
> Лог с Root коммутатора
> Switch#sh spanning-tree
> [оверквотинг удален]
> Такой конфиг на всех коммутаторах
> [оверквотинг удален]
> Результат комманды  sh logging со всех коммутаторов одинаковый
> [оверквотинг удален]

Ну... ваше право...

https://www.google.ru/search?num=50&newwindow=1&site=&source...

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от crash (ok) on 24-Май-16, 07:31 

> Результат комманды  sh logging со всех коммутаторов одинаковый

не удивительно, ведь

>     Buffer logging:  disabled, xml disabled,
>           filtering disabled

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от zanswer on 24-Май-16, 07:59 
>[оверквотинг удален]
>    SW4
>            
>         \  
>           /
>            
>            
>  SW3
> На SW3 порт заблокирован в сторону SW2
> Вопрос: Падает SW5
> SW3 не отправляет BPDU от Root коммутатора SW4 почему ?

А SW3 должен это сделать? SW5 направил BPDU в адрес SW4, Root в адрес SW3, теперь, как только истечёт таймаут SW4, сообщит SW5 и SW3, что топология изменилась, SW3 изменит статус порта в сторону SW2.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Mirzhan email(ok) on 24-Май-16, 08:11 
>[оверквотинг удален]
>>
>>
>>  SW3
>> На SW3 порт заблокирован в сторону SW2
>> Вопрос: Падает SW5
>> SW3 не отправляет BPDU от Root коммутатора SW4 почему ?
> А SW3 должен это сделать? SW5 направил BPDU в адрес SW4, Root
> в адрес SW3, теперь, как только истечёт таймаут SW4, сообщит SW5
> и SW3, что топология изменилась, SW3 изменит статус порта в сторону
> SW2.

Все правильно только после истечения тайм аута 20 сек SW3 изменит статус порта в сторону
> SW2,но ведь после падения SW5 Root ведь отдает свои данные SW3 а он их не отдает SW4 я думаю что из за того что из Root port в designated bpdu не ходит только designated в Root port как думаете ?

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от Apple on 06-Июн-16, 09:47 
>[оверквотинг удален]
>>> На SW3 порт заблокирован в сторону SW2
>>> Вопрос: Падает SW5
>>> SW3 не отправляет BPDU от Root коммутатора SW4 почему ?
>> А SW3 должен это сделать? SW5 направил BPDU в адрес SW4, Root
>> в адрес SW3, теперь, как только истечёт таймаут SW4, сообщит SW5
>> и SW3, что топология изменилась, SW3 изменит статус порта в сторону
>> SW2.
> Все правильно только после истечения тайм аута 20 сек SW3 изменит статус
> порта в сторону
>> SW2,но ведь после падения SW5 Root ведь отдает свои данные SW3 а он их не отдает SW4 я думаю что из за того что из Root port в designated bpdu не ходит только designated в Root port как думаете ?

BPDU из Root в сторону Designated не отправляются, поскольку в таком случае, Root получит свой же BPDU, только Cost Of Path будет равным стоимости всего пути от него самого, до него самого. Получается тогда, что образовалась петля, раз он получил свой же BPDU обратно.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Почему коммутатор не отправляет BPDU от Root коммутатора"  +/
Сообщение от zanswer on 06-Июн-16, 10:39 
>[оверквотинг удален]
>>> На SW3 порт заблокирован в сторону SW2
>>> Вопрос: Падает SW5
>>> SW3 не отправляет BPDU от Root коммутатора SW4 почему ?
>> А SW3 должен это сделать? SW5 направил BPDU в адрес SW4, Root
>> в адрес SW3, теперь, как только истечёт таймаут SW4, сообщит SW5
>> и SW3, что топология изменилась, SW3 изменит статус порта в сторону
>> SW2.
> Все правильно только после истечения тайм аута 20 сек SW3 изменит статус
> порта в сторону
>> SW2,но ведь после падения SW5 Root ведь отдает свои данные SW3 а он их не отдает SW4 я думаю что из за того что из Root port в designated bpdu не ходит только designated в Root port как думаете ?

Идея собственно говоря проста, Root Bridge шлёт BPDU каждые 2 секунды, тем самым сообщая, что он жив, далее, коммутаторы пересылают его BPDU из designated портов, при этом увеличивая Cost Of Path. Если же коммутатор получает BPDU на designated порту, то он разумно предполагает, что либо образовалась петля, либо на этом порту кто-то объявил себя Root Bridge.

В случае SW3 он на порту в сторону SW2, который будет Alternate для него, получает BPDU с установленным флагом TC, от Root Bridge. Ждёт истечения Max Age и переводит Alternate порт в Root, а Root в Designated, поскольку на текущем Root порту он не получает больше BPDU от Root Bridge. SW4 получил BPDU с TC от SW5, при этом он тоже ждёт истечения Max Age, чтобы изменить статусы портов.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру