The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Настройка NAT"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Настройка NAT"  +/
Сообщение от Tilon (ok) on 21-Янв-16, 17:01 
Добрый всем день. Помогите правильно настроить NAT.

interface GigabitEthernet0/0
ip address 87.123.12.xxx 255.255.255.0
ip nat outside

interface GigabitEthernet0/1
ip address 10.50.6.1 255.255.255.0
ip nat inside

interface GigabitEthernet0/2
ip address 10.180.230.254 255.255.255.0
ip nat outside

ip nat inside source list test interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 87.123.12.xxx

Сеть 10.50.6.1 входит в ACL Test. Выход в инет осуществляется с помощью интерфейса interface GigabitEthernet0/0

В чём собственно вопрос: Есть некая приблуда (типа криптошлюза), которая смотрит в свою сеть 10.182.233.0 / 24 . Эта приблуда имеет на одном из интерфейсов адрес 10.180.230.253 и связывается с Cisco по interface GigabitEthernet0/2

Хостам необходимо попадать в сеть 10.182.233.0 / 24  через эту приблуду
т.е. если клиенту нужен выход в инет, он идёт через 87.123.12.xxx, как только ему нужно попасть в 10.182.233.0 он должен идти через interface GigabitEthernet0/2. Как это сделать?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Настройка NAT"  +/
Сообщение от Golub Mikhail (ok) on 21-Янв-16, 17:36 
>[оверквотинг удален]
> ip route 0.0.0.0 0.0.0.0 87.123.12.xxx
> Сеть 10.50.6.1 входит в ACL Test. Выход в инет осуществляется с помощью
> интерфейса interface GigabitEthernet0/0
> В чём собственно вопрос: Есть некая приблуда (типа криптошлюза), которая смотрит в
> свою сеть 10.182.233.0 / 24 . Эта приблуда имеет на одном
> из интерфейсов адрес 10.180.230.253 и связывается с Cisco по interface GigabitEthernet0/2
> Хостам необходимо попадать в сеть 10.182.233.0 / 24  через эту приблуду
> т.е. если клиенту нужен выход в инет, он идёт через 87.123.12.xxx, как
> только ему нужно попасть в 10.182.233.0 он должен идти через interface
> GigabitEthernet0/2. Как это сделать?

Добавьте маршрут в 10.182.233.0 / 24 через 10.180.230.253.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Настройка NAT"  +/
Сообщение от Tilon (ok) on 21-Янв-16, 17:54 
>[оверквотинг удален]
>> Сеть 10.50.6.1 входит в ACL Test. Выход в инет осуществляется с помощью
>> интерфейса interface GigabitEthernet0/0
>> В чём собственно вопрос: Есть некая приблуда (типа криптошлюза), которая смотрит в
>> свою сеть 10.182.233.0 / 24 . Эта приблуда имеет на одном
>> из интерфейсов адрес 10.180.230.253 и связывается с Cisco по interface GigabitEthernet0/2
>> Хостам необходимо попадать в сеть 10.182.233.0 / 24  через эту приблуду
>> т.е. если клиенту нужен выход в инет, он идёт через 87.123.12.xxx, как
>> только ему нужно попасть в 10.182.233.0 он должен идти через interface
>> GigabitEthernet0/2. Как это сделать?
> Добавьте маршрут в 10.182.233.0 / 24 через 10.180.230.253.

Я добавил
ip route 10.182.233.0 255.255.255.0 10.180.230.253
Но конекта всё равно нет(

Когда заменяю нат на
ip nat inside source list test interface GigabitEthernet0/2 overload

связь появляется. Но в таком случае интернета нет(
Нельзя же добавить два разных ната на один лист.?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Настройка NAT"  +/
Сообщение от crash (ok) on 22-Янв-16, 07:35 
> связь появляется. Но в таком случае интернета нет(
> Нельзя же добавить два разных ната на один лист.?

можете использовать два разных листа, если вам очень надо через NAT сделать.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Настройка NAT"  +/
Сообщение от Tilon (ok) on 22-Янв-16, 08:59 
>> связь появляется. Но в таком случае интернета нет(
>> Нельзя же добавить два разных ната на один лист.?
> можете использовать два разных листа, если вам очень надо через NAT сделать.

Получается что только через NAT. Так уж настроена приблуда и перенастроить я её не могу.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

3. "Настройка NAT"  +/
Сообщение от crash (ok) on 22-Янв-16, 07:33 
> т.е. если клиенту нужен выход в инет, он идёт через 87.123.12.xxx, как
> только ему нужно попасть в 10.182.233.0 он должен идти через interface
> GigabitEthernet0/2. Как это сделать?

настроить маршрутизацию? Сказать на cisсо, что в сеть 10.182.233.0/24 можно попасть через 10.180.230.253. На приблуде тоже настроить, что для попадания в сеть 10.50.6.0/24 надо идти на 10.180.230.254. Ну и настроить в самой сети 10.182.233.0/24 маршрутизацию, если это необходимо

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Настройка NAT"  +/
Сообщение от Tilon (ok) on 22-Янв-16, 09:12 
>> т.е. если клиенту нужен выход в инет, он идёт через 87.123.12.xxx, как
>> только ему нужно попасть в 10.182.233.0 он должен идти через interface
>> GigabitEthernet0/2. Как это сделать?
> настроить маршрутизацию? Сказать на cisсо, что в сеть 10.182.233.0/24 можно попасть через
> 10.180.230.253. На приблуде тоже настроить, что для попадания в сеть 10.50.6.0/24
> надо идти на 10.180.230.254. Ну и настроить в самой сети 10.182.233.0/24
> маршрутизацию, если это необходимо

Вот что получилось. Прописав данный маршрут на Cisco - пинг с маршрутизатора пошёл до 10.182.233.0 удалённой сети. (забыл кстати написать что сеть удалённая. т.е. эта приблуда играет роль типа криптошлюза VPN)..
Но от клиентов пинга до удаленно сети нет 10.182.233.0

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "Настройка NAT"  +/
Сообщение от ShyLion (ok) on 22-Янв-16, 12:05 
> ip nat inside source list test interface GigabitEthernet0/0 overload

убрать

добавить:


ip access-list extended nat
permit ip 10.50.6.0 0.0.0.255 10.180.230.0 0.0.0.255
permit ip 10.50.6.0 0.0.0.255 10.182.233.0 0.0.0.255
deny ip any 10.0.0.0 0.255.255.255
deny ip any 172.16.0.0 0.15.255.255
deny ip any 192.168.0.0 0.0.255.255
permit ip 10.50.6.0 0.0.0.255 any
!
route-map RM_NAT_Gi00
match interface Gi0/0
match ip address name nat
!
route-map RM_NAT_Gi02
match interface Gi0/2
match ip address name nat
!
!
ip nat inside source route-map RM_NAT_Gi00 interface Gi0/0 overload
ip nat inside source route-map RM_NAT_Gi02 interface Gi0/2 overload
!
ip route 10.182.233.0 255.255.255.0 10.180.230.253
!

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Настройка NAT"  +/
Сообщение от ShyLion (ok) on 22-Янв-16, 12:07 
естественно, что все обращения в сети 10.180.230.0 и 10.182.233.0 будут с одного адреса интерфейса Gi0/2

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Настройка NAT"  +/
Сообщение от Tilon (ok) on 22-Янв-16, 16:50 
>[оверквотинг удален]
>  match interface Gi0/2
>  match ip address name nat
> !
> !
> ip nat inside source route-map RM_NAT_Gi00 interface Gi0/0 overload
> ip nat inside source route-map RM_NAT_Gi02 interface Gi0/2 overload
> !
> ip route 10.182.233.0 255.255.255.0 10.180.230.253
> !
>

СПАСИБО!!!! Это именно то что нужно!! Всё заработало!

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру