The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Мультилинк поверх IP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Мультилинк поверх IP"  
Сообщение от hanabana (ok) on 04-Май-09, 00:02 
Здравствуйте!

Мне необходимо объединить несколько медленных Ethernet каналов в один туннель (это - ADSL модемы, только провайдер не даёт управление над ними)
Схема примерно такая

                              fe0/1.1 --Канал 500кбит/с -- ge0/1.1
                              fe0/1.2 --Канал 500кбит/с -- ge0/1.2
Офис --[c3725]                                                            [c7201] ge0/0 -- Офис
                              fe0/1.3 --Канал 500кбит/с -- ge0/1.3
                              fe0/1.4 --Канал 500кбит/с -- ge0/1.4

На каждом канале - своя подсеть.
Это вообще можно сделать?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Мультилинк поверх IP"  
Сообщение от chocholl (??) on 04-Май-09, 08:32 
в один это вряд ли, а вот использование eigrp на всех тунелях, поможет загрузить их более-менее равномерно.

>[оверквотинг удален]
>          
>       fe0/1.3 --Канал 500кбит/с --
>ge0/1.3
>            
>          
>       fe0/1.4 --Канал 500кбит/с --
>ge0/1.4
>
>На каждом канале - своя подсеть.
>Это вообще можно сделать?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Мультилинк поверх IP"  
Сообщение от den (??) on 05-Май-09, 11:33 
до другой точки чистый L2 (провайдер дает чистый ethernet) ?
если да, то можно построить pppoe multilink, но я делал в свое время freebsd mpd в качестве клиента и 7204 в качестве pppoe server. Фишка всех манипуляций, чтобы mpd делал запросы на построение логического канала через отдельный adsl модем, тогда задействуется вся пропускная способность. ppp multilink делает баланс per packet ну и надежность приемлемая, если к примеру один модем отвалился. Но еще раз повторяю это возможно, если у вас L2 транспорт.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Мультилинк поверх IP"  
Сообщение от hanabana (ok) on 05-Май-09, 17:18 
Оказалось всё не просто, а очень просто.
Создал GRE тунели по числу IP каналов, включил per-packet load-balancing и CEF сделал всё, что требовалось.

ip cef

interface Tunnel0
ip address 192.168.88.34 255.255.255.252
ip load-sharing per-packet
tunnel source ...
tunnel destination ...
interface Tunnel1
ip address 192.168.88.38 255.255.255.252
ip load-sharing per-packet
tunnel source ...
tunnel destination ...

ip route 192.168.1.0 255.255.255.0 192.168.88.33
ip route 192.168.1.0 255.255.255.0 192.168.88.37

На второй - симметрично.

ip cef
interface Tunnel0
ip address 192.168.88.33 255.255.255.252
ip load-sharing per-packet
tunnel source ...
tunnel destination ...
interface Tunnel1
ip address 192.168.88.37 255.255.255.252
ip load-sharing per-packet
tunnel source ...
tunnel destination ...

ip route 192.168.1.0 255.255.255.0 192.168.88.34
ip route 192.168.1.0 255.255.255.0 192.168.88.38

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Мультилинк поверх IP"  
Сообщение от hanabana (ok) on 05-Май-09, 18:12 
>ip route 192.168.1.0 255.255.255.0 192.168.88.34
>ip route 192.168.1.0 255.255.255.0 192.168.88.38

Когда копировал из второй ошибся, здесь
ip route 192.168.2.0 255.255.255.0 192.168.88.34
ip route 192.168.2.0 255.255.255.0 192.168.88.38

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру