The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Маршрутизация между Vlan + шлюз интернет"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
Курсы по Juniper Junos в Москве и Петербурге
"Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от Ramsei email(ok) on 07-Окт-12, 22:38 
Приветствую.

Из оборудования есть маршрутизатор watchguard, cisco 3560, cisco 2960

Устройство watchguard раздает интернет, cisco 3560 используется как маршрутизатор между Vlan, а cisco 2960 как устройство доступа.
Схема примерно такая:
http://clip2net.com/page/m162549/35082244
Маршрутизация между Vlan работает т.е. компьютеры из Vlan 101 102 103 видят друг друга и устройства. Получается что шлюзом по умолчанию для всех устройств всех VLAN являются локальные адреса cisco 3560.
Как настроить cisco 3560 чтобы она пересылала все пакеты на адрес интернет шлюза watchguard в соответствующем VLAN. И при этом занималась маршрутизацией между VLAN ?
Т.е. чтобы у пользователей vlan 101,102,103 был интернет

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от crash (ok) on 08-Окт-12, 06:52 
> Как настроить cisco 3560 чтобы она пересылала все пакеты на адрес интернет
> шлюза watchguard в соответствующем VLAN.

может быть ip route 0.0.0.0 0.0.0.0 ip-watchguard ?

Ну а между watchguard и 3560 настроить L3.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от Ramsei email(ok) on 08-Окт-12, 09:48 
>> Как настроить cisco 3560 чтобы она пересылала все пакеты на адрес интернет
>> шлюза watchguard в соответствующем VLAN.
> может быть ip route 0.0.0.0 0.0.0.0 ip-watchguard ?
> Ну а между watchguard и 3560 настроить L3.

Пробовал, но к сожалению не работает, что-то не так потому как такая схема ни на реальном железе ни в PT не работает. Как можно еще решить эту проблему, у кого какие идеи ?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от McS555 (ok) on 08-Окт-12, 10:26 
>>> Как настроить cisco 3560 чтобы она пересылала все пакеты на адрес интернет
>>> шлюза watchguard в соответствующем VLAN.
>> может быть ip route 0.0.0.0 0.0.0.0 ip-watchguard ?
>> Ну а между watchguard и 3560 настроить L3.
> Пробовал, но к сожалению не работает, что-то не так потому как такая
> схема ни на реальном железе ни в PT не работает. Как
> можно еще решить эту проблему, у кого какие идеи ?

Так, я где сами интерфейсы настроены? На 3560?  Vlan 101 102 103.

Можешь показать sho run 3560?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от McS555 (ok) on 08-Окт-12, 10:26 
Ну и как бы L3 -есть команда ip routing?
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от Ramsei email(ok) on 28-Окт-12, 17:22 
>>>> Как настроить cisco 3560 чтобы она пересылала все пакеты на адрес интернет
>>>> шлюза watchguard в соответствующем VLAN.
>>> может быть ip route 0.0.0.0 0.0.0.0 ip-watchguard ?
>>> Ну а между watchguard и 3560 настроить L3.
>> Пробовал, но к сожалению не работает, что-то не так потому как такая
>> схема ни на реальном железе ни в PT не работает. Как
>> можно еще решить эту проблему, у кого какие идеи ?
> Так, я где сами интерфейсы настроены? На 3560?  Vlan 101 102
> 103.
> Можешь показать sho run 3560?

Собственно конфиг, к Ge0/1 и 0/2 подключены 2960 на них также транк настроен, к 2960 подключены компы порты к которым подключены настроены как access и прописаны vlan.

К Ge0/3 подключен wathguard c ip 10.0.0.1

Пересылка пакетов на адрес интернет шлюза 10.0.0.1 не идет, куда копать ?

! Last configuration change at 05:05:55 UTC Mon Mar 1 1993 by admin
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 3560-2floor-dsw1
!
boot-start-marker
boot-end-marker
!
enable secret 4
!
username admin privilege 15 secret 4
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
system mtu routing 1500
ip routing
ip domain-name test.local
!
ip dhcp pool vlan2
network 10.50.1.0 255.255.255.0
default-router 10.50.1.1
domain-name test.local
dns-server 8.8.8.8
!
ip dhcp pool vlan101
network 10.50.3.0 255.255.255.0
default-router 10.50.4.1
domain-name test.local
dns-server 8.8.8.8
!
ip dhcp pool vlan102
network 10.50.4.0 255.255.255.0
default-router 10.50.4.1
domain-name test.local
dns-server 8.8.8.8
!
ip dhcp pool vlan103
network 10.50.5.0 255.255.255.0
default-router 10.50.5.1
domain-name test.local
dns-server 8.8.8.8
!
crypto pki trustpoint TP-self-signed-2425915776
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2425915776
revocation-check none
rsakeypair TP-self-signed-2425915776
!
!
crypto pki certificate chain TP-self-signed-2425915776
certificate self-signed 01
        quit
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh authentication-retries 0
ip ssh version 2
!
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/3
no switchport
ip address 10.0.0.2 255.255.255.0
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
!
interface Vlan2
ip address 10.50.1.1 255.255.255.0
!
interface Vlan3
ip address 10.50.0.1 255.255.255.0
!
interface Vlan101
ip address 10.50.3.1 255.255.255.0
!
interface Vlan102
ip address 10.50.4.1 255.255.255.0
!
interface Vlan103
ip address 10.50.5.1 255.255.255.0
!
interface Vlan104
ip address 10.50.6.1 255.255.255.0
!
interface Vlan105
ip address 10.50.7.1 255.255.255.0
!
interface Vlan106
ip address 10.50.8.1 255.255.255.0
!
interface Vlan107
ip address 10.50.9.1 255.255.255.0
!
ip default-gateway 10.50.0.1
!
!
access-list 23 permit 10.50.0.0 0.0.15.255
!
!
!
!
line con 0
line vty 0 4
access-class 23 in
exec-timeout 60 0
privilege level 15
logging synchronous
transport input ssh
line vty 5 15
transport input ssh

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

9. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от fantom (ok) on 28-Окт-12, 17:29 
>[оверквотинг удален]
>>> схема ни на реальном железе ни в PT не работает. Как
>>> можно еще решить эту проблему, у кого какие идеи ?
>> Так, я где сами интерфейсы настроены? На 3560?  Vlan 101 102
>> 103.
>> Можешь показать sho run 3560?
> Собственно конфиг, к Ge0/1 и 0/2 подключены 2960 на них также транк
> настроен, к 2960 подключены компы порты к которым подключены настроены как
> access и прописаны vlan.
> К Ge0/3 подключен wathguard c ip 10.0.0.1
> Пересылка пакетов на адрес интернет шлюза 10.0.0.1 не идет, куда копать ?

и что говорит ping 10.0.0.1 на

>[оверквотинг удален]
> !
> line con 0
> line vty 0 4
>  access-class 23 in
>  exec-timeout 60 0
>  privilege level 15
>  logging synchronous
>  transport input ssh
> line vty 5 15
>  transport input ssh

И что говорит ping 10.0.0.1 на 3560-ом??

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от Ramsei email(ok) on 28-Окт-12, 17:42 
>[оверквотинг удален]
>> line con 0
>> line vty 0 4
>>  access-class 23 in
>>  exec-timeout 60 0
>>  privilege level 15
>>  logging synchronous
>>  transport input ssh
>> line vty 5 15
>>  transport input ssh
> И что говорит ping 10.0.0.1 на 3560-ом??

Success rate is 0 percent (0/5)
говорит
какого х**на непонятно, если комп подключать и настроить ip он работает, т.е. вариант с неисправным портом отпадает.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от fantom (ok) on 28-Окт-12, 19:24 
>[оверквотинг удален]
>>>  privilege level 15
>>>  logging synchronous
>>>  transport input ssh
>>> line vty 5 15
>>>  transport input ssh
>> И что говорит ping 10.0.0.1 на 3560-ом??
> Success rate is 0 percent (0/5)
> говорит
> какого х**на непонятно, если комп подключать и настроить ip он работает, т.е.
> вариант с неисправным портом отпадает.

А ICMP на этом вашем девайсе не отфильтрованы случаем?
Или маска /8 например...

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от Ramsei email(ok) on 28-Окт-12, 20:21 
>[оверквотинг удален]
>>>>  transport input ssh
>>>> line vty 5 15
>>>>  transport input ssh
>>> И что говорит ping 10.0.0.1 на 3560-ом??
>> Success rate is 0 percent (0/5)
>> говорит
>> какого х**на непонятно, если комп подключать и настроить ip он работает, т.е.
>> вариант с неисправным портом отпадает.
> А ICMP на этом вашем девайсе не отфильтрованы случаем?
> Или маска /8 например...

Нет, icmp разрешены
Маска везде /24

2й день сижу понять не могу, что этой железке надо

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

5. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от crash (ok) on 08-Окт-12, 11:51 
>>> Как настроить cisco 3560 чтобы она пересылала все пакеты на адрес интернет
>>> шлюза watchguard в соответствующем VLAN.
>> может быть ip route 0.0.0.0 0.0.0.0 ip-watchguard ?
>> Ну а между watchguard и 3560 настроить L3.
> Пробовал, но к сожалению не работает, что-то не так потому как такая
> схема ни на реальном железе ни в PT не работает. Как
> можно еще решить эту проблему, у кого какие идеи ?

это реально работает. Поэтому конфиг в студию.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от Moomintroll (ok) on 08-Окт-12, 17:54 
> Пробовал, но к сожалению не работает, что-то не так потому как такая
> схема ни на реальном железе ни в PT не работает. Как
> можно еще решить эту проблему, у кого какие идеи ?

А на watchguard есть маршруты к VLAN'ам через 3560?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

7. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от Ilya (??) on 16-Окт-12, 05:28 
на watchguard настроить прописать маршруты на 3560-ую в сторону вланов абонентов, соотвестветнно на 3560 прописать дефолт в сторону watchguard. Между watchguard и 3560 настроить транспортный влан с х.х.х.х/29. Все должно работать. И не забудьте 3560 перевести в режим маршрутизации если ios позволяет командой в глобальном режиме ip routing.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

13. "Маршрутизация между Vlan + шлюз интернет"  +/
Сообщение от nezabudka email on 26-Фев-16, 11:45 
> на watchguard настроить прописать маршруты на 3560-ую в сторону вланов абонентов, соотвестветнно
> на 3560 прописать дефолт в сторону watchguard. Между watchguard и 3560
> настроить транспортный влан с х.х.х.х/29. Все должно работать. И не забудьте
> 3560 перевести в режим маршрутизации если ios позволяет командой в глобальном
> режиме ip routing.

ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip nat inside source list 23 int GigabitEthernet0/3 overload

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру