The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Swich, QOS-LLQ, need help!"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Swich, QOS-LLQ, need help!"  +/
Сообщение от Борис Иванович email on 09-Фев-09, 09:42 
Добрый день,
Пытаюсь поднять QOS для VoIP трафика на свичах Cisco ME 3400... RTP трафик идет маркированным DSCP EF, а сигнализация AF31 (снимал трэйсы ваершарком). На свичах настроил класс мапы и полиси мапы...
class-map match-any DATA-REALTIME
match ip dscp ef
match ip dscp cs5
match cos  5
match cos  4
class-map match-any DATA-CRITICAL
match ip dscp cs6
match ip dscp af31
match ip dscp cs3
match cos  6
match cos  3
class-map match-any DATA-PREFERRED
match ip dscp af21
match ip dscp cs2
match cos  2

policy-map QOS-model
class DATA-REALTIME
    priority
class DATA-CRITICAL
    bandwidth remaining percent 50
class DATA-PREFERRED
    bandwidth remaining percent 35

присвоил сервис полиси на интерфейс
interface FastEthernet0/24
port-type nni
switchport trunk allowed vlan 105-107
switchport mode trunk
service-policy output QOS-model

но при этом при просмотре полисинга на интерфейсе, счетчики на классмапах остаются нулевыми и только счетчик дефолтового трафика изменяется...
sh policy-map interface fa0/24
FastEthernet0/24

  Service-policy output: QOS-model

    Class-map: DATA-REALTIME (match-any)
      0 packets
      Match: ip dscp ef (46)
      Match: ip dscp cs5 (40)
      Match: cos  5
      Match: cos  4
        Priority
      Output Queue:
        Max queue-limit default threshold: 48
        Tail Packets Drop: 0

    Class-map: DATA-CRITICAL (match-any)
      5013 packets
      Match: ip dscp cs6 (48)
      Match: ip dscp af31 (26)
      Match: ip dscp cs3 (24)
      Match: cos  6
      Match: cos  3
      Output Queue:
        Max queue-limit default threshold: 48
        Tail Packets Drop: 0

    Class-map: DATA-PREFERRED (match-any)
      0 packets
      Match: ip dscp af21 (18)
      Match: ip dscp cs2 (16)
      Match: cos  2
      Output Queue:
        Max queue-limit default threshold: 48
        Tail Packets Drop: 0

    Class-map: class-default (match-any)
      2886007 packets
      Match: any
        Output Queue:
          Max queue-limit default threshold: 48
          Tail Packets Drop: 268

хотя, я точно знаю, что через этот порт проходит RTP трафик, т.е. счетчики пакетов для реалтайм класса должны обрабатываться и изменяться...
Нужен свежий взгляд и совет специалистов. Может я что то пропустил...

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Swich, QOS-LLQ, need help!"  +/
Сообщение от trianon (??) on 09-Фев-09, 11:15 
>Добрый день,
>Пытаюсь поднять QOS для VoIP трафика на свичах Cisco ME 3400... RTP
>трафик идет маркированным DSCP EF, а сигнализация AF31 (снимал трэйсы ваершарком).
>На свичах настроил класс мапы и полиси мапы...
>class-map match-any DATA-REALTIME
> match ip dscp ef
> match ip dscp cs5
> match cos  5
> match cos  4

А можно на L2-интерфейсе матчить DSCP-метки? Может в этом проблема?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Swich, QOS-LLQ, need help!"  +/
Сообщение от Борис Иванович email on 09-Фев-09, 11:22 
>[оверквотинг удален]
>>Пытаюсь поднять QOS для VoIP трафика на свичах Cisco ME 3400... RTP
>>трафик идет маркированным DSCP EF, а сигнализация AF31 (снимал трэйсы ваершарком).
>>На свичах настроил класс мапы и полиси мапы...
>>class-map match-any DATA-REALTIME
>> match ip dscp ef
>> match ip dscp cs5
>> match cos  5
>> match cos  4
>
>А можно на L2-интерфейсе матчить DSCP-метки? Может в этом проблема?

Вот этого я и не знаю... поэтому и спрашиваю совета специалистов... Хотя, если на L2 интерфейс нельзя было бы вешать полиси где матчатся L3 overhead, то железка просто не дала бы вешать этот полиси. А может я и не прав.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Swich, QOS-LLQ, need help!"  +/
Сообщение от trianon (??) on 09-Фев-09, 11:31 
>[оверквотинг удален]
>>> match ip dscp cs5
>>> match cos  5
>>> match cos  4
>>
>>А можно на L2-интерфейсе матчить DSCP-метки? Может в этом проблема?
>
>Вот этого я и не знаю... поэтому и спрашиваю совета специалистов... Хотя,
>если на L2 интерфейс нельзя было бы вешать полиси где матчатся
>L3 overhead, то железка просто не дала бы вешать этот полиси.
>А может я и не прав.

Я сам только на L3 настраивал, вы же вешаете на L2 транк, на нем, в принципе, лучше бы с 802.1p метками работать. Можно попробовать на входе, куда приходят пакеты с DSCP-метками, стелать match ip dscp и set cos.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Swich, QOS-LLQ, need help!"  +/
Сообщение от Botan (ok) on 09-Фев-09, 11:40 
так насторойте L2 qos, посмотрите сколько на вашем свиче очередей и вперед, голосовой траффик в PQ а все остальное уж как сами распишите

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Swich, QOS-LLQ, need help!"  +/
Сообщение от Борис Иванович email on 09-Фев-09, 13:12 
>так насторойте L2 qos, посмотрите сколько на вашем свиче очередей и вперед,
>голосовой траффик в PQ а все остальное уж как сами распишите
>

Сделал полиси которое делает ремарк кода DSCP на COS... Счетчики на полиси заработали и все вроде как гуд, но я не могу понять, почему не работает с DSCP? ведь все равно происходит просмотр L3 заголовка на L2 интерфейсе и ремарк DSCP на COS...

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Swich, QOS-LLQ, need help!"  +/
Сообщение от trianon (??) on 09-Фев-09, 13:35 
>>так насторойте L2 qos, посмотрите сколько на вашем свиче очередей и вперед,
>>голосовой траффик в PQ а все остальное уж как сами распишите
>>
>
>Сделал полиси которое делает ремарк кода DSCP на COS... Счетчики на полиси
>заработали и все вроде как гуд, но я не могу понять,
>почему не работает с DSCP? ведь все равно происходит просмотр L3
>заголовка на L2 интерфейсе и ремарк DSCP на COS...

Попробуйте сделать на входящем интерфейсе mls qos trust ip-dscp (как-то так, не помню точно)

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Swich, QOS-LLQ, need help!"  +/
Сообщение от Борис Иванович email on 09-Фев-09, 13:56 
>
>Попробуйте сделать на входящем интерфейсе mls qos trust ip-dscp (как-то так, не
>помню точно)

К сожалению, на Cisco ME 3400 такого сделать не получится.. нет такой команды... а на 3750 такая команда есть.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Swich, QOS-LLQ, need help!"  +/
Сообщение от limmaa (ok) on 14-Май-15, 04:25 
>>так насторойте L2 qos, посмотрите сколько на вашем свиче очередей и вперед,
>>голосовой траффик в PQ а все остальное уж как сами распишите
>>
> Сделал полиси которое делает ремарк кода DSCP на COS... Счетчики на полиси
> заработали и все вроде как гуд, но я не могу понять,
> почему не работает с DSCP? ведь все равно происходит просмотр L3
> заголовка на L2 интерфейсе и ремарк DSCP на COS...

Столкнулся с такой же проблемой. Не могли бы вы подсказать, что именно прописали для работы счетчиков полиси ?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру