The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"BGP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"BGP"  
Сообщение от sda email(ok) on 13-Янв-09, 14:27 
Добрый день, уважаемые гуру. Имеется проблема. Пир нам анонсит свои подсети, но почему то исходящий трафик направляется через апстрима.

router bgp 31138
neighbor 83.217.0.80 remote-as 41411
neighbor 83.217.0.80 description ### STS TTK ###
neighbor 83.217.0.80 default-originate
neighbor 83.217.0.80 version 4
neighbor 83.217.0.80 soft-reconfiguration inbound
neighbor 83.217.0.80 prefix-list NO-DEF in
neighbor 217.150.48.10 remote-as 20485
neighbor 217.150.48.10 description ### TransTK ###
neighbor 217.150.48.10 update-source Loopback0
neighbor 217.150.48.10 version 4
neighbor 217.150.48.10 soft-reconfiguration inbound
neighbor 217.150.48.10 prefix-list bogons in
neighbor 217.150.48.10 prefix-list PRJ-TTK out
neighbor 217.150.48.10 filter-list 5 out
!
ip prefix-list NO-DEF seq 5 deny 0.0.0.0/0
ip prefix-list NO-DEF seq 10 deny 83.217.0.0/20 le 32   #наши сети
ip prefix-list NO-DEF seq 15 permit 0.0.0.0/0 ge 1
!
ip prefix-list PRJ-TTK seq 10 permit 83.217.0.0/20
ip prefix-list PRJ-TTK seq 20 permit 83.217.24.0/21
ip prefix-list PRJ-TTK seq 200 deny 0.0.0.0/0 ge 1
!
ip as-path access-list 5 permit ^$
ip as-path access-list 5 permit ^43501$
!

gw-prj#sh ip bgp neighbors 83.217.0.80 rou
BGP table version is 10457330, local router ID is 217.150.40.39
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 62.33.42.0/24    83.217.0.80              0             0 41411 ?
*> 89.250.160.0/20  83.217.0.80              0             0 41411 ?

gw-prj#sh ip bgp neighbors 217.150.48.10  rou | i 89.250.160.0
*  89.250.160.0/24  217.150.48.10         1000      0      0 20485 41411 ?
*  89.250.160.0/20  217.150.48.10         1000      0      0 20485 41411 ?
*  189.250.160.0/19 217.150.48.10         1000      0      0 20485 3491 701 8151 i


Думаю, что это из-за значения metric. Как его изменить? Или подскажите как в данном случае правильнее разрулить ситуацию?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

  • BGP, Capuchino, 15:51 , 13-Янв-09, (1)  
    • BGP, Capuchino, 15:55 , 13-Янв-09, (2)  
      • BGP, sda, 16:01 , 13-Янв-09, (3)  
        • BGP, green79, 16:41 , 13-Янв-09, (4)  
          • BGP, sda, 16:54 , 13-Янв-09, (5)  

Сообщения по теме [Сортировка по времени | RSS]


1. "BGP"  
Сообщение от Capuchino on 13-Янв-09, 15:51 
Добрый день!
команда #s ip bgp 89.250.160.0/24 ,в принципе покажет более понятно почему маршрут лучший, я так понял из-за local preference, по умолчанию он равен 100, у тебя 1000.
Значит уже что-то настроено в вашей AS, вполне возможно route-map.
Вот эти строки лишние.

ip prefix-list NO-DEF seq 10 deny 83.217.0.0/20 le 32, потому что bgp так работает, что
не будет принимать свои подсети так как в as-path присутствует своя же AS.

ip prefix-list PRJ-TTK seq 200 deny 0.0.0.0/0 ge 1, по умолчанию и так всё запрещает как
в access-list.

простой способ разрулить - это создать route-map, указав weight или local pref более высокий, и повесить его на входе с с as20485.
Пример можно наверное на cisco.com найти, если не найдёте, то пишите, создадим.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "BGP"  
Сообщение от Capuchino on 13-Янв-09, 15:55 
конечно на входе с as41411, вы же хотите чтобы трафик шёл через них.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "BGP"  
Сообщение от sda email(ok) on 13-Янв-09, 16:01 
>конечно на входе с as41411, вы же хотите чтобы трафик шёл через
>них.

Спасибо за ответ. Меня интересует еще почему, сделав
interface FastEthernet0/0
ip policy route-map FE00
!
ip access-list extended STS
permit ip any 62.33.42.0 0.0.0.255
permit ip any 89.250.160.0 0.0.15.255
!
route-map FE00 permit 30
match ip address STS
set ip default next-hop 83.217.0.80
!
route-map FE00 permit 100

Все равно уходит через апстрим. СТранно это все

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "BGP"  
Сообщение от green79 (ok) on 13-Янв-09, 16:41 
>[оверквотинг удален]
> permit ip any 62.33.42.0 0.0.0.255
> permit ip any 89.250.160.0 0.0.15.255
>!
>route-map FE00 permit 30
> match ip address STS
> set ip default next-hop 83.217.0.80
>!
>route-map FE00 permit 100
>
>Все равно уходит через апстрим. СТранно это все

set ip next-hop 83.217.0.80
Вам поможет

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "BGP"  
Сообщение от sda email(ok) on 13-Янв-09, 16:54 
>[оверквотинг удален]
>>route-map FE00 permit 30
>> match ip address STS
>> set ip default next-hop 83.217.0.80
>>!
>>route-map FE00 permit 100
>>
>>Все равно уходит через апстрим. СТранно это все
>
>set ip next-hop 83.217.0.80
>Вам поможет

Спасибо, помогло :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру