The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Два провайдера в интернет"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Два провайдера в интернет"  
Сообщение от CarTer (ok) on 09-Янв-09, 15:26 
Помогите настроить циску (7206) на одновременное использование двух каналов от разных провайдеров.

Имеется два провайдера.
К ISP1 подключены как оператор связи.
К ISP2 подключены как абонент.


Клиентов из группы №1 с использованием канала от ISP2 подключаем посредством PPPoE с использованием NAT, т.к. выдаются «серые» адреса. Все работает нормально.

Требуется клиентов из группы №2 подключить к сети Интернет посредством PPPoE без использования NAT с использованием канала от ISP1, т.к. будут выдаваться белые адреса.

Настройки выданные провайдером ISP1:
Point-to-point
86.66.174.252/32
86.66.174.253 GW пров
86.66.174.254 GW наш
Сеть
86.66.179.0/24


version 12.4
!
aaa new-model
!
aaa authentication ppp default group radius
aaa authorization network default group radius
aaa accounting delay-start
aaa accounting update periodic 2
aaa accounting network default start-stop group radius
!
aaa session-id common

ip subnet-zero
ip cef
!
!
bba-group pppoe global
virtual-template 1
sessions max limit 8000
sessions per-mac limit 1
sessions per-vlan limit 500
sessions auto cleanup
!
!
interface FastEthernet0/2
no ip address
duplex half
speed auto

!
# ISP2
interface FastEthernet0/2.1
description antenna
encapsulation dot1Q 3
ip address 80.50.20.218 255.255.255.248
!
#ISP1
interface FastEthernet0/2.2
description info_center
encapsulation dot1Q 2
ip address 86.66.174.254 255.255.255.252
!
interface GigabitEthernet0/2
description billing_&_pppoe
ip address 192.168.2.1 255.255.255.0
  duplex auto
speed auto
media-type rj45
negotiation auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/3
  duplex auto
speed auto
media-type rj45
negotiation auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/3.5
  encapsulation dot1Q 5
ip address 10.115.200.229 255.255.255.0
  pppoe enable group global
no cdp enable
!
interface Virtual-Template1
ip unnumbered GigabitEthernet0/2
ip access-group 105 in
ip access-group 106 out
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
autodetect encapsulation ppp
no peer default ip address
ppp max-bad-auth 3
ppp encrypt mppe 128 passive
ppp authentication chap
ppp authorization radius
ppp accounting radius
!
ip classless
ip route 0.0.0.0 0.0.0.0 80.50.20.217
!
no ip http server
no ip http secure-server
!
ip flow-export version 5
ip flow-export destination 192.168.2.2 9996
!
ip nat inside source list NAT_LAN_Staff interface FastEthernet0/2.1 overload
!
ip access-list extended NAT_LAN_Staff
permit ip 10.200.0.0 0.0.0.255 any
deny   ip any any
!
ip radius source-interface GigabitEthernet0/2
logging alarm informational
access-list 105 dynamic test1 permit ip any any
access-list 106 dynamic test2 permit ip any any
no cdp run
!
!
!
radius-server attribute nas-port format e UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU
radius-server configure-nas
radius-server host 192.168.2.2 auth-port 1812 acct-port 1813
radius-server timeout 10
radius-server vsa send accounting
radius-server vsa send authentication
!
control-plane
!
gatekeeper
shutdown
!
end

Заранее спасибо



Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Два провайдера в интернет"  
Сообщение от Vaso Petrovich on 10-Янв-09, 10:02 
а может вам еще и ключ от квартиры где деньги лежат? (с)
тема миллион раз обсуждалась, есть готовые примеры, вы крайне удивитесь, но поиск работает... так что... хватит ленится...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Два провайдера в интернет"  
Сообщение от CarTer (??) on 10-Янв-09, 11:03 
>а может вам еще и ключ от квартиры где деньги лежат? (с)
>
>тема миллион раз обсуждалась, есть готовые примеры, вы крайне удивитесь, но поиск
>работает... так что... хватит ленится...

ДА по иском пользовался. Предлагают решить с помощью PBR

На интерфейсе interface Virtual-Template1
ip policy route-map ISP

Создаю список доступа
access-list 1 permit 86.66.170.0 0.0.0.255

route-map ISP permit 10
match ip address 1
set ip next-hop 86.66.174.253 (шлю провайдера)

И вот это правило не отрабатывает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Два провайдера в интернет"  
Сообщение от CarTer (ok) on 10-Янв-09, 11:14 
Вот таблица роута

Gateway of last resort is 80.50.20.217 to network 0.0.0.0

     80.0.0.0/29 is subnetted, 1 subnets
C       84.50.20.218 is directly connected, FastEthernet0/2.1
S    192.168.9.0/24 [1/0] via 10.115.200.1
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C       10.115.200.0/24 is directly connected, GigabitEthernet0/3.5
C       10.200.0.2/32 is directly connected, Virtual-Access28
C       10.200.0.3/32 is directly connected, Virtual-Access10
C       10.200.0.1/32 is directly connected, Virtual-Access13
C       10.200.0.15/32 is directly connected, Virtual-Access37
C       10.200.0.12/32 is directly connected, Virtual-Access4
     86.0.0.0/30 is subnetted, 1 subnets
C       86.66.174.252 is directly connected, FastEthernet0/2.2
C    192.168.2.0/24 is directly connected, GigabitEthernet0/2
S*   0.0.0.0/0 [1/0] via 80.50.20.217


show ip route 86.66.179.13
Routing entry for 95.66.179.13/32
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Routing Descriptor Blocks:
  * directly connected, via Virtual-Access38
      Route metric is 0, traffic share count is 1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру