The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Генерирование NetFlow роутером из трафика со SPAN порта свича"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Учет трафика и статистика)
Изначальное сообщение [ Отслеживать ]

"Генерирование NetFlow роутером из трафика со SPAN порта свича"  +/
Сообщение от Slot on 18-Авг-15, 15:45 
Имеется схема сети
https://yadi.sk/i/WYAvPVqaiWpXH
Свич вполне себе корректно зеркалирует трафик с Provider port на SPAN port(проверено).
Хотелось бы настроить интерфейс Gi0/1 Cisco 2911ой так что бы генерировался NetFlow статистика и отправлялась на 10.0.105.100
Причем очень НЕ хочется что бы зеркалируемый трафик приходящий на Gi0/1 маршрутизировался куда либо, во избежание флуда.
Пробовал настраивать следующим образом

ip cef
!
interface Loopback2
no ip address
ip policy route-map ToNULL
!
interface GigabitEthernet0/0
ip address 10.0.105.3 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
ip flow ingress
ip flow egress
ip policy route-map ToLoop2 // Здесь пробовал сначала ставить ToNULL, но результат тот же.
duplex auto
speed auto
!
ip flow-export source GigabitEthernet0/0
ip flow-export version 5
ip flow-export destination 10.0.105.100 9996
!
access-list 44 permit any
access-list 55 permit any
!
route-map ToNULL permit 10
match ip address 55
set interface Null0
!
route-map ToLoop2 permit 10
match ip address 44
set interface Loopback2

Но в NetFlow статистике только широковещательный трафик :(
Что я делаю не так и возможно ли вообще генерировать NetFlow без прохождения трафика через роутер?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Генерирование NetFlow роутером из трафика со SPAN порта свича"  +/
Сообщение от VolanD (ok) on 18-Авг-15, 16:30 
>[оверквотинг удален]
> route-map ToNULL permit 10
>  match ip address 55
>  set interface Null0
> !
> route-map ToLoop2 permit 10
>  match ip address 44
>  set interface Loopback2
> Но в NetFlow статистике только широковещательный трафик :(
> Что я делаю не так и возможно ли вообще генерировать NetFlow без
> прохождения трафика через роутер?

А почему не отдавать SPAN а коллектор?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Генерирование NetFlow роутером из трафика со SPAN порта свича"  +/
Сообщение от Slot on 19-Авг-15, 07:49 
> А почему не отдавать SPAN а коллектор?

Пробовал. Там сам коллектор это виртуалка на Hyper-V и причем старой версии которая не умеет отдельной виртуалке выделять отдельную сетевую, а если делать виртсвич то гипервизор не умеет превращать его в хаб. :(

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

5. "Генерирование NetFlow роутером из трафика со SPAN порта свича"  +/
Сообщение от VolanD (ok) on 19-Авг-15, 08:21 
>> А почему не отдавать SPAN а коллектор?
> Пробовал. Там сам коллектор это виртуалка на Hyper-V и причем старой версии
> которая не умеет отдельной виртуалке выделять отдельную сетевую, а если делать
> виртсвич то гипервизор не умеет превращать его в хаб. :(

Если RSPAN и просто отдельный влан на тот же самый линк?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

2. "Генерирование NetFlow роутером из трафика со SPAN порта свича"  +/
Сообщение от Zhuravlev Ilya email on 18-Авг-15, 22:45 
мишшон импосибру.
С маршрутизацией не так всё плохо, можно попробовать создать отдельный врф с дефолтным маршрутом в null 0.
Но ip flow ingress работает с маршрутизацией, и спан не поможет - нужно чтобы destination-mac  у пакетов был макушник роутера.
egress тут кстати ни к чему.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Генерирование NetFlow роутером из трафика со SPAN порта свича"  +1 +/
Сообщение от Slot on 19-Авг-15, 07:53 
> мишшон импосибру.
> С маршрутизацией не так всё плохо, можно попробовать создать отдельный врф с
> дефолтным маршрутом в null 0.

Я пробовал в null как сразу с интерфейса, так и через Loopback2(см. выше)
> Но ip flow ingress работает с маршрутизацией,

отлично, передам руководству.
>и спан не поможет - нужно чтобы destination-mac  у пакетов был макушник роутера.

Тут вот не врубился конечно, но думаю уже не важно...
> egress тут кстати ни к чему.

да думал что исходящие на Loopback2 поймаются...


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Генерирование NetFlow роутером из трафика со SPAN порта свича"  +/
Сообщение от Zhuravlev Ilya on 19-Авг-15, 13:41 
>>и спан не поможет - нужно чтобы destination-mac  у пакетов был макушник роутера.
> Тут вот не врубился конечно, но думаю уже не важно...

По протоколу арп клиент получает мак-адрес айпишника роутера, который указан для дефолтной маршрутизации, и при отсылке пакетов выставляет в них destination-mac роутера. Если указан левый мак назначения, то роутер такой пакет не будет пытаться обрабатывать. Хотя и тут можно попробовать как отработает proxy arp.
Короче, желаемое тянет за собой сплошные извращения и костыли непонятной устойчивости.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "Генерирование NetFlow роутером из трафика со SPAN порта свича"  +/
Сообщение от Slot (ok) on 10-Сен-15, 08:14 
> Короче, желаемое тянет за собой сплошные извращения и костыли непонятной устойчивости.

Вот почти дословные мои обьяснения руководству, а они всё равно - задай вопрос на форумах... СПАСИБО! :)


Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру