The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Помогите разобраться"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Помогите разобраться"  +/
Сообщение от rapport_mur (ok) on 11-Авг-15, 09:15 
Была связка между двумя коммутаторами Cisco 2960 (назовем его A) и неуправляемым D-link через модемы xDSL. К 2960 подключен шлюз прямым линком.
Все работало.
Понадобился резервный канал. Заменили dlink на 2960 (назовем его B) с sfp модулем. Получилось между двумя 2960 1канал - dsl линия, 2канал - оптика.
Оптика gigabit поэтому она в работе, dsl в резерве. Обрываю оптику и получается совсем непонятная для меня картина:
1. PVST отрабатывает правильно;
2. MAC таблица обновляется и адрес сопоставляется с правильным интерфейсом.
3. С коммутатора A коммутатор B пингуется, и можно по телнету залезть, с коммутатора B коммутатор A тоже;
4. С шлюза пингуется A но не пингуется B. C коммутатора B шлюз не пингуется.
5. В дебаге icmp видно что при пинге со шлюза коммутатора B  он отвечает, но на шлюз эти ответы не приходят.

Настройки шлюза:

interface GigabitEthernet0/1.4
encapsulation dot1Q 4
ip address 10.50.138.129 255.255.255.128
ip flow ingress
ip flow egress
ip ospf 1 area 0
logging event subif-link-status
snmp trap link-status

Настройки коммутатора A:

spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 4 priority 4096
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/18
description to_B_via_DSLmodem
switchport access vlan 4
switchport mode access
speed 100
spanning-tree cost 19
!
interface GigabitEthernet0/25
description to_B_via_fiber
switchport access vlan 4
switchport mode access
!
interface Vlan4
description ASU
ip address 10.50.138.147 255.255.255.128
no ip route-cache

Конфиг коммутатора B:
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending

interface FastEthernet0/24
description to_A_via_DSL
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/1
description to_A_via_fiber
switchport access vlan 4
switchport mode access
media-type sfp
!
i
interface Vlan4
ip address 10.50.138.249 255.255.255.128
!
ip default-gateway 10.50.138.129


Подскажите куда копать.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Помогите разобраться"  +/
Сообщение от rusadmin (ok) on 11-Авг-15, 11:05 
show spann vla 4  с обоих коммутаторов
Так же настораживает стоимость порта в сторону DSL модема на коммутаторе А.
Она очень высока для резерва

И переходите уже хотябы на rpvst

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Помогите разобраться"  +/
Сообщение от rapport_mur (ok) on 12-Авг-15, 13:25 
Всмысле стоимость очень высока для резерва? Главное чтобы выше чем у основного была, разе не так?

Схема такая:
A (Gi0/18) - DSL - (Fa0/24) B
A (Gi0/25) - FIBER - (Gi0/1) B
A (Gi0/1) - Gateway

IP адреса:
A (10.50.138.147)
B (10.50.138.249)
Gateway (10.50.138.129)

При работающих двух каналах:

A#sh spanning-tree vl 4

VLAN0004
  Spanning tree enabled protocol ieee
  Root ID    Priority    4100
             Address     64d9.89df.a200
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4100   (priority 4096 sys-id-ext 4)
             Address     64d9.89df.a200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.1    P2p
Gi0/18              Desg FWD 19        128.18   P2p
Gi0/25              Desg FWD 4         128.25   P2p

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.50.138.147           -   64d9.89df.a243  ARPA   Vlan4
Internet  10.50.138.129           0   ccef.4880.0481  ARPA   Vlan4
Internet  10.50.138.249           6   1c17.d388.dc41  ARPA   Vlan4

A#sh mac address-table address ccef.4880.0481
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   2    ccef.4880.0481    DYNAMIC     Gi0/1
  10    ccef.4880.0481    DYNAMIC     Gi0/1
   4    ccef.4880.0481    DYNAMIC     Gi0/1
   3    ccef.4880.0481    DYNAMIC     Gi0/1
Total Mac Addresses for this criterion: 4


A#sh mac address-table address 1c17.d388.dc41
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   4    1c17.d388.dc41    DYNAMIC     Gi0/25

  

B#sh spanning-tree vlan 4

VLAN0004
  Spanning tree enabled protocol ieee
  Root ID    Priority    4100
             Address     64d9.89df.a200
             Cost        4
             Port        25 (GigabitEthernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32772  (priority 32768 sys-id-ext 4)
             Address     1c17.d388.dc00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/24              Altn BLK 19        128.24   P2p
Gi0/1               Root FWD 4         128.25   P2p

B#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.50.138.147           2   64d9.89df.a243  ARPA   Vlan4
Internet  10.50.138.129          67   ccef.4880.0481  ARPA   Vlan4
Internet  10.50.138.249           -   1c17.d388.dc41  ARPA   Vlan4

B#sh mac address-table address  ccef.4880.0481
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   4    ccef.4880.0481    DYNAMIC     Gi0/1
Total Mac Addresses for this criterion: 1

B#sh mac address-table address  64d9.89df.a243
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   4    64d9.89df.a243    DYNAMIC     Gi0/1
Total Mac Addresses for this criterion: 1


При обрыве оптики:

A#sh spanning-tree vl 4

VLAN0004
  Spanning tree enabled protocol ieee
  Root ID    Priority    4100
             Address     64d9.89df.a200
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4100   (priority 4096 sys-id-ext 4)
             Address     64d9.89df.a200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/18              Desg FWD 19        128.18   P2p


A#ping 10.50.138.129

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.50.138.129, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/6 ms

A#ping 10.50.138.249

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.50.138.249, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/10 ms

A#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.50.138.147           -   64d9.89df.a243  ARPA   Vlan4
Internet  10.50.138.129           6   ccef.4880.0481  ARPA   Vlan4
Internet  10.50.138.249          13   1c17.d388.dc41  ARPA   Vlan4


A#sh mac address-table  add 1c17.d388.dc41
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   4    1c17.d388.dc41    DYNAMIC     Gi0/18
Total Mac Addresses for this criterion: 1

A#sh mac address-table  add  ccef.4880.0481
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   2    ccef.4880.0481    DYNAMIC     Gi0/1
  10    ccef.4880.0481    DYNAMIC     Gi0/1
   4    ccef.4880.0481    DYNAMIC     Gi0/1
   3    ccef.4880.0481    DYNAMIC     Gi0/1
Total Mac Addresses for this criterion: 4

B#sh spanning-tree vl 4

VLAN0004
  Spanning tree enabled protocol ieee
  Root ID    Priority    4100
             Address     64d9.89df.a200
             Cost        19
             Port        24 (FastEthernet0/24)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32772  (priority 32768 sys-id-ext 4)
             Address     1c17.d388.dc00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 15

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/24              Root FWD 19        128.24   P2p

B#ping 10.50.138.147
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.50.138.147, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/9 ms

B#ping 10.50.138.129
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.50.138.129, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

B#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.50.138.147           5   64d9.89df.a243  ARPA   Vlan4
Internet  10.50.138.129          70   ccef.4880.0481  ARPA   Vlan4
Internet  10.50.138.249           -   1c17.d388.dc41  ARPA   Vlan4

B#sh mac address-table add ccef.4880.0481
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   4    ccef.4880.0481    DYNAMIC     Fa0/24
Total Mac Addresses for this criterion: 1

B#sh mac address-table add 64d9.89df.a243
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   4    64d9.89df.a243    DYNAMIC     Fa0/24
Total Mac Addresses for this criterion: 1

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Помогите разобраться"  +/
Сообщение от rusadmin (ok) on 14-Авг-15, 14:52 
Простите за задержку.
Не вижу косяков. Даже дизайн ваш нарисовал. Криминала не вижу.
Попробуйте после обрыва очистить арп таблицы на коммутаторе B и маршрутизаторе (clear ip arp ....). Для чистоты эксперемента.
Было бы неплохо удостоверится, что через модемы точно ходит трафик: встать ноутом на модем удаленной стороны и попингать роутер.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Помогите разобраться"  +/
Сообщение от rapport_mur (ok) on 17-Авг-15, 08:44 
> Простите за задержку.
> Не вижу косяков. Даже дизайн ваш нарисовал. Криминала не вижу.
> Попробуйте после обрыва очистить арп таблицы на коммутаторе B и маршрутизаторе (clear
> ip arp ....). Для чистоты эксперемента.
> Было бы неплохо удостоверится, что через модемы точно ходит трафик: встать ноутом
> на модем удаленной стороны и попингать роутер.

Таблицы чистил и arp и mac. Никакого эффекта.
Через модемы трафик ходит, я ведь могу с коммутатора на коммутатор залезть при обрыве оптики.
Трафик почему то не идет на шлюз.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру