The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"BGP , использование резервного канала"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"BGP , использование резервного канала"  
Сообщение от sere9a (ok) on 12-Дек-08, 16:53 
Имеется 2811 и два провайдера. Работает через BGP. Канал второго провайдера используется в только в случае если отвалился первый... Получается, что один канал просто простаивает. Во внутренней сети есть одна машина, она грузит канал больше всех остальных. Вопрос: как заставить ходить эту машину через канал резевного провайдера?
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "BGP , использование резервного канала"  
Сообщение от nm email(??) on 12-Дек-08, 17:21 
а as у Вас /24, или больше?
>Имеется 2811 и два провайдера. Работает через BGP. Канал второго провайдера используется
>в только в случае если отвалился первый... Получается, что один канал
>просто простаивает. Во внутренней сети есть одна машина, она грузит канал
>больше всех остальных. Вопрос: как заставить ходить эту машину через канал
>резевного провайдера?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "BGP , использование резервного канала"  
Сообщение от mario23 email on 12-Дек-08, 18:09 
>Имеется 2811 и два провайдера. Работает через BGP. Канал второго провайдера используется
>в только в случае если отвалился первый... Получается, что один канал
>просто простаивает. Во внутренней сети есть одна машина, она грузит канал
>больше всех остальных. Вопрос: как заставить ходить эту машину через канал
>резевного провайдера?

у вас сейчас бгп поднят или для этого хотите поднять ?


можно и без bgp
пропишинте на интерфейсе локальной  сети к примеру 192.168.0.0/24

interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.0
ip policy route-map test

пишем acl вида
access-list 1 permit 192.168.0.2 0.0.0.0
айпи это та самая машинка

ну и пишем роут мап

route-map test permit 200
description ###super_pogirun_traffa
match ip address 1
set ip next-hop ip интерфеса смотрящего на резервного прова  

ну и надо что бы был роут прописан для некстхопа

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "BGP , использование резервного канала"  
Сообщение от sere9a (ok) on 12-Дек-08, 18:14 
>[оверквотинг удален]
>айпи это та самая машинка , от провайдера получаем группу реальных адресов /24
>
>ну и пишем роут мап
>
>route-map test permit 200
> description ###super_pogirun_traffa
> match ip address 1
> set ip next-hop ip интерфеса смотрящего на резервного прова
>
>ну и надо что бы был роут прописан для некстхопа

BGP уже поднят, без него не обойтись , т.к. необходимо переключатся на резервного провайдера если основной упадёт, AS -  /24

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "BGP , использование резервного канала"  
Сообщение от mario23 email on 12-Дек-08, 18:21 
>[оверквотинг удален]
>>
>>route-map test permit 200
>> description ###super_pogirun_traffa
>> match ip address 1
>> set ip next-hop ip интерфеса смотрящего на резервного прова
>>
>>ну и надо что бы был роут прописан для некстхопа
>
>BGP уже поднят, без него не обойтись , т.к. необходимо переключатся на
>резервного провайдера если основной упадёт, AS -  /24

с bgp мало знаком но вот PBR очень подходит для данного решения так что погуглите на тему
BGP и route-map

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "BGP , использование резервного канала"  
Сообщение от mario23 email on 12-Дек-08, 18:24 
>[оверквотинг удален]
>>> set ip next-hop ip интерфеса смотрящего на резервного прова
>>>
>>>ну и надо что бы был роут прописан для некстхопа
>>
>>BGP уже поднят, без него не обойтись , т.к. необходимо переключатся на
>>резервного провайдера если основной упадёт, AS -  /24
>
>с bgp мало знаком но вот PBR очень подходит для данного решения
>так что погуглите на тему
>BGP и route-map

вот ваше
Router(config)# ip prefix-list 1 permit 172.16.0.0/16

Router(config)# ip prefix-list 2 permit 192.168.1.0/24

Router(config)# route-map RED permit 10

Router(config-route-map)# match ip address prefix-list 1

Router(config-route-map)# set ip next hop 10.1.1.1

Router(config-route-map)# continue 20

Router(config-route-map)# exit

Router(config)# route-map RED permit 20

Router(config-route-map)# match ip address prefix-list 2

Router(config-route-map)# set ip next hop 10.2.2.2

Router(config-route-map)# end


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "BGP , использование резервного канала"  
Сообщение от mario23 email on 12-Дек-08, 18:30 
>[оверквотинг удален]
>
>Router(config-route-map)# exit
>
>Router(config)# route-map RED permit 20
>
>Router(config-route-map)# match ip address prefix-list 2
>
>Router(config-route-map)# set ip next hop 10.2.2.2
>
>Router(config-route-map)# end

только вот надо первым поставить ваш сервак нужный что бы он сначала его проверил а потом остальные префиксы

принцип я думаю понятен

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "BGP , использование резервного канала"  
Сообщение от sere9a (ok) on 12-Дек-08, 18:26 
>[оверквотинг удален]
>>> set ip next-hop ip интерфеса смотрящего на резервного прова
>>>
>>>ну и надо что бы был роут прописан для некстхопа
>>
>>BGP уже поднят, без него не обойтись , т.к. необходимо переключатся на
>>резервного провайдера если основной упадёт, AS -  /24
>
>с bgp мало знаком но вот PBR очень подходит для данного решения
>так что погуглите на тему
>BGP и route-map

Да, спасибо.

С route-map  у нас получится отправлять запросы , но боюсь , что приходить они будут на адерс первого провайдера...Может тут as-path prepend  поможет?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "BGP , использование резервного канала"  
Сообщение от f0x (??) on 12-Дек-08, 23:16 
>[оверквотинг удален]
>>
>>с bgp мало знаком но вот PBR очень подходит для данного решения
>>так что погуглите на тему
>>BGP и route-map
>
>Да, спасибо.
>
>С route-map  у нас получится отправлять запросы , но боюсь ,
>что приходить они будут на адерс первого провайдера...Может тут as-path prepend
> поможет?

ИМХО проще попросить у второго провайдера подсеть /30 из его диапазона и выдать этой машинке.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "BGP , использование резервного канала"  
Сообщение от mario23 email on 15-Дек-08, 11:33 
>[оверквотинг удален]
>>>BGP и route-map
>>
>>Да, спасибо.
>>
>>С route-map  у нас получится отправлять запросы , но боюсь ,
>>что приходить они будут на адерс первого провайдера...Может тут as-path prepend
>> поможет?
>
>ИМХО проще попросить у второго провайдера подсеть /30 из его диапазона и
>выдать этой машинке.

а я имелл виду из своей подсети выделить /32 и ее префиксом шарахнуть для все того же сервака  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "BGP , использование резервного канала"  
Сообщение от f0x (??) on 16-Дек-08, 10:46 
>[оверквотинг удален]
>>>
>>>С route-map  у нас получится отправлять запросы , но боюсь ,
>>>что приходить они будут на адерс первого провайдера...Может тут as-path prepend
>>> поможет?
>>
>>ИМХО проще попросить у второго провайдера подсеть /30 из его диапазона и
>>выдать этой машинке.
>
>а я имелл виду из своей подсети выделить /32 и ее префиксом
>шарахнуть для все того же сервака

Очень многие провайдеры префиксы меньше /24 в BGP режут. Так что я думаю не поможет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "BGP , использование резервного канала"  
Сообщение от ios_support email(??) on 16-Дек-08, 11:07 
>[оверквотинг удален]
>>>> поможет?
>>>
>>>ИМХО проще попросить у второго провайдера подсеть /30 из его диапазона и
>>>выдать этой машинке.
>>
>>а я имелл виду из своей подсети выделить /32 и ее префиксом
>>шарахнуть для все того же сервака
>
>Очень многие провайдеры префиксы меньше /24 в BGP режут. Так что я
>думаю не поможет.

анонисируй сеть через одного провайдера с большим as-patch а для входящих роутов поставь LP поменьше и у тебя получится что приоритетным всегда будет только тот канал у которого самый короткий as-patch а для исходящего приоритет будет у того у которого LP больше ))


  (А*)-------
             |
              ----(ТВОЯ АС)
             |
  (Б)--------

neighbor БББ.БББ.БББ.БББ route-map add_as out
neighbor БББ.БББ.БББ.БББ route-map set_lp in

route-map add_as permit 10
set as-path prepend 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

route-map set_lp permit 10
set local-preference 90    

1* номер твоей АС

с таким конфигом провайдер Б заработает только после падения бгп сессии с провайдером А

если нужна работа двух каналов одновременно то просто получай фул таблицу от обоих провайдеров и трафик будет ходить по самому короткому пути ))) к тебе и от тебя

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "BGP , использование резервного канала"  
Сообщение от f0x (??) on 16-Дек-08, 11:26 
>[оверквотинг удален]
> set local-preference 90
>
>1* номер твоей АС
>
>с таким конфигом провайдер Б заработает только после падения бгп сессии с
>провайдером А
>
>если нужна работа двух каналов одновременно то просто получай фул таблицу от
>обоих провайдеров и трафик будет ходить по самому короткому пути )))
>к тебе и от тебя

А пробовали такую схему в реальных условиях? У меня навешено около 15 препендов на одного из двух провайдеров, но входящий трафик через них всё равно примерно равный.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "BGP , использование резервного канала"  
Сообщение от ios_support email(ok) on 16-Дек-08, 12:04 
>[оверквотинг удален]
>>с таким конфигом провайдер Б заработает только после падения бгп сессии с
>>провайдером А
>>
>>если нужна работа двух каналов одновременно то просто получай фул таблицу от
>>обоих провайдеров и трафик будет ходить по самому короткому пути )))
>>к тебе и от тебя
>
>А пробовали такую схему в реальных условиях? У меня навешено около 15
>препендов на одного из двух провайдеров, но входящий трафик через них
>всё равно примерно равный.

у меня так работает спроси у провайдера возможно они обкусывают ))) посмотри через Looking Glass

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "BGP , использование резервного канала"  
Сообщение от f0x (??) on 16-Дек-08, 15:56 
>[оверквотинг удален]
>>>если нужна работа двух каналов одновременно то просто получай фул таблицу от
>>>обоих провайдеров и трафик будет ходить по самому короткому пути )))
>>>к тебе и от тебя
>>
>>А пробовали такую схему в реальных условиях? У меня навешено около 15
>>препендов на одного из двух провайдеров, но входящий трафик через них
>>всё равно примерно равный.
>
>у меня так работает спроси у провайдера возможно они обкусывают ))) посмотри
>через Looking Glass

Не откусывают, спрашивал. И через Looking Glass все препенды видны.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "BGP , использование резервного канала"  
Сообщение от fantom email(ok) on 23-Дек-08, 10:37 
>[оверквотинг удален]
>>>> поможет?
>>>
>>>ИМХО проще попросить у второго провайдера подсеть /30 из его диапазона и
>>>выдать этой машинке.
>>
>>а я имелл виду из своей подсети выделить /32 и ее префиксом
>>шарахнуть для все того же сервака
>
>Очень многие провайдеры префиксы меньше /24 в BGP режут. Так что я
>думаю не поможет.

Не просто очень многие, скорее подавляющее большинство.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "BGP , использование резервного канала"  
Сообщение от shutdown now on 16-Дек-08, 13:17 
>[оверквотинг удален]
>>
>>route-map test permit 200
>> description ###super_pogirun_traffa
>> match ip address 1
>> set ip next-hop ip интерфеса смотрящего на резервного прова
>>
>>ну и надо что бы был роут прописан для некстхопа
>
>BGP уже поднят, без него не обойтись , т.к. необходимо переключатся на
>резервного провайдера если основной упадёт, AS -  /24

с /24  тебе никак не выкрутится, скажем с помощью pbr ты отправишь траф через другого оператора, но назад он вернётся через основной канал

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру