The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"redistribute static nexus"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"redistribute static nexus"  +/
Сообщение от Bbi4 email(ok) on 03-Авг-15, 16:45 
Добрый день,

Была похожая тема(https://www.opennet.ru/openforum/vsluhforumID6/1404.html#TOP), но ответа не было, поэтому повторюсь.

Есть коммутатор 6500, к нему подключен nexus5500, поднята динамическая маршрутизация EIGRP. Есть vrf. Все хорошо, но есть проблема с редистрибуцией статики.

Nexus:

vrf context n5k1
  ip route 172.16.41.21/32 192.168.100.2 tag 151
  ip route 172.30.32.0/22 192.168.100.2 tag 151
  ip route 192.168.93.0/24 192.168.100.2 tag 151

ip prefix-list Static4Redistribute seq 5 permit 192.168.93.0/24

route-map RedistributeStaticRoute permit 10
  match tag 151
route-map RedistributeStaticRoute permit 20
  match ip address prefix-list Static4Redistribute

interface Vlan3967
  desc Eigrp 2 6506
  no shutdown
  vrf member n5k1
  ip address 172.31.255.18/29
  ip router eigrp 110

router eigrp 110
  autonomous-system 110
  router-id 172.31.255.18
  redistribute static route-map RedistributeStaticRoute
  default-information originate always
  address-family ipv4 unicast
  vrf n5k1

Ничего не редистрибутируется.

Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf default
C: No. of comparisions, M: No. of matches

route-map RedistributeStaticRoute permit 10
  match tag 151                                              C: 2      M: 0    
route-map RedistributeStaticRoute permit 20
  match ip address prefix-list Static4Redistribute           C: 2      M: 0    

Total accept count for policy: 0    
Total reject count for policy: 2    
Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1
Core-Nexus-1#

Есть мысли?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "redistribute static nexus"  +/
Сообщение от sproot (ok) on 06-Авг-15, 04:57 
>[оверквотинг удален]
>  M: 0
> route-map RedistributeStaticRoute permit 20
>   match ip address prefix-list Static4Redistribute      
>      C: 2    
>  M: 0
> Total accept count for policy: 0
> Total reject count for policy: 2
> Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1
> Core-Nexus-1#
> Есть мысли?

привет
может надо
ip prefix-list Static4Redistribute seq 5 permit 192.168.93.0/24 ge 32
?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "redistribute static nexus"  +/
Сообщение от sproot (ok) on 07-Авг-15, 06:22 
>[оверквотинг удален]
>>  M: 0
>> Total accept count for policy: 0
>> Total reject count for policy: 2
>> Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1
>> Core-Nexus-1#
>> Есть мысли?
> привет
> может надо
> ip prefix-list Static4Redistribute seq 5 permit 192.168.93.0/24 ge 32
> ?

Немного промахнулся, только сейчас заметил.
Нужно ip prefix-list Static4Redistribute seq 5 permit 192.168.93.0/24 le 32
Получилось-то?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "redistribute static nexus"  +/
Сообщение от Bbi4 email(ok) on 07-Авг-15, 08:39 
>[оверквотинг удален]
>>> Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1
>>> Core-Nexus-1#
>>> Есть мысли?
>> привет
>> может надо
>> ip prefix-list Static4Redistribute seq 5 permit 192.168.93.0/24 ge 32
>> ?
> Немного промахнулся, только сейчас заметил.
> Нужно ip prefix-list Static4Redistribute seq 5 permit 192.168.93.0/24 le 32
> Получилось-то?

Нет. Не получилось. Смущает статистика по редистрибуции.

Core-Nexus-1# sh ip eigrp route-map statistics redistribute static
C: No. of comparisions, M: No. of matches

route-map RedistributeStaticRoute permit 10
  match tag 151                                              C: 2      M: 0    
route-map RedistributeStaticRoute permit 20
  match ip address prefix-list Static4Redistribute           C: 2      M: 0    

Total accept count for policy: 0    
Total reject count for policy: 2    
Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1

Почему в vrf n5k1 вообще ничего нет. Статика именно в этом vrf описана. Может здесь собака порылась?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "redistribute static nexus"  +/
Сообщение от sproot (ok) on 07-Авг-15, 09:06 
>[оверквотинг удален]
>  M: 0
> route-map RedistributeStaticRoute permit 20
>   match ip address prefix-list Static4Redistribute      
>      C: 2    
>  M: 0
> Total accept count for policy: 0
> Total reject count for policy: 2
> Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1
> Почему в vrf n5k1 вообще ничего нет. Статика именно в этом vrf
> описана. Может здесь собака порылась?

Я думаю, не хватает директивы default-metric в router eigrp

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "redistribute static nexus"  +/
Сообщение от sproot (ok) on 10-Авг-15, 02:33 
>[оверквотинг удален]
>  M: 0
> route-map RedistributeStaticRoute permit 20
>   match ip address prefix-list Static4Redistribute      
>      C: 2    
>  M: 0
> Total accept count for policy: 0
> Total reject count for policy: 2
> Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1
> Почему в vrf n5k1 вообще ничего нет. Статика именно в этом vrf
> описана. Может здесь собака порылась?

Получилось?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру