The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"BGP балансирование нагрузки на каналы"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 05-Дек-08, 10:21 
Есть маршрутизатор 3745, есть два провайдера подключеные по BGP.
На нашу автономную систему выдано 512 внешних ip. (х.х.х.0/23)

Задача:
Разделить сеть х.х.у.0/23 на х.х.у.0/24 и х.х.z.0/24 и проанонсировать их к дмум провайдерам с разными препендами.

Было сделано:

1. На ripe были созданы route на обе сети с префиксом 24
2. Конфигурация циски

router bgp MyAS
no synchronization
bgp router-id A.B.C-0.1
network A.B.C-0.0/23
network A.B.C-0.0/24
network A.B.C-1.0/24

! Описываем соседей

neighbor 101.102.103.104 remote-as 1111

! на пути к этому соседу есть дополнительный маршрутизатор

neighbor 101.102.103.104 ebgp-multihop 2
neighbor 101.102.103.104 prefix-list PREFIX-LE-24 in
neighbor 101.102.103.104 route-map Prov001 out
neighbor 101.102.103.104 filter-list 10 out

neighbor 201.202.203.204 remote-as 2222
neighbor 201.202.203.204 prefix-list PREFIX-LE-24 in
neighbor 201.202.203.204 route-map Prov002 out
neighbor 201.202.203.204 filter-list 10 out
no auto-summary

! Этот фильтр не разрешает принимать снаружи анонсы сетей меньше /24

ip prefix-list PREFIX-LE-24 seq 10 permit 0.0.0.0/0 le 24
ip prefix-list PREFIX-LE-24 seq 20 deny 0.0.0.0/0

! Описание сетей для route-map -ов

ip prefix-list OURNET-001 seq 10 permit A.B.C-0.0/24
ip prefix-list OURNET-002 seq 10 permit A.B.C-1.0/24

! Анонсировать наружу только свою AS

ip as-path access-list 10 permit ^$

! Первый провайдер, анонсируем ему одну сеть без препендов, другую с двумя препендами

route-map Prov001 permit 10
match ip address prefix-list OURNET-001

route-map Prov001 permit 20
match ip address prefix-list OURNET-002
set as-path prepend MyAS MyAS

! Второй провайдер - все наоборот

route-map Prov002 permit 10
match ip address prefix-list OURNET-002

route-map Prov002 permit 20
match ip address prefix-list OURNET-001
set as-path prepend MyAS MyAS

Проблема в том что все равно сети с префиксом 24 не аносируются

cisco#sh ip bgp neighbors 101.102.103.104 advertised-routes
BGP table version is 3456128, local router ID is A.B.C-0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> A.B.C-0.0/23  0.0.0.0                  0         32768 i

Total number of prefixes 1


Что можете подсказать? Что я упускаю?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "BGP балансирование нагрузки на каналы"  
Сообщение от GolDi (??) on 05-Дек-08, 10:58 
>[оверквотинг удален]
>
>   Network        
> Next Hop        
>   Metric LocPrf Weight Path
>*> A.B.C-0.0/23  0.0.0.0                  0         32768 i
>
>Total number of prefixes 1
>
>
>Что можете подсказать? Что я упускаю?

Во первых упустили добавить match as-path 10  - только свою AS.
Попробуйте удалить  network A.B.C-0.0/23, или переписать
ip prefix-list OURNET-001 seq 10 permit A.B.C-0.0/24
через le 24

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 05-Дек-08, 11:58 
> Во первых упустили добавить match as-path 10  - только свою
>AS.
> Попробуйте удалить  network A.B.C-0.0/23, или переписать
>ip prefix-list OURNET-001 seq 10 permit A.B.C-0.0/24
>через le 24

1. в смысли упустили match as-path 10?

neighbor 101.102.103.104 filter-list 10 out
neighbor 201.202.203.204 filter-list 10 out

ip as-path access-list 10 permit ^$

2. Пробывал удалять network A.B.C-0.0/23, при этом наружу не какие маршруты не анонсируются

3. cisco#ip prefix-list OURNET-1 seq 10 permit ?
  A.B.C.D  IP prefix <network>/<length>, e.g., 35.0.0.0/8
через le 24 не  хочет прописывать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "BGP балансирование нагрузки на каналы"  
Сообщение от Felixz (??) on 05-Дек-08, 12:09 
На все Ваши сети нужно статику в null или Вы это сделали, но не рассказали?!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 05-Дек-08, 12:26 
>На все Ваши сети нужно статику в null или Вы это сделали,
>но не рассказали?!

По подробнее. Только осваиваю протокол.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "BGP балансирование нагрузки на каналы"  
Сообщение от Felixz (??) on 05-Дек-08, 13:33 
>>На все Ваши сети нужно статику в null или Вы это сделали,
>>но не рассказали?!
>
>По подробнее. Только осваиваю протокол.

BGP анонсирует сети, которые есть в таблице маршрутов. Соответственно, необходимо занести объявить подсеть за маршрутизатором, а только потом её аносировать:

router bgp 65000
   network 10.10.10.0 netmask 255.255.255.0
!

ip route 10.10.10.0 255.255.255.0 Null0

ну, и по вкусу, можно

interface Null0
  no ip unreachables
!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "BGP балансирование нагрузки на каналы"  
Сообщение от Felixz (??) on 05-Дек-08, 13:36 
>>На все Ваши сети нужно статику в null или Вы это сделали,
>>но не рассказали?!
>
>По подробнее. Только осваиваю протокол.

Надеюсь, что Вы в курсе, что способом который вы воплощаете в жизнь, получится рулить только входящей нагрузкой.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 12-Дек-08, 07:27 
>>>На все Ваши сети нужно статику в null или Вы это сделали,
>>>но не рассказали?!
>>
>>По подробнее. Только осваиваю протокол.
>
>Надеюсь, что Вы в курсе, что способом который вы воплощаете в жизнь,
>получится рулить только входящей нагрузкой.

Действительно проблема была в этом, забыл прописать роуты на сети с префиксом ле 24.
Спасибо за совет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "BGP балансирование нагрузки на каналы"  
Сообщение от GolDi (??) on 05-Дек-08, 12:17 
>> Во первых упустили добавить match as-path 10  - только свою
>>AS.
>> Попробуйте удалить  network A.B.C-0.0/23, или переписать
>>ip prefix-list OURNET-001 seq 10 permit A.B.C-0.0/24
>>через le 24
>
>1. в смысли упустили match as-path 10?
>
>neighbor 101.102.103.104 filter-list 10 out
>neighbor 201.202.203.204 filter-list 10 out

Попробуйте включить filter-list в route-map

>
>ip as-path access-list 10 permit ^$
>
>2. Пробывал удалять network A.B.C-0.0/23, при этом наружу не какие маршруты не
>анонсируются
>
>3. cisco#ip prefix-list OURNET-1 seq 10 permit ?
>  A.B.C.D  IP prefix <network>/<length>, e.g., 35.0.0.0/8
> через le 24 не  хочет прописывать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 05-Дек-08, 12:36 
> Попробуйте включить filter-list в route-map

А можно пример? А что это даст?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "BGP балансирование нагрузки на каналы"  
Сообщение от GolDi (??) on 05-Дек-08, 13:00 
>> Попробуйте включить filter-list в route-map
>
> А можно пример? А что это даст?

Покажите лучше конфиг и sh ip route

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 16-Дек-08, 08:54 
Выкладываю полность конфиг:

interface Loopback0
description For NetFlow
ip address 10.1.0.1 255.255.255.0
ip route-cache policy
ip route-cache flow
shutdown
!

interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 172.200.0.3 255.255.255.248 secondary
ip address 172.17.0.25 255.255.255.248 secondary
ip address 172.17.0.89 255.255.255.252 secondary
ip address 172.17.0.65 255.255.255.252 secondary
ip address 193.33.100.1 255.255.255.240 secondary
ip address 83.234.83.3 255.255.255.240 secondary
ip address 62.33.137.3 255.255.255.240
ip policy route-map CHECK_SOURCE

!
interface FastEthernet0/0.254
encapsulation dot1Q 254
ip address 192.168.254.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Serial0/0  #интерфейс в сторону маршрутизатора(маршрутизатор не знает БГП), через которого подключаемся к ТТК
ip address 217.150.54.166 255.255.255.252 secondary
ip address 62.33.137.253 255.255.255.252
ip nat outside
ip virtual-reassembly
ip route-cache flow
no fair-queue
!
interface FastEthernet0/1  # интерфейс в сторону СТК
no ip address
ip route-cache flow
speed 10
full-duplex
no cdp enable
!
interface FastEthernet0/1.111
encapsulation dot1Q 111
ip address 195.46.118.30 255.255.255.252
ip nat outside
ip virtual-reassembly
!

router bgp 42443
no synchronization
bgp router-id 193.33.100.1
bgp log-neighbor-changes
network 193.33.100.0
network 193.33.101.0
neighbor 195.46.116.185 remote-as 8382   # канал СТК
neighbor 195.46.116.185 ebgp-multihop 2
neighbor 195.46.116.185 prefix-list PREFIX-LE-24 in
neighbor 195.46.116.185 route-map STK out
neighbor 195.46.116.185 filter-list 10 out
neighbor 217.150.36.158 remote-as 20485  # канал ТТК
neighbor 217.150.36.158 ebgp-multihop 2
neighbor 217.150.36.158 prefix-list PREFIX-LE-24 in
neighbor 217.150.36.158 route-map TTK out
neighbor 217.150.36.158 filter-list 10 out
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 62.33.137.254
ip route 62.33.137.128 255.255.255.224 62.33.137.1
ip route 83.234.83.16 255.255.255.240 62.33.137.10
ip route 83.234.83.64 255.255.255.240 62.33.137.14
ip route 83.234.83.168 255.255.255.252 62.33.137.1
ip route 83.234.83.184 255.255.255.248 62.33.137.14
ip route 172.0.0.0 255.255.255.224 172.17.0.66
ip route 172.16.0.0 255.240.0.0 172.17.0.17
ip route 172.16.0.252 255.255.255.252 172.17.0.17
ip route 172.17.0.1 255.255.255.255 172.17.0.17
ip route 172.17.0.24 255.255.255.248 172.0.0.2
ip route 172.17.0.24 255.255.255.248 172.17.0.34
ip route 192.168.0.0 255.255.224.0 192.168.254.3
ip route 192.168.10.0 255.255.255.0 192.168.254.3
ip route 192.168.100.0 255.255.255.0 192.168.254.2
ip route 192.168.101.0 255.255.255.0 192.168.254.2
ip route 192.168.102.0 255.255.255.0 192.168.254.2
ip route 192.168.103.0 255.255.255.0 192.168.254.2
ip route 192.168.104.0 255.255.255.0 192.168.254.2
ip route 193.33.100.0 255.255.255.0 Null0
ip route 193.33.101.0 255.255.255.0 Null0
ip route 193.33.101.64 255.255.255.240 193.33.100.14
ip route 195.46.116.185 255.255.255.255 195.46.118.29
ip route 217.150.36.158 255.255.255.255 217.150.54.165 permanent
!
ip as-path access-list 10 permit ^$
ip flow-export version 5
ip flow-export destination 62.33.137.11 9995
!
ip http server
no ip http secure-server
ip nat pool net-2 193.33.100.16 193.33.100.31 netmask 255.255.255.240
ip nat pool homenet-2 193.33.101.16 193.33.101.31 netmask 255.255.255.240
ip nat inside source list ElegantUsers pool net-2 overload
ip nat inside source list VtownUsers pool net-2 overload
ip nat inside source list VtownUsers2 pool homenet-2 overload
!
ip access-list extended ElegantUsers
permit ip 192.168.0.0 0.0.63.255 any
ip access-list extended Routing
permit ip any host 193.33.100.5
ip access-list extended VtownUsers
permit ip 192.168.103.0 0.0.0.255 any
permit ip 192.168.104.0 0.0.0.255 any
ip access-list extended VtownUsers2
permit ip 192.168.100.0 0.0.0.255 any
permit ip 192.168.102.0 0.0.0.255 any
permit ip 192.168.123.0 0.0.0.255 any
permit ip 192.168.124.0 0.0.0.255 any
permit ip 192.168.101.0 0.0.0.255 any
!
!
ip prefix-list OURNET-1 seq 10 permit 193.33.100.0/24
!
ip prefix-list OURNET-2 seq 10 permit 193.33.101.0/24
!
ip prefix-list PREFIX-LE-24 seq 30 permit 0.0.0.0/0 le 24
ip prefix-list PREFIX-LE-24 seq 40 deny 0.0.0.0/0
access-list 1 permit 83.234.83.0 0.0.0.255
access-list 1 permit 62.33.137.0 0.0.0.255
access-list 2 permit 193.33.100.0 0.0.0.255
access-list 3 permit 193.33.101.0 0.0.0.255
snmp-server community vtufnewwbcrf RO
!
route-map CHECK_SOURCE permit 10
match ip address 1
set ip next-hop 62.33.137.254
!
route-map TTK permit 10
match ip address prefix-list OURNET-2
!
route-map TTK permit 20
match ip address prefix-list OURNET-1
set as-path prepend 42443 42443 42443 42443 42443
!
route-map STK permit 10
match ip address prefix-list OURNET-1
!
route-map STK permit 20
match ip address prefix-list OURNET-2
set as-path prepend 42443 42443 42443 42443 42443

#############

Почему то канал СТК не хочет прогружаться

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "BGP балансирование нагрузки на каналы"  
Сообщение от shutdown now on 16-Дек-08, 13:14 
>[оверквотинг удален]
>
>   Network        
> Next Hop        
>   Metric LocPrf Weight Path
>*> A.B.C-0.0/23  0.0.0.0                  0         32768 i
>
>Total number of prefixes 1
>
>
>Что можете подсказать? Что я упускаю?

sh ip route A.B.C-0.0 и A.B.C-1.0 чего говорит? может, нет у тебя этих маршрутов, поэтому бгп их и не анонсит

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 17-Дек-08, 05:04 
>[оверквотинг удален]
>>   Metric LocPrf Weight Path
>>*> A.B.C-0.0/23  0.0.0.0                  0         32768 i
>>
>>Total number of prefixes 1
>>
>>
>>Что можете подсказать? Что я упускаю?
>
>sh ip route A.B.C-0.0 и A.B.C-1.0 чего говорит? может, нет у тебя
>этих маршрутов, поэтому бгп их и не анонсит

После пересоздание роутов A.B.C-0.0 и A.B.C-1.0 на Null, анонсироваться стало нормально(обе сети).

Сейчас не просто не хочет прогружаться канал СТК, большая часть идет через ттк, и лишь малая часть через стк.....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "BGP балансирование нагрузки на каналы"  
Сообщение от shutdown now on 17-Дек-08, 09:44 
>[оверквотинг удален]
>>>Что можете подсказать? Что я упускаю?
>>
>>sh ip route A.B.C-0.0 и A.B.C-1.0 чего говорит? может, нет у тебя
>>этих маршрутов, поэтому бгп их и не анонсит
>
>После пересоздание роутов A.B.C-0.0 и A.B.C-1.0 на Null, анонсироваться стало нормально(обе сети).
>
>
>Сейчас не просто не хочет прогружаться канал СТК, большая часть идет через
>ттк, и лишь малая часть через стк.....

попробуй препендов на ТТК навесить, можно с их коммьюнитями поиграться

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "BGP балансирование нагрузки на каналы"  
Сообщение от fit (ok) on 17-Дек-08, 05:06 
>>   Metric LocPrf Weight Path
>>*> A.B.C-0.0/23  0.0.0.0                  0         32768 i
>>
>>Total number of prefixes 1
>>
>>
>>Что можете подсказать? Что я упускаю?
>
>sh ip route A.B.C-0.0 и A.B.C-1.0 чего говорит? может, нет у тебя
>этих маршрутов, поэтому бгп их и не анонсит

После пересоздание роутов A.B.C-0.0 и A.B.C-1.0 на Null, анонсироваться стало нормально(обе сети).

Сейчас не просто не хочет прогружаться канал СТК, большая часть идет через ттк, и лишь малая часть через стк.....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру