The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"l2tpv3 проброс через ip сеть"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"l2tpv3 проброс через ip сеть"  
Сообщение от Ecomak email(ok) on 03-Дек-08, 09:32 
Возник вопрос пробросить влан через сеть ip.

Имеем 2 cisco 7606 между ними layer3 интерфейс. В каждую транком подключена 3750, на которой заведены вланы.
всё делаю по мануалу
http://www.cisco.com/en/US/docs/ios/12_3t/12_3t2/feature/gui...

На обоих концах указываю

l2tp-class class1
authentication
password 7 044B0A151C

pseudowire-class vlan-connect
encapsulation l2tpv3
protocol l2tpv3 class1
ip local interface Loopback100
_________________________________________

Конфиги интерфейсов
#sh run int Gi4/24.113
!
interface GigabitEthernet4/24.113
encapsulation dot1Q 113
xconnect ip_router_1 113 pw-class vlan-connect
end


#sh run int Gi4/24.113

interface GigabitEthernet4/24.113
encapsulation dot1Q 113
xconnect ip_router_1 113 pw-class vlan-connect
end

На Лупбеках с обоих сторон прописаны соответствующие ip адреса
Сессия l2tpv3 активна

На одном из каталистов завел влан и в Gi1/0/18 подключил железку, устройство пингуется, вижу мак адрес
#sh mac-address-table dynamic int Gi1/0/18
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
113    001a.6478.fe72    DYNAMIC     Gi1/0/18
Total Mac Addresses for this criterion: 1

А вот на 3750 на другом конце такого мака не вижу...
Конфиг интерефейса, куда подключено устройство в 113 влане
#sh run int Gi1/0/18
interface GigabitEthernet1/0/18
description server monitiring ETH2
switchport access vlan 113
end

#sh run int vlan 113
!
interface Vlan113
ip address 172.16.0.254 255.255.255.0
end


Не могу понять в чем затык.. пробовал xconnect указывать инкапсулировать во вреймы mpls, но натолкнулся на ту же проблему - при поднятом туннеле, на другом конце мак как будто не приходил

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "l2tpv3 проброс через ip сеть"  
Сообщение от EDA_SPB on 04-Дек-08, 09:33 
Непонятно на каком устройстве заведен интерфейс 3-го уровня:
>#sh run int vlan 113
>!
>interface Vlan113
> ip address 172.16.0.254 255.255.255.0
>end

В Вашей схеме не вижу ему места.
У нас работает так:
access port switch -- trunk switch -- trunk router -- subinterface -- tunnel xconnect -- subinterface -- trunk router -- trunk switch -- access port switch

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "l2tpv3 проброс через ip сеть"  
Сообщение от Ecomak email(ok) on 04-Дек-08, 19:43 
>[оверквотинг удален]
>>!
>>interface Vlan113
>> ip address 172.16.0.254 255.255.255.0
>>end
>
>В Вашей схеме не вижу ему места.
>У нас работает так:
>access port switch -- trunk switch -- trunk router -- subinterface --
>tunnel xconnect -- subinterface -- trunk router -- trunk switch --
>access port switch

Извиняюсь, исправил, int  vlan 113 удалил.
Схема, как описана у вас.
На транковом свиче, который на другом конце сказал
conf t
vlan 113
но мака не увидел....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "l2tpv3 проброс через ip сеть"  
Сообщение от Moka on 04-Дек-08, 20:02 
>[оверквотинг удален]
>>access port switch -- trunk switch -- trunk router -- subinterface --
>>tunnel xconnect -- subinterface -- trunk router -- trunk switch --
>>access port switch
>
>Извиняюсь, исправил, int  vlan 113 удалил.
>Схема, как описана у вас.
>На транковом свиче, который на другом конце сказал
>conf t
>vlan 113
>но мака не увидел....

А есть ли на борту 7600 ES карты или SIP-400? Без них вроде бы не должно работать
http://www.cisco.com/en/US/prod/collateral/iosswrel/ps8802/p...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "l2tpv3 проброс через ip сеть"  
Сообщение от Ecomak email(ok) on 07-Дек-08, 20:27 
>А есть ли на борту 7600 ES карты или SIP-400? Без них
>вроде бы не должно работать
>http://www.cisco.com/en/US/prod/collateral/iosswrel/ps8802/p...

Честно говоря не знаю...дело в том, что до этого по layer3 был проброшен влан и для него всё работает и сейчас! Пытаюсь на этой же железке пробросить еше один, но всё тщетно...
Инкапсуляцию пробовал mpls и l2tp, не хочет и всё... Уже не понимаю, как отдебажить проблему.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "l2tpv3 проброс через ip сеть"  
Сообщение от Ecomak email(ok) on 16-Янв-09, 10:07 
Проблему наконец удалось решить с помощью более сведущих товарищей. Ниже описан рецепт, как проблема разрешилась в моём случае.

Итак необходимо пробросить влан, заведенные на catalyst 3750 по третьему уровню.
Имеем конфигурацию на каталистах 3750 с одной и второй стороны соответственно:

sw01#sh run int vlan 111
Building configuration...

Current configuration : 64 bytes
!
interface Vlan111
ip address 172.16.1.100 255.255.255.0
end

sw02#sh run int vlan 111
Building configuration...

Current configuration : 64 bytes
!
interface Vlan111
ip address 172.16.1.253 255.255.255.0
end

А на двух 7606 поднимаем кроссконнект

7606-1#sh run int Gi4/3.5111
Building configuration...

Current configuration : 140 bytes
!
interface GigabitEthernet4/3.5111
description test vlan 111
encapsulation dot1Q 111
xconnect x.x.x.x 5111 encapsulation mpls
end

7606-2#sh run int Gi4/24.111
Building configuration...

Current configuration : 142 bytes
!
interface GigabitEthernet4/24.111
description test vlan 111
encapsulation dot1Q 111
xconnect y.y.y.y 5111 encapsulation mpls
end

sw01#ping 172.16.1.253 source 172.16.1.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.253, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.100
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Всё работает, а грабли были вот в чем:
Имеем, что
3750 подключен в порт GigabitEthernet4/2 на 7606 с одной стороны, а второй
3750 подключен в порт GigabitEthernet4/3 7606 на обратной стороне.

Таким образом, если бы на 7606 я создал не интерфейс GigabitEthernet4/24.111, а скажем

GigabitEthernet4/3.111 или
GigabitEthernet4/6.111, эта бадяга работать не будет!

На 76 нужно создавать такой интерфейс, который будет иметь номер порта, указывающим откуда будет приходить пробрасываемый влан!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "l2tpv3 проброс через ip сеть"  
Сообщение от RifleMan email(??) on 19-Янв-09, 13:19 
EoMPLS: работает на любых (в т.ч. линейных) картах _только_
с сабинтерфейса.
с SVI: только при наличии SIP/ES и т.д.
L2TPv3: при наличии SIP карт (ES20 кажется ещё не осилили).

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру