The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"вопрос по разметке трафика сигнализации "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"вопрос по разметке трафика сигнализации "  
Сообщение от beaver33 email(??) on 25-Ноя-08, 10:06 
Всем привет, и удачи во всех Ваших сегодняшних делах.

Вопрос не нов, может Кто-нибудь где-то и встречался с этим.
Настроили у нас АТС с возможностью использования IP телефонии.  Данные, которые оставил
специалист
SIGNALING
Forwarding Class=AF3
Drop Precedence=LOW
MEDIA
Forwarding Class=EF
Drop Precedence=High
------------------------------------------------
что собственно я и отобразил в конфиге (но может быть и заблуждаюсь..... критику приветствую)
1. конфиг
class-map match-any Signaling
match  dscp cs3
match  dscp af31
class-map match-any Voice
match  dscp ef

policy-map QoSPolicy
class Voice
  priority percent 33
class Signaling
  bandwidth percent 5
class class-default
  fair-queue
  random-detect
policy-map mih_shape
class class-default
  shape average 256000
  service-policy QoSPolicy

2. прикрутил к интерфейсу
interface FastEthernet0/0
service-policy output QoSPolicy

3. статистика
sh class
-----------------------------------------------------------------
Class Map match-any class-default (id 0)
   Match any

Class Map match-any Signaling (id 5)
   Match   dscp af31 (26)
   Match   dscp af32 (28)
   Match   dscp af33 (30)


Class Map match-any Voice (id 6)
   Match   dscp ef (46)

sh policy-map interface FastEthernet0/0
-------------------------------------------------------------------------------
FastEthernet0/0

  Service-policy output: QoSPolicy

    Class-map: Voice (match-any)
      13191 packets, 976134 bytes
      5 minute offered rate 3000 bps, drop rate 0 bps
      Match:  dscp ef (46)
        13191 packets, 976134 bytes
        5 minute rate 3000 bps
      Queueing
        Strict Priority
        Output Queue: Conversation 264
        Bandwidth 33 (%)
        Bandwidth 33000 (kbps) Burst 825000 (Bytes)
        (pkts matched/bytes matched) 1/74
        (total drops/bytes drops) 0/0

    Class-map: Signaling (match-any)
      0 packets, 0 bytes <------->  ничего не попадает в сигнализацию :((
      5 minute offered rate 0 bps, drop rate 0 bps
       Match:  dscp af31 (26)
        0 packets, 0 bytes <-----> ничего не попадает в сигнализацию :((
        5 minute rate 0 bps
      Match:  dscp af32 (26)
        0 packets, 0 bytes <-----> ничего не попадает в сигнализацию :((
        5 minute rate 0 bps
       Match:  dscp af33 (30)
        0 packets, 0 bytes <-----> ничего не попадает в сигнализацию :((
        5 minute rate 0 bps
      Queueing
        Output Queue: Conversation 265
        Bandwidth 5 (%)
        Bandwidth 5000 (kbps)Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)
      38479 packets, 3917652 bytes
      5 minute offered rate 55000 bps, drop rate 0 bps
      Match: any
      Queueing
        Flow Based Fair Queueing
        Maximum Number of Hashed Queues 256
        (total queued/total drops/no-buffer drops) 0/0/0
         exponential weight: 9

  class    Transmitted      Random drop      Tail drop    Minimum Maximum  Mark
           pkts/bytes       pkts/bytes       pkts/bytes    thresh  thresh  prob
      0   38480/3917718         0/0              0/0           20      40  1/10
-------------------------------------------------------------------------------------
ну и собственно вопрос,
почему не попадает тарфик в сигнализацию ?
сотрудники звонят друг дружке, говорят и радуются как дети, и не знают, что есть такой вопросец.
Спасибо, и извиняюсь за Ваше оторванное время.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "вопрос по разметке трафика сигнализации "  
Сообщение от GolDi (??) on 25-Ноя-08, 10:54 
>[оверквотинг удален]
>      0/0    
>         0/0  
>         20  
>    40  1/10
>-------------------------------------------------------------------------------------
>ну и собственно вопрос,
>почему не попадает тарфик в сигнализацию ?
>сотрудники звонят друг дружке, говорят и радуются как дети, и не знают,
>что есть такой вопросец.
>Спасибо, и извиняюсь за Ваше оторванное время.

Видимо сигнализация не попадает в этот класс, а идёт в default классе.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "вопрос по разметке трафика сигнализации "  
Сообщение от beaver33 email(??) on 25-Ноя-08, 11:04 
>>ну и собственно вопрос,
>>почему не попадает тарфик в сигнализацию ?
>>сотрудники звонят друг дружке, говорят и радуются как дети, и не знают,
>>что есть такой вопросец.
>>Спасибо, и извиняюсь за Ваше оторванное время.
>
>Видимо сигнализация не попадает в этот класс, а идёт в default классе.
>

-----------------------------------------------------------------------------------
Спасибо, GolDi за Ваш быстрый ответ !
а возможно ли на цисках этот момент отловить debug'ом ?
потому как всё работает, но сигнализацию не видит ни провайдер ни мы.
и почему может не размечаться и не попадать сигнализация в своё правило ?
условия нам специалист озвучил
SIGNALING
Forwarding Class=AF3
Drop Precedence=LOW
MEDIA
Forwarding Class=EF
Drop Precedence=High

голос и дефолт считается.... :(
Спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "вопрос по разметке трафика сигнализации "  
Сообщение от ru_irk_LEXX (ok) on 26-Ноя-08, 19:28 
Может вы просто не метите сигнализацию?
Допустим, в войповом диалпире (если циска как voip-гейтом работает)
что-то ip qos dscp af3 signalling прописать?

Насколько я понимаю, вопрос у вас изначально возник на тему "как сделать приоритезацию голоса провайдером"?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "вопрос по разметке трафика сигнализации "  
Сообщение от Mick66 (ok) on 27-Ноя-08, 07:03 
Можно так:
class-map match-all v-sig
  match ip dscp af31

а можно и так:
class-map match-all v-sig
  match access-group 110


access-list 110 permit tcp any eq 1720 any
access-list 110 permit tcp any any eq 1720

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "вопрос по разметке трафика сигнализации "  
Сообщение от beaver33 email(??) on 28-Ноя-08, 08:45 
>[оверквотинг удален]
>class-map match-all v-sig
>  match ip dscp af31
>
>а можно и так:
> class-map match-all v-sig
>  match access-group 110
>
>
> access-list 110 permit tcp any eq 1720 any
> access-list 110 permit tcp any any eq 1720

Здравсуйте, Mick66. Спасибо за Ваше внимание.
я поизучал Ваш совет с пристрастием и знаете - что-то всё-таки полезло в сигнализацию

class-map match-any Signaling
match access-group 140
match ip dscp af31
match ip dscp af33
match ip dscp af32

Extended IP access list 140
    10 permit tcp any eq 2427 any (3 matches)
    20 permit udp any eq 2427 any (3386 matches)
    30 permit tcp any eq 3000 any (10 matches)

именно по этим портам атс и работает. Буду посмотреть, что там и как.
Спасибо, Mick66 !  Удачи Вам в во всех Ваших делах !!!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "вопрос по разметке трафика сигнализации "  
Сообщение от beaver33 (ok) on 30-Ноя-08, 20:37 
>[оверквотинг удален]
>matches)
>    20 permit udp any eq 2427 any (3386
>matches)
>    30 permit tcp any eq 3000 any (10
>matches)
>
>именно по этим портам атс и работает. Буду посмотреть, что там и
>как.
>Спасибо, Mick66 !  Удачи Вам в во всех Ваших делах !!!
>

Вот такой еще вопрос возник попутно, у меня на моём маршрутизаторе весь этот трафик
считается (в SDM диаграмма рисуется, что не может не радовать), а вот провайдер один раз говорит, что видит дефолт и войс и по прежнему не видит сигнализацию,
а в другой раз, на следующий день - что не видит ничего.

.... по прежнему безутешен в своей печали, от того объеиа знаний, которое постоянно изобретает человечество :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру