The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"cisco 871w wifi и интернет"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"cisco 871w wifi и интернет"  
Сообщение от Ecomak email(ok) on 01-Ноя-08, 15:12 
Есть сабжевая железка с 4 FastEthernet уровня 2 и одним ван уровень 3 и один вайфайный интерфейс.
Задача: получать по вану белый ip и в него натить машины пользователя, которые подключаются по вайфаю, для доступа в инет
Проблема в том, что в инет пускает только одного пользователя.. Если по вайфаю подключается еще одна машина, то она получает  ip адрес из подести 192.168.1.254, но в инет доступа нет. С циски машина пингуется, а вот в трансляциях её не видно.

Как сделать, чтобы все машины, подклюенные по беспроводной сети выходили во вне?
Собственно конфиг

PromoWiFI#sh run
Building configuration...

Current configuration : 2151 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PromoWiFI
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxx
!
aaa new-model
!
!
!
aaa session-id common
!
resource policy
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool Local
   network 192.168.1.0 255.255.255.0
   dns-server a.a.a.a
   default-router 192.168.1.254
!
ip dhcp pool local_ethernet
   network 192.168.10.0 255.255.255.0
   dns-server a.a.a.a
   default-router 192.168.10.254
!
!
!
!
!
!
!
!
bridge crb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address 77.238.239.233 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
description PromoWiFI
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
encryption mode ciphers tkip
!
ssid PromoWiFI
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 12345678
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 192.168.10.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan2
no ip address
!
interface Dialer0
no ip address
!
ip default-gateway gateway_ip
ip classless
ip route 0.0.0.0 0.0.0.0 gateway_ip
!
no ip http server
no ip http secure-server
ip nat pool Local b.b.b.b b.b.b.b netmask 255.255.255.0
ip nat inside source list 3 pool Local
!
access-list 3 permit 192.168.1.0 0.0.0.255
access-list 3 permit 192.168.10.0 0.0.0.255
!
control-plane
!
bridge 10 protocol vlan-bridge
bridge 10 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "cisco 871w wifi и интернет"  
Сообщение от GolDi (??) on 01-Ноя-08, 15:16 
>[оверквотинг удален]
>bridge 10 protocol vlan-bridge
>bridge 10 route ip
>!
>line con 0
> no modem enable
>line aux 0
>line vty 0 4
>!
>scheduler max-task-time 5000
>end

А размер pool-а позволяет натиться нескольким машинам?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "cisco 871w wifi и интернет"  
Сообщение от Ecomak email(ok) on 01-Ноя-08, 15:24 
А что им помешает натится?
В пуле один ip адрес. У меня везде сделано так, что в один внешний адрес натится вся серая подсеть класса С

>>end
>
> А размер pool-а позволяет натиться нескольким машинам?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "cisco 871w wifi и интернет"  
Сообщение от Ecomak email(ok) on 05-Ноя-08, 11:55 
в конец строки
ip nat inside source list 3 pool Local
надо добавить overload и всс заработает :)

ip nat inside source list 3 pool Local overload

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру