The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"VPN работает но как-то странно!"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"VPN работает но как-то странно!"  
Сообщение от dmitryp (ok) on 07-Авг-08, 21:17 
Настроил VPN доступ из дома на работу (cisco 2821) - connected! Все Ok! Получаю из пула ip адрес! Но на этом везение и заканчивается! Удаленную сеть не видно никак! Объясните плиз почему это может происходить?
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "VPN работает но как-то странно!"  
Сообщение от Keeper (??) on 07-Авг-08, 21:37 
>Настроил VPN доступ из дома на работу (cisco 2821) - connected! Все
>Ok! Получаю из пула ip адрес! Но на этом везение и
>заканчивается! Удаленную сеть не видно никак! Объясните плиз почему это может
>происходить?

\видимо, потому что широковещательные запросы не проходят по такому каналу.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "VPN работает но как-то странно!"  
Сообщение от dmitryp (ok) on 07-Авг-08, 22:01 
>>Настроил VPN доступ из дома на работу (cisco 2821) - connected! Все
>>Ok! Получаю из пула ip адрес! Но на этом везение и
>>заканчивается! Удаленную сеть не видно никак! Объясните плиз почему это может
>>происходить?
>
>\видимо, потому что широковещательные запросы не проходят по такому каналу.

Увеличение скорости канала провайдером может помочь?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "VPN работает но как-то странно!"  
Сообщение от igmikor (ok) on 07-Авг-08, 22:13 
>>>Настроил VPN доступ из дома на работу (cisco 2821) - connected! Все
>>>Ok! Получаю из пула ip адрес! Но на этом везение и
>>>заканчивается! Удаленную сеть не видно никак! Объясните плиз почему это может
>>>происходить?
>>
>>\видимо, потому что широковещательные запросы не проходят по такому каналу.
>
>Увеличение скорости канала провайдером может помочь?

Уважаемый, без конфигов - это просто гадание.
Кроме того, не забывайте про маршрутизацию. на обоих сторонах VPN канала хосты должны знать, на какой роутер отправлять пакеты в ответ на запрос.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "VPN работает но как-то странно!"  
Сообщение от dmitryp (??) on 07-Авг-08, 22:33 
>[оверквотинг удален]
>>>>происходить?
>>>
>>>\видимо, потому что широковещательные запросы не проходят по такому каналу.
>>
>>Увеличение скорости канала провайдером может помочь?
>
>Уважаемый, без конфигов - это просто гадание.
>Кроме того, не забывайте про маршрутизацию. на обоих сторонах VPN канала хосты
>должны знать, на какой роутер отправлять пакеты в ответ на запрос.
>

Полного конфига вот именно сейчас дать не могу но вот что касается vpn то сделал следующее

aaa new-model
aaa authentication login default local
aaa authentication login vpn_xauth local
aaa authorization exec default local
aaa authorization network vpn_group local
aaa session-id common
username dmitryp privilege 15 password 0 tiktak
!
ip local pool POOL_VPN 192.168.1.10 192.168.1.20    
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp client configuration group ups
key 12345678
pool POOL_VPN
acl 150                        
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map DYN 1
set transform-set ESP-3DES-SHA
reverse-route                    
!
crypto map CMAP client authentication list vpn_xauth
crypto map CMAP isakmp authorization list vpn_group
crypto map CMAP client configuration address respond
crypto map CMAP 65535 ipsec-isakmp dynamic DYN
!
interface FastEthernet0/0
ip address 195.14.35.X 255.255.255.248
crypto map CMAP
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
!
access-list 150 permit ip 192.168.1.0 0.0.0.255 any

Хотя это в принципе почти что и все! Ну плюс еще статический маршрут конечно!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "VPN работает но как-то странно!"  
Сообщение от igmikor (ok) on 07-Авг-08, 23:42 
>[оверквотинг удален]
>Полного конфига вот именно сейчас дать не могу но вот что касается
>vpn то сделал следующее
>
>aaa new-model
>aaa authentication login default local
>aaa authentication login vpn_xauth local
>aaa authorization exec default local
>aaa authorization network vpn_group local
>aaa session-id common
>username dmitryp privilege 15 password 0 tiktak

я бы завел отдельного пользователя для подключения по VPN

>!
>ip local pool POOL_VPN 192.168.1.10 192.168.1.20

рекомендую назначать IP адреса из совсем другой сети. иначе возникает проблема с маршрутизацией.
ip local pool POOL_VPN 172.16.1.10 172.16.1.20

>[оверквотинг удален]
>crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
>!
>crypto dynamic-map DYN 1
> set transform-set ESP-3DES-SHA
> reverse-route
>!
>crypto map CMAP client authentication list vpn_xauth
>crypto map CMAP isakmp authorization list vpn_group
>crypto map CMAP client configuration address respond
>crypto map CMAP 65535 ipsec-isakmp dynamic DYN

просто так. странно большой номер у crypto map пусть будет 5

>!
>interface FastEthernet0/0
>ip address 195.14.35.X 255.255.255.248
> crypto map CMAP
>!
>interface FastEthernet0/1
> ip address 192.168.1.1 255.255.255.0
>!
>access-list 150 permit ip 192.168.1.0 0.0.0.255 any

здесь тоже поправить можно
access-list 150 permit ip 192.168.1.0 0.0.0.255 172.16.0.0 0.0.255.255

>
>Хотя это в принципе почти что и все! Ну плюс еще статический
>маршрут конечно!

И на хостах в сети прописать типа
route add 172.16.0.0 mask 255.255.0.0 192.168.1.1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру