The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"второй адрес интерфейсу Serial0"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 14:58 
Здравствуйте!

у меня на интерфейсе Serial0 висит модем завязаный с другим модемом, и интерфейс по протоколу PPP получает адресс по согласованию "negociated", внимание вопрос....:-) как присвоить еще один адресс secondari этому интерфейсу? адресс будет реальный...., циска говорит что нельзя присвоить адрес secodari, если был присвоен адрес по negociated?

Как быть в данной ситуации

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "второй адрес интерфейсу Serial0"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 16:39 
>Здравствуйте!
>
>у меня на интерфейсе Serial0 висит модем завязаный с другим модемом, и
>интерфейс по протоколу PPP получает адресс по согласованию "negociated", внимание вопрос....:-)
>как присвоить еще один адресс secondari этому интерфейсу? адресс будет реальный....,
>циска говорит что нельзя присвоить адрес secodari, если был присвоен адрес
>по negociated?
>
>Как быть в данной ситуации

прописать первый и второй адрес статикой

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "второй адрес интерфейсу Serial0"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 16:40 
>[оверквотинг удален]
>>
>>у меня на интерфейсе Serial0 висит модем завязаный с другим модемом, и
>>интерфейс по протоколу PPP получает адресс по согласованию "negociated", внимание вопрос....:-)
>>как присвоить еще один адресс secondari этому интерфейсу? адресс будет реальный....,
>>циска говорит что нельзя присвоить адрес secodari, если был присвоен адрес
>>по negociated?
>>
>>Как быть в данной ситуации
>
>прописать первый и второй адрес статикой

а вообще, вероятно можно и обойтись без второго адреса на интерфейсе
что за нужда в нем?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 17:22 
>
>а вообще, вероятно можно и обойтись без второго адреса на интерфейсе
>что за нужда в нем?

     второй адресс реальный и под ним осуществляется выход в инет.., а под теми которые получаю по PPP настоена корпоративная сеть... данная реализация работает на маршрутизаторе, который организован под FreeBSD. А теперь его нужно заменить на Cisco 805.
      По поводу того чтобы статически прописать адреса... возникает вопрос... по ppp я получаю адрес допустим 192.168.1.2 с маской 255.255.255.255, какую маску я пропишу при указании статического адреса? на 255,255,255,255 он ругается....


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "второй адрес интерфейсу Serial0"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 17:35 
>[оверквотинг удален]
>>что за нужда в нем?
>
>     второй адресс реальный и под ним осуществляется
>выход в инет.., а под теми которые получаю по PPP настоена
>корпоративная сеть... данная реализация работает на маршрутизаторе, который организован под FreeBSD.
>А теперь его нужно заменить на Cisco 805.
>      По поводу того чтобы статически прописать
>адреса... возникает вопрос... по ppp я получаю адрес допустим 192.168.1.2 с
>маской 255.255.255.255, какую маску я пропишу при указании статического адреса? на
>255,255,255,255 он ругается....

не вдаваясь в детали ваших хитрых настроек, конкретно вот это решается так:
int loop 0
ip add 192.168..1.2 255.255.255.255

int s0/0
ip unn loo0

если вы мигрируете с фри, то не стоит создавать подобную конструкцию на циске
нарисуйте схуму подключения и покажите что к чему, вполне возможно что есть простые решения

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 17:58 
>[оверквотинг удален]
>int loop 0
>ip add 192.168..1.2 255.255.255.255
>
>int s0/0
>ip unn loo0
>
>если вы мигрируете с фри, то не стоит создавать подобную конструкцию на
>циске
>нарисуйте схуму подключения и покажите что к чему, вполне возможно что есть
>простые решения

интересное решение....а как вариант создать субинтерфейс уже с реальным, дополнительным адресом, зачем его перенаправлять на loopback ...
я пробывал поднять субинтерфейс, но после команды ser 0.1 циска пишет что это не возможно.. почему?
Serial 0 уже настроен и работает...
вот конфиг....

!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
logging queue-limit 100
!
ip subnet-zero
ip dhcp excluded-address 10.5.77.1 10.5.77.10
!
ip dhcp pool DHCPpool#1
   network 10.5.77.0 255.255.255.0
   default-router 10.5.77.1
   dns-server 10.5.77.3
!
!
!
!
interface Ethernet0
ip address 10.5.77.1 255.255.255.0
ip nat inside
!
interface Serial0
physical-layer async
ip address negotiated
ip nat outside
encapsulation ppp
async mode dedicated
no keepalive
ppp pap sent-username test password 0 test
!
ip nat inside source list 1 interface Serial0 overload
ip classless
ip route 10.5.64.0 255.255.255.0 Serial0
ip http server
!
!
access-list 1 permit 10.0.0.0 0.255.255.255
!
line con 0
password ,ecblj
login
stopbits 1
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
password ,ecblj
login
!
end


В моей ситуации нужно заменить только роутер на другой... схема проста


                (х.х.х.х- реальный адрес)--              -----(Интернет)
лвс-----Cisco 805                         ---провайдер---
               (172.2.x.x-корпоратив)------              ----(корпоратвная сеть)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "второй адрес интерфейсу Serial0"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 18:15 
>[оверквотинг удален]
>
>            
>    (х.х.х.х- реальный адрес)--    
>         -----(Интернет)
>лвс-----Cisco 805          
>          
>   ---провайдер---
>            
>   (172.2.x.x-корпоратив)------        
>      ----(корпоратвная сеть)

в схему не воткнул... понять что к чему не смог
своими словами опишите
и что такое за сеть 10.5.64.0 255
я так понял корпоратив лежит дальше за тем же serial0 ?
или где?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 19:32 
>[оверквотинг удален]
>>   ---провайдер---
>>            
>>   (172.2.x.x-корпоратив)------        
>>      ----(корпоратвная сеть)
>
>в схему не воткнул... понять что к чему не смог
>своими словами опишите
>и что такое за сеть 10.5.64.0 255
>я так понял корпоратив лежит дальше за тем же serial0 ?
>или где?

сори ... 10.5.64.0 это подсеть за подсетью 172.2.х.х

        
           (х.х.х.х- реальный адрес)                    l---(Интернет)
лвс--(Cisco 805) 172.2.x.2->ppp->172.2.x.1(провайдер)---l
                                                        l---(172.2.x.x корпоратив)  
                                                                        l       l
                                                                        l       l  и т.д
                                                                        l       l
                                                                     подсеть   ...
                                                                    10.5.64.0 10.x.x.x
вобщем реализация реального адреса в этой ситуации больше зависит от провайдера, а менять они ничего не собираются т.к. существует оф договор. Т.к. организ. бюджетная... проще получается заменить один шлюз...

Но как поветить на Serial два адресса? вот мой вопрос.
И не могу поднять на этом же интерфейсе subinterface


    
      

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 19:35 
>[оверквотинг удален]
>вобщем реализация реального адреса в этой ситуации больше зависит от провайдера, а
>менять они ничего не собираются т.к. существует оф договор. Т.к. организ.
>бюджетная... проще получается заменить один шлюз...
>
>Но как поветить на Serial два адресса? вот мой вопрос.
>И не могу поднять на этом же интерфейсе subinterface
>
>
>
>

поплыл рисунок... если непонятно... перересую :-)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "второй адрес интерфейсу Serial0"  
Сообщение от GolDi (??) on 28-Май-08, 19:40 
>Но как поветить на Serial два адресса? вот мой вопрос.
>И не могу поднять на этом же интерфейсе subinterface
>
>

    На ppp второй адрес нельзя присвоить.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 19:51 

>
>    На ppp второй адрес нельзя присвоить.

как быть какие варианты?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "второй адрес интерфейсу Serial0"  
Сообщение от GolDi (??) on 28-Май-08, 19:56 
>
>>
>>    На ppp второй адрес нельзя присвоить.
>
>как быть какие варианты?

Рисовать понятную схему.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 20:13 
>
>Рисовать понятную схему.

                 лвс
                  |
                  |
             (Cisco 805)
              172.2.x.2 + (х.х.х.х- реальный адрес)
                  |
                  |
                 ppp
                  |
                  |
              (провайдер)-----ИНТЕРНЕТ
               172.2.x.1
                  |
                  |
             Корпоративная
                 сеть
              172.2.x.x    
                  |
                  |
           |---------------- и т.д....
           |                        |                                                  
           |                        |                                  
         подсеть             ...                                              
        10.5.64.0         10.x.x.x

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "второй адрес интерфейсу Serial0"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 20:50 
>[оверквотинг удален]
> |
>           |
>          
>          
> |
>         подсеть  
>          ...
>
>        10.5.64.0    
>     10.x.x.x

по вашей схеме получается что сеть 172.2.x. должна быть в двух сегментах сети по обе стороны провайдера
не правильно это
я не понимаю почему вы не можете по аналогии с маршрутом для сети 10.5.64.0 прописать маршрут для 172.2.x. в serial0
ну и что бы на других маршрутизаторах правильно прописали обратный маршрут

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 20:57 
>по вашей схеме получается что сеть 172.2.x. должна быть в двух сегментах
>сети по обе стороны провайдера
>не правильно это
>я не понимаю почему вы не можете по аналогии с маршрутом для
>сети 10.5.64.0 прописать маршрут для 172.2.x. в serial0
>ну и что бы на других маршрутизаторах правильно прописали обратный маршрут

потому что я не имею туда доступ, только к сваим маршрутизаторам..

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 21:01 

>потому что я не имею туда доступ, только к сваим маршрутизаторам..

по адресам 172.2.х.х все гуд. там все работает... мне нужно привязать реальный IP чтобы через него под NAT люди ходили в инет

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 21:07 
>
>по адресам 172.2.х.х все гуд. там все работает... мне нужно привязать реальный
>IP чтобы через него под NAT люди ходили в инет

На FreeBSD он был привязан к Serial интерфейсу как alias и смотрел на провайдера....
может повесить его на внутрений и прописать маршрутизацию...
если так то как маршрутизация должна выглядеть?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "второй адрес интерфейсу Serial0"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 21:17 
>
>>потому что я не имею туда доступ, только к сваим маршрутизаторам..
>
>по адресам 172.2.х.х все гуд. там все работает... мне нужно привязать реальный
>IP чтобы через него под NAT люди ходили в инет

а зачем вам что-то "привязывать"?
если просто прописать трансляцию на этот адрес?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 28-Май-08, 21:23 

>а зачем вам что-то "привязывать"?
>если просто прописать трансляцию на этот адрес?

можете понаписать как это должно выглядеть?
мне не понятно что вы имеете ввиду под трансляцией


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "второй адрес интерфейсу Serial0"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 22:04 
>
>>а зачем вам что-то "привязывать"?
>>если просто прописать трансляцию на этот адрес?
>
>можете понаписать как это должно выглядеть?
>мне не понятно что вы имеете ввиду под трансляцией

трансляции в смысле NAT/PAT
ip nat ins sou list NAT pool Pool1 overload
!
ip nat pool Pool1 172.2.1.1 172.2.1.1 255.255.255.252
!
ip access-list extanded NAT
deny ip lo.cal.net 0.0.0.255 10.56.0.0 0.0.0.255
per ip an an

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 29-Май-08, 17:22 
>[оверквотинг удален]
>>мне не понятно что вы имеете ввиду под трансляцией
>
>трансляции в смысле NAT/PAT
>ip nat ins sou list NAT pool Pool1 overload
>!
>ip nat pool Pool1 172.2.1.1 172.2.1.1 255.255.255.252
>!
>ip access-list extanded NAT
>deny ip lo.cal.net 0.0.0.255 10.56.0.0 0.0.0.255
>per ip an an

Спасибо всем кто помог, все решил через трансляцию ....:-)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "второй адрес интерфейсу Serial0"  
Сообщение от GolDi (??) on 29-Май-08, 11:47 
>
>>потому что я не имею туда доступ, только к сваим маршрутизаторам..
>
>по адресам 172.2.х.х все гуд. там все работает... мне нужно привязать реальный
>IP чтобы через него под NAT люди ходили в инет

  1. Создайте loopback
  2. Привязывайте реальный IP на loopback.
  3. Далее - если пакеты идут в internet, тогда их надо натить через loopback.
  4. Если пакеты идут в вашу сеткуза провайдером, то натить не надо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "второй адрес интерфейсу Serial0"  
Сообщение от Vetal email(??) on 30-Май-08, 17:35 
>  3. Далее - если пакеты идут в internet, тогда их
>надо натить через loopback.
>  4. Если пакеты идут в вашу сеткуза провайдером, то натить
>не надо.

как реализуется это условие?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру