The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"ограничивать скорость по Ip из одной подсети."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (ACL, фильтрация и ограничение трафика)
Изначальное сообщение [ Отслеживать ]

"ограничивать скорость по Ip из одной подсети."  +/
Сообщение от sergeyfromkomi (ok) on 20-Сен-12, 14:49 
Ув. инженеры подскажите, как можно ограничивать  скорость на каждого абонента индивидуально(на ip адрес), живущих в одной подсети(192.168.10.0/24) и затерминированных на один общий влан циски? В настоящий момент это решено на freebsd, возможно ли это решить на циске?

Подробно:
Абоненты работают по vlan per switch(на каждый дом свой отдельный влан). Каждый свич терминируется на подинтерфейс(192.168.10.1/24) freebsd. Каждый абонент видит только свой шлюз. Понятно, что абоненты одного свича имеют разные скорости. Единственное, что мешает уйти от freebsd, проблема с ИНДИВИДУАЛЬНЫМ ограничением скорости каждому абоненту в одной подсети (192.168.10.0/24).
Очевидно "навешивание" traffic-shape  на подинтерфейс ограничит скорость на всю сеть (192.168.10.0/24), а не на отдельный ip из этой сети.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "ограничивать скорость по Ip из одной подсети."  +/
Сообщение от fantom (ok) on 20-Сен-12, 15:32 
>[оверквотинг удален]
> влан циски? В настоящий момент это решено на freebsd, возможно ли
> это решить на циске?
> Подробно:
> Абоненты работают по vlan per switch(на каждый дом свой отдельный влан). Каждый
> свич терминируется на подинтерфейс(192.168.10.1/24) freebsd. Каждый абонент видит только
> свой шлюз. Понятно, что абоненты одного свича имеют разные скорости. Единственное,
> что мешает уйти от freebsd, проблема с ИНДИВИДУАЛЬНЫМ ограничением скорости каждому
> абоненту в одной подсети (192.168.10.0/24).
> Очевидно "навешивание" traffic-shape  на подинтерфейс ограничит скорость на всю сеть (192.168.10.0/24),
> а не на отдельный ip из этой сети.

вешайте service policy....

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "ограничивать скорость по Ip из одной подсети."  +/
Сообщение от sergeyfromkomi (ok) on 20-Сен-12, 15:54 
> вешайте service policy....

это ваше предположение или знания? есть пример реализации?


Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "ограничивать скорость по Ip из одной подсети."  +/
Сообщение от beepop (ok) on 20-Сен-12, 16:06 
>[оверквотинг удален]
> влан циски? В настоящий момент это решено на freebsd, возможно ли
> это решить на циске?
> Подробно:
> Абоненты работают по vlan per switch(на каждый дом свой отдельный влан). Каждый
> свич терминируется на подинтерфейс(192.168.10.1/24) freebsd. Каждый абонент видит только
> свой шлюз. Понятно, что абоненты одного свича имеют разные скорости. Единственное,
> что мешает уйти от freebsd, проблема с ИНДИВИДУАЛЬНЫМ ограничением скорости каждому
> абоненту в одной подсети (192.168.10.0/24).
> Очевидно "навешивание" traffic-shape  на подинтерфейс ограничит скорость на всю сеть (192.168.10.0/24),
> а не на отдельный ip из этой сети.

class-map match-any myIP
match access-group 2041
class-map match-any notmyIP
match access-group 2042
!
!
policy-map shape
class myIP
   police rate 6000000 bps peak-rate 6000000 bps
     conform-action transmit
     exceed-action drop
     violate-action drop
class notmyIP
   police rate 5000000 bps peak-rate 5000000 bps
     conform-action transmit
     exceed-action drop
     violate-action drop
!
!
interface GigabitEthernet0/2.xxx
description myNETWORK
encapsulation dot1Q 711
ip address xxx.xxx.xxx.xxx 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
service-policy input shape
service-policy output shape
!
!
access-list 2041 permit ip xxx.xxx.xxx.xxx 0.0.0.7 any
access-list 2041 permit ip any xxx.xxx.xxx.xxx 0.0.0.7
access-list 2041 deny   ip any any
access-list 2042 permit ip xxx.xxx.xxx.xxx 0.0.0.7 any
access-list 2042 permit ip any xxx.xxx.xxx.xxx 0.0.0.7
access-list 2042 deny   ip any any

ну аксесс листы под себя правте не подсетями указывайте к примеру а конкретным адресом

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "ограничивать скорость по Ip из одной подсети."  +/
Сообщение от sergeyfromkomi (ok) on 20-Сен-12, 17:48 
>[оверквотинг удален]
> !
> !
> access-list 2041 permit ip xxx.xxx.xxx.xxx 0.0.0.7 any
> access-list 2041 permit ip any xxx.xxx.xxx.xxx 0.0.0.7
> access-list 2041 deny   ip any any
> access-list 2042 permit ip xxx.xxx.xxx.xxx 0.0.0.7 any
> access-list 2042 permit ip any xxx.xxx.xxx.xxx 0.0.0.7
> access-list 2042 deny   ip any any
> ну аксесс листы под себя правте не подсетями указывайте к примеру а
> конкретным адресом

если необходимо именно каждому конкретному адресу нарезать полосу ( а не всей сети ) то придется писать отдельный класс ?
вот допустим у есть 100 пользователей и у каждого свой адрес. Пишем 100 ACL и 100 class-map ?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "ограничивать скорость по Ip из одной подсети."  +/
Сообщение от beepop (ok) on 20-Сен-12, 18:06 
>[оверквотинг удален]
>> access-list 2041 deny   ip any any
>> access-list 2042 permit ip xxx.xxx.xxx.xxx 0.0.0.7 any
>> access-list 2042 permit ip any xxx.xxx.xxx.xxx 0.0.0.7
>> access-list 2042 deny   ip any any
>> ну аксесс листы под себя правте не подсетями указывайте к примеру а
>> конкретным адресом
> если необходимо именно каждому конкретному адресу нарезать полосу ( а не всей
> сети ) то придется писать отдельный класс ?
> вот допустим у есть 100 пользователей и у каждого свой адрес. Пишем
> 100 ACL и 100 class-map ?

класс режет вам канал для всех пользователей которые входят в его ACL, если вам нужно для каждого индивидуально - то сколько пользователей столько и классов соответственно.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "ограничивать скорость по Ip из одной подсети."  +/
Сообщение от RSG (??) on 21-Сен-12, 09:14 
> В настоящий момент это решено на freebsd, возможно ли
> это решить на циске?

Может это:

http://www.cisco.com/en/US/tech/tk389/tk813/tk863/tsd_techno...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру