The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"VPN на IPSEC'e иногда подвисает, как правило, на 1 час "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от Nikolay email(??) on 29-Авг-07, 02:20 
Прошу помощи в разрешении проблемы:
VPN на IPSEC'e иногда подвисает, как правило, на 1 час

Используем роутер Cisco SB101-K9:
туннель задаем как указано ниже:

crypto isakmp policy 20
hash md5
authentication pre-share
crypto isakmp key xxxxxxxxxxxxxxxxx address 217.14.48.65
crypto isakmp keepalive 60 5
crypto isakmp nat keepalive 10
!
!
crypto ipsec transform-set myset esp-des esp-md5-hmac
!
crypto map toRemoteSite 10 ipsec-isakmp
set peer 217.14.48.65
set transform-set myset
match address 111

И поднимаем его на интерфейсе:
!
interface Ethernet1
ip address 192.168.200.60 255.255.255.0
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
no cdp enable
crypto map toRemoteSite
!
Случается подвисание канала в самый неподходящий момент.
И как правило через ~ 1час , если ничего не делать, он сам поднимается.
Чтобы столько не ждать, опускаю/поднимаю int e1 или перепрописываю строку
crypto map toRemoteSite на этом int e1.

Когда канал висит на sh cry isa sa дает следующее
dst             src             state          conn-id slot status
217.14.48.65    192.168.200.60  MM_NO_STATE          0    0 ACTIVE
217.14.48.65    192.168.200.60  MM_NO_STATE          0    0 ACTIVE (deleted)

Как это исправить? Или поставить проверку и по ней делать перезапуск.
Час слишком большой простой, а доступ до железки есть не всегда.    

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от Logan (??) on 29-Авг-07, 10:11 
>[оверквотинг удален]
>   state        
>  conn-id slot status
>217.14.48.65    192.168.200.60  MM_NO_STATE      
>    0    0 ACTIVE
>217.14.48.65    192.168.200.60  MM_NO_STATE      
>    0    0 ACTIVE (deleted)
>
>
>Как это исправить? Или поставить проверку и по ней делать перезапуск.
>Час слишком большой простой, а доступ до железки есть не всегда.

Попробуйте убрать строки :
crypto isakmp keepalive 60 5
crypto isakmp nat keepalive 10

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от ccenter email(ok) on 30-Авг-07, 03:24 
>
>Попробуйте убрать строки :
>crypto isakmp keepalive 60 5
>crypto isakmp nat keepalive 10

Так эти строки как раз включают механизм, который должен устранять эти зависания.

Из приведенной части конфига видно, что мой роутер находится за NAT'ом, и согласно рекомендациям CISCO я включаю эти команды:    

= crypto isakmp keepalive 60 5  = проверяет нет-ли потери канала и при обнаружении такого должен запустит процедуру установления пира по новой. И вот тут, видимо, какой-то сбой происходит. Потому что при "ручном" перезапуске пир поднимается.

= crypto isakmp nat keepalive 10 =  это нужно, т.к. я нахожусь за натом.

Что еще посоветуете?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от ВОЛКА email on 30-Авг-07, 09:34 
а на другой стороне что?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от ccenter email(??) on 31-Авг-07, 12:58 
>а на другой стороне что?

cisco 3620


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от ccenter email(??) on 02-Сен-07, 07:06 
>>а на другой стороне что?
>
>cisco 3620

Есть предложения?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от dxer on 08-Сен-07, 01:05 
>>>а на другой стороне что?
>>
>>cisco 3620
>
>Есть предложения?

Обновить IOS как вариант, по конфигу нареканий нет, на самом деле.....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "VPN на IPSEC'e иногда подвисает, как правило, на 1 час "  +/
Сообщение от Filosof email on 01-Окт-09, 21:54 
>Случается подвисание канала в самый неподходящий момент.
>И как правило через ~ 1час , если ничего не делать, он
>сам поднимается.
>Чтобы столько не ждать, опускаю/поднимаю int e1 или перепрописываю строку
>crypto map toRemoteSite на этом int e1.

классно, у меня он, зараза не поднимается, помогает только ребут.
Сейчас и ребут не помогает...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру