The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Организация резервного канала: что выбрать?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Организация резервного канала: что выбрать?"  
Сообщение от lerik on 17-Авг-07, 10:49 
Всем привет!
Задача:
2 cisco871 связаны между собой через два различных канала. На каждой из цисок поднят loopback интерфейс:

router1:
interface Loopback0
ip addr 192.168.231.1 255.255.255.255

router2:
interface Loopback0
ip addr 192.168.231.2 255.255.255.255

Надо сделать так, чтоб каждой циске был доступен loopback интерфейс соседней через оба канала (один основной, другой резервный). При этом варианты с протоколами RIP, EIGRP и прочими не подходят, т.к. они используют мультикаст. Остается вариант с BGP либо "Надежная статическая резервная маршрутизация с отслеживанием объектов" (вчера нарыл нарыл на сайте киски и никогда не пробывал). Вот пример такой конфигурации (router1):

interface Loopback0
ip address 192.168.231.1 255.255.255.255

interface ethernet 0
description primary-link
ip address 10.1.1.1 255.255.255.0

interface ethernet 1
description backup-link
ip address 10.2.2.2 255.255.255.0

ip sla monitor 1
type echo protocol ipIcmpEcho 192.168.231.2
timeout 1000
frequency 3
threshold 2

ip sla monitor schedule 1 life forever start-time now
track 123 rtr 1 reachability

access list 101 permit icmp any host 192.168.231.2 echo
route map MY-LOCAL-POLICY permit 10
match ip address 101
set ip next-hop 10.1.1.242
set interface null 0
!
ip local policy route-map MY-LOCAL-POLICY

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123
ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

В данном примере основной сеть 10.1.1.0/24 - это сетка основного канала, 10.2.2.0/24 - резервного. Настройка второй циске - аналогичная.


Вопрос: что лучше использовать???

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Организация резервного канала: что выбрать?"  
Сообщение от lerik on 17-Авг-07, 10:51 
Т.е. что лучше BGP или приведенный выше способ или может есть еще какой-нить вариант. Главное, чтоб обойтись без хождения мультикастов в основном и резервном каналах.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Организация резервного канала: что выбрать?"  
Сообщение от sm00th (??) on 17-Авг-07, 14:27 
>Т.е. что лучше BGP или приведенный выше способ или может есть еще
>какой-нить вариант. Главное, чтоб обойтись без хождения мультикастов в основном и
>резервном каналах.

не знаю как со sla конечно
но в BGP вариант вполне реальный и проверенный. Поднимаешь между ними BGP-сессию. И в качестве bgp router-id указываешь loopback своей циски. Ну на крайняк можно его анонсировать по BGP - но по идее bgp router-id должно хватить.
Мультикаст BGP не использует - т.к. там создаётся соединение IP-IP - которое жёстко прописывается на рутере.

+ имеешь 2 линка с резервом.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру