The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Классификация 'плохого' трафика"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (ACL, фильтрация и ограничение трафика)
Изначальное сообщение [ Отслеживать ]

"Классификация 'плохого' трафика"  +/
Сообщение от LILO email(ok) on 12-Авг-07, 15:07 
Добрый день.

есть жалание на пограничнм роутере "порезать" весь не совсем хороший трафик типа p2p
я думаю, что подобные задачи уже решались, поэтму пришел за советом.
работаю я на 7200/G1 на данный момент потоки не привышают 100Mbs, соответвенно ресурсы есть по QoS/CAR.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Классификация 'плохого' трафика"  +/
Сообщение от asto (??) on 14-Авг-07, 07:09 
>Добрый день.
>
>есть жалание на пограничнм роутере "порезать" весь не совсем хороший трафик типа
>p2p
>я думаю, что подобные задачи уже решались, поэтму пришел за советом.
>работаю я на 7200/G1 на данный момент потоки не привышают 100Mbs, соответвенно
>ресурсы есть по QoS/CAR.

классифируйте трафик например с помощью nbar и режьте полосу пропускания для класса ptp-трафика

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Классификация 'плохого' трафика"  +/
Сообщение от LILO email(??) on 14-Авг-07, 13:56 
>>Добрый день.
>>
>>есть жалание на пограничнм роутере "порезать" весь не совсем хороший трафик типа
>>p2p
>>я думаю, что подобные задачи уже решались, поэтму пришел за советом.
>>работаю я на 7200/G1 на данный момент потоки не привышают 100Mbs, соответвенно
>>ресурсы есть по QoS/CAR.
>
>классифируйте трафик например с помощью nbar и режьте полосу пропускания для класса
>ptp-трафика

пример не покажите ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Классификация 'плохого' трафика"  +/
Сообщение от asto (??) on 14-Авг-07, 15:13 
class-map match-any ptp_traffic
match protocol kazaa
match protocol napster

policy-map ptp_policed
class ptp_traffic
police 128000 8000 exceed-action drop

interface s0/0
service-policy output ptp_policed

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Классификация 'плохого' трафика"  +/
Сообщение от LILO email(??) on 14-Авг-07, 17:49 
>class-map match-any ptp_traffic
>match protocol kazaa
>match protocol napster
>
>policy-map ptp_policed
>class ptp_traffic
>police 128000 8000 exceed-action drop
>
>interface s0/0
>service-policy output ptp_policed

а какким образом классифицировать трафик torrent,emule ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Классификация 'плохого' трафика"  +/
Сообщение от asto (??) on 15-Авг-07, 06:50 
для eMule по-моему match protocol edonkey - не помню точно как, циски тоже нету под рукой. будете конфигурировать, посмотрите сами :)
не знаю, есть или нет торрент в базе nbar, но в случае отсутствия его  можно добавить ручками через acl:
match access-list torrent

ip access-list extended torrent
permit tcp any range 6681 6689 any eq 6969

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Классификация 'плохого' трафика"  +/
Сообщение от Andrei_V email(ok) on 09-Фев-08, 12:37 
>class-map match-any ptp_traffic
>match protocol kazaa
>match protocol napster
>
>policy-map ptp_policed
>class ptp_traffic
>police 128000 8000 exceed-action drop
>
>interface s0/0
>service-policy output ptp_policed

Собственно так и сделал:

Положил вот эти файлики: bittorrent.pdlm directconnect.pdlm eDonkey.pdlm
как бинарники на циску: copy tftp: flash:

И потом настроил полисинг:

ip nbar pdlm flash:bittorrent.pdlm
ip nbar pdlm flash:eDonkey.pdlm
ip nbar pdlm flash:directconnect.pdlm

class-map match-all torrents
match protocol bittorrent
match protocol edonkey
match protocol directconnect

policy-map limit-torrents
class torrents
police 512000 32000 64000 conform-action transmit exceed-action drop violate-action drop

interface FastEthernet1/0
service-policy input limit-torrents

Т.е. ограничил всех любителей торрентов на 512К.
После дня работы смотрю статистику и не вижу, чтобы этот полисинг вообще хотя бы что-то отработал:

sh policy-map int fa 1/0
FastEthernet1/0

  Service-policy input: limit-torrents

    Class-map: torrents (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol bittorrent
      Match: protocol edonkey
      Match: protocol directconnect
      police:
        512000 bps, 32000 limit, 64000 extended limit
        conformed 0 packets, 0 bytes; action: transmit
        exceeded 0 packets, 0 bytes; action: drop
        violated 0 packets, 0 bytes; action: drop
        conformed 0 bps, exceed 0 bps, violate 0 bps

    Class-map: class-default (match-any)
      39644 packets, 14310277 bytes
      5 minute offered rate 291000 bps, drop rate 0 bps
      Match: any

Что-то сделал не так?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Классификация 'плохого' трафика"  +/
Сообщение от sergey (??) on 22-Окт-10, 10:24 
думаю стоит заменить  

class-map match-all
на
class-map match-any

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Классификация 'плохого' трафика"  +/
Сообщение от Andrei_V email(ok) on 22-Окт-10, 14:12 
Сейчас сделано так:

ip nbar pdlm flash:bittorrent.pdlm
ip nbar pdlm flash:eDonkey.pdlm
ip nbar pdlm flash:directconnect.pdlm

class-map match-any torrents
  match protocol bittorrent
  match protocol edonkey
  match protocol directconnect

policy-map limit-torrents
class torrents
    police 4096000 1536000 1536000 conform-action transmit  exceed-action drop

interface FastEthernet0/0
...
service-policy input limit-torrents
service-policy output limit-torrents


Почти ничего не матчится:

C3725#sh policy-map int fa 0/0
FastEthernet0/0

  Service-policy input: limit-torrents

    Class-map: torrents (match-any)
      23500 packets, 3778342 bytes
      5 minute offered rate 5000 bps, drop rate 0 bps
      Match: protocol bittorrent
        23423 packets, 3716676 bytes
        5 minute rate 5000 bps
      Match: protocol edonkey
        77 packets, 61666 bytes
        5 minute rate 0 bps
      Match: protocol directconnect
        0 packets, 0 bytes
        5 minute rate 0 bps
      police:
          cir 4096000 bps, bc 1536000 bytes
        conformed 23500 packets, 3778342 bytes; actions:
          transmit
        exceeded 0 packets, 0 bytes; actions:
          drop
        conformed 5000 bps, exceed 0 bps

    Class-map: class-default (match-any)
      23248367 packets, 9121220314 bytes
      5 minute offered rate 9670000 bps, drop rate 0 bps
      Match: any

  Service-policy output: limit-torrents

    Class-map: torrents (match-any)
      8580 packets, 1750711 bytes
      5 minute offered rate 5000 bps, drop rate 0 bps
      Match: protocol bittorrent
        8552 packets, 1727678 bytes
        5 minute rate 5000 bps
      Match: protocol edonkey
        28 packets, 23033 bytes
        5 minute rate 0 bps
      Match: protocol directconnect
        0 packets, 0 bytes
        5 minute rate 0 bps
      police:
          cir 4096000 bps, bc 1536000 bytes
        conformed 8580 packets, 1750711 bytes; actions:
          transmit
        exceeded 0 packets, 0 bytes; actions:
          drop
        conformed 5000 bps, exceed 0 bps

    Class-map: class-default (match-any)
      7662414 packets, 3227689044 bytes
      5 minute offered rate 9524000 bps, drop rate 0 bps
      Match: any

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру