The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"VPN на Cisco PIX-515 + D-Link DFL-200 не устанавливается до ..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"VPN на Cisco PIX-515 + D-Link DFL-200 не устанавливается до ..."  
Сообщение от AlexeyI email(ok) on 01-Мрт-07, 18:16 
Здравствуйте!
Помогите решить следующую проблему – не устанавливается тоннель между DFL-200 и Cisco PIX 515.
IKE устанавливается, а вот IPSec почемуто не работает

Конфиг для Cisco:
: Saved
: Written by enable_15 at 09:13:04.700 UTC Thu Mar 1 2007
!
PIX Version 7.2(2)
!
hostname pixfirewall
domain-name office.ru
enable password * encrypted
names
!
interface Ethernet0
nameif outside
security-level 0
ip address A.A.A.A 255.255.255.0
!
interface Ethernet1
nameif inside
security-level 100
ip address 192.168.21.1 255.255.255.0
!
interface Ethernet2
shutdown
no nameif
no security-level
no ip address
!
passwd * encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name office.ru
access-list outside_20_cryptomap extended permit ip 192.168.21.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list outside_nat0_outbound extended permit ip 192.168.21.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list 101 extended permit ip 192.168.21.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list 101 extended deny ip any any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm
asdm history enable
arp timeout 14400
nat (inside) 0 0.0.0.0 0.0.0.0
nat (outside) 0 access-list outside_nat0_outbound
route outside 0.0.0.0 0.0.0.0 B.B.B.B 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server RADIUS protocol radius
aaa-server TASACS+ protocol tacacs+
no eou allow clientless
http server enable
http 192.168.21.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set MySet esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set peer B.B.B.B
crypto map outside_map 20 set transform-set MySet ESP-DES-SHA
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 14400
crypto isakmp policy 30
authentication pre-share
encryption des
hash sha
group 2
lifetime 14400
tunnel-group B.B.B.B type ipsec-l2l
tunnel-group B.B.B.B ipsec-attributes
pre-shared-key 123456
chain
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.21.2-192.168.21.50 inside
dhcpd dns 195.14.50.1 195.14.50.21 interface inside
dhcpd enable inside
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:2179bf7db366f592ecc9bc1edd0395aa
: end

Конфиг для длинки:

BASE
LAN: 192.168.20.1
WAN: B.B.B.B
Gateway: A.A.A.A

VPN

Name: Cisco
Local Net: 192.168.20.0/24
Authentication
Pre Shared Key: 123456
LanToLan tunnel:
Remote net: 192.168.21.0 - 192.168.21.254
Remote gateway: A.A.A.A

ADVANCED:
MTU: 1500
IKE mode: main
IKE DH group: 2 – modp 1024-bit
NAT traversal: On if supported and needed (NAT detected between gateways)
Keepaives: no keepalives

IKE proposal list:
DES SHA-1 14400
DES MD5 14400

IPSec proposal list:
DES SHA-1 28800
DES MD5 28800

Длинка в логах пишет следующее:

[2007-03-02 12:06:29] <6>EFW: IPSEC: prio=1 Phase-2 [initiator] for ipv4(icmp:0,[0..3]=192.168.20.2) and ipv4(icmp:0,[0..3]=192.168.21.1) failed; Aborted notification.

[2007-03-02 12:06:29] <4>EFW: IPSEC: prio=3 Authenticated notify "Responder lifetime notification" from A.A.A.A:500 for protocol ISAKMP spi[0..16]=f3 16 65 33 f4 43 9d 44 0b dd af e3 44 84 88 70

[2007-03-02 12:06:29] <6>EFW: IPSEC: prio=1 Phase-1 [initiator] between ipv4(udp:500,[0..3]=B.B.B.B) and ipv4(udp:500,[0..3]=A.A.A.A) done.

Хочу узнать почему не коннектится?
Время в группах вроде правильно стоит. Может в аксесс листе циски что не так?
Помогите плиз.

Еще вот Дебаг IPSEC

IPSEC: Received a PFKey message from IKE
IPSEC: Parsing PFKey GETSPI message
IPSEC: Creating IPsec SA
IPSEC: Getting the inbound SPI
IPSEC: New embryonic SA created @ 0x019D8608,
SCB: 0x01980670,
Direction: inbound
SPI : 0x423C6783
Session ID: 0x0000010B
VPIF num : 0x00000002
Tunnel type: l2l
Protocol : esp
Lifetime : 240 seconds
IPSEC: Received a PFKey message from IKE
IPSEC: Parsing PFKey GETSPI message
IPSEC: Creating IPsec SA
IPSEC: Getting the inbound SPI
IPSEC: New embryonic SA created @ 0x027CDAD0,
SCB: 0x02815640,
Direction: inbound
SPI : 0x08BF8B53
Session ID: 0x0000010B
VPIF num : 0x00000002
Tunnel type: l2l
Protocol : esp
Lifetime : 240 seconds

И через некоторое время:

IPSEC: Received a PFKey message from IKE
IPSEC: Destroy current inbound SPI: 0x423C6783
IPSEC: Received a PFKey message from IKE
IPSEC: Destroy current inbound SPI: 0x08BF8B53

PS: да, и еще проблема – пинги от длинки до циски ходят, а наоборот нет. Где галку в циске поставить?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "VPN на Cisco PIX-515 + D-Link DFL-200 не устанавливается до ..."  
Сообщение от Ra email(??) on 02-Мрт-07, 16:09 
Ты вот это вот выкинь DFL-200... Я както через задницу такое настроил, до сих пор не понимаю как.... Но оно постоянно глючит рвётся.... Иногда не рвётся но пакеты только в одну сторону пропускает, или ещё какие глюки были... Вобщем после долгих мучений поставил DFL-800 она ваще не делает то, что заявленно в описании !!!! Тоже выкинул. Поставил сиську всесто D-Link`а и теперь я забыл про этого клиента.....
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "VPN на Cisco PIX-515 + D-Link DFL-200 не устанавливается до ..."  
Сообщение от AlexeyI email(ok) on 02-Мрт-07, 17:39 
>Ты вот это вот выкинь DFL-200... Я както через задницу такое настроил,
>до сих пор не понимаю как.... Но оно постоянно глючит рвётся....
>Иногда не рвётся но пакеты только в одну сторону пропускает, или
>ещё какие глюки были... Вобщем после долгих мучений поставил DFL-800 она
>ваще не делает то, что заявленно в описании !!!! Тоже выкинул.
>Поставил сиську всесто D-Link`а и теперь я забыл про этого клиента.....
>

Я б с радостью, только вот начальство этого не поймет, т.к. длинков дофига а киска одна и через нее впоследствии будет подключаться много длинков. :(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "VPN на Cisco PIX-515 + D-Link DFL-200 не устанавливается до ..."  
Сообщение от AlexeyI email(ok) on 09-Мрт-07, 15:06 
>>Ты вот это вот выкинь DFL-200... Я както через задницу такое настроил,
>>до сих пор не понимаю как.... Но оно постоянно глючит рвётся....
>>Иногда не рвётся но пакеты только в одну сторону пропускает, или
>>ещё какие глюки были... Вобщем после долгих мучений поставил DFL-800 она
>>ваще не делает то, что заявленно в описании !!!! Тоже выкинул.
>>Поставил сиську всесто D-Link`а и теперь я забыл про этого клиента.....
>>
>
>Я б с радостью, только вот начальство этого не поймет, т.к. длинков
>дофига а киска одна и через нее впоследствии будет подключаться много
>длинков. :(


Короче я их всетаки подружил. работает нормально. :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "VPN на Cisco PIX-515 + D-Link DFL-200 не устанавливается до ..."  
Сообщение от icu email(ok) on 29-Мрт-07, 14:49 
>Короче я их всетаки подружил. работает нормально. :)

У меня те же железки и те же беды... :(

Запостите, пожалуйста, как решили проблему.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "VPN на Cisco PIX-515 + D-Link DFL-200 не устанавливается до ..."  
Сообщение от AlexeyI (??) on 02-Апр-07, 11:02 
>>Короче я их всетаки подружил. работает нормально. :)
>
>У меня те же железки и те же беды... :(
>
>Запостите, пожалуйста, как решили проблему.


http://forum.dlink.ru/viewtopic.php?t=36769&highlight=

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру