The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"CS3640 - захлебнулась"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"CS3640 - захлебнулась"  
Сообщение от Alexander email(??) on 16-Янв-07, 12:52 
Всем доброго времени!
Посоветуйте - как быть в такой ситуации:
стояла себе и работала сабжевая циска. В один прекрасный день появился клиент, который гоняет не так много трафика, зато очень много пакетиков. Через FastEth 0/0 стало бегать иногда до 3000 пакетиков как по входу, так и по выходу. От этого кошке стало временами становится очень плохо. Загрузка процессора под 100%, потери пакетов и т.д.
Можно ли как-то облегчить ее участь в данной ситуации? Необходимо немного смягчить такие пики хотя бы на месяц. Что тут можно сделать?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "CS3640 - захлебнулась"  
Сообщение от Wowa (??) on 16-Янв-07, 13:00 
>Всем доброго времени!
>Посоветуйте - как быть в такой ситуации:
>стояла себе и работала сабжевая циска. В один прекрасный день появился клиент,
>который гоняет не так много трафика, зато очень много пакетиков. Через
>FastEth 0/0 стало бегать иногда до 3000 пакетиков как по входу,
>так и по выходу. От этого кошке стало временами становится очень
>плохо. Загрузка процессора под 100%, потери пакетов и т.д.
>Можно ли как-то облегчить ее участь в данной ситуации? Необходимо немного смягчить
>такие пики хотя бы на месяц. Что тут можно сделать?

3000 pps это для нее нормально...
Надо включить fast switching

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "CS3640 - захлебнулась"  
Сообщение от Nailer (??) on 16-Янв-07, 15:16 
>Всем доброго времени!
>Посоветуйте - как быть в такой ситуации:
>стояла себе и работала сабжевая циска. В один прекрасный день появился клиент,
>который гоняет не так много трафика, зато очень много пакетиков. Через
>FastEth 0/0 стало бегать иногда до 3000 пакетиков как по входу,
>так и по выходу. От этого кошке стало временами становится очень
>плохо. Загрузка процессора под 100%, потери пакетов и т.д.
>Можно ли как-то облегчить ее участь в данной ситуации? Необходимо немного смягчить
>такие пики хотя бы на месяц. Что тут можно сделать?


sh ip cef покажите...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "CS3640 - захлебнулась"  
Сообщение от Alexander email(??) on 16-Янв-07, 19:46 
>>Всем доброго времени!
>>Посоветуйте - как быть в такой ситуации:
>>стояла себе и работала сабжевая циска. В один прекрасный день появился клиент,
>>который гоняет не так много трафика, зато очень много пакетиков. Через
>>FastEth 0/0 стало бегать иногда до 3000 пакетиков как по входу,
>>так и по выходу. От этого кошке стало временами становится очень
>>плохо. Загрузка процессора под 100%, потери пакетов и т.д.
>>Можно ли как-то облегчить ее участь в данной ситуации? Необходимо немного смягчить
>>такие пики хотя бы на месяц. Что тут можно сделать?
>
>
>sh ip cef покажите...


cef включен.
вывод sh if cef показывать длинно - много строк

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "CS3640 - захлебнулась"  
Сообщение от Alx65 email(ok) on 17-Янв-07, 17:46 
А что еще стоит на интерфейсе обращенном к клиенту? (ACL, route-ma и т.д.?)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "CS3640 - захлебнулась"  
Сообщение от Alexander email(??) on 17-Янв-07, 21:53 
>А что еще стоит на интерфейсе обращенном к клиенту? (ACL, route-ma и
>т.д.?)

Имеет место среди нескольких subif vlanov SNAT, но через него бегает не так много трафика. Аклы висят на нескольких subifa'х, но без них со стороны некоторых клиентов и тем более из интернет ИМХО будет "поддувать" - не такая уж и неуязвимая IOS. Кроме того висят traffic-shaper'а. Но опять же - если нужно обжать на интерфейсе несколько ip - rate-limit не очень удобен.
Или я может где-то заблуждаюсь?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "CS3640 - захлебнулась"  
Сообщение от Alexander email(??) on 17-Янв-07, 21:57 
>>А что еще стоит на интерфейсе обращенном к клиенту? (ACL, route-ma и
>>т.д.?)
>
>Имеет место среди нескольких subif vlanov SNAT, но через него бегает не
>так много трафика. Аклы висят на нескольких subifa'х, но без них
>со стороны некоторых клиентов и тем более из интернет ИМХО будет
>"поддувать" - не такая уж и неуязвимая IOS. Кроме того висят
>traffic-shaper'а. Но опять же - если нужно обжать на интерфейсе несколько
>ip - rate-limit не очень удобен.
>Или я может где-то заблуждаюсь?

Еще забыл - имеется Netflow, который сыпеться на машинку с *nix.
Имеется бжпа, правда анонсиков там 50/50 не очень много (далеко не фулл). Или может ей будет намного легче если в анонсиках будет дефолт и пара всего сеточек на 256?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "CS3640 - захлебнулась"  
Сообщение от Nailer (??) on 18-Янв-07, 11:08 
>>>А что еще стоит на интерфейсе обращенном к клиенту? (ACL, route-ma и
>>>т.д.?)
>>
>>Имеет место среди нескольких subif vlanov SNAT, но через него бегает не
>>так много трафика. Аклы висят на нескольких subifa'х, но без них
>>со стороны некоторых клиентов и тем более из интернет ИМХО будет
>>"поддувать" - не такая уж и неуязвимая IOS. Кроме того висят
>>traffic-shaper'а. Но опять же - если нужно обжать на интерфейсе несколько
>>ip - rate-limit не очень удобен.
>>Или я может где-то заблуждаюсь?
>
>Еще забыл - имеется Netflow, который сыпеться на машинку с *nix.
>Имеется бжпа, правда анонсиков там 50/50 не очень много (далеко не фулл).
>Или может ей будет намного легче если в анонсиках будет дефолт
>и пара всего сеточек на 256?

Конфиг-то покажите..

sh int switching тоже.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "CS3640 - захлебнулась"  
Сообщение от Alx65 email(ok) on 18-Янв-07, 12:08 
Посмотрите
sh proc cpu sort - какой процесс(ы) жрут камень

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "CS3640 - захлебнулась"  
Сообщение от Alexander email(??) on 18-Янв-07, 12:51 
>Посмотрите
>sh proc cpu sort - какой процесс(ы) жрут камень


Это уже не раз смотрел. Основной "жрущий" процесс IP..... - но он всего 10-15%. А в статистике за 5 сек 5 мин и 1 мин - в 5секундной статистике наибольшая доля - это прерывания, наприем, 96%/78%.

PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  31  1834592704 758278726       2419 15.96% 15.81% 15.53%   0 IP Input
  21    89931800   7773681      11568  0.90%  0.76%  0.75%   0 Per-Second Jobs

sh int switching мой IOS не кушает.

Конфиг:
Current configuration : 32504 bytes
!
! Last configuration change at 18:13:01 GMT+2 Mon Jan 15 2007
! NVRAM config last updated at 13:00:24 GMT+2 Sun Dec 31 2006
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
no service dhcp
!
hostname Имя :)
!
boot system flash:c3640-is-mz.122-37.bin
no logging buffered
enable secret 5 ....................
enable password 7 ...................
!
clock timezone GMT+2 2
clock summer-time EET/Kiev recurring last Sun Mar 1:00 last Sun Oct 1:00
ip subnet-zero
no ip icmp rate-limit unreachable DF
ip wccp version 1
ip flow-cache entries 64000
ip cef
!
!
ip tcp path-mtu-discovery
ip name-server ..............
!
frame-relay switching
call rsvp-sync
!
!
!
!
interface Loopback1
description SNAT_ip
ip address .................
!
!
interface FastEthernet0/0
description XXX
no ip address
ip route-cache flow
no ip mroute-cache
load-interval 30
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/0.1
description YYY
encapsulation isl 1
ip address ... secondary
ip address ... secondary
ip address ...
no ip redirects
ip nat outside
no ip mroute-cache
traffic-shape group xxx
traffic-shape group xxx
traffic-shape group xxx
traffic-shape group xxx
...
no cdp enable
!
interface FastEthernet0/0.2
...............
!
............
............
!
interface FastEthernet0/0.29
description ZZZ
encapsulation isl 29
ip address ........
no ip redirects
no cdp enable
!
interface Serial0/0
! не используется
!
interface FastEthernet0/1
description FFF
no ip address
load-interval 30
duplex auto
speed auto
no cdp enable
!
autonomous-system 12345
!
router bgp 12345
no synchronization
bgp log-neighbor-changes
network ddd
network eee
aggregate-address uuu
aggregate-address uuu
тут с десяток нейборов с роутмапами
!
ip nat pool MYPOOL ip1 ip2 netmask maska
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip nat inside source list AAA interface Loopback1 overload
ip flow-export source FastEthernet0/0.1
ip flow-export version 5
ip flow-export destination ip1 20001
ip flow-aggregation cache protocol-port
export destination ip1 20001
enabled
!
ip classless
тут всякие статик роуты
no ip http server
ip as-path access-list ............
ip as-path access-list ............
ip as-path access-list ............
!

Дальше аклы и роутмапы.
Кое-где на subifах стоят rate-limit. IP и имена вырезаны из конфига.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру