The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Релиз системы самодостаточных пакетов Flatpak 1.8.0"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от opennews (?), 25-Июн-20, 12:00 
Опубликована  новая стабильная ветка инструментария Flatpak 1.8, который предоставляет систему для сборки самодостаточных пакетов, не привязанных к конкретным дистрибутивам Linux и выполняемых в специальном контейнере, изолирующем приложение от остальной системы. Поддержка выполнения Flatpak-пакетов обеспечена для Arch Linux, CentOS, Debian, Fedora, Gentoo, Mageia, Linux Mint и Ubuntu. Пакеты с Flatpak включены в репозиторий Fedora и поддерживаются в штатной программе управления приложениями GNOME...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=53229

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


2. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +29 +/
Сообщение от Аноним (2), 25-Июн-20, 12:08 
> В сборочном крипте configure предоставлена возможность сборки без libsystemd;

Бунт на корабле!

Ответить | Правка | Наверх | Cообщить модератору

7. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Owlet (?), 25-Июн-20, 12:28 
Видимо, это оказалось нужно кому-то, кроме хейтеров, только и всего.
Ответить | Правка | Наверх | Cообщить модератору

17. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +5 +/
Сообщение от Аноним (17), 25-Июн-20, 13:08 
Просто Лёня не доглядел.
Ответить | Правка | Наверх | Cообщить модератору

50. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от НяшМяш (ok), 25-Июн-20, 16:17 
Ждём завтра пост от Лёни, что редхат переходит на снапы.
Ответить | Правка | Наверх | Cообщить модератору

164. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (164), 27-Июн-20, 08:47 
И до кучи на армы.
Ответить | Правка | Наверх | Cообщить модератору

25. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (25), 25-Июн-20, 13:43 
Угу, хейтеры sysvinit могут только хейтить.
Ответить | Правка | К родителю #7 | Наверх | Cообщить модератору

111. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (111), 26-Июн-20, 06:39 
fix: Видимо, это оказалось нужно кому-то, кроме системддрочеров, только и всего.
Ответить | Правка | К родителю #7 | Наверх | Cообщить модератору

29. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (-), 25-Июн-20, 14:02 
Кто-то будет недоволен...
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

117. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от VladSh (?), 26-Июн-20, 07:59 
Ну так - самодостаточный релиз системы самодостаточных пакетов!
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

3. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от JL2001 (ok), 25-Июн-20, 12:08 
//оффтоп

nixpkg спасёт мир, а не вот это вот всё, что пытается спихнуть мир с края (включая и docker как метод распространения приложений)

Ответить | Правка | Наверх | Cообщить модератору

165. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (164), 27-Июн-20, 08:48 
Только ебилды только хардкор как в хромос.
Ответить | Правка | Наверх | Cообщить модератору

4. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от Аноним (4), 25-Июн-20, 12:08 
Пользуюсь, нужен
Ответить | Правка | Наверх | Cообщить модератору

6. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +8 +/
Сообщение от Аноним (6), 25-Июн-20, 12:13 
Поставил себе недавно на ноут с интегрированной видеокартой 16гб оперативы, snap. А через snap хромиум. Запустил это чудо. 4логических CPU взлетели до небес. Думал ноут на своих куллерах улетит в космос. В тоже время, у меня всегда запущена виртуалка, где из deb репы установлен, запущен ff, открыто с десяток запиненых вкладок и все летает. В виртуалке 1гб оперативы, 1логическое ядро, dwm. Попытка использования snap не удалась, чет они там лишнего накомпилировали.
Ответить | Правка | Наверх | Cообщить модератору

8. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от iPony129412 (?), 25-Июн-20, 12:34 
Ну так при первом запуске SNAP приложения (после установки, или апдейта) можно успеть чаю выпить. Это давно известный факт.
Потом нормально становится.
Ответить | Правка | Наверх | Cообщить модератору

9. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +45 +/
Сообщение от Аноним (9), 25-Июн-20, 12:39 
>Потом нормально становится.

чай начинает действовать?

Ответить | Правка | Наверх | Cообщить модератору

12. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (12), 25-Июн-20, 12:57 
Потому и не взлетают кулеры, что всего одно ядро.
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

31. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +5 +/
Сообщение от Аноним (31), 25-Июн-20, 14:03 
Запускай софт из репозитория это самый правильный способ.
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

74. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (74), 25-Июн-20, 20:33 
Самый правильный способ это компилировать их исходников, написав его на кануне.
Ответить | Правка | Наверх | Cообщить модератору

79. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +8 +/
Сообщение от anonom (?), 25-Июн-20, 21:38 
На чём?
Ответить | Правка | Наверх | Cообщить модератору

88. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от коржик (?), 25-Июн-20, 23:54 
на perl 7 вестимо
Ответить | Правка | Наверх | Cообщить модератору

112. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (111), 26-Июн-20, 06:47 
Самый правильный способ это компилировать их исходников и собирать пакет для вашего любимого дистра.
Ответить | Правка | К родителю #74 | Наверх | Cообщить модератору

120. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Dnina (ok), 26-Июн-20, 11:22 
По-моему я ставил h264ify в хром на минте, чтобы ютуб не грузил проц. Но это было именно с ютубом.
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

125. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 26-Июн-20, 11:52 
Ну кстати да.
Firefox на калькуляторах бывает сам заставляет YouTube показывать менее жрущий h.264 кодек.
Chromium такого не делает.  
Ответить | Правка | Наверх | Cообщить модератору

142. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (142), 26-Июн-20, 17:03 
Заметил, что youtube тормозит в Pale Moon.
Ответить | Правка | Наверх | Cообщить модератору

147. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 26-Июн-20, 18:51 
> Заметил, что youtube тормозит в Pale Moon.

Ну это очевидно, в этом трухлявом пне хоть что будет тормозить

Ответить | Правка | Наверх | Cообщить модератору

157. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (157), 26-Июн-20, 22:50 
Это говнокод ютуба. 100%.
Всего-то надо видео в теге <video></video> показать без всяких JS (и комментариев, хотя, они и так успешно их отключают и видео выпиливают).
Раньше с таким тегом, браузер мог играть через любой плагин (от проигрывателей VLC, QuickTime, DivX). А сейчас во что превратился веб?
Google must die.
Ответить | Правка | Наверх | Cообщить модератору

10. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Аноним (10), 25-Июн-20, 12:49 
>и выполняемых в специальном контейнере, изолирующем приложение от остальной системы

если кто забыл, то linux уже есть механизм изоляции приложений - запуск от имени разных пользователей. Если приложения запущены от одного пользователя, значит они по определению не должны быть изолированы друг от друга.

Flatpak - ненужное г.

Ответить | Правка | Наверх | Cообщить модератору

14. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (12), 25-Июн-20, 13:00 
Я как-то гуглил как запустить от другого пользователя с GUI. Это такой гемор, то конфиги у рута, то права портятся. Помню, на винде это было очень легко. Единственное, что просто запустить от рута. Но надо использовать su, а не sudo. Иначе конфиги пользователя испортятся. И в Ubuntu 18.04 почему-то su не работает (не принимает пароль), а в 16.04 работает. Печаль, короче.
Ответить | Правка | Наверх | Cообщить модератору

23. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +6 +/
Сообщение от Аноним (10), 25-Июн-20, 13:34 
знаешь, почему в flatpak кажется что меньше гемора? Потому что эти гении не пользуются своим же говнокодом и тупо выдают всем приложениям в своем флатхабе максимальные разрешения. По факту там нет никакой изоляции :))
Ответить | Правка | Наверх | Cообщить модератору

119. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (119), 26-Июн-20, 08:36 
Я помню как поставил evolution - а там нельзя аттач открыть. Потому что его не скомпилили с новым gtk который может работать с порталами.

Потом поставил freecad - и оказалось что есть проблема с плагинами. Что-то там происходило с путями к ним и в итоге они не работали.

У vscode есть максимальный доступ к хосту, но тем неменее запуск компиляторов и тулзов с хоста будет крайне геморройным, придется кажую тулзуз запускать через flatpak-spawn. + проблемы с плагинами и тд.


В итоге flatpak даже с отключенной изоляцией пригоден далеко не для всех приложений.

Ответить | Правка | Наверх | Cообщить модератору

124. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (124), 26-Июн-20, 11:50 
https://forums.linuxmint.com/viewtopic.php?t=279042
Ответить | Правка | К родителю #23 | Наверх | Cообщить модератору

16. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +9 +/
Сообщение от jfdbngh (?), 25-Июн-20, 13:04 
Это слишком просто, что не может не раздражать прогрессивное линукс-сообщество:
1. Делаем изоляцию из-за недостаточной секурности.
2. Делаем костыли для обхода изоляции, ибо юзать это невозможно.
3. Возвращаемся к пункту 1.

Следующий уровень изоляции ПО в линуксах - каждое приложение будет поставляться с собственной ОС и гипервизором.

На винде калькулятор запускается мгновенно. Калькулятор из snap-а на убунте запускается несколько секунд.

Ответить | Правка | К родителю #10 | Наверх | Cообщить модератору

34. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от kata containers (?), 25-Июн-20, 14:20 
> Следующий уровень изоляции ПО в линуксах - каждое приложение будет поставляться
> с собственной ОС и гипервизором.

стоп, чего это - "следующий"? Мы это уже пять лет как продали!

> На винде калькулятор запускается мгновенно.

но он может украсть твои...э...мы еще не придумали, что может украсть небезопасТный калькулятор, но напряженно морщим лбы!

> Калькулятор из snap-а на убунте запускается несколько секунд.

Зато безопастно! Э...нет. Устаревшая модель безопасности, мы не рекомендуем ей пользоваться - разделение на уровне костылей и подпорок операционной системы. Помещайте каждый калькулятор в изолированный гипервизором контейнер - как вот мы умеем!
(что вам, 200 мегабайт всего лишь жалко?!)


Ответить | Правка | Наверх | Cообщить модератору

43. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (157), 25-Июн-20, 14:46 
В калькуляторе была телеметрия. А пасьянс требовал 3D.
Ответить | Правка | Наверх | Cообщить модератору

97. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 26-Июн-20, 03:01 
> стоп, чего это - "следующий"? Мы это уже пять лет как продали!

В этом вся суть коммерческого по.

Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

134. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от pofigist (?), 26-Июн-20, 15:33 
> Следующий уровень изоляции ПО в линуксах - каждое приложение будет поставляться с собственной ОС и гипервизором.

https://www.qubes-os.org/

Ответить | Правка | К родителю #16 | Наверх | Cообщить модератору

11. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (12), 25-Июн-20, 12:56 
У них был баг, что в Qt приложениях не работали диалоги открыть/сохранить. Я им сообщал на гитхабе. Пинали в ответ из репы flatpak в flathub, из flathub в qt. Так и не исправили свое поделие. Но я давно не проверял. И не хочется, учитывая сколько там мелких файлов. Второе ненужно после питона. Хотя, иногда софт оттуда был полезен.

Например, Audacity ломает Audigy 2 ZS, а во флатпаке благодаря изоляции, нет. Но мне не нравится, что там роллинг. Всегда хочется стабильности, забэкапить определенную версию. А как это сделать во Flatpak ума не приложу. На случай, если прога испортится или ее выпилят.

Ответить | Правка | Наверх | Cообщить модератору

98. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 26-Июн-20, 03:02 
Только один баг? Враки.
Ответить | Правка | Наверх | Cообщить модератору

13. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +5 +/
Сообщение от Аноним (13), 25-Июн-20, 12:57 
это что получается, для того чтобы запаковать "калькулятор" для Gnome, нужно тащить весь Gnome runtime с собой?
если так - то это 🤮
Ответить | Правка | Наверх | Cообщить модератору

15. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (12), 25-Июн-20, 13:00 
Да, но эти крупные пакеты шарятся между собой по умолчанию.
Ответить | Правка | Наверх | Cообщить модератору

18. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (13), 25-Июн-20, 13:20 
Да, действительно, тогда - по-легче. Но со временем, количество таких установленных рантаймов будет расти.
Ответить | Правка | Наверх | Cообщить модератору

19. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +14 +/
Сообщение от Аноним (10), 25-Июн-20, 13:24 
чтобы шарить пакеты между собой, уже есть нормальные пакетные менеджеры. Рекомендую.
Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

49. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от iLex (ok), 25-Июн-20, 15:57 
Увы, эти менеджеры работают только в комплекте с целой толпой добрых дядь-майнтейнеров. И если эти дяди вдруг решили, что для данного дистрибутива вот эта софтина сойдёт и версии от 2004 года, то вам не повезло - будете окаменевшей мамонтятиной пользоваться, и ещё спасибо говорить, что хоть такое есть.
Ответить | Правка | Наверх | Cообщить модератору

58. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Аноним (58), 25-Июн-20, 17:40 
Ничего не мешает собрать, даже если пакета вообще нет.
Ответить | Правка | Наверх | Cообщить модератору

67. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iLex (ok), 25-Июн-20, 19:32 
Ну какую-нибудь утилитку на 1500 строк чистой сишки собрать и вправду не проблема. Но вот хотел бы я посмотреть, как вы будете собирать к примеру LibreOffice. Или Freecad. Или Krita. А с этими новыми пакетами - красота же: берём и ставим, и никаких проблем.
Ответить | Правка | Наверх | Cообщить модератору

72. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (58), 25-Июн-20, 20:11 
> хотел бы я посмотреть, как вы будете собирать к примеру LibreOffice

По readme. Ставишь сборочные dev зависимости, сборочные инструменты, а потом
./configure
make
sudo make install

или
meson build
ninja -C build

Если что-то не собирается (дистрибутив старый) надо посмотреть ошибку. Скорее всего придется обновить (собрать) более новую версию какого-нибудь зависимого пакета или компилятор (например, meson).

Ответить | Правка | Наверх | Cообщить модератору

73. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (58), 25-Июн-20, 20:14 
> сборочные dev зависимости

На deb-based я бы порекомендовал выполнить для этого команду
sudo apt build-dep libreoffice
Несмотря на более старую версию в репозитории и возможные различия в требованиях новых версий, лишним точно не будет.

Ответить | Правка | Наверх | Cообщить модератору

169. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от pin (??), 27-Июн-20, 10:02 
У вас огромны опыт по сборке, ага. Это видно даже без очков.
Ответить | Правка | К родителю #72 | Наверх | Cообщить модератору

33. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от iPony129412 (?), 25-Июн-20, 14:09 
Типа того.
И вот у тебя один калькулятор с Gnome 3.22, а другой с Gnome 3.24, а третий с KDE 5.15
Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

32. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от Аноним (-), 25-Июн-20, 14:04 
Юзай Appimage бро, это лучшее.
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

113. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (111), 26-Июн-20, 06:50 
>это что получается, для того чтобы запаковать "калькулятор" для Gnome, нужно тащить весь Gnome runtime с собой?

Ну так в противном случае, придётся ставить ради калькулятора Gnome runtime в систему.

Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

21. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –5 +/
Сообщение от Аноним (21), 25-Июн-20, 13:28 
Зачем оно нужно, когда есть snap?
Ответить | Правка | Наверх | Cообщить модератору

22. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –5 +/
Сообщение от Аноним (22), 25-Июн-20, 13:32 
Вот знаешь, зашел сюда с той же мыслью
Ответить | Правка | Наверх | Cообщить модератору

24. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (10), 25-Июн-20, 13:38 
snap - универсальная система сборки самодостаточных пакетов, контролируемая canonical.
flatpak - универсальная система сборки самодостаточных пакетов, контролируемая gnome.

догадайся с одного раза, для чего нужны они обе.

Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

56. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –4 +/
Сообщение от IRASoldier_registered (ok), 25-Июн-20, 17:13 
Вот и хорошо, что они кем-то контролируются, а не сферическим в вакууме комьюнити. Значит - будут развиваться.
Ответить | Правка | Наверх | Cообщить модератору

95. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Ваш Анонимус (?), 26-Июн-20, 02:11 
Снап без системды не работает.
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

123. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (124), 26-Июн-20, 11:45 
snap тормозит, фризы GUI и низкий fps.
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

26. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +8 +/
Сообщение от Аноним (26), 25-Июн-20, 13:46 
Отказался. Ни snap ни flatpak больше не использую. Слишком жирно и толсто. Никому не рекомендую если есть выбор.
Ответить | Правка | Наверх | Cообщить модератору

27. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от Аноним (26), 25-Июн-20, 13:47 
Нет времени объяснять почему, просто верьте мне.
Ответить | Правка | Наверх | Cообщить модератору

99. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 26-Июн-20, 03:04 
Так а что тут объяснять. Это и ежу понятно.
Ответить | Правка | Наверх | Cообщить модератору

66. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Анончик9999 (?), 25-Июн-20, 19:32 
Ещё и от репозиториев откажись.
Ответить | Правка | К родителю #26 | Наверх | Cообщить модератору

75. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (-), 25-Июн-20, 20:38 
От репозиториев - давно пора. И от дистров.
Ответить | Правка | Наверх | Cообщить модератору

114. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (111), 26-Июн-20, 06:52 
Единственно верная бжественная 10-чка? :)
Ответить | Правка | Наверх | Cообщить модератору

136. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (136), 26-Июн-20, 16:40 
> Единственно верная бжественная 10-чка? :)

11 на днях анонсирована.

Ответить | Правка | Наверх | Cообщить модератору

161. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (161), 27-Июн-20, 03:34 
ALFS / BSD-from-scratch наше фсио
Ответить | Правка | К родителю #75 | Наверх | Cообщить модератору

69. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –4 +/
Сообщение от Аноним (-), 25-Июн-20, 19:54 
Пользуюсь, рекомендую.
Ответить | Правка | К родителю #26 | Наверх | Cообщить модератору

126. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (124), 26-Июн-20, 12:23 
Типа без этой прослойки софт станет намного меньше?
Ответить | Правка | К родителю #26 | Наверх | Cообщить модератору

28. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (-), 25-Июн-20, 13:50 
Очередной setup.exe.
Ответить | Правка | Наверх | Cообщить модератору

35. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Аноним (35), 25-Июн-20, 14:21 
Что не сделают, чтобы не сделать линукс платформой, как Windows/Android/iOS/Mac OS.

А давайте будет таскать приложения полностью! Со всеми зависимостями? Чтобы они стартовали полчаса, читая все свои библы.

Тьфу ты. Когда этот бред закончится.

// b.

Ответить | Правка | Наверх | Cообщить модератору

39. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (157), 25-Июн-20, 14:42 
Фреймворковский Paint.NET запускается быстрее Гимпа.
Это из-за питонятины? extensions script fu.
Ответить | Правка | Наверх | Cообщить модератору

60. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (60), 25-Июн-20, 17:54 
это как блокнот с офисом сравнивать
Ответить | Правка | Наверх | Cообщить модератору

62. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (58), 25-Июн-20, 18:06 
Примитивненько, даже обрезки нормальной нет, но симпатично.
Ответить | Правка | Наверх | Cообщить модератору

116. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Анонимemail (116), 26-Июн-20, 07:50 
Ты хоть раз запускал Paint.NET? Шикарный легкий редактор. Gimp работает с быстротой фотошопа а по функциональности как полено!
Ответить | Правка | Наверх | Cообщить модератору

115. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (111), 26-Июн-20, 06:54 
>как Windows
>А давайте будет таскать приложения полностью! Со всеми зависимостями?

Как будто в Шиндошс не так.

Ответить | Правка | К родителю #35 | Наверх | Cообщить модератору

127. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (127), 26-Июн-20, 13:00 
В Windows это не так, да.
Ответить | Правка | Наверх | Cообщить модератору

36. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +3 +/
Сообщение от Аноним (36), 25-Июн-20, 14:26 
для запуска десятка приложений на раз все еще нужно 10 гб рантаймов хранить?
Ответить | Правка | Наверх | Cообщить модератору

37. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от Аноним (37), 25-Июн-20, 14:29 
Постоянно читаю о том, что flatpak и snap не нужны. Кто-нибудь может объяснить позицию утверждающих это? Даже если вы не согласны, просто объясните чем люди не довольны.

Тем что получают блобы? Но ведь пакетные менеджеры тоже устанавливают блобы. Вопрос только в доверии к поставщикам и пользователи не могут быть уверены в том, что в пакеты дистрибутива не вшиты бэкдоры. В этом можно быть уверенным только проведя ревью кода и собрав его самостоятельно, и то, даже компилятор может быть с бэкдорами.

В чём основная претензия?

Ответить | Правка | Наверх | Cообщить модератору

38. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –4 +/
Сообщение от Аноним (38), 25-Июн-20, 14:40 
Appimage же
Ответить | Правка | Наверх | Cообщить модератору

40. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 25-Июн-20, 14:42 
Основная проблема - это низкое качество.
Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

42. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Аноним (157), 25-Июн-20, 14:44 
> В чём основная претензия?

Все как обычно. Тормоза, много мелких файлов, неконтролируемость, неэстетичность.

Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

44. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Отражение луны (ok), 25-Июн-20, 14:48 
Здесь подавляющее большинство - рядовые пользователи, которые из-за пары прочитанных статей наивно думают, что обладают какими-то знаниями, и поэтому им обязательно нужно ими поделиться. Вполне естественно, что в попытке блеснуть знаниями они будут критиковать все, что остается ими непонятым. Это работает примерно так же, как с инстаграмм блоггершами, которые постят про вред 5G и про то, что вакцины высасывают души.
Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

46. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Im banana man (?), 25-Июн-20, 15:00 
Инстаграм блогершы действительно высасывают души, что потом шапочка из фольги не поможет с 5G, понял )
Ответить | Правка | Наверх | Cообщить модератору

145. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (145), 26-Июн-20, 17:58 
Deadbeef тянет, как пассиковый )
Ответить | Правка | К родителю #44 | Наверх | Cообщить модератору

48. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (10), 25-Июн-20, 15:53 
ну представь: ты поставил vscode из flatpak, открыл там терминал, пытаешься запустить скрипт на питоне, а терминал пишет "/usr/bin/python не найден". Почему? Потому что flatpak для пущей безопасности примонтировал в /usr свой "рантайм" (название-то какое, прости господи), в котором питона действительно нет. Либо есть, но другой версии. Либо нужной версии, но не установлены нужные тебе модули.

Иными словами, flatpak вынуждает пользователей полностью отказаться от существующих пакетных менеджеров их дистров и перейти на свою экосистему. Тебе точно это надо?

Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

53. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от IRASoldier_registered (ok), 25-Июн-20, 16:36 
>вынуждает пользователей

Вот всегда ржал с этого - у некоторых постсовков, когда предлагается альтернатива чему-то старому и привычному, они начинают вопить - "нас вынуждают".

Ну так вбей себе в голову: flatpack тебя не вынуждает. Ты просто _помимо_ софта, устанавливаемого с помощью традиционных пакетных менеджеров можешь пользоваться софтом, устанавливаемым с помощью flatpack. Да, у тебя будет две экосистемы. Не нравится - не пользуйся. Потому что тебя никто не вынуждает.

И да, некоторый софт _уже_ поставляется в первую очередь в виде flatpack. Потому что создателю софта удобно сделать одну универсальную поставку. И только потом его собирают другие люди для дистрибутивов, чтобы он был доступен через пакетные менеджеры. Или не собирают. Но это можешь сделать ты сам для себя. Никто не обязан тебе его собирать.

Ответить | Правка | Наверх | Cообщить модератору

59. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от iPony129412 (?), 25-Июн-20, 17:47 
> И да, некоторый софт _уже_ поставляется в первую очередь в виде flatpack

Кто?

Ответить | Правка | Наверх | Cообщить модератору

93. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от IRASoldier_registered (ok), 26-Июн-20, 00:51 
Просто зайди на Flathub, а потом посмотри, есть ли это в репах твоего %DISTRONAME%. А если есть - сравни версии и обрати внимание на даты сборки в репах.

Ответить | Правка | Наверх | Cообщить модератору

104. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 26-Июн-20, 04:57 
Ну ты же можешь примеры привести? Что значит зайди.
Я минут пять поискал - не смог. Наверно есть такие редкие случаи.
Ответить | Правка | Наверх | Cообщить модератору

105. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 26-Июн-20, 05:10 
> И да, некоторый софт _уже_ поставляется в первую очередь в виде flatpack. Потому что создателю софта удобно сделать одну универсальную поставку
> просто зайди на Flathub, а потом посмотри, есть ли это в репах твоего %DISTRONAME%. А если есть - сравни версии и обрати внимание на даты сборки в репах.

Ну и да. Твое второе высказывание совершенно параллельно к первому.


Ответить | Правка | К родителю #93 | Наверх | Cообщить модератору

133. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от IRASoldier_registered (ok), 26-Июн-20, 15:08 
Ты не понял. Берем, например, Foliate. Сравниваем версии на Flathub, в репах Ubuntu (или оно там в ppa?) и в репах Fedora. Еще весной на Flathub была более свежая версия.

Ответить | Правка | Наверх | Cообщить модератору

140. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 26-Июн-20, 16:56 
> Ты не понял. Берем, например, Foliate. Сравниваем версии на Flathub, в репах
> Ubuntu (или оно там в ppa?) и в репах Fedora. Еще
> весной на Flathub была более свежая версия.

Это ты не понял, у тебя первый комментарий был не про свежесть версий, а что разработчик радостный запакует в Flathub.

И я так и знал что будет про один Foliate  🤣 - это единственный пример, который я вот знаю. Что вот разработчик на сайте написал "а вот нате FlatHub скачивайте".

https://johnfactotum.github.io/foliate/

Есть ещё GIMP. Но там прям жирно пишут и с восклицательным знаком, что лучше уж не надо.

> GIMP for Unix-like systems

If available, the official package from your Unix-like distribution is the recommended method of installing GIMP! The flatpak build is new and has known limitations, though it will likely provide faster updates, following GIMP releases closely.
Therefore choose your installation medium according to your needs.

Ответить | Правка | Наверх | Cообщить модератору

64. Скрыто модератором  +7 +/
Сообщение от Аноним (10), 25-Июн-20, 19:27 
Ответить | Правка | К родителю #53 | Наверх | Cообщить модератору

94. Скрыто модератором  –4 +/
Сообщение от IRASoldier_registered (ok), 26-Июн-20, 01:09 
Ответить | Правка | Наверх | Cообщить модератору

100. Скрыто модератором  +/
Сообщение от deeaitch (ok), 26-Июн-20, 03:08 
Ответить | Правка | К родителю #64 | Наверх | Cообщить модератору

55. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (37), 25-Июн-20, 17:13 
А если я поставлю флэтпаком slaveNiggerShell, то смогу использовать этот шелл из VSCodium, который поставил нормально? Если да, то это не выглядит проблемой. И можно ли как-нибудь readonly пробросить мой питон в flatpak vscode? Если да, то получается нужно просто сконфигурировать
Ответить | Правка | К родителю #48 | Наверх | Cообщить модератору

68. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (10), 25-Июн-20, 19:46 
>И можно ли как-нибудь readonly пробросить мой питон в flatpak vscode? Если да, то получается нужно просто сконфигурировать

можно конечно, об этом даже в новости написано:

>Добавлены новые полномочия доступа к ФС - "host-etc" и "host-os", позволяющие получить доступ к системным каталогам /etc и /usr

вот только нафига конфигурировать то, что раньше в принципе было не нужно конфигурировать? Ради безопасности, которой по факту нет? Защитить /usr, смонтировав его в другое место - гениальная идея, просто ржу в голос с неё.

Ответить | Правка | Наверх | Cообщить модератору

137. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (142), 26-Июн-20, 16:43 
> Питона действительно нет. Либо есть, но другой версии. Либо нужной версии, но не установлены нужные тебе модули

Какой ужас.

Ответить | Правка | К родителю #48 | Наверх | Cообщить модератору

54. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –6 +/
Сообщение от IRASoldier_registered (ok), 25-Июн-20, 17:11 
> В чём основная претензия?

Олдфажество и упоротость, всего навсего. Новое, непривычное - значит "не нужно".

Хороший обзор по теме:

https://habr.com/ru/post/433052/

(И да, то, как snap внедрили в Ubuntu - отстой, безотносительно объективных спорных моментов со snap как таковых.)

Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

89. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от ann (??), 26-Июн-20, 00:07 
Это не новое. Этому новому 100 лет в обед. setup.exe и dll hell называется.

Просто мамкины виндопрограмеры влезли в линух, а проме этого бреда они ничего не знаю и осилить не могут. В винде нет манов, поэтому они не умеют их читать и даже о их существовании не знаю. В винде принято каждому васяну городить свой велосипед и таскать все либы с собой.

Это не олдскул не может осилить новое, это мамкины програмеры не могут прочитать пары страниц мана и тащат с собой единственный выученный способ распространения софта. И клали они на всех болт.

Ответить | Правка | Наверх | Cообщить модератору

92. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от IRASoldier_registered (ok), 26-Июн-20, 00:49 
>это мамкины програмеры не могут

Конечно. Linux же только для программеров. Пользователям там делать нечего, и делать им удобно - это не Linux way. И стандарты, которым надо следовать - это тоже не Linux way, а если им кто-то следует - это несвобода же.

"Чтобы с этих пор по-новому,
Оставалось все по-старому.

Ай, Аллах! Ай, Аллах!
Ниспошли прогресс в делах."
(с)

> В винде принято каждому васяну городить свой велосипед и таскать все либы с собой

".NET? Не, не слышал! Visual C++ Redistributable - не, не слышал!"

Ответить | Правка | Наверх | Cообщить модератору

101. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –4 +/
Сообщение от deeaitch (ok), 26-Июн-20, 03:09 
Вообще-то у Linux всё было в порядке со стондартами, пока не пришли вы виндузятники.
Ответить | Правка | Наверх | Cообщить модератору

129. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (129), 26-Июн-20, 14:00 
Ну расскажи как тот же дебиан соблюдает стандарты. Например FHS.
Ответить | Правка | Наверх | Cообщить модератору

143. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от ann (??), 26-Июн-20, 17:36 
А чего ты один стандарт выбрал который тебе удобен? У Debian есть свой, созданый ещё до FHS. Его и соблюдают.

В противовес веде, где вообще каждый вася свой огород делает.

Ответить | Правка | Наверх | Cообщить модератору

154. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (129), 26-Июн-20, 21:49 
Разупорин прими. Каждый вася свой огород делает - это как раз в линупce. Где-то система инициализации бсдшная, где-то systemd, где-то systemv. Где-то пакеты пакеты в deb, где-то в rpm, где-то в apk, где-то в тарболлах или ебилдах. Где-то графика иксовая, где-то вяленый или AWT. Звук, опять же, может идти как через пульсу, так и непосредственно через всякие OSS, ALSA или что-то ещё. Софт может собираться только gcc, но не шлангом или наоборот. И так далее и тому подобное.
Ответить | Правка | Наверх | Cообщить модератору

159. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 27-Июн-20, 02:31 
Да сиди ты в своей винде. Не работает у тебя потому что руки крюки. И про линух так можно сказать. Про венду когда что-то не работает так отбрехаться не выйдет. Это же ПРОДУКТИЩЕ сделаеное умными программистами и по человечески.

Только нихрена не работает, всё тормозит, глючит, нет нормальных хоткеев и постоянно обновляется.

Ответить | Правка | Наверх | Cообщить модератору

166. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (166), 27-Июн-20, 09:00 
Бомбануло? Страдай, потому что в кocтылинупce это неизбежно. У меня под виндой всё нужное мне работает без тормозов и с нужными хоткеями
Ответить | Правка | Наверх | Cообщить модератору

174. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от deeaitch (ok), 27-Июн-20, 20:31 
> Бомбануло? Страдай, потому что в кocтылинупce это неизбежно. У меня под виндой
> всё нужное мне работает без тормозов и с нужными хоткеями

Да, я страдаю. Страдаю от того что для того чтобы начать работать а не заниматься ИБД (имитация бурной деятельности) мне приходиться запускать virtualbox и внутри НОРМАЛЬНУЮ систему а не это твоё убожество. И да, я буду страдать некоторое время пока не найду достойную другую работу где будут НОРМАЛЬНЫЕ условия и НОРМАЛЬНЫЕ системы (как вариант возможность выбора)

А ты и дальше будешь заниматься ИБД (иммитация бурной деятельности) и восхвалять свою систему.

Заметь, не я прилез к тебе со своей системой, ты припёрса как д....л и начал кричать что все убогие и всё у вас тупо и не так как в истинно верной венде. Сиди и дальше там, и надеюсь ни ты ни твоё потмство в мир нормального софта никогда не попадёт.

Ответить | Правка | Наверх | Cообщить модератору

181. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (166), 28-Июн-20, 08:21 
>Да, я страдаю

Страдай и дальше. Я-то третий десяток лет живу в мире с нормальным софтом, где для выполнения простенькой операции не нужно городить костыли из смеси sed, grep, awk и какого-нибудь баша с перлом. С нормальной файлухой, в которой при распаковке архива/копировании файлов с флешки/качании торрента ни разу не видел сообщения "не могу создать файл, поскольку у него имя слишком длинное". Где если уж мне захочется чего на скорую руку напрограммить - мне не надо гадать из qt функции тянуть или же из gtk/lesstif/vxWidgets/ещё какой помойки, поскольку всё нужное уже есть в WinAPI. Где, наконец, есть полноценные форт-системы, позволяющие это самое WinAPI вызывать напрямую, а не через 100500 фреймворков и абстракций.
>Заметь, не я прилез к тебе со своей системой, ты припёрса как д....л и начал кричать что все убогие и всё у вас тупо и не так как в истинно верной венде

Не звизди. Всё началось с твоего кукарека про то что якобы в линупce всё всегда нормально было пока в ваш каток люди не заглянули.

Ответить | Правка | Наверх | Cообщить модератору

186. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 28-Июн-20, 20:06 
> в
> линупce всё всегда нормально было

Было. И будет. Не переживай. Жили без вас прекрасно и дальше проживём.

Ответить | Правка | Наверх | Cообщить модератору

190. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (190), 28-Июн-20, 20:46 
Датычо:) Я эти вскукареки вообще-то больше 20 лет слышу с предсказуемым результатом.
Ответить | Правка | К родителю #186 | Наверх | Cообщить модератору

196. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 30-Июн-20, 02:33 
> Датычо:) Я эти вскукареки вообще-то больше 20 лет слышу с предсказуемым результатом.

Ну каждый слышит то что хочет. Ты слышишь кукареки. Наверное стоит где-то осмотр пройти.

А тем временем огромная куча людей прекрасно пользуется и довольны.

Ответить | Правка | К родителю #190 | Наверх | Cообщить модератору

160. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 27-Июн-20, 02:33 
> Ну расскажи как тот же дебиан соблюдает стандарты. Например FHS.

https://www.debian.org/doc/manuals/maint-guide/ - на, просвещайся.

Ответить | Правка | К родителю #129 | Наверх | Cообщить модератору

167. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (166), 27-Июн-20, 09:09 
И чо? Такая методичка есть и у красной шапки, и в арчевики похожее видео, и в других местах. Но это совершенно не означает что я могу взять и всунуть в дебиан пакет от арча или из убунты в центось, хотя собирается всё это гнутое ненужно из одних и тех же сорцов.
Ответить | Правка | Наверх | Cообщить модератору

175. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от deeaitch (ok), 27-Июн-20, 20:32 
> И чо? Такая методичка есть и у красной шапки, и в арчевики
> похожее видео, и в других местах. Но это совершенно не означает
> что я могу взять и всунуть в дебиан пакет от арча
> или из убунты в центось, хотя собирается всё это гнутое ненужно
> из одних и тех же сорцов.

Означает. Ты прочитай, внимательно, там всё написано.

Ответить | Правка | Наверх | Cообщить модератору

180. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (166), 28-Июн-20, 08:06 
Я тебе русским языком написал: такая методичка имеется у большинства дистров. Gentoo, Arch, RHEL и так далее и тому подобное. Однако я не могу взять арчевский пакет и без шаманства поставить его в центось или рпмку от центоси в убунте несмотря на то, что софтина во всех случаях собрана из одних и тех же сорцов. Такая вот линупcячья стандартизация, ага. Это же не винда, в которой некоторыми программами я благополучно пользуюсь ещё с 2004 года и они без проблем работают на всём что моложе NT 4. Без переборки и даже смотрения исходников.
Ответить | Правка | Наверх | Cообщить модератору

185. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 28-Июн-20, 20:05 
> Я тебе русским языком написал: такая методичка имеется у большинства дистров. Gentoo,
> Arch, RHEL и так далее и тому подобное. Однако я не
> могу взять арчевский пакет и без шаманства поставить его в центось
> или рпмку от центоси в убунте несмотря на то, что софтина
> во всех случаях собрана из одних и тех же сорцов. Такая
> вот линупcячья стандартизация, ага. Это же не винда, в которой некоторыми
> программами я благополучно пользуюсь ещё с 2004 года и они без
> проблем работают на всём что моложе NT 4. Без переборки и
> даже смотрения исходников.

Я не верю что есть настолько не грамотные люди. У тебя всё есть, почитай документацию нормально. Всё там есть.

Ответить | Правка | Наверх | Cообщить модератору

189. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (190), 28-Июн-20, 20:45 
У тебя по ходу дела с русским языком проблемы больше, чем ты думаешь. Ну да объясню так, чтобы даже такие как ты поняли. Есть ведро линупca. Поверх ведра работают всякие glibc и прочие системные библиотеки, если ты такое слово вообще хоть раз слышал. Поверх всего этого работает всякая прикладнуха - браузеры там, апач с мускулом, плееры, графическая оболочка и тому подобное. Собирается вся эта ненужная шняга из так называемых исходных текстов, в которые всякие кpacнoглaзыe бараны очень любят смотреть, но при этом ничего в написанном не понимают, само собой. Сорцы ядра, системных библиотек и прикладнухи одни и те же во всех линупcaх, что характерно, - но вот заставить работать результаты сборки в одном костылинупce в других сортах его же крайне проблематично и если версия в твоём так называемом дpистрибутиве тебя не устраивает - ты задолбаешься приспосабливать туда более подходящую, вот такие у вас там стандарты. Я даже не буду брать экзотику из серии "поставь рпмку из Scientific Linux (доводилось по работе этот кусок гoвнa админить несколько лет в своё время) в какую-нибудь манджару", но даже в пределах одного и того же семейства дриcтрибутивов это тот ещё цирк и сование deb-пакета из убунты в дебиан (или из дебиана в убунту) может породить очень интересные результаты в виде напрочь сдохшей системы. В винде в отличие от кocтылинупcoв всё сделано по уму и я спокойно запускаю под десяткой некоторые вещи, которыми ещё под Windows 2000 пользовался. Без пересборки под какая там сейчас версия visual studio актуальная. Тупо запустил файл и работаешь, ага. Писалось бы оно под гoвнoлинупc и его так называемые стандарты вместо полноценной операционной системы - скорее всего сейчас эта штука бы вообще не собралась, а бинарник от старой версии бы ни фига не запустился, само собой: опыт сборки заброшенных авторами года 3-4 назад программулек в современных гoвнoлинупcaх у меня есть и я давно понял что проще самому с нуля переписать чем это пропатчить.
Ответить | Правка | Наверх | Cообщить модератору

194. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 30-Июн-20, 02:22 
Я прекрасна знаю о своих проблемах с русским.

Где-ж ты раньше был учитель по русскому, я бы уже ленгвистом стал.

Но конечно, тебе некогда, ты же создаешь грамотные операционные системы а не то ведро которое всех окружает. Тоннами пакеты сопровождаешь и делаешь мир лучше.

Ответить | Правка | Наверх | Cообщить модератору

198. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от ann (??), 30-Июн-20, 15:43 
У тебя видно знания так и блещут. Аж прёт
Ответить | Правка | Наверх | Cообщить модератору

197. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 30-Июн-20, 02:35 
со своим уставом в чужой монастырь не ходят
Ответить | Правка | К родителю #180 | Наверх | Cообщить модератору

138. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (142), 26-Июн-20, 16:47 
> Visual C++ Redistributable

Некоторые их и таскают, ставят параллельно системным. Еще бывает redist вшивается в dll, называется static сборка. Ты redist не видишь, а он есть в проге.

Ответить | Правка | К родителю #92 | Наверх | Cообщить модератору

118. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 26-Июн-20, 08:03 
> Хороший обзор по теме: https://habr.com/ru/post/433052/

Ничего не вижу хорошего

> Свобода или рабство?

Всё. Это маркер. Как автор спадает к глупой религии, то сразу начинается бредятина.

> Чем больше своих приложений, тем меньше "взбрыки" в апстриме будут задевать компанию. Достаточно вспомнить историю, когда голосование в Дебиан по поводу systemd похоронило upstart, разрабатывавшийся Canonical.

То-то раньше в Debian дефолтом был Upstart? Нет? А как так тогда?
А всё просто - в Canonical не фанатики. Появилось что-то нормальное (systemd) - взяли выкинули свой Upstart.
Нету денег на декстоп - выкинули Unity 7 (которая и так опиралась на GNOME) в пользу GNOME со своими рюшками.

Не такой цели, о каких-то "взбрыках". Просто есть ниша, которой просто нет в репах дебиана.

Ответить | Правка | К родителю #54 | Наверх | Cообщить модератору

132. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от IRASoldier_registered (ok), 26-Июн-20, 15:05 
> Как автор спадает к глупой религии, то сразу начинается бредятина.

Так это до сих пор массовая проблема линуксоидов. Вместо практических вопросов ставить религиозные, а потом натягивать высосанные из пальца "практические" соображения на религиозный выбор. Слава небесам, этого дерьма все меньше, "верующие" стали, фактически, маргиналитетом и развитие Linux диктуется соображениями технологической применимости, удобства и выгоды.

А хороша статья не этим - хороша она тем, что озвучивает проблему _хотелок_ комьюнити vs качество процесса разработки и выкладки.


Ответить | Правка | Наверх | Cообщить модератору

139. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (142), 26-Июн-20, 16:50 
> Слава небесам

Почему именно им? Бог вездесущ вообще-то.
А с другой стороны Иисус зачем-то действительно возносился к небесам, в космос, наверное, улетал. На для древних писак это простительно.

Ответить | Правка | Наверх | Cообщить модератору

70. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (-), 25-Июн-20, 19:56 
Люди не готовы меняться для них новое - плохо, старое привычное - хорошо.
Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

41. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от Аноним (41), 25-Июн-20, 14:44 
Ну для стима очень неплохая вешь. Особенно если отредактировать права доступа.
Ответить | Правка | Наверх | Cообщить модератору

45. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –2 +/
Сообщение от Аноним (45), 25-Июн-20, 14:50 
Пользую -- относительно доволен. Для редко используемых приложений и на посмотреть. Когда нет желания загаживать систему. В сравнении с debian-testing обновления во флатпаке приходят меньше.
Ответить | Правка | Наверх | Cообщить модератору

61. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +5 +/
Сообщение от Аноним (61), 25-Июн-20, 17:55 
Но ведь есть нормальный формат распространяемых пакетов вместо этого дерьма. У флатпака минусов куда больше, чем плюсов.
Ответить | Правка | Наверх | Cообщить модератору

162. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (161), 27-Июн-20, 03:36 
> Для редко используемых приложений и на посмотреть. Когда нет желания загаживать систему.

man chroot

Ответить | Правка | К родителю #45 | Наверх | Cообщить модератору

47. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (47), 25-Июн-20, 15:18 
> Упрощена реализация установки в режиме P2P (позволяет организовать загрузку приложений и runtime-наборов через промежуточные узлы или накопители для систем без сетевого подключения)

Что такое P2P в разрезе : система без сетевого подключения.

?

Ответить | Правка | Наверх | Cообщить модератору

71. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (-), 25-Июн-20, 19:59 
Можно на флешках переносить ostree репозитории. В Endless пользуются этим, там в их центр приложений интегрирована поддержка.
Ответить | Правка | Наверх | Cообщить модератору

51. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –5 +/
Сообщение от IRASoldier_registered (ok), 25-Июн-20, 16:31 
Грубо упрощая - как snap, только версия здорового человека.
Ответить | Правка | Наверх | Cообщить модератору

63. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +8 +/
Сообщение от Аноним (63), 25-Июн-20, 18:12 
А что, ещё никто не догадался распространять приложения в виде слепка оперативки компа разработчика гигов на 16?
Ответить | Правка | Наверх | Cообщить модератору

65. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +4 +/
Сообщение от Olex (?), 25-Июн-20, 19:28 
Ну конечно куча дерьма и дыр в систему это стильно, модно, молодежно. Ну конечно мы олдфаги и ничего не понимаем. Даже того:зачем пытаться повторять ошибки Microsoft, Apple и Google. Хотя мой отец говорил: умный учится на чужих ошибках, а дураки - на своих.
Ответить | Правка | Наверх | Cообщить модератору

76. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от Аонимныйemail (?), 25-Июн-20, 20:41 
Глупые разработчики Линукс, до сих пор не могут перевести дистрибутивы на Ролинг Релиз, ну или хотя бы на частичный Ролинг, вон Майкрософт в Винде, и то приложения переводит в Мазик, чтобы независимо от системы могли обновляться, нет слов...
Ответить | Правка | Наверх | Cообщить модератору

80. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +4 +/
Сообщение от arthi747 (ok), 25-Июн-20, 21:46 
Ага. Только сегодня сразу две новости узрел как винда "прекрасно" обновляется. Нашли что приводить в пример.
Ответить | Правка | Наверх | Cообщить модератору

81. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (58), 25-Июн-20, 22:05 
Роллинг это непостоянство. Не нужно.
Ответить | Правка | К родителю #76 | Наверх | Cообщить модератору

90. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от ann (??), 26-Июн-20, 00:13 
Ничего ты не понимаешь. Если не будет ролинга система не будет сутками обновляться и тогда придётся рабоать. А так можно "у меня винда обновляется" и часами ничего не делать списывая рабочее время на обновления.
Ответить | Правка | Наверх | Cообщить модератору

78. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Аноним (78), 25-Июн-20, 21:10 
Гомогейство поглотило линух.
Ответить | Правка | Наверх | Cообщить модератору

82. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +5 +/
Сообщение от ann (??), 25-Июн-20, 22:56 
Какого только говна люди не придумают лишь бы маны не читать.
Ответить | Правка | Наверх | Cообщить модератору

83. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от ann (??), 25-Июн-20, 23:01 
Это называется я у мамы криворук и тугодум. Я смог только флатпак\снап осилить и то через одно место.

Уважение к чужому труду, пользователям и мантейнерам дистрибутивов это не про меня. Я буд лепить свои какашки и оборачивать тонной хрени чтобы не так воняло. А так то я пишу классный софт, он супер современный. Правда собирается только на моём компе, и то только до перезагрузки.

Ответить | Правка | Наверх | Cообщить модератору

84. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от ann (??), 25-Июн-20, 23:02 
А повторяемая сборка - не, не слышали. Мы лучше ещё один гавнопак придумаем.
Ответить | Правка | Наверх | Cообщить модератору

86. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Ддд (?), 25-Июн-20, 23:45 
Клоуны. Проще было бы иметь в системе разные рантаймы а не паковать их в каждый пакет.  Снапы вообще меры не знают - каждый чих по 200мб минимум
Ответить | Правка | Наверх | Cообщить модератору

91. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (-), 26-Июн-20, 00:41 
> Проще было бы иметь в системе разные рантаймы а не паковать их в каждый пакет.

Ровно так flatpak и делает.

Ответить | Правка | Наверх | Cообщить модератору

96. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от deeaitch (ok), 26-Июн-20, 02:52 
Это поколение программистов которое мы заслужили. Мы сами его выростили.

Это поколение которое не в состоянии освоить пакетный менеджер, это поколение которое редактор текста с подсветкой синтаксиса и плагинами (vscode) называют IDE, это поколение которое не понимает толком сборку софта, это поколение которое пишет такого качества софт что собирается он только на одной машине разработчика поэтому им нужен флатошлак.

Мы сами их выростили, помогая поставить линукс в надежде приобщить к прекрасному. Но тут как, можно вывести виндузятника из венды, но нельзя вывести виндовс с бывшего виндузятника.

Линукс был хорошим примером (в его лучшие годы) того, как просто сообщество интузиастов в свободное время может создать стройную логичную и красивую систему. И даже красная шапка в то время делала хорошие вещи для Linux, не портила, а именно делала.

Сейчас Linux хороший пример того как быдлокодеры способны извратить всё над чем работали кучища людей.

Мы выростили этих быдлокодеров, мы открыли им дверь в мир Linux. То что они сейчас делают это наше наказание.

Это не корпорации, корпорации были всегда, это быдлокодеры которые работают в этих корпорациях.

Зато понимаешь пишет своё .... собирает флакошлак и гордо говорит я программист под Linux. И все такое ууууууууууу ты крутой, давай дружить.

Это печально на самом деле. Квалификация падает прямо на глазах.

Они уже не знаю что бывают форматы передачи данных отличные от json. Но при этом у них портянки на bash, а лапша длинной в километр на json их не смущает. Почему? Они не знают другого. Они не могут осилить bash даже на начальном уровне.

Это они считают что api = rest (т.е. http)

И это пугает. Если их спросить то увидишь большие одивлённые глаза обкакавшейся белочки "А что можно как-то иначе?"

Печально. И это не толко в IT. Люди которые делали продукты, кторые поднимали / создавали экономику стран. Все они уходят на пенсию. А то что выросло.... оно ни о чём. Веб головного мозга обёрнутый в json и всё это внутри электрона который запускает жопаскрипт чтобы запустить жопаскипт чтобы запустить электрон который запустит жопаскипт.....

Но они программисты, многие даже написав календарик к mail.ru для андроид говорят что они embedded программисты.

Удачи вам ребята.

Ответить | Правка | Наверх | Cообщить модератору

102. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (102), 26-Июн-20, 03:53 
Это естественный ход событий, мир меняется. Хорошо это или плохо это другая тема
Ответить | Правка | Наверх | Cообщить модератору

106. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (63), 26-Июн-20, 06:13 
Чем больше предоставляешь школоте благ цивилизации, тем она тупее.
Ответить | Правка | Наверх | Cообщить модератору

109. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от deeaitch (ok), 26-Июн-20, 06:24 
> Это естественный ход событий, мир меняется. Хорошо это или плохо это другая
> тема

Согласен

Ответить | Правка | К родителю #102 | Наверх | Cообщить модератору

103. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от iPony129412 (?), 26-Июн-20, 04:52 
> Это поколение которое не в состоянии освоить пакетный менеджер

Глупости. Но всё равно тебе придётся в том числе идти мимо него.

> это поколение которое редактор текста с подсветкой синтаксиса и плагинами (vscode) называют IDE

В первый раз от тебя такое слышу.
А так и до этого vscode разработчики использовали редакторы на стреоидах типа того же vim/emacs.

> Линукс, линукc, линукс

А линукс тут и не причём - так везде.
Конечно раньше были профессионалы одни в IT.
Теперь "набежало". Ну так и профессионалы никуда не делись.
Ну а там где ресурсов нет и шаром покати будет вот такое плохого качества, или даже вообще ничего. Это закономерно. Вода под лежащий камень не течёт.

Ответить | Правка | К родителю #96 | Наверх | Cообщить модератору

107. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (63), 26-Июн-20, 06:19 
Профессионалов вытесняют школьники альтернативной ориентации. Ведь если ты возразишь альтернативному, что его код - гοвно, он поднимет визг о притеснении альтернативных, и тебя уволят. Если ты скажешь, что ты не альтернативный, тебя уволят. Так было с разработчиком JavaScript, которого уволили за традиционный гетеровзгляд.
Ответить | Правка | Наверх | Cообщить модератору

108. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (63), 26-Июн-20, 06:23 
А почему так получилось? Среди девятерых верховных судей Штатов, которые голосовали за введение альтернативщины, половина оказались... альтернативными. Представляете, 5 человек, перевернувшие всё вверх ногами.
Ответить | Правка | Наверх | Cообщить модератору

110. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 26-Июн-20, 06:31 
>> Это поколение которое не в состоянии освоить пакетный менеджер
> Глупости. Но всё равно тебе придётся в том числе идти мимо него.
>> это поколение которое редактор текста с подсветкой синтаксиса и плагинами (vscode) называют IDE
> В первый раз от тебя такое слышу.
> А так и до этого vscode разработчики использовали редакторы на стреоидах типа
> того же vim/emacs.

Может в певый. Я люблю emacs, больше чем vim. Почти умею его готовить (некоторым вещам так и не удалось научить). Просто на работе даже надоели с этим vscode. В чёс проблема не хочу говорить сейчас, портить себе настроение перед сном.

В любом случае если кого обидел, извиняюсь. Я тоже устал. И быть бэбиситером не лёгкое дело. Иногда накипает.

>> Линукс, линукc, линукс
> А линукс тут и не причём - так везде.
> Конечно раньше были профессионалы одни в IT.
> Теперь "набежало". Ну так и профессионалы никуда не делись.
> Ну а там где ресурсов нет и шаром покати будет вот такое
> плохого качества, или даже вообще ничего. Это закономерно. Вода под лежащий
> камень не течёт.

Да, ты прав

Ответить | Правка | К родителю #103 | Наверх | Cообщить модератору

200. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (200), 06-Июл-20, 16:05 
vim/emacs это не на стероидах, это на галоперидоле.
Ответить | Правка | К родителю #103 | Наверх | Cообщить модератору

168. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (166), 27-Июн-20, 09:14 
Это поколение не осилившее орфографию русского языка, но при этом пытающееся на нём учить других как им жить.
Ответить | Правка | К родителю #96 | Наверх | Cообщить модератору

176. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 27-Июн-20, 20:35 
> Это поколение не осилившее орфографию русского языка, но при этом пытающееся на
> нём учить других как им жить.

А я не говорил что русский мой родной язык. Кроме орфографии уже и придраться не к чему?

При этом я как минимум осили несколько языков. Пусть не все из них хорошо, с ошибками, но у меня их несколько. И несколько это больше 5.

И я знаю, я буду учить эти языки до конца жизни. При этом так и не сравняюсь с носителями. Что естественно.

Но ты не волнуйся, можешь и дальше ИБД в винде делать. Зачем знать несколько чего-то, можно знать одно гавно и всех учить что именно так надо.

Ответить | Правка | Наверх | Cообщить модератору

178. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 27-Июн-20, 20:41 
> При этом я как минимум осили несколько языков. Пусть не все из
> них хорошо, с ошибками, но у меня их несколько. И несколько
> это больше 5.

И да, сертификаты у меня есть.

Ответить | Правка | Наверх | Cообщить модератору

183. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (166), 28-Июн-20, 08:36 
Ценность твоих сертификатов наглядно показывает твоя русскоязычная орфография и способность понимать написанное по-русски. С высокой степенью вероятности с остальными языками у тебя не лучше.
Ответить | Правка | Наверх | Cообщить модератору

187. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 28-Июн-20, 20:07 
> Ценность твоих сертификатов наглядно показывает твоя русскоязычная орфография и способность
> понимать написанное по-русски. С высокой степенью вероятности с остальными языками у
> тебя не лучше.

Но она показывает спобоность писать и читать на не радном языке. В отличии от тебя, неосилятора даже манимальных мануалов на английском.

Ответить | Правка | Наверх | Cообщить модератору

191. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (190), 28-Июн-20, 20:55 
>спобоность

способность
>радном

родном
>манимальных

минимальных

Учись на следующий сертификат дальше, страдающий бэбиситтер-линупcoпрограммер. И чисто для сведения: кроме русского и английского я ещё хорошо знаю немецкий, в своё время подрабатывал переводчиком именно с него. Без всяких выданных самому себе сертификатов.

Ответить | Правка | Наверх | Cообщить модератору

195. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 30-Июн-20, 02:30 
Я то выучусь, не переживай.

Тем временем я осилил документацию, у меня спокойно собираются пакеты для различных линуксов. А у тебя так и остануться знания уровня ютубинки от васяна про фатшлак.

Ответить | Правка | Наверх | Cообщить модератору

172. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (172), 27-Июн-20, 15:48 
Выростили
Интузиастов

Ответить | Правка | К родителю #96 | Наверх | Cообщить модератору

177. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от deeaitch (ok), 27-Июн-20, 20:36 
> Выростили
> Интузиастов

Да, действительно, теперь платене капец. Ты жешь поколение хромого потребления лучше знаешь.

Ответить | Правка | Наверх | Cообщить модератору

179. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от deeaitch (ok), 27-Июн-20, 20:44 
> Выростили
> Интузиастов

Выростили им..ци..в которы даже авторизаваться не могут в со своим любимым браузером.

Ответить | Правка | К родителю #172 | Наверх | Cообщить модератору

121. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Билл Гейтс (?), 26-Июн-20, 11:38 
Линукс никогда не взлетит на десктопах, Линукс сильно фрагментирован и маргенален. Продолжайте изобретать костыли и велосипеды, а нормальные люди под Windows продолжат использовать сборки программ от их авторов, а не от армии криворуких и не успевающих за всем маинтейнеров пакетов.
Ответить | Правка | Наверх | Cообщить модератору

128. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –1 +/
Сообщение от Аноним (128), 26-Июн-20, 13:58 
> Линукс никогда не взлетит на десктопах, Линукс сильно фрагментирован и маргенален. Продолжайте изобретать костыли и велосипеды, а нормальные люди под Windows продолжат использовать сборки программ от их авторов, а не от армии криворуких и не успевающих за всем маинтейнеров пакетов.

Раздалось пронзительное кукареканье со стороны мелкомягкого адепта. Но линуксоиды, как всегда, не обратили на него внимания. Биллибой — не человек, что с него взять? И сегодня ему предстоит очень трудный день. У него уже много лет каждый лень был очень трудным и его вера в майков была разработана до такого состояния, что без труда вмещала методички за последние 10 лет.

Ответить | Правка | Наверх | Cообщить модератору

130. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (129), 26-Июн-20, 14:04 
Покукарeчь за швaбoдку, двухпроцентный.
Ответить | Правка | Наверх | Cообщить модератору

141. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Аноним (142), 26-Июн-20, 17:00 
> сборки программ от их авторов

Нафаршированные тулбарами от яндекса.
С другой стороны пробиться в официальные репозитории трудно. Но если производитель выкладывает deb или rpm, структуру пакета проверить легко.

Ответить | Правка | К родителю #121 | Наверх | Cообщить модератору

144. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (63), 26-Июн-20, 17:44 
> deb или rpm, структуру пакета проверить легко.

Вот поэтому придумали флэтпаки, чтобы проще троянов фигачить

Ответить | Правка | Наверх | Cообщить модератору

192. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (166), 28-Июн-20, 21:48 
Пингвин птица гордая, пока не пнёшь - не полетит.
Ответить | Правка | К родителю #121 | Наверх | Cообщить модератору

131. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от Аноним (131), 26-Июн-20, 14:32 
>  армии криворуких и не успевающих за всем маинтейнеров пакетов.

Ваш будущий выбор очевиден - Gentoo.

Ответить | Правка | Наверх | Cообщить модератору

135. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Билл Гейтс (?), 26-Июн-20, 16:08 
Весьма странный и нелогичный вывод.
Ответить | Правка | Наверх | Cообщить модератору

146. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (131), 26-Июн-20, 18:10 
>Весьма странный и нелогичный вывод.

Отчего же так?

Ответить | Правка | Наверх | Cообщить модератору

150. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Билл Гейтс (?), 26-Июн-20, 20:20 
От того, что даже в Gentoo нельзя избавиться от маинтейнеров и устанавливать программы напрямую от разработчкика, сразу, как только они появляются.
Ответить | Правка | Наверх | Cообщить модератору

148. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +2 +/
Сообщение от ann (??), 26-Июн-20, 19:22 
Вот не нашёл ни одного приложения которому нету прямо замены и только в флатшлаке.
Ответить | Правка | Наверх | Cообщить модератору

149. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (149), 26-Июн-20, 19:30 
> Разрешён прямой доступ к звуковым устройствам ALSA для приложений, имеющих доступ к Pulseaudio.

Кто пробовал? Звук в Блендере починился?

Ответить | Правка | Наверх | Cообщить модератору

151. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (151), 26-Июн-20, 21:21 
> От того, что даже в Gentoo нельзя избавиться от маинтейнеров и устанавливать программы напрямую от разработчкика, сразу, как только они появляются.

На самом деле это легко можно сделать. Есть так называемые live ebuild как правило они имеют название app.9999.build. С их помощью происходит сборка и установка как вы желали - с git. Соостветственно и ошибки сборки так же будут на вас.

Ответить | Правка | Наверх | Cообщить модератору

199. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (199), 30-Июн-20, 17:21 
Да, а лайв ебилд с прописанными зависимостями и костылями под очередную альтернативно-одарённую сборку сам появился, без мейнтейнера. И не надо мне говорить, что самому написать можно, из всего комьюнити, которое я видел во времена использования gentoo, только 5% это умеют и не ленятся сделать.
Ответить | Правка | Наверх | Cообщить модератору

152. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (151), 26-Июн-20, 21:29 
Извините, правильно будет так app-9999.ebuild
Ответить | Правка | Наверх | Cообщить модератору

155. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  –3 +/
Сообщение от Аноним (155), 26-Июн-20, 22:31 
Одна боль и беда от ваших линуксов и ни одного дня светлого. То одно не работает, то другое. Я пользоваться хочу, а не сидеть слепнем, под капотом шарить. Посадите разрабов рядом, я за каждый косяк буду пробивать, думаю мне придётся до смерти их забить.
Ответить | Правка | Наверх | Cообщить модератору

156. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (156), 26-Июн-20, 22:38 
install windows 10
Ответить | Правка | Наверх | Cообщить модератору

158. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от ann (??), 27-Июн-20, 00:16 
Боль от другого. Прими уже чтонибудь, не мучайся.
Ответить | Правка | К родителю #155 | Наверх | Cообщить модератору

163. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от Аноним (163), 27-Июн-20, 06:20 
Свеча с новокаином поможет.
Ответить | Правка | К родителю #155 | Наверх | Cообщить модератору

170. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от user90 (?), 27-Июн-20, 12:44 
Пожалуй основной косяк тут в сочетании разработчик+распространение, когда в линуксовой модели распространение = дистрибутив, и с этим нихрена не сделать! А все попытки совместить сабж с дистрибутивом лишь костыли с изолентой, от которых будет страдать в первую очередь сам [глупый] йузер, решивший таки заюзать Flatpak.
Ответить | Правка | Наверх | Cообщить модератору

171. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (63), 27-Июн-20, 15:20 
Просто разработчики настолько тупые, что проект компилируется и работает только на их машине. Вот поэтому придумали всякие шлакпаки.
Ответить | Правка | Наверх | Cообщить модератору

173. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +1 +/
Сообщение от user90 (?), 27-Июн-20, 16:56 
Скорее ленивые. Или может такую зависимость просто нельзя прописать у пакета. Скажем, кейлоггер))
Ответить | Правка | Наверх | Cообщить модератору

184. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от ан (?), 28-Июн-20, 11:41 
Ставлю из flatpak то что очково поставить напрямую в систему: Viber, Skype, Zoom, Remmina, PyCharm и то чего либо нет в репах дистра или в репах устаревшая версия.
Проблема одна - жирно занимает места, но если место есть и не перебарщивать, то очень полезная технология.
Snap как-то не зашел совсем, и версии в нем под дистр и могут быть безнадежно устаревшими. А на flatpak все версии свежие и работает одинаково на разных компах с разными дистрами, что на ubuntu 16.04, что на Arch, что на Gentoo.
И не надо, например, в gentoo c XFCE тонны кутей комплять ради одного приложения, а в 16.04 можно актуальной версией ПО воспользоваться, а не ставить из реп архаичную древность или заниматься переустановкой дистра на последний релиз.
Ответить | Правка | Наверх | Cообщить модератору

188. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (188), 28-Июн-20, 20:07 
Сколько ж ты говна перечислил.. смотри, чтоп оно тебя не поставило раком, лягушонок)
Ответить | Правка | Наверх | Cообщить модератору

193. "Релиз системы самодостаточных пакетов Flatpak 1.8.0"  +/
Сообщение от Аноним (193), 29-Июн-20, 23:10 
Для дебиан stretch в бакпортах
только 1.2.5
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру