The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"OpenNews: Инициатива по прекращению поддержки старых версий ..."
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [Проследить за развитием треда]

"OpenNews: Инициатива по прекращению поддержки старых версий ..."
Сообщение от opennews on 05-Авг-05, 16:44 
Adrian Bunk  предложил (http://kerneltrap.org/node/5527) включить в -mm ветку патч, убирающий поддержку старых версий GCC (http://gcc.gnu.org/) в Linux ядре 2.6.x.


При использовании этого патча, ядро уже не сможет быть собрано GCC 2.95, 2.96, 3.0 и 3.1. Останется лишь поддержка версий 3.2, 3.3, 3.4, 4.0.


Общественность, в списке рассылки LKM, крайне отрицательно отозвалась о присланном патче. Например, при его использовании, ядро вообще не сможет быть собрано на платформе VAX (http://linux-vax.sourceforge.net/), некоторые замечают странные ошибки, проявляющиеся только при сборке последней версией GCC.


В итого, ядро будет еще долго поддерживать сборку с использованием  GCC 2.95.

URL: http://kerneltrap.org/node/5527
Новость: https://www.opennet.ru/opennews/art.shtml?num=5873

Cообщить модератору | Наверх | ^

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


2. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от gate email on 05-Авг-05, 16:51 
да уж, красноглазики уже не знают чего бы еще сделать для своего линупса.

пару недель назад была новость о патчах, с помощью которых можно собирать древние 2.2 ядра новым напильником, а тут все наоборот :)

Cообщить модератору | Наверх | ^

3. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Czarker email on 05-Авг-05, 16:55 
А мне кажется, это неплохая мысль. Надо чистить код.
Cообщить модератору | Наверх | ^

4. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Аноним email on 05-Авг-05, 18:17 
Старье в утиль! Даже мс от 98 виндов отказались. Новые версии требуют для зависимостей пакеты новых версий. Так почему ядро не может?
Cообщить модератору | Наверх | ^

5. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от const (??) on 05-Авг-05, 21:38 
Видать, кому-то влом обновлять компилятор... Однако ж не влом обновлять ядро! О_о
Cообщить модератору | Наверх | ^

10. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Аноним on 07-Авг-05, 12:06 
>Видать, кому-то влом обновлять компилятор... Однако ж не влом обновлять ядро! О_о

Сэр хоть раз обновлял GCC без обновления версии дистрибутива и половины пакетов в нем ?


Cообщить модератору | Наверх | ^

11. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от rost on 07-Авг-05, 12:31 
не знаю как автор того сообщения... но я менял ;) точнее не менял,а просто поставил новый компилятор в /opt и прописал его в $PATH. ВСЕ! и ничего обновлять и пересобирать не надо ;)
Cообщить модератору | Наверх | ^

6. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Wulf email on 06-Авг-05, 00:43 
Все, на что хватило автора патча, это поправить проверку на версию gcc без каких-либо других измений в коде ядра :-). Неудивительно, что остальные люди из LKM "крайне отрицательно отозвалась о присланном патче". Вообще, исходя из публикаций в инете, можно подумать о том, что единственная система которая пытается получить выгоду от gcc >=3  является dragonflybsd. А остальные пытаются отдать дань моде.
Cообщить модератору | Наверх | ^

7. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от demongloom on 06-Авг-05, 00:49 
Дык а что еще требуется? Только указать что требуется гыц 3
Cообщить модератору | Наверх | ^

13. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Аноним on 08-Авг-05, 04:16 
Если в курсе, то какие преимущества они используют. Кроме как улучшенной кодогенерации?
Расширенный синтаксис?

Спасибо!

Cообщить модератору | Наверх | ^

15. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от wulf on 08-Авг-05, 13:04 
> Если в курсе, то какие преимущества они используют. Кроме как улучшенной кодогенерации?

из Release Notes for DragonFly 1.2.0

This will be last release that uses GCC 2.95.x as the default compiler. Both GCC 3.4.x and GCC 2.95.x are supported in this release through the use of the CCVER environment variable ('gcc2' or 'gcc34'). GCC 2.95.x is to be retired soon due to its lack of TLS support. The current development branch will soon start depending heavily on TLS support and __thread both within the kernel and in libc and other libraries. This release fully supports TLS segments for programs compiled with gcc-3.4.x.

Cообщить модератору | Наверх | ^

18. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Аноним on 09-Авг-05, 05:11 
В свете распространения многопроцессорности, многоядерности, широкого использования многопоточности, решение использовать TLS обоснованное. А там заодно и С99 использовать будут.
Cообщить модератору | Наверх | ^

8. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Аноним email on 06-Авг-05, 01:04 
Зачем такие примочки вообще нужны ! Лучше бы зделали чтонибудь полезное .
Cообщить модератору | Наверх | ^

9. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Аноним email on 07-Авг-05, 02:03 
Согласен... Безопасностью ядра бы занялись...
Cообщить модератору | Наверх | ^

12. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Аноним email on 07-Авг-05, 17:04 
Все от кривых рук. Ибо ВСЕ версии софта должны компилиться ВСЕМИ версиями компиляторов. Иначе это ущербность программистов, не более, не менее.
Cообщить модератору | Наверх | ^

14. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от andreyn email(??) on 08-Авг-05, 09:12 
А это попросту невозможно. Версии GCC <3.* шли своим путём развития. А начиная с 3.* стали стремится в сторону соотвествия международным стандартам POSIX, ISO.
Cообщить модератору | Наверх | ^

16. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Khizha email on 08-Авг-05, 17:52 
Согласен. Версии 2.9х вообще не соответствуют ISO. Особенно в STL.
Cообщить модератору | Наверх | ^

17. "Инициатива по прекращению поддержки старых версий GCC в Linu..."
Сообщение от Mike email(??) on 09-Авг-05, 01:26 
2.9х не поддерживает более новый стандарт языка С -  С99, а поддерживает С89 (кто читал "Язык программирования С", тот поймёт). С99 - более удобный для написания программ, расширены стандартные библиотеки, ослаблена строгость синтаксиса (например, что переменные теперь можно объявлять по ходу программы, а не только в начале конструкции).
Cообщить модератору | Наверх | ^

Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру