The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Проект OpenBSD начинает публиковать обновления пакетов для с..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от opennews (??), 14-Авг-19, 19:37 
Анонсирована (https://marc.info/?l=openbsd-announce&m=156577865917831&w=2) публикация обновлений пакетов для стабильной ветки OpenBSD. Ранее при использовании  ветки "-stable" можно было получать только бинарные обновления к базовой системе через syspatch (https://man.openbsd.org/syspatch). Пакеты собирались один раз для релизной ветки и более не обновлялись.


Теперь же планируется поддерживать три ветки:


-  "-release": замороженная ветка, пакеты из которой собираются один раз для релиза и более не обновляются (6.3, 6.4, 6.5, ...).
-  "-stable": только консервативные обновления. Собранные из портов пакеты обновляются только для последнего релиза (в настоящее время 6.5).
-  "-current": находящаяся в разработке основная ветка, в неё попадают самые значительные изменения. Пакеты собираются только для ветки "-current".


В "-stable" планируется добавлять, главным образом, исправления уязвимостей для портов, а также некоторые прочие важные исправления. Сейчас обновления для -stable/amd64 уже появились на большинстве зеркал (каталог /pub/OpenBSD/6.5/packages-stable), обновления для i386 собираются и тоже скоро будут доступы.  Узнать больше про управление пакетами в OpenBSD можно в соответствующей главе (https://www.openbsd.org/faq/faq15.html) официального FAQ (https://www.openbsd.org/faq/).


Необходимая для использования ветки "-stable" эвристика уже добавлена в утилиту pkg_add, которая может задействовать пакеты из каталога "/packages-stable/" при использовании /etc/installurl без выставления переменной окружения PKG_PATH  или при использовании модификаторов %c или %m в переменной PKG_PATH. Сразу после очередного значительного релиза OpenBSD публикуется пустой каталог "packages-stable", который затем наполняется по мере публикации обновлений с устранением уязвимостей и ошибок.

URL: https://undeadly.org/cgi?action=article;sid=20190814112133
Новость: https://www.opennet.ru/opennews/art.shtml?num=51283

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


2. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –4 +/
Сообщение от Alexeyemail (??), 14-Авг-19, 19:42 
Всё становится на свои места, как у FreeBSD. Это хорошо.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +3 +/
Сообщение от пох. (?), 14-Авг-19, 19:51 
у фребеэсде "квартальные срезы", это совсем не о том.

то есть зачем может понадобиться бинарный пакет двухлетней давности - я примерно догадываюсь.
А вот зачем может понадобиться бинарный пакет собранный два года назад в "штабильной" полуподдерживаемой версии и с тех пор не обновлявшийся, при том что пакет, собранный для stable, скорее всего будет и в ней работать, а не будет так лучше б и не надо - это я хз.

при том что, разумеется, бинарные пакеты отличные от последних нужны только и исключительно быстро заткнуть какую-то текущую дырку. Во всех остальных случаях всегда можно самому собрать именно такой, какой тебе надо.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

8. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от б.б. (?), 14-Авг-19, 19:53 
> А вот зачем может понадобиться бинарный пакет собранный два года назад в "штабильной" полуподдерживаемой версии и с тех пор не обновлявшийся

ча-го? TTL штабильной версии - полгода

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от пох. (?), 14-Авг-19, 19:54 
так они для неживых тоже собрались сохранять.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

14. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –3 +/
Сообщение от zzz (??), 14-Авг-19, 21:02 
Что значит "неживых" и кто тут взялся решать, что живое, а что нет? "Седина в бороду, маразм в голову"?
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

16. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +1 +/
Сообщение от Дон Ягон (ok), 14-Авг-19, 22:00 
> Что значит "неживых" и кто тут взялся решать, что живое, а что нет? "Седина в бороду, маразм в голову"?

Речь про, например, это:
https://cdn.openbsd.org/pub/OpenBSD/6.3/packages/amd64/
https://cdn.openbsd.org/pub/OpenBSD/5.9/packages/amd64/
И 6.3, и 5.9 - неподдерживаемые релизы. И пакеты к ним - тухлятина.
Вопрос в том, зачем их хранить.

С другой стороны, лично я в этом и трагедии не вижу, хотя и пользы от этого тоже как будто бы нет.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

32. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –2 +/
Сообщение от zzz (??), 15-Авг-19, 11:49 
Ситуации разные бывают. В FreeBSD 11.1 майкрософтовчане сломали драйвер sata на HV2008. Не помню, починили ли в 11.2, но в 12.0 починили точно. В другой ситуации то ли потеряли сырцы, то ли давно ушел разработчик софтины, но спека требовала поставить конкретную версию конкретно тухлого дебиана.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

49. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +1 +/
Сообщение от PereresusNeVlezaetBuggy (ok), 07-Сен-19, 01:21 
Зеркала их хранить не обязаны. Зато если вам потребуется, например, продублировать имеющуюся систему, такой архив сильно выручит.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

51. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от Дон Ягон (ok), 09-Сен-19, 23:59 
> Зеркала их хранить не обязаны. Зато если вам потребуется, например, продублировать имеющуюся систему, такой архив сильно выручит.

Спасибо за ответ. Я, правда, в любом случае не очень сильно переживаю из-за наличия этих файлов, есть и ничего страшного.

PS: Рад снова видеть тебя тут, хоть мы и не знакомы. Твои посты про openbsd всегда интересны и полезны.

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

26. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от zurapa (ok), 15-Авг-19, 08:52 
Я сейчас не к контексту данной новости, а больше к вашему вопросу, зачем может понадобиться бинарный пакет, скольки-нибудь лет давности.

Вот была такая хорошая стабильная, дырявая технология pptp. Да, конечно, сейчас её не безопасно использовать, легко ломается и всё такое. Только правда жизни такова, что npppd почему-то умеет pptp сервер, а пакет pptp вырезали из OpenBSD ещё на версии 5.9, если не ошибаюсь. А также, многие кровавые энтерпразы, которые не газ пром, с неба звёзд не хватают, поэтому не переделывают свои VPN и по прежнему используют pptp подключение к корпоративной сети. Так вот я о чём. Вот зафанатил пацанчик от OpenBSD сел в неё, всё ему нравится, а маршрутизатор настроить, чтобы в свой кровавый энтерпрайз лазить не может. И вот тут начинается ковыряние палкой в навозной куче трицератопсов той ещё эпохи.

В общем иногда бывает нужно старые пакетики достать и поставить, которых уже нет в производстве. Другое дело, что эти пакетики не встанут на новую систему, из-за отсутствия других старых пакетиков, и всё как снежный ком. Проще из исходников собрать.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

28. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от пох. (?), 15-Авг-19, 10:08 
> Я сейчас не к контексту данной новости, а больше к вашему вопросу, зачем может понадобиться
> бинарный пакет, скольки-нибудь лет давности.

это вам - в freebsd. Там такое вроде бы держат (теперь).

А тут у вас не бинарный пакет сколькитолетней давности, а бинарный пакет сколькитолетней давности собранный _для_версии_системы_ той же давности в день ее выпуска. Которая вам скорее всего - нафиг не нужна, а если даже она вам и нужна - вам нафиг не нужен тот пакет, вам нужен либо текущий, либо последний еще собираемый.

И да, самостоятельную сборку из портов тоже никто не отменял, в том числе и с чекаута на дату до всемирного потопа.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

33. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –4 +/
Сообщение от zzz (??), 15-Авг-19, 11:54 
Убавь понты, тебя никто не уполномачивал говорить за всех, что нужно и какой версии. Бывают случаи, когда нужна вот именно тот древний релиз с теми древними пакетами. И раз разработчики опенка на это пошли, значит таких случаев достаточно.
Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

37. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +1 +/
Сообщение от пох. (?), 15-Авг-19, 14:31 
> Убавь понты, тебя никто не уполномачивал говорить за всех, что нужно и

переадресую это тебе

> какой версии. Бывают случаи, когда нужна вот именно тот древний релиз
> с теми древними пакетами.

вот мы и обсуждаем - как этот случай выглядит. Если тебе нечего сказать - ну так помолчал бы, за умного бы глядишь, сошел.

> И раз разработчики опенка на это пошли, значит таких случаев достаточно.

разработчики вовсе не являются непогрешимыми и б-говдохновленными.
И могут делать херню - например, просто потому что могут - скрипты для этой цели имеются, а для сопровождения и обновлений пакетов хотя бы под предыдущую версию - нет.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

38. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –3 +/
Сообщение от zzz (??), 15-Авг-19, 17:22 
Выше я привел примеры того, зачем бывают нужны старые версии. Если бы ты умел читать - то прочитал бы и промолчал по своему же совету, которые ты активно раздаешь, но сам им не следуешь, начиная с "обмазывайтесь свежайшим", как тебе ниже указали, как указали и на то, что никому не интересно, что ты там думаешь по поводу чего-то там, а думаешь ты всегда одинаково в любой теме.
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

39. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от пох. (?), 15-Авг-19, 17:52 
> Выше я привел примеры того, зачем бывают нужны старые версии. Если бы

если бы ты научился не хамить незнакомым людям - я бы может и потратил время на детальное разжевывание, чем отличается установка старых дебианов от установки пакетов собранных три года назад на праздник нового релиза. А пока неохота. Оба твои примера - /0

> на то, что никому не интересно, что ты там думаешь по

никому неинтересно что тебе неинтересно.

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

41. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –1 +/
Сообщение от zzz (??), 15-Авг-19, 21:33 
Другого ответа от благородного дона со звездой во лбу я и не ожидал. Вы все как на подбор сперва рвете на себе рубаху, а как до дела, так сразу как мыши под лавку, и строите из себя оскорбленную невинность.
Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

42. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от ПростоЧитатель (?), 16-Авг-19, 23:36 
> разработчики вовсе не являются непогрешимыми и б-говдохновленными.

1 пох - являются непогрешимым и б-говдохновленным? (да-нет?)
> И могут делать херню

2 пох НЕ может делать херню? (да-нет?)

Если оба ответа - да, То пох - НЕ разработчик
Иначе - пох, может, поменьше категоричности?

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

46. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от zurapa (ok), 18-Авг-19, 20:12 
> Убавь понты, тебя никто не уполномачивал говорить за всех, что нужно и
> какой версии. Бывают случаи, когда нужна вот именно тот древний релиз
> с теми древними пакетами. И раз разработчики опенка на это пошли,
> значит таких случаев достаточно.

На сколько я помню Тео за то, чтобы операционные системы работали без лишнего шаманства, поэтому как раз и остаются релизы старые, чтобы что-то древнее можно было вытащить, поставить и завести без извратов с кучей пересборок под текущую систему, которая всё равно через полгода обновится, и всё придётся делать по новой.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

45. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от zurapa (ok), 18-Авг-19, 20:10 
>> Я сейчас не к контексту данной новости, а больше к вашему вопросу, зачем может понадобиться
>> бинарный пакет, скольки-нибудь лет давности.
> это вам - в freebsd. Там такое вроде бы держат (теперь).
> А тут у вас не бинарный пакет сколькитолетней давности, а бинарный пакет
> сколькитолетней давности собранный _для_версии_системы_ той же давности в день ее выпуска.
> Которая вам скорее всего - нафиг не нужна, а если даже
> она вам и нужна - вам нафиг не нужен тот пакет,
> вам нужен либо текущий, либо последний еще собираемый.
> И да, самостоятельную сборку из портов тоже никто не отменял, в том
> числе и с чекаута на дату до всемирного потопа.

Вы это сказали со знанием дела, или просто подискутировать? Спрашиваю к том, что есть вопросы по этой теме сборки утилит в OpenBSD, что в дистрибутив зашиты, но не знаю куда задавать.

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

47. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +1 +/
Сообщение от Аноним (47), 19-Авг-19, 15:58 
> ... бинарные пакеты отличные от последних нужны только и исключительно быстро заткнуть какую-то текущую дырку ...

Или открыть дырку там где её не было ;)

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

3. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –2 +/
Сообщение от пох. (?), 14-Авг-19, 19:43 
вот объясните мне, благородный дон, зачем в принципе нужно хранить мусорную свалку устаревших дырявых бинарных сборок для устаревших версий системы? Если у проекта очевидно все хреново с ресурсами - не проще и не лучше ли как раз от этого ненужна освободить место?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +1 +/
Сообщение от Дон Ягон (ok), 14-Авг-19, 19:47 
> вот объясните мне, благородный дон

Если у меня не мания величия и это ко мне, то, на самом деле, это не ко мне.
Я не участник проекта OpenBSD, только пользователь и доброжелатель.

> зачем в принципе нужно хранить мусорную свалку устаревших дырявых бинарных сборок для устаревших версий системы?

Речь про бинарники для неподдерживаемых -release веток?
Не знаю, зачем их хранить, твоя аргументация мне вполне понятна. ЕМНИП, поддерживаются только 2 последних релиза - вот только для них бы и хранил.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

9. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –2 +/
Сообщение от пох. (?), 14-Авг-19, 19:54 
да собственно и для предпоследнего непонятно, зачем - бинарник для последнего в нем запустится.
Если прям очень-очень надо.

Борьба за воспроизводимость initial setup при отсутствии нормальной поддержки даже базовой системы в нем? Нууу, знаете... Ядерный реактор я бы такой системе, пожалуй, не доверил.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

17. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +1 +/
Сообщение от Дон Ягон (ok), 14-Авг-19, 22:12 
> да собственно и для предпоследнего непонятно, зачем - бинарник для последнего в нем запустится.

Насколько я понимаю, не факт. Могу ошибаться, ибо не интересовался этим вопросом в контексте OpenBSD. Но кажется, работоспособность пакетов от новой версии в старой там не гарантируется (как в принципе и почти везде). А гарантировать работу пакетов для поддерживаемых релизов всё-таки хочется.

> Борьба за воспроизводимость initial setup при отсутствии нормальной поддержки даже базовой системы в нем?

Я могу только повторить: я не знаю, зачем это делается. Мои предположения: или для какой-то странной истории или потому что руками чистить лень (или некому), автоматику писать лень (или некому), а место не жмёт.

> Ядерный реактор я бы такой системе, пожалуй, не доверил.

Из-за того, что они не удаляют пакеты и релизные образы для старых систем?
Нууу, знаете... Я, конечно, не имею опыта управления атомным реактором, но почти уверен, что есть более веские причины для того, чтобы не использовать там OpenBSD, чем наличие на зеркалах старых пакетов.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

19. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от анонн (ok), 14-Авг-19, 23:23 
> Но кажется, работоспособность пакетов от новой версии в
> старой там не гарантируется (как в принципе и почти везде). А гарантировать работу пакетов для поддерживаемых релизов всё-таки хочется.

Насчет гарантий не буду спорить, но во фре есть "compat"
https://www.freshports.org/misc/compat4x/
https://www.freshports.org/misc/compat6x/
.
.
https://www.freshports.org/misc/compat10x/
> This package allows you to install the compat10x libraries on your system, so you can use legacy binaries that depend on them.


grep COMPAT /usr/src/sys/amd64/conf/GENERIC
options     COMPAT_FREEBSD32    # Compatible with i386 binaries
options     COMPAT_FREEBSD4        # Compatible with FreeBSD4
options     COMPAT_FREEBSD5        # Compatible with FreeBSD5
options     COMPAT_FREEBSD6        # Compatible with FreeBSD6
options     COMPAT_FREEBSD7        # Compatible with FreeBSD7
options     COMPAT_FREEBSD9        # Compatible with FreeBSD9
options     COMPAT_FREEBSD10    # Compatible with FreeBSD10
options     COMPAT_FREEBSD11    # Compatible with FreeBSD11

Потестил на http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-relea... (2007 год, mpg - потому что минимальные зависимости), т.е. скачал, распаковал, запустил.
Вполне работает, проигрывает вебрадио.
Но вот для чего-то более сложного придется городить огород из jail/chroot, а что там будет с иксами - как-то и пробовать не хочется.
Для действительно старого софта - как бы не проще все в виртуалку запихнуть.

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

20. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от Дон Ягон (ok), 15-Авг-19, 00:17 
> Насчет гарантий не буду спорить, но во фре есть "compat"

А разве оно работает в обратную сторону?
Оно же, если я всё верно помню, для того, чтобы (условно) запускать пакеты от восьмёрки в девятке или десятке или выше.
Но не для того, чтобы запускать в восьмёрке пакеты от десятки или 12. Разве нет?
А речь, вроде бы, про это.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от анонн (ok), 15-Авг-19, 01:04 
> А разве оно работает в обратную сторону?

Не, не. Новые сисколы так просто не завезешь.

> Оно же, если я всё верно помню, для того, чтобы (условно) запускать
> пакеты от восьмёрки в девятке или десятке или выше.
> Но не для того, чтобы запускать в восьмёрке пакеты от десятки или
> 12. Разве нет?
> А речь, вроде бы, про это.

Я пару раз перечитал ветку и до Вашего ответа в #17 (где я таки проглядел формулировку "Но кажется, работоспособность пакетов от _новой версии в старой_ там не гарантируется (как в принципе и почти везде)" ) у меня такое впечатление, что речь шла о "запускать старое в новом".


Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

22. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от Дон Ягон (ok), 15-Авг-19, 01:17 
> Не, не. Новые сисколы так просто не завезешь.

Ну вот да.

> у меня такое впечатление, что речь шла о "запускать старое в новом".

Я сначала действительно написал "обратная совместимость" и только потом отредактировал на вариант с  "новой версией в старой". Так что, возможно, неправильное понимание было спровоцировано мною.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

18. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +5 +/
Сообщение от ПростоЧитатель (?), 14-Авг-19, 22:41 
То "обмазываетесь свежайшим", то "мусорная свалка"...
Простите, но очень похоже на этакое высокомерное старческое брюзжание.
Ну хранят люди историю системы без вашего высочайшего соизволения, и чё?
Прям эти файлы вас кусают.
А для ядерных реакторов и без опенка имеется множество штабильных, недырявых и широко распространённых операционных систем.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

40. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от пох. (?), 15-Авг-19, 17:54 
> То "обмазываетесь свежайшим", то "мусорная свалка"...

вам тоже совсем неизвестны отдельные от этих-двух вариантов?
Ну значит, имею право на высокомерие.

> Ну хранят люди историю системы без вашего высочайшего соизволения, и чё?

ничего - спросил у автора новости, нахрена. Автор ответил что тоже, в общем, не понимает.
Ну ооок.


Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

43. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от ПростоЧитатель (?), 16-Авг-19, 23:49 
пох: (19:43 14/08/2019)
> вот объясните мне, благородный дон, зачем в принципе нужно хранить мусорную свалку?

пох: (10:11 15/08/2019)
> я вот гуанохранилку из навоза собираю

Всего ночь прошла, и всё понял.
Прям другой человек.

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

44. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от пох. (?), 17-Авг-19, 22:13 
> Всего ночь прошла, и всё понял.
> Прям другой человек.

у меня там гуано другого сорта. Если бы мне нужно было хранить инфраструктуру для использования древней-древней версией чегонибудь-bsd, я бы хранил там исходники. Которые, если современные уже не собираются или вообще исчезли, в крайнем случае можно и самому поправить в отдельных местах, или собрать в минимальном варианте. (нет http2 - нет уязвимостей в нем)

к сожалению, для того что мне на самом деле нужно, не получится. Полноценную билдсистему я не осилю у себя держать.

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

24. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +3 +/
Сообщение от mma (?), 15-Авг-19, 05:59 
Вот есть машина на которой работает бородатая система, работает есть не просит, уязвимостями не светит. И тут тебе для каких-то внутренних функций(обработка и выгрузка данных например) понадобилось какое-нибудь приложение. А тут оказывается горячие парни поудаляли старые релизы и ты такой "ох шит что же я это не зазеркалировал в свое время".
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

29. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от пох. (?), 15-Авг-19, 10:11 
дык - собери! Вот архивы с исходниками старых версий - их да, неплохо бы хранить. И места поменьше расходуется, и востребованы они не на единственной версии системы.

Не знаю как сейчас с этим у опенка.
У фри - разно.

> ты такой "ох шит что же я это не зазеркалировал в свое время".

а ты думаешь, я вот гуанохранилку из навоза собираю - для защиты жилья от демонов?

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

35. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от ПростоЧитатель (?), 15-Авг-19, 13:03 
>"вот объясните мне,..., зачем"
>"я вот гуанохранилку из навоза собираю"
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

36. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от пох. (?), 15-Авг-19, 14:20 
>>"вот объясните мне,..., зачем"

в смысле? Вот затем и собираю, чтобы хранить архивы древних версий никому кроме меня ненужного софта, на дядь надежды мало - они только отпечатки пальцев и relation graphs вечно хранить планировали.

Платить за это денег - не хочу, поэтому из навоза - прах к праху, дерьмо к дерьму.

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

48. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от zurapa (ok), 19-Авг-19, 17:53 
> Вот есть машина на которой работает бородатая система, работает есть не просит,
> уязвимостями не светит. И тут тебе для каких-то внутренних функций(обработка и
> выгрузка данных например) понадобилось какое-нибудь приложение. А тут оказывается горячие
> парни поудаляли старые релизы и ты такой "ох шит что же
> я это не зазеркалировал в свое время".

Во-во-во-во! У меня так было!

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

5. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  –7 +/
Сообщение от Растошизик (?), 14-Авг-19, 19:51 
Уже переписали на Rust?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +2 +/
Сообщение от Минона (ok), 14-Авг-19, 20:33 
Хаскель не ржавеет!
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +2 +/
Сообщение от б.б. (?), 14-Авг-19, 19:52 
не прошло и 23-х лет :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от Ананимус (?), 14-Авг-19, 20:48 
Ну чот припознились ребята.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

50. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от PereresusNeVlezaetBuggy (ok), 07-Сен-19, 01:26 
Они и раньше были, но пакеты собирала M:Tier. Ещё раньше проект также сам собирал пакеты, но перестал из-за нехватки ресурсов (в первую очередь, человеческих).
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

13. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от Аноним (13), 14-Авг-19, 20:54 
Ну наконец-то! Джвадчать лет ждал.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

31. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +2 +/
Сообщение от Анонимemail (31), 15-Авг-19, 11:03 
Все это хорошо, но где песня ?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

34. "Проект OpenBSD начинает публиковать обновления пакетов для с..."  +/
Сообщение от Andrey Mitrofanov_N0 (??), 15-Авг-19, 11:55 
> Все это хорошо, но где песня ?

Поздно.  Пестнь про _бинари_ уже перекупила Микрософта: https://www.opennet.ru/openforum/vsluhforumID3/40483.html#18

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру