The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"dhcp option 82"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"dhcp option 82"  
Сообщение от vld email(ok) on 16-Окт-06, 10:39 
Добрый день.
Есть схема Router2821-Catalyst3750-ClientPC. Нужно по конкретному порту коммутатора выдавать всегда один и тот же IP. DHCP сервер - на 2821.
Без dhcp option 82 клиент получает IP просто из пула адресов, после включения опции - нет. Клиент подключен к интерфейсу fa 1/0/35
В чем может быть проблема?
Вот конфиги:
2821:
!
ip dhcp pool POOL1
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   class CLASS1
      address range 192.168.0.10 192.168.0.10
!
!
ip dhcp class CLASS1
   relay agent information
      relay-information hex 0017e0399b27*
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 4
ip dhcp relay information trusted
ip address 192.168.0.1 255.255.255.0
no cdp enable
!

cisco2800#sh ver
Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(9)T, RELEASE SOFTWARE (fc1)


Catalyst:

!
interface FastEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
ip dhcp snooping trust
!
interface FastEthernet1/0/35
switchport access vlan 4
switchport protected
spanning-tree portfast
ip dhcp snooping trust
!
!
ip dhcp snooping vlan 4
ip dhcp snooping information option allow-untrusted
ip dhcp snooping
ip dhcp-server 192.168.0.1
!


Switch1#sh ip dhcp snooping
Switch DHCP snooping is enabled
DHCP snooping is configured on following VLANs:
4
Insertion of option 82 is enabled
Option 82 on untrusted port is allowed
Verification of hwaddr field is enabled
Interface                    Trusted     Rate limit (pps)
------------------------     -------     ----------------
FastEthernet1/0/1            yes         unlimited
FastEthernet1/0/2            yes         unlimited
FastEthernet1/0/35           yes         unlimited
FastEthernet1/0/36           yes         unlimited
FastEthernet1/0/37           yes         unlimited

Switch1#sh int fa 1/0/35
FastEthernet1/0/35 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0017.e039.9b27 (bia 0017.e039.9b27)

Switch1#sh ver
Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(25)SEB4, RELEASE SOFTWARE (fc1)

Вот пример на циске
http://cisco.com/en/US/products/sw/iosswrel/ps5012/products_feature_guide09186a0080173d22.html
не очень понятен их пример, в частности
ip dhcp class CLASS1
relay agent information
relay-information hex 01030a0b0c02050000000123
relay-information hex 01030a0b0c02*
relay-information hex 01030a0b0c02050000000000 bitmask 0000000000000000000000FF
Спасибо :)


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

  • dhcp option 82, vld, 11:45 , 16-Окт-06, (1)  

Сообщения по теме [Сортировка по времени, UBB]


1. "dhcp option 82"  
Сообщение от vld email(ok) on 16-Окт-06, 11:45 
неправильно Class1 прописываю. А вот как это сделать правильно?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру