The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"конфигурация vrf"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"конфигурация vrf"  
Сообщение от unpinget on 04-Сен-06, 18:21 
Доброго времени суток! Подскажите пожалуйста где можно найти документацию по vrf(virtual routing and forwarding), а то в гугле что-то ничего нормального не нашел...

Просто требуется настроить интерфейсы так, чтобы один интерфейс использовал одну таблицу маршрутизации, а другой - другую.

Заранее спасибо!

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "конфигурация vrf"  
Сообщение от StSphinx (??) on 04-Сен-06, 21:02 
>Доброго времени суток! Подскажите пожалуйста где можно найти документацию по vrf(virtual routing
>and forwarding), а то в гугле что-то ничего нормального не нашел...
>
>
>Просто требуется настроить интерфейсы так, чтобы один интерфейс использовал одну таблицу маршрутизации,
>а другой - другую.
>
>Заранее спасибо!


Вам нужен полноценный MPLS или просто изоляция таблиц маршрутизации?
Если полноценный MPLS то www.cisco.com , www.mpls-exp.ru
Если просто изоляция то вот пример:

ip vrf TEST
rd 100:2
route-target export 100:2
route-target import 100:2

interface MFR1.2 point-to-point
ip vrf forwarding TEST
ip address 192.168.2.2 255.255.255.252
no cdp enable
frame-relay interface-dlci 15

interface FastEthernet0/0.12
encapsulation dot1Q 12
ip vrf forwarding TEST
ip address 172.16.12.254 255.255.255.0
no ip redirects
no snmp trap link-status

ip route vrf COMMON 0.0.0.0 0.0.0.0 192.168.2.1

Это частный способ организации VPN используя VRF, когда нет CE портов, не запущен lable switching, LDP/TDP, есть только PE порты. Способ извращенный, IMHO, требующий конфигурирования VPN по всей сети, end-to-end.
Почитать можно на www.cisco.com, как всегда :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "конфигурация vrf"  
Сообщение от unpinget on 05-Сен-06, 12:20 
to StSphinx

спасибо что откликнулись, но на самом деле мне нужно сделать такую вещь:

cisco 2801 служит интернет-гейтвеем для сети 10.1.1.0/24 (пользователи выходят через внешний адрес 12.12.12.1)

в какой-то момент нам понадобилось занатить еще одну сеть 10.10.10.0/24 через внешний адрес 13.13.13.1, да так, чтобы она никоим образом не могла общаться с 10.1.1.0/24 (acl не решение). побродив в интернете узнал, что это можно сделать средствами vrf.

создал такой конфиг (часть вырезана):
  
-------------------------------------
!
ip vrf TestVrf
rd 100:1
!
ip route vrf TestVrf 0.0.0.0 0.0.0.0 FastEthernet0/0.10 13.13.13.1
!
ip nat pool ma-ext 13.13.13.2 13.13.13.2 prefix-length 28
ip nat inside source list 50 pool ma-ext overload
!
access-list 50 permit 10.10.10.0 0.0.0.255

interface FastEthernet0/0.15
  encapsulation dot1Q 15
  ip vrf forwarding TestVrf
  ip address 10.10.10.1 255.255.255.0
  no ip proxy-arp
  ip nat inside
  ip virtual-reassembly
  no snmp trap link-status
  no cdp enable
!
interface FastEthernet0/0.10
  encapsulation dot1Q 10
  ip vrf forwarding TestVrf
  ip address 13.13.13.2 255.255.255.240
  no ip proxy-arp
  ip nat outside
  ip virtual-reassembly
  no snmp trap link-status
  no cdp enable
!
------------------------------------------

на show ip route vrf TestVrf:
Gateway of last resort is 13.13.13.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0.15
     13.13.13.0/28 is subnetted, 1 subnets
C       13.13.13.0 is directly connected, FastEthernet0/0.10
S*   0.0.0.0/0 [1/0] via 13.13.13.1, FastEthernet0/0.10

т.е. таблица маршрутизации такая, какая и должна быть.

проблема в том что когда я пингую с компьютера 10.10.10.4 интернет, пакеты не натятся.

вопрос в принципе такой: правильно ли я настроил vrf для 2-х интерфейсов?


help me please...

Заранее благодарю!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "конфигурация vrf"  
Сообщение от Nailer (??) on 05-Сен-06, 11:12 
>Доброго времени суток! Подскажите пожалуйста где можно найти документацию по vrf(virtual routing
>and forwarding), а то в гугле что-то ничего нормального не нашел...
>
>
>Просто требуется настроить интерфейсы так, чтобы один интерфейс использовал одну таблицу маршрутизации,
>а другой - другую.
>
>Заранее спасибо!


Вы уверены, что policy-based routing не решит вашу задачу?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "конфигурация vrf"  
Сообщение от unpinget on 05-Сен-06, 12:22 
>
>Вы уверены, что policy-based routing не решит вашу задачу?

спасибо, я посмотрю )

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "конфигурация vrf"  
Сообщение от SanyaZar (ok) on 09-Фев-09, 17:14 
>[оверквотинг удален]
>>and forwarding), а то в гугле что-то ничего нормального не нашел...
>>
>>
>>Просто требуется настроить интерфейсы так, чтобы один интерфейс использовал одну таблицу маршрутизации,
>>а другой - другую.
>>
>>Заранее спасибо!
>
>
>Вы уверены, что policy-based routing не решит вашу задачу?

А каким образом с помощью policy-based routing можно запретить пакетам проходить в соседний вилан? Можете скинуть кусок конфа?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру